FAQ eMule :: Bienvenue

Bienvenue dans la FAQ eMule

La FAQ est sans cesse mise à jour en ligne, c'est pourquoi, il est nécessaire de la consulter régulièrement à l'adresse http://www.emule-project.net/faq/.
Tous les sujets importants sont couverts. Si malgré tout, vous continuez à rencontrer des problèmes ou si vous désirez apporter un commentaire à propos de cette FAQ, vous pouvez me contacter à l'adresse suivante : Monk@emule-project.net

Je ne répondrai pas aux emails contenant des questions :
> | déjà couvertes par cette FAQ
> | déjà discutées dans les forums
> | concernant des téléchargements ou des fichiers autres que le programme eMule
> | écrites en une autre langue que l'anglais ou l'allemand

Guide du débutant - Introduction à eMule

FAQ - Foire Aux Questions *

Informations générales

  • Les Icônes

  • Couleurs des barres de progression

  • Rang dans la file d’attente - QR

  • L’ID expliquée

  • Evaluation & Score

  • Listes

  • Fichiers utilisés

Réglages d'eMule - Les préférences

  • Général

  • Affichage

  • Connexion

  • Proxy

  • Serveur

  • Dossiers

  • Fichiers

  • Alertes

  • Statistiques

  • IRC *

  • Planification

  • Interface Web

  • Sécurité

  • Propriétés étendues *

  • Preferences.ini

Ports, Pare-feu & Routeurs

  • Ports

  • Pare-feu - Général

  • Pare-feu - WindowsXP

  • Routeurs

    • Solwise SAR-7x5

    • Lucent CellPipe 20A-GX-E

    • SMC Barricade 7004 ABR

    • Linksys BEFSR41

    • Cisco 677/678

Serveurs

  • Mise à jour de la liste des serveurs

  • Adresses des listes de serveurs

  • Résolution Dynamique DNS

Fonctions

  • La recherche de fichiers (recherche booléenne)

  • Système de Crédit

  • Identification sécurisée des Utilisateurs

  • Bannissement des clients agressifs

  • Echange de Sources

  • Prévisualisation des Fichiers

  • Online Signature

  • Chat IRC

  • Amis

  • Filtrage des IP

  • Catégories

  • Interface Web

Dépannage

  • Messages d'Erreur
  • Liens eD2k
  • ServeurWeb
  • Téléchargements
  • "Comportement étrange"
  • Connexion au serveur
  • Mise en liste noire

Outils

*Dernière mise à jour le 24/10/03 (v.30b) par Monk (Traduction française par Ogmios)


FAQ eMule :: Guide du débutant

Guide du débutant

Si vous débutez avec eMule, lisez ce petit tutoriel. Les sujets abordés ici peuvent être approfondis en lisant les diverses sections de la FAQ.
1. Téléchargement et installation
Vous pouvez obtenir le logiciel Ici. Vous avez le choix entre un installeur ou seulement l’exécutable dans un fichier compressé (zip). Extrayez le fichier zip là où vous le désirez et lancez l’exécutable.

Note:
Si vous utilisez Windows98 le message d’erreur suivant peut s’afficher : oleacc.dll non trouvée. Cette dll fait partie de MS System Updates for Win98.
2. Préférences
Après le démarrage d’eMule allez dans Préférences. Nous allons maintenant décrire les réglages les plus importants, si vous désirez plus de détails, consultez la FAQ.

- Général

Surnom
Entrez ici votre pseudo. Et surtout ne laissez pas http://emule-project.net, ça finit par devenir lassant.
Associer eMule avec le format de liens web eDonkey
Pour qu’eMule accepte ce format particulier de liens web, pressez le bouton [image]. Si ce bouton est grisé, eMule est déjà associé aux liens.
- Connexion
L’onglet Connexion est de loin le plus important de la section Préférences. Prenez donc le temps de soigneusement lire les explications suivantes.
Assistant
Pour un réglage rapide, utilisez l’assistant. Il établira des valeurs correctes pour bien débuter.
o | Système d’exploitation
Il est recommandé d’utiliser un système d’exploitation récent comme Windows 2000 ou XP dans la mesure où ils prennent en charge les connexions multiples beaucoup mieux que Windows 9x/ME
o | Téléchargements simultanés
Ce réglage affecte le nombre de sources max. autorisées. Choisissez-le en fonction du nombre de fichiers que vous comptez ajouter dans votre liste de transferts.
Note: N’ajoutez pas trop de fichiers dans votre liste de téléchargements. Le nombre de Sources trouvées dans l’onglet des Statistiques ne devrait pas dépasser environ 3000. Les requêtes permanentes générées par un trop grand nombre de sources risquent de provoquer des blocages de votre connexion internet. Lorsqu'en développant la liste des sources d’un téléchargement dans la liste des transferts, vous observez de nombreux « Trop de connexions », cela signifie que trop de sources sont trouvées pour la capacité de votre connexion internet. Dans ce cas, réduisez la valeur de votre Limite Forte.
o | Type de connexion
Sélectionnez votre type de connexion dans la liste. Il est important de choisir la valeur correcte. Si votre type de connexion n’est pas présent dans la liste, choisissez Personnalisé et entrez les valeurs vous-même dans la boite de dialogue. Faites attention à la différence entre kiloBits/s [kb/s] et kiloOctets/s [ko/s]. Un octet est égal à 8 bits.
Appuyez sur Appliquer et vous en aurez fini avec le réglage de votre connexion.

- Dossiers
Dans Préférences-Dossiers vous pouvez spécifier le répertoire dans lequel les fichiers dont le téléchargement est achevé seront sauvegardés (Fichiers Reçus) ainsi que le chemin pour les fichiers en cours (Fichiers Temporaires).
Les répertoires désignés dans les Dossiers Partagés sont mis à disposition sur le réseau. Si vous désirez partager de multiples sous-dossiers, utilisez la touche CTRL.

Note:Si vous passez d’eDonkey2000 à eMule, vous pouvez utiliser les mêmes dossiers reçus et temporaires que ceux que vous utilisiez avec eDonkey. Les fichiers seront automatiquement ajoutés après le redémarrage d’eMule.
3. | Serveurs
Les serveurs sont nécessaires pour accéder au réseau. Au premier démarrage, il est important d’avoir une liste de serveurs récente.
La manière la plus simple pour mettre à jour votre liste de serveurs est d’utiliser la boite de dialogue de la mise à jour server.met depuis URL. Reportez-vous ici pour plus de détails.
Il y a de nombreux sites internet qui mettent à disposition de bons fichiers server.met. Cependant, pour démarrer, copiez simplement cette URL :
http://ed2kmet.x24hr.com/pl/slist.pl?download/server-max.met

dans votre presse-papier et collez-la dans la boite de dialogue avant de presser le bouton de mise à jour. Merci à Maurice d’offrir ce service. Dans la rubrique Serveurs, la fenêtre Log vous renseigne sur le nombre de serveurs ajoutés.
4. | La Connexion au Serveur
Une fois que votre liste de serveurs est mise à jour, pressez le bouton de connexion [image] dans le coin supérieur gauche.
Une fois connecté à un serveur, la barre de statut tout en bas de la fenêtre du programme doit ressembler à ceci :

Important:
traduit une ID forte (high ID). Tout est parfait.
si vous observez cette icône à chaque tentative de connexion, vous avez une ID faible (Low ID) et vous devez alors consulter les rubriques ID, Pare-feu, et Routeurs dans la FAQ.
5. | C’est terminé !

Maintenant, vous pouvez commencer à ajouter des fichiers à télécharger par l’intermédiaire de la recherche intégrée à eMule (utilisez la Recherche Globale si vous n’obtenez pas les résultats souhaités), par l’utilisation des moteurs de recherche Web que sont Jigle et FileDonkey ou par le biais de l’un des nombreux sites de liens.
6. | Bon à savoir
o | Explications sur les icônes eMule
o | Les couleurs des barres de progression
o | Le rang dans la file d'attente - QR
o | Si vous désirez une bonne vitesse de téléchargement, ajoutez des fichiers ayant de nombreuses sources. Les fichiers qui possèdent moins de 100 sources sont considérés comme rares et sont plus longs à obtenir. Faites preuve de patience !
o | Plus eMule fonctionne longtemps, plus il est rapide. N’espérez pas de forts taux de téléchargement tout de suite après le démarrage.
o | Ce réseau est mieux approprié aux gros fichiers. Merci de ne pas partager de grandes collections de petits fichiers. Cela surcharge inutilement le réseau.
o | Vous serez récompensés de votre partage.
Amusez-vous bien avec eMule !

Dernière mise à jour le : 28/12/02 par Monk

Traduction française : www.emule-inside.net


eMule FAQ :: FAQ - Index

FAQ - Index

Installation et mise à jour de la version
> | Quelle est l'influence du système d'exploitation ?
> | Message d'erreur oleacc.dll non trouvée
> | Installeur ou Binaires ?
> | Comment conserver mes réglages / mes téléchargements lors de la mise à jour vers une nouvelle version d'eMule ?
> | Mise à niveau à partir d'eDonkey / d'Overnet vers eMule et conservation des téléchargements
Serveur, Connexions et ID
> | Où obtenir une liste de serveurs ?
> | Quel est le serveur le meilleur et le plus rapide ?
> | Selon quel rythme dois-je mettre à jour la liste de serveurs ?
> | Pourquoi eMule ne se connecte pas ?
> | Pourquoi est-ce que j'obtiens une ID faible (low ID) ?
> | eMule se déconnecte sans cesse du serveur
Vitesse et réglages
> | Puis-je lancer eMule, ajouter la dernière vidéo à la mode et obtenir un résultat dans les 5 minutes ?
> | Ce qui influence les téléchargements
> | Quels sont les meilleurs réglages ?
> | Comment puis-je augmenter ma vitesse de téléchargement ?
> | Quels taux de téléchargement puis-je espérer ?
> | Quelle doit être la taille de la file d'attente ?
Crédits
> | Que sont ces crédits et pourquoi dois-je les accumuler ?
> | Où puis-je voir mes crédits ?
> | J'ai perdu / effacé mon fichier clients.met. Ai-je perdu mes crédits ?
> | Les crédits sont-ils sécurisés ?
> | Comment perdre ses crédits à coup sûr.
Téléchargements et fichiers partagés
> | Mes téléchargements ont disparu de la liste.
> | Que signifie cette barre colorée dans les transferts ?
> | Que sont les valeurs xx / yy (zz) dans la colonne des sources ?
> | Que signifie QR ?
> | Pourquoi mes sources affichent Demande un autre fichier ?
> | Que signifient Trop de connexions ?
> | Puis-je changer le nom d'un téléchargement ?
> | Que signifient les points d'exclamation rouge et vert ?
> | Comment puis-je ajouter un commentaire / une évaluation à un fichier ?
> | Comment puis-je savoir qu'un fichier est un fake (faux) ?
> | Mes téléchargements ne se terminent pas.
> | Mes téléchargements sont finis mais affichent Erroné.
> | Mes téléchargements sont finis mais n'apparaissent pas dans les fichiers reçus
> | Le dossier des fichiers temporaires est trop volumineux. Puis-je l'effacer ?
> | Comment puis-je retirer du partage certains fichiers ?
Utiliser eMule
> | Astuces générales
> | Comment puis-je ajouter un ami ?
> | Comment allouer un accès ami réservé en émission ?
> | Comment nettoyer l'historique de la saisie semi-automatique des recherches ?
> | Quelle est la signification des icônes devant les sources, etc. ?
> | Puis-je kicker ou bannir d'autres utilisateurs ?
> | Pourquoi est-ce que je n'obtiens que 201 résultats lors d'une recherche ?
> | Devrais-je attribuer à tous mes fichiers une priorité haute ou release ?
Divers
> | Pourquoi la navigation sur internet est-elle ralentie lorsqu'eMule fonctionne ?
> | Qu'est ce qu'un Mod?
> | Est-ce que les Mods sont meilleurs ou plus rapides ?
> | J'ai reçu un message m'indiquant qu'eMule est bannie
> | Où pourrais-je recevoir plus d'aide ?
> | Est-ce qu'eMule est anonyme ?
> | Mon pare-feu rapporte des attaques ou pourquoi eMule envoie-t-elle des mails ?
> | Mon pare-feu rapporte toujours des connexions après que j'aie arrêté eMule
> | Qu'est-ce que l'IP Filter ?
> | Puis-je copier l'aide / la FAQ sur mon site personnel ?
eMule ne fonctionne toujours pas !

Mis à jour le : 03/10/03 par Monk


FAQ eMule :: FAQ - Installation

FAQ

Installation et mise à jour de la version

> | Quelle est l'influence du système d'exploitation ?
> | Message d'erreur oleacc.dll non trouvée
> | Installeur ou Binaires ?
> | Comment conserver mes réglages / mes téléchargements lors de la mise à jour vers une nouvelle version d'eMule ?
> | Mise à niveau à partir d'eDonkey / d'Overnet vers eMule et conservation des téléchargements

Quelle est l'influence du système d'exploitation ?
eMule fonctionne avec toutes les versions de Windows supérieures à Windows 95. Une application de p2p utilise de nombreuses connexions réseau et nécessite donc une implémentation réseau stable. Windows 98 et ME ont une implémentation du réseau très succinte ce qui détériore les performances d'eMule. Les systèmes d'exploitation plus récents comme Windows 2000 ou XP sont plus appropriés.
N'utilisez pas les patches du registre pour Windows 98, qui promettent d'augmenter le nombre de connexions possibles. Elles ne fonctionnent pas correctement et peuvent rendre votre système instable.

Message d'erreur oleacc.dll non trouvée
Ce message d'erreur peut apparaître lors du démarrage d'eMule sur une machine sous Windows 98. La dll manquante se trouve dans Windows 98 System Update.

Installeur ou Binaires ?
L'installeur est souhaitable lors d'une première installation d'eMule, parce qu'il contient tous les fichiers nécessaires, ainsi que la documentation. Il suffit de lancer l'exécutable et l'installeur vous guide à travers toutes les étapes du processus.
La distribution binaire est une archive. Le contenu de cette archive doit être extrait dans le dossier désiré. Cette présentation est utile lors d'une mise à jour.

Comment conserver mes réglages / mes téléchargements lors de la mise à jour vers une nouvelle version d'eMule ?
Extrayez ou installez une nouvelle version d'eMule dans le même dossier que vous utilisiez pour votre ancienne version. Seuls les fichiers eMule.exe et non utilisés seront remplacés. Tous les réglages et les téléchargements seront conservés.
eMule doit être fermée avant de procéder à une mise à jour !

Mise à niveau à partir d'eDonkey / d'Overnet vers eMule et conservation des téléchargements
Les versions d'eDonkey antérieures à la v.47 utilisent un système de part compatible avec eMule, alors que les versions postérieures à la v.47 divisent les téléchargements en cours en de nombreux fichiers individuels.
Pour les anciennes versions d' eDonkey, utilisez tout simplement comme dossier temporaire d'eMule le répertoire que vous utilisiez jusqu'à présent avec eDonkey. Ou déplacez les fichiers part dans le dossier temporaire d'eMule alors que celle-ci n'est pas en cours de fonctionnement.
Les nouvelles versions d'eDonkey et d'Overnet utilisent le système de division des part. Une option "ancienne méthode" est disponible dans ces clients, et permet d'organiser les téléchargements en cours, sous forme de fichiers uniques. Toutefois, le fichier part.met demeure dans son nouveau format, incompatible.
eMule v0.30c introduit une fonction de conversion permettant l'importation de fichiers part étrangers dans les téléchargements d'eMule. Elle importe l'ancien format (eMule, eDonkey <=.47) mais aussi les formats divisé et "ancienne méthode" des versions d'eDonkey / Overnet >.47. Les formats non-eMule seront convertis en format eMule.
La fonction d'importation est accessible par le menu rapide (en pressant Alt+X) ! Vous n'avez qu'à indiquer un dossier contenant des fichiers part et eMule tentera de les convertir automatiquement puis de les ajouter à vos téléchargement en cours, sans avoir besoin d'arrêter le programme ou de le relancer.

Mis à jour le : 24/09/03 par Ornis


FAQ eMule :: FAQ - Serveur

FAQ

Serveur, Connexions et ID

> | Où obtenir une liste de serveurs ?
> | Quel est le serveur le meilleur et le plus rapide ?
> | Selon quel rythme dois-je mettre à jour la liste de serveurs ?
> | Pourquoi eMule ne se connecte pas ?
> | Pourquoi est-ce que j'obtiens une ID faible (low ID) ?
> | eMule se déconnecte sans cesse du serveur

Où obtenir une liste de serveurs ?
http://ed2k.has.it – Cliquez simplement sur Add to eMule.

Quel est le serveur le meilleur et le plus rapide ?
Il n'y a aucun serveur plus rapide ou meilleur. Ils sont utilisés pour la connexion sur le réseau et la recherche de fichiers et de sources. Pour obtenir un résultat de recherche, eMule interroge chaque serveur de sa liste et l'ensemble de ces serveurs lors d'une recherche globale.
De plus, eMule échange des sources avec les autres clients eMule ce qui lui permet de trouver des sources de manière encore plus rapide.

Selon quel rythme dois-je mettre à jour la liste de serveurs ?
Au cours des sessions ou si vous utilisez eMule régulièrement, il est inutile de mettre à jour votre liste des serveurs. Les réglages par défaut d'eMule font en sorte que cette liste soit en permanence à jour.

Pourquoi eMule ne se connecte pas ?
La connexion d'eMule peut prendre un certain temps car les serveurs peuvent être hors ligne ou peuvent ne pas répondre. Si eMule ne se connecte pas du tout, assurez-vous d'avoir une liste de serveurs récente et vérifiez qu'aucun logiciel de type pare-feu, routeur, logiciel de connexion automatique, ne bloque le trafic d'eMule.
Vérifiez aussi les Préférences -> Serveurs -> Connexion automatique seulement aux serveurs statiques. Si cette option est cochée et que vous ne possédez pas un fichier staticservers.dat contenant des serveurs valides, eMule ne se connectera pas..

Pourquoi est-ce que j'obtiens une ID faible (low ID) ?
eMule fonctionne pleinement seulement si les ports suivants sont ouverts dans les pare-feu ou routeurs :
• 4662 TCP
• 4672 UDP
• 4711 TCP
Plus d'informations sont disponibles dans les chapitres Pare-feu et Routeurs.

eMule se déconnecte sans cesse du serveur
Quelques raisons expliquent des déconnexions d'eMule d'un serveur :
• Trop de fichiers dans la liste des téléchargements (seulement les versions d'eMule antérieures à v.30a)
• Trop de fichiers partagés (seulement les versions d'eMule antérieures à v.29a)
• Des problèmes au niveau du serveur
• Des problèmes au niveau du réseau en général
Le plus souvent, eMule se connecte à nouveau, lorsqu'une connexion à un serveur est perdue. Ce n'est pas un évènement critique.

Mis à jour le : 03/09/03 par Monk


FAQ eMule :: FAQ - Réglages

FAQ

Vitesse et réglages

> | Puis-je lancer eMule, ajouter la dernière vidéo à la mode et obtenir un résultat dans les 5 minutes ?
> | Ce qui influence les téléchargements
> | Quels sont les meilleurs réglages ?
> | Comment puis-je augmenter ma vitesse de téléchargement ?
> | Quels taux de téléchargement puis-je espérer ?
> | Quelle doit être la taille de la file d'attente ?

Puis-je lancer eMule, ajouter la dernière vidéo à la mode et obtenir un résultat dans les 5 minutes ?
Non, absolument pas ! Comme eMule est spécialisée pour les gros fichiers, le réseau est chargé à 100% pratiquement en permanence. Une règle simple dit "La somme de toutes les émissions du réseau = la somme de tous les téléchargements". Les gros fichiers demandent beaucoup de trafic en émission et si l'on considère les taux d'émission plutôt bas accordés actuellement par les fournisseurs d'accès à l'internet, il est tout à fait naturel que les téléchargements prennent un certain temps.
eMule est un réseau de partage des fichiers et pas un négoce (NdT : qui accorde des données contre rétribution). Si vous parvenez à comprendre la différence, eMule est faite pour vous.

Ce qui influence les téléchargements
Voici quelques facteurs qui influencent la vitesse de téléchargement :
• Les réglages d'eMule
• Une ID forte (High ID) (paramètres du pare-feu et du routeur)
• La durée de la session eMule
• Le nombre de sources que possède un téléchargement
• La disponibilité des parties élémentaires
• La popularité du téléchargement
De mauvais réglages d'eMule (mauvaises limites, trop de connexions), une ID faible et une durée de session insuffisante ont un impact négatif sur la vitesse des téléchargements. Les fichiers très populaires (nouvelles diffusions) et généralement les fichiers qui présentent peu de sources ou une mauvaise diffusion des morceaux élémentaires sont aussi à l'origine de mauvais taux de téléchargement.

Quels sont les meilleurs réglages ?
Il n'y a pas de meilleurs réglages pour eMule car la performance dépend fortement du type et de la vitesse de la connexion internet ainsi que du système d'exploitation utilisé. Vous devriez toujours utiliser l'assistant car il donne une bonne base pour ces réglages. L'essentiel est de fournir des valeurs correctes pour votre connexion internet et votre système d'exploitation.

De bons réglages pour la très répandue connexion DSL 512 / 128 seraient :

Windows XP
 | Capacité de réception : 64 (= 512 / 8)
 | Capacité d'émission : 16 (= 128 / 8)
 | Limite de réception : 60
 | Limite d'émission : 12 (= 16 x 0,75)
 | Limite forte : 500
 | Connexions max. : 400
 | Connexions max. / 5 sec : 30
 | Téléchargement d'environ 6 à 20 fichiers simultanément.
Windows 98 / ME
 | Capacité de réception : 64 (= 512 / 8)
 | Capacité d'émission : 60 (= 128 / 8)
 | Limite de réception : 92
 | Limite d'émission : 12 (= 16 x 0,75)
 | Limite forte : 300
 | Connexions max. : 200
 | Connexions max. / 5 sec : 20
 | Ne téléchargez pas plus de 12 fichiers en même temps

Vous ne devriez pas forcer les limites. Des limites trop élevées peuvent entraver votre connexion et ainsi diminuer vos performances. La limite d'émission devrait se situer à environ 75% de votre capacité maximale d'émission.

Comment puis-je augmenter ma vitesse de téléchargement ?
En dehors des réglages corrects, seuls les fichiers que vous voulez télécharger décident de la vitesse. Pour obtenir de bonnes performances moyennes, tenez compte de ces quelques conseils :
• eMule doit fonctionner très longtemps. Plus ce temps est long, meilleure sont les performances. Préférez toujours.
• Ne téléchargez pas seulement un fichier
• Recherchez des fichiers avec 150 sources ou plus
• N'essayez pas d'obtenir le tout dernier fichier mis en partage
• Emettez autant que possible de façon à accumuler du crédit
• Ne regardez pas sans cesse eMule. Elle n'aime pas trop cela.

Quels taux de téléchargement puis-je espérer ?
Si vous nourrissez une eMule bien configurée avec quelques bons fichiers, vous obtenez, en général, des taux entre 20 et 30 ko/s, après un certain temps de mise en route. Certaines fois, ce taux peut beaucoup diminuer et d'autres fois, il peut atteindre deux à trois fois cette valeur.

Quelle doit être la taille de la file d'attente ?
Une file d'attente longue augmente l'efficacité du système de crédit. Des QR très élevés ne signifient pas que vous ne téléchargerez jamais de ces sources car de nombreux modificateurs existent, qui diminuent grandement le temps d'attente.

Mis à jour le : 03/09/03 par Monk


FAQ eMule :: FAQ - Crédits

FAQ

Crédits

> | Que sont ces crédits et pourquoi dois-je les accumuler ?
> | Où puis-je voir mes crédits ?
> | J'ai perdu / effacé mon fichier clients.met. Ai-je perdu mes crédits ?
> | Les crédits sont-ils sécurisés ?
> | Comment perdre ses crédits à coup sûr.

Que sont ces crédits et pourquoi dois-je les accumuler ?
Les crédits récompensent les utilisateurs qui émettent. La quantité de données transférées détermine la quantité de crédits. Les crédits ne sont pas globaux, ils ne peuvent être utilisés que chez le client qui vous les a accordés.
Les crédits sont un modificateur majeur lors du calcul de la progression dans la file d'attente d'un autre client. Plus vous avez des crédits, plus vous avancez vite.

Où puis-je voir mes crédits ?
Pour empêcher toute manipulation du score, les crédits ne sont pas sauvegardés localement sur votre disque dur mais sur les disques durs des autres clients. Il n'est pas possible de compter ses propres crédits.

J'ai perdu / effacé mon fichier clients.met. Ai-je perdu mes crédits ?
La perte de ce fichier ne signifie pas la perte de vos crédits mais de ceux que vous avez accordés à toutes les autres personnes. eMule crée une sauvegarde du fichier clients.met (clients.met.BAK), vous pouvez donc restaurer le fichier en renommant la sauvegarde en clients.met.

Les crédits sont-ils sécurisés ?
eMule utilise une méthode d'établissement des liaisons de type poignée de main cryptée, afin de s'assurer que les crédits appartiennent bien à un client déterminé. Les crédits sauvegardés pour un utilisateur ne sont accordés que si l'authentification s'effectue avec succès..

Comment perdre ses crédits à coup sûr.
Comme décrit ci-dessus, les crédits sont couplés à l'authentification sécurisée de l'utilsateur. La clé secrète pour cette authentification est calculée à partir d'informations sauvegardées dans les fichiers preferences.dat et cryptkey.dat. Qu'un seul de ces fichiers soit perdu et vous ne pourrez plus prouver que vous êtes le propriétaire légitime de ces crédits.
Si vous perdez seulement le fichier cryptkey.dat, il est obligatoire de supprimer aussi le fichier preferences.dat.

Mis à jour le : 03/09/03 par Monk


FAQ eMule :: FAQ - Téléchargements

FAQ

Téléchargements et fichiers partagés

> | Mes téléchargements ont disparu de la liste.
> | Que signifie cette barre colorée dans les transferts ?
> | Que sont les valeurs xx / yy (zz) dans la colonne des sources ?
> | Que signifie QR ?
> | Pourquoi mes sources affichent Demande un autre fichier ?
> | Que signifient Trop de connexions ?
> | Puis-je changer le nom d'un téléchargement ?
> | Que signifient les points d'exclamation rouge et vert ?
> | Comment puis-je ajouter un commentaire / une évaluation à un fichier ?
> | Comment puis-je savoir qu'un fichier est un fake (faux) ?
> | Mes téléchargements ne se terminent pas.
> | Mes téléchargements sont finis mais affichent Erroné.
> | Mes téléchargements sont finis mais n'apparaissent pas dans les fichiers reçus
> | Le dossier des fichiers temporaires est trop volumineux. Puis-je l'effacer ?
> | Comment puis-je retirer du partage certains fichiers ?

Mes téléchargements ont disparu de la liste.
Ceci peut se produire après un plantage ou après la mise à jour vers une nouvelle version.

• | Vérifiez si le chemin correct pointant vers le dossier temporaire est entré dans les Préferences -> Dossiers
• | Remplacez les fichiers .part.met dans le dossier temporaire par leurs sauvegardes .part.met.BAK.
• | Reportez-vous au chapitre Dépannage dans l'Aide.

Que signifie cette barre colorée dans les transferts ?
Les couleurs traduisent la disponibilité des parties du fichier. Le rouge signifie qu'aucune source actuellement connectée ne dispose de cette partie. Voir ce sujet pour de plus amples détails.

Que sont les valeurs xx / yy (zz) dans la colonne des sources ?
Les valeurs sont celles du nombre de sources trouvées pour un téléchargement donné.
• xx - Nombre de sources utiles
• yy - Nombre de sources total
• + aa - Nombre de sources auxquelles on Demande un autre fichier (visible seulement lorsque les Contrôles avancés sont activés)
• zz - Sources actuellement en cours de transfert

Que signifie QR ?
QR est l'abréviation de queue rank qui peut se traduire par rang dans la file d'attente. C'est votre position dans la file d'attente de l'autre client. On peut espérer l'initiation, dans un bref délai, d'un transfert pour les sources indiquant un QR inférieur à 20. Les crédits permettent d'avancer plus rapidement dans la file d'attente.
Le rang dans la file d'attente n'est pas perdu même si votre IP change ou si eMule est fermée pendant une courte période de temps.

Pourquoi mes sources affichent Demande un autre fichier ?
eMule n'occupe qu'un accès dans la file d'attente d'un autre client. Si un autre utilisateur possède plus d'un fichier que vous demandez en téléchargement, eMule n'entre en file d'attente que pour un fichier. Lorsque l'attente est terminée pour le premier fichier, elle passe au deuxième. La même source affichera Demande un autre fichier pour le fichier pour lequel on ne peut entrer en file d'attente. La fonction A4AF (NdT : A4AF = Asked For Another File = Autre fichier demandé), dans le menu obtenu par clic droit dans la fenêtre des téléchargements, permet d'assigner manuellement des sources A4AF à un fichier désiré.

Que signifient Trop de connexions ?
Ce statut de la source signifie que le nombre de sources devant être traité est supérieur au nombre de connexions qui peuvent être ouvertes. Cela se produit généralement lorsque de trop nombreux fichiers sont ajoutés dans la fenêtre des transferts ou lorsque la Limite Forte est réglée trop haute.

Puis-je changer le nom d'un téléchargement ?
Vous pouvez changer le nom d'un fichier comme vous le désirez car un téléchargement n'est pas reconnu par son nom mais par la valeur unique de son hachage (hash). Sélectionnez un un téléchargement et choisissez -> Voir détails fichier dans le menu obtenu par clic droit ou pressez le bouton du milieu de votre souris. Tenez compte de l'extension lorsque vous modifiez le nom d'un fichier dans l'onglet Nom de fichier.

Que signifient les points d'exclamation rouge et vert ?
Les points d'exclamation sont une indication sur le commentaire ou l'évaluation de ce téléchargement.
• Vert = évaluation positive
• Rouge = évaluation négative

Comment puis-je ajouter un commentaire / une évaluation à un fichier ?
Vous pouvez ajouter des commentaires et des évaluations dans la table principale des Partages. Cliquez simplement sur le bouton du milieu de votre souris ou faites un clic droit -> Changer le commentaire du fichier sur n'importe quel fichier en partage.
S'il vous plaît, apportez des commentaires constructifs !

Comment puis-je savoir qu'un fichier est un fake (faux) ?
Vous pouvez facilement reconnaître les faux en regardant les différents noms du fichier. Faites un clic droit sur le téléchargement -> Voir détails fichier -> Nom de fichier ou cliquez sur le bouton du milieu de votre souris, pour ouvrir la liste de tous les noms que prend ce fichier chez les différentes sources. Si les noms sont très différents ou sont contradictoires, il s'agit probablement d'un faux. Les résultats des recherches affichant un + dans le style de l'explorateur indiquent aussi que différents noms ont été trouvés.

Mes téléchargements ne se terminent pas.
Si un téléchargement ne s'achève pas au bout d'une très longue attente, cela peut avoir deux causes :
Aucune source complète :
Si la barre de progression affiche des parties en rouge qui ne virent jamais au bleu, et que toutes les sources trouvées ont les mêmes parties manquantes, le fichier est probablement mort et le téléchargement ne se terminera jamais. La colonne des Transferts, Vu complet pour la dernière fois, affiche la date à laquelle toutes les parties du fichier étaient disponibles.
Téléchargement corrompu :
La fenêtre de Log dans la table principale des Serveurs, affiche une entrée si une partie corrompue a été reçue. Si vous recevez toujours une corruption pour la même partie d'un fichier donné, il est possible que ce téléchargement soit complètement corrompu (cas très rare).

Mes téléchargements sont finis mais affichent Erroné.
Cette erreur apparaît, en général, lorsque les dossiers accueillant les fichiers temporaires et ceux accueillant les fichiers reçus se trouvent sur des disques ou des partitions différents. eMule ne peut terminer le téléchargement car il n'y a pas assez d'espace libre sur le disque de réception.

Mes téléchargements sont finis mais n'apparaissent pas dans les fichiers reçus
Lorsqu'eMule affiche un téléchargement comme terminé mais que le fichier n'est pas déplacé dans le dossier de réception, vous pouvez le faire vous-même, manuellement. Tout d'abord, examinez les -> Détails du fichier et assurez-vous qu'il est bien complet en comparant les tailles. Notez le numéro du .part correspondant et copiez le nom complet du fichier dans le presse-papiers. Dans l'explorateur de Windows, rendez-vous dans votre dossier temporaire et déplacez le fichier en question dans le répertoire de réception (incoming), puis renommez-le avec son nom final que vous avez entreposé dans le presse-papiers. Prenez bien soin d'indiquer son extension correcte. Le plus souvent, ces fichiers ne possèdent plus de part.met associé.

Le dossier des fichiers temporaires est trop volumineux. Puis-je l'effacer ?
Ce répertoire sauvegarde tous vos téléchargements incomplets. L'effacer, entraîne l'effacement de tous vos téléchargements en cours ! En raison du système de transfert utilisé par eMule, il peut arriver que la taille totale qu'occupera un téléchargement terminé soit occupée, bien que quelques kilo-octets seulement aient été transférés.

Comment puis-je retirer du partage certains fichiers ?
eMule partage les fichiers dès lors que :

• | une partie élémentaire d'un téléchargement (morceau ou chunk) est terminée et que la vérification n'y a pas trouvé d'erreur
• | il se trouve dans le dossier pour les Fichiers reçus ou est marqué comme partagé dans les Préférences -> Dossiers -> Dossiers partagés

Pour retirer un partage, vous devez l'enlever de votre dossier de réception des fichiers (incoming) ou de votre dossier partagé. Le partage des téléchargements en cours ne peut être désactivé.

Mis à jour le 03/10/03 par Monk


FAQ eMule :: FAQ - Utiliser eMule

FAQ

Utiliser eMule

> | Astuces générales
> | Comment puis-je ajouter un ami ?
> | Comment allouer un accès ami réservé en émission ?
> | Comment nettoyer l'historique de la saisie semi-automatique des recherches ?
> | Quelle est la signification des icônes devant les sources, etc. ?
> | Puis-je kicker ou bannir d'autres utilisateurs ?
> | Pourquoi est-ce que je n'obtiens que 201 résultats lors d'une recherche ?
> | Devrais-je attribuer à tous mes fichiers une priorité haute ou release ?

Astuces générales
De nombreuses fonctions d'eMule sont accessibles par le menu contextuel. C'est un menu qui s'ouvre lors d'un clic droit de la souris sur différents objets. De plus, de nombreuses zones et objets réagissent à un double clic ou même à un clic sur le bouton du milieu de la souris. Un menu rapide s'ouvre en pressant les touches ALT + x. Exercez-vous à ces différentes combinaisons. Cela est utile.

Comment puis-je ajouter un ami ?
Les Amis sont gérés depuis la fenêtre principale des Messages. Pour ajouter un ami, faites un clic droit dans la liste des Amis et choisissez -> Ajouter un ami. Vous avez besoin des informations suivantes :
• Adresse IP – obligatoire. Vous devez l'avoir. Demandez-la à votre futur ami.
• Port – en général 4662; obligatoire aussi
• Nom – Choisissez un nom. Non obligatoire.
Une autre manière d'ajouter un ami est de faire directement un clic droit sur une source dans la fenêtre principale des transferts et de choisir -> Ajouter aux amis. eMule se chargera alors de retrouver toutes les informations requises.

Comment allouer un accès ami réservé en émission ?
Un clic droit sur l'un de vos amis vous permet de lui établir un slot ami en émission. Cet accès en émission sera actif dès que le prochain accès se libérera, ce qui autorisera ainsi votre ami à télécharger.

Comment nettoyer l'historique de la saisie semi-automatique des recherches ?
Cliquez à l'intérieur du champ de recherche puis pressez les touches CTRL ou ALT et SUPPR.

Quelle est la signification des icônes devant les sources, etc. ?
Vous trouverez une description détaillée dans le chapitre sur les Icônes.

Puis-je kicker ou bannir d'autres utilisateurs ?
Non. Cette fonction ne sera jamais implémentée dans eMule car elle se trouve en contradiction avec sa philosophie.

Pourquoi est-ce que je n'obtiens que 201 résultats lors d'une recherche ?
La recherche provoque une charge très lourde des serveurs. Pour limiter l'impact de nombreux clients effectuant des recherches, eMule retourne un maximum de 201 résultats suite à une recherche. Si vous en désirez plus, utilisez le moteur de recherche web Jigle (accessible aussi depuis eMule).

Devrais-je attribuer à tous mes fichiers une priorité haute ou release ?
Non. Les priorités sont utiles pour favoriser certains fichiers par rapport à d'autres. Les priorités sont relatives. Mettre tous les fichiers en priorité basse est identique à les mettre tous en priorité haute ou normale.
Les priorités des téléchargements influencent la manière dont eMule traite les fichiers lors de la recherche de sources ou lors de l'établissement des connexions. Les priorités en émission déterminent quels fichiers eMule favorise lorsque quelqu'un les demande. Les clients distants qui réclament des fichiers en émission possédant une priorité élevée, avancent plus vite dans votre file d'attente.

Mis à jour le : 03/09/03 par Monk


FAQ eMule :: FAQ - Divers

FAQ

Divers

> | Pourquoi la navigation sur internet est-elle ralentie lorsqu'eMule fonctionne ?
> | Qu'est ce qu'un Mod?
> | Est-ce que les Mods sont meilleurs ou plus rapides ?
> | J'ai reçu un message m'indiquant qu'eMule est bannie
> | Où pourrais-je recevoir plus d'aide ?
> | Est-ce qu'eMule est anonyme ?
> | Mon pare-feu rapporte des attaques ou pourquoi eMule envoie-t-elle des mails ?
> | Mon pare-feu rapporte toujours des connexions après que j'aie arrêté eMule
> | Qu'est-ce que l'IP Filter ?
> | Puis-je copier l'aide / la FAQ sur mon site personnel ?

Pourquoi la navigation sur internet est-elle ralentie lorsqu'eMule fonctionne ?
Selon les réglages établis, eMule peut ouvrir un nombre très conséquent de connexions et utiliser beaucoup de bande passante. Cela peut ralentir d'autres applications internet, comme par exemple la navigation sur le web. En particulier, de mauvais réglages ou des réglages trop optimistes provoquent une baisse sérieuse des performances au cours de la navigation sur internet.

Qu'est ce qu'un Mod?
Tout le monde peut utiliser le code source d'eMule. Aussi d'autres personnes ont développé des versions modifiées de l'originale. L'équipe officielle d'eMule n'apporte aucune aide sur ces versions.

Est-ce que les Mods sont meilleurs ou plus rapides ?
La plupart du temps non. Les versions officielles d'eMule profitent du développement des mods, mais les développeurs de versions modifiées ne peuvent changer de manière importante, le fonctionnement interne d'eMule, sans la rendre incompatible avec le reste du réseau. Ceci rend toute augmentation de la vitesse très improbable.
Les mods proposent de nouvelles fonctions et de nouveaux bogues que vous pouvez apprécier ou non. Déjà certains d'entre eux présentent des "fonctions" qui sont extrêmement nuisibles à l'ensemble du réseau. Ces versions de tricheurs ou "leechers" ne doivent pas être utilisées et la version officielle d'eMule tente de les combattre par des fonctions de sécurisation et par le bannissement.
Les versions modifiées présentes sur nos forums sont justes et se conforment aux règles du réseau..

J'ai reçu un message m'indiquant qu'eMule est bannie
Les versions officielles d'eMule ne génèrent pas ce genre de messages ; ils proviennent de versions modifiées. Si vous utilisez une version officielle, vous pouvez les ignorer ou les filtrer.

Où pourrais-je recevoir plus d'aide ?
Si vous ne parvenez pas à régler un problème après avoir lu la FAQ et l'aide, vous pouvez demander sur :

• | les Forum (utilisez la fonction de recherche avant d'ouvrir un nouveau sujet)
• | IRC - en vous rendant sur la fenêtre principale d'IRC dans eMule et en pressant "connecter". Pour entrer dans le salon d'aide en anglais, tapez /join #emule. D'autres salons sont également disponibles, comme #emule-french (langue française), #emule-spanish ou #emule-dutch.

Est-ce qu'eMule est anonyme ?
Les réseaux de P2P dépendent entièrement d'une connexion directe entre deux utilisateurs, de manière à transférer des données. Pour accomplir cela, l'IP du client cible doit être connue. Cette IP rend l'utilisateur identifiable et traçable. Il n'y a que deux façons de garantir l'anonymat : le routage du trafic à travers des serveurs proxy anonymes ou sa retransmission par l'intermédiaire d'autres clients.
Les serveurs proxy ont de nombreux inconvénients. Ils peuvent être fermés, le degré d'anonymat dépend de la loyauté de l'administrateur et le trafic qu'ils consomment coûte très cher. Imaginons un serveur eMule moyen de 100000 clients. Imaginons que chacun de ces clients connectés crée un trafic de 10 kB/s dans chaque direction. Le serveur devrait gérer un volume de transfert de 2.000MB (1,9GB) par seconde. Personne ne peut s'offrir un tel serveur.
Le routage de tout le trafic à travers des clients tiers, crée un problème similaire car la moitié du trafic serait utilisé pour garantir l'anonymat. Ce qui signifie que chaque utilisateur devrait émettre deux fois plus qu'aujourd'hui pour maintenir les performances du réseau au niveau actuel.
Pour le moment, il n'existe aucune méthode sûre et judicieuse permettant de garantir l'anonymat sur un réseau de P2P !

Mon pare-feu rapporte des attaques ou pourquoi eMule envoie-t-elle des mails ?
Les pare-feu logiciels analysent le trafic en inspectant à travers quels ports passe ce trafic. De nombreux ports sont communément réservés à certaines applications. Par exemple, le port 110 est en général utilisé pour recevoir les e-mails et le port 25 pour les envoyer. De même les trojans et autres logiciels néfastes utilisent des ports spécifiques.
Désormais, tous les ports sont librement configurables dans eMule et certains utilisateurs utilisent des ports réservés en principe à d'autres applications. Ceci peut amener les pare-feu à rapporter des attaques ou à considérer qu'eMule expédie des mails uniquement parce qu'elle effectue ses transferts à travers un certain port.
Si vous utilisez la version officielle d'eMule, vous pouvez être assurés qu'elle n'envoie aucune information à votre insu. De plus, aucune faille de sécurité n'est connue dans la version actuelle .30b.

Mon pare-feu rapporte toujours des connexions après que j'aie arrêté eMule
Votre client eMule est connu comme une source pour les autres clients sur le réseau. De plus, les serveurs font aussi connaître votre client comme la source des fichiers que vous partagez. Lorsque vous arrêtez eMule, vous continuez à recevoir du trafic en provenance des autres utilisateurs qui vous interrogent sur la possibilité d'une éventuelle connexion. Ceci subsiste pendant un certain temps.

Qu'est-ce que l'IP Filter ?
L'IP filter (filtre d'IP) est utilisé pour bloquer le trafic de certaines adresses internet qui pourraient se révéler nocives au réseau. Le plus populaire de ces filtres est L'IP Filter de Lussnig. Téléchargez le fichier ip.prefix depuis son site, renommez-le en ipfilter.dat et copiez-le dans le répertoire ../config d'eMule. Puis rendez-vous dans les Préférences -> Sécurité -> Filtres IP et pressez le bouton Recharger.

Puis-je copier l'aide / la FAQ sur mon site personnel ?
Vous pouvez copier n'importe quelle partie de l'Aide et de la FAQ, tant que vous en mentionnez l'auteur et que vous placez un lien vers http://www.emule-project.net. Il est de bon goût et respectueux de m'en avertir.

Mis à jour le : 03/10/2003 par Monk


FAQ eMule :: Les Icônes

Les Icônes

Client en cours de transfert ou d’envoi de son “hashset”

Client en attente ou en cours d’interrogation

Connexion en cours

Pas de partie à charger, Demande un autre fichier ou incapable de se connecter en raison d’une ID faible (“low ID”)

Statut inconnu

Nouveau Message

Client eDonkey classique, mldonkey ou ancienne version du client eMule

Client capable de comprendre le protocole eMule étendu

Client normal avec un crédit élevé (il possède une priorité plus élevée)

Client capable de comprendre le protocole eMule étendu et qui possède un crédit élevé

Client mlDonkey

Client mlDonkey qui possède un crédit élevé

Client hybride eDonkey2000-Overnet

Client hybride eDonkey2000-Overnet et qui possède un crédit élevé

Client Shareaza

Client Shareaza qui possède des points de crédit

Clients authentifiés par l'identification sécurisée

Vous êtes connecté avec une ID forte (“high ID”)

Vous êtes connecté avec une ID faible (“low ID”)

Vous n’êtes pas connecté

Icône d’eMule connecté à un serveur avec une ID forte (HighID) lorsque le programme est réduit en icône

Icône d’eMule connecté à un serveur avec une ID faible (LowID) lorsque le programme est réduit en icône

Icône d’eMule non connecté à un serveur lorsque le programme est réduit en icône

Un commentaire sur le fichier ou une évaluation positive ont été donnés à ce téléchargement

Evaluation du fichier : Fake (falsifié), Corrompu ou Invalide

S’applique à la version : .29a +
Dernière mise à jour : 24/08/03 par Monk


FAQ eMule :: Couleurs des barres de progression

Couleurs des barres de progression

Chaque téléchargement dans le tableau des transferts possède une barre colorée qui illustre la disponibilité et la progression du fichier courant.

(style plat) [image] (style arrondi)

Noir illustre les parties du fichier déjà téléchargées
Rouge indique une partie manquante dans toutes les sources connues
Différents tons de bleu représentent la disponibilité de cette partie dans les sources. Plus le bleu est foncé plus la disponibilité est importante
Jaune indique une partie en cours de téléchargement
La barre verte au sommet montre l’avancement global du téléchargement de ce fichier

(style plat) [image] (style arrondi)
Une barre verte symbolise un téléchargement complet.

(style plat) [image] (style arrondi)
Une barre de progression rouge ou bleue sombre traduit un téléchargement arrêté ou en pause.

Si vous développez la liste d'un téléchargement vous découvrez ses sources et les barres correspondantes. Pour voir les sources, faites simplement un double clic sur un téléchargement (ou un simple clic, en fonction du réglage des Préférences -> Général). Les couleurs ont ici une signification légèrement différente :

(style plat) [image] (style arrondi)

Noir illustre les parties du fichier déjà téléchargées
Bleu représente les parties dont vous avez besoin
Argent symbolise les parties qui manquent à la source
Vert montre les parties qui vous sont envoyées actuellement
Jaune traduit une partie en attente (déjà demandée)

Compteur des sources
 Les quatre valeurs xx / yy +aa (zz) affichées après la barre de progression constituent le compteur des sources de ce fichier et apportent les informations suivantes :

• xx - Nombre de sources utiles
• yy - Nombre total des sources
• + aa - Nombre des sources auxquelles on Demande un autre fichier (visible seulement lorsque les Contrôles avancés sont activés)
• zz - Sources actuellement en cours de transfert

Parties obtenues
Cette barre apparaît dans la file d'attente des envois si la fonction est supportée par l'autre client. Elle montre la progression du fichier que l'autre utilisateur est en train de télécharger.

Noir illustre les parties que l'autre utilisateur possède déjà,
Argent symbolise les parties qui manquent encore
Vert montre les parties actuellement émises
Jaune traduit une partie en attente (déjà demandée)

Disponibilité des fichiers partagés
Chaque fichier partagé affiche sa disponibilité sous forme d'une barre. Le code des couleurs est identique à celui employé pour les barres de progression.

Rouge indique une partie manquante dans toutes les sources connues
Différents tons de bleu donnent une idée de la diffusion des différentes parties.

Dernière mise à jour : 27/09/03 par Monk


FAQ eMule :: Rang dans la file d'attente

Rang dans la file d’attente - QR

les clients eMule indiquent un QR:[x] dans la vue des sources.
QR signifie queue ranking (rang dans la file d’attente). C’est votre position actuelle dans la file d’attente de cette source.

Bien entendu, la valeur la plus faible est la meilleure.

Dernière mise à jour : 14/12/02 par Monk


FAQ eMule :: L'ID Expliquée

L’ID expliquée

L’ID est une valeur calculée à partir de l’adresse IP du client. Elle est assignée par le serveur, lorsqu’eMule se connecte à lui avec succès. L’ID indique s’il est possible ou non de mettre deux clients en communication directe.

Après la connexion, l’ID est affichée dans la fenêtre de Log des Serveurs.

eMule n’indique ensuite plus l’ID. Toutefois, le statut de celle-ci est illustré par l’icône située dans le coin inférieur droit à côté du nom du serveur auquel vous êtes connecté.

indique une ID Forte (“High ID”)
indique une ID Faible (“Low ID”)

Une ID forte signifie que le port choisi dans Préférences -> Connexions (par défaut 4662) est ouvert et librement accessible.

En revanche, une ID faible signifie que ce port est bloqué ou ne peut être atteint à cause de l’utilisation d’un pare-feu, d’un routeur ou d’un serveur proxy.
Le fait d’avoir une ID faible ne signifie pas que l’émission ou la réception de données sont impossibles mais comporte plusieurs inconvénients :

- L’IP de la machine sur laquelle s’exécute eMule est inconnue. Aussi toutes les requêtes comme la mise en file d’attente ou la connexion à ce client doivent être routées par le serveur auquel il est connecté. Ce routage est responsable d’une charge CPU considérable du serveur ce qui réduit le nombre maximal d’utilisateurs qu’il peut accueillir. Les serveurs Lugdunum limitent le nombre d’utilisateurs possédant une ID faible voire même les bannissent tout simplement.

- Deux clients possédant une ID faible ne peuvent se connecter l’un à l’autre car il est impossible d’acheminer des messages à travers deux serveurs différents. Ceci a pour conséquence un nombre plus faible de sources disponibles pour le téléchargement.

- Lorsque les serveurs sont très sollicités, il peut arriver que les messages soient perdus et qu’eMule soit privée d’importantes informations sur la progression dans la file d’attente ou les requêtes de téléchargement. Ceci peut gêner l’augmentation du crédit et altérer la qualité des téléchargements.

Notes:
- Le problème de l’ID n’affecte que l’échange de messages entre clients. Le transfert réel de données est toujours traité de client à client.

- S’il vous est impossible d’obtenir une ID forte, il est préférable de vous connecter à des serveurs accueillant peu d’utilisateurs car ils disposent de plus de ressources libres que les gros serveurs congestionnés.

- Vous pouvez aussi vous voir attribuer une ID faible lorsque le serveur auquel vous vous connectez est trop occupé pour répondre convenablement ou est simplement mal configuré. Si vous êtes convaincu que vos réglages sont corrects et que vous devriez avoir une ID forte, connectez vous à un autre serveur. Lancez eMule et utilisez ce script de test (merci à TheDonkeyNetwork) afin de vérifier votre configuration.

- Si votre ID est forte, peu importe sa valeur. Une valeur numérique plus élevée n’est pas meilleure et n’offre aucun avantage.

- La valeur d’une ID faible, même si elle est très basse, n’a aucune importance. Une ID faible est une valeur inférieure à 16777216.

- Pour obtenir une ID forte à partir de votre IP la conversion s’effectue de la manière suivante : pour une IP = A.B.C.D l’ID Forte = A + 256*B + 256*256*C + 256*256*256*D.

Important:
Depuis la version .23a les sources présentant une ID faible sont ignorées par eMule dans le but de conserver une charge minimale des serveurs. Seules les sources à ID faibles connectés au même serveur que votre client et les sources à ID faibles qui désirent télécharger un de vos fichiers sont acceptées. De plus, les sources à ID faibles ne sont pas échangées entre clients.

Dernière mise à jour : 10/12/02


FAQ eMule :: Evaluation

Evaluation & Score

La fenêtre de file d'attente montre les clients qui attendent un accès en émission. Cette liste est visible lorsque l'on presse En Attente dans la fenêtre des Transferts.
La plupart des valeurs affichées n'ont pas besoin d'explication à l'exception d'Evaluation et de Score.

Evaluation
A l'origine, chaque client de la file d'attente possède une évaluation de 100. Cette valeur initiale est modifiée par les fichiers partagés que l'utilisateur réclame et par quelques autres facteurs :

> | Banni Modificateur : x 0 Les utilisateurs bannis ne reçoivent pas d'évaluation et donc pas de slot d'émission.
> | ID faible (Low ID) Modificateur : aucun [x 0,8] Les versions antérieures à la v.27a assignaient un modificateur de 0.8 aux utilisateurs ayant une ID faible. Ceci a été supprimé.
> | Connecté Modificateur : aucun [x 1,5] Le bonus de x 1,5 pour le fait d'être déjà connecté a été supprimé depuis la v.27a+.
> | Crédits Modificateur : x 1 - x 10 Le système de crédit calcule ce modificateur majeur correspondant au rapport émission / réception.
> | Priorité des fichiers pour les fichiers partagés. Modificateur : x1,8 - x 0,2 Les utilisateurs qui demandent un fichier à télécharger reçoivent un modificateur correspondant à la priorité établie pour ce partage. Les versions antérieures à la v.27a utilisent les valeurs entre crochets.
 | Release: | x 1,8 [x 5]
 | Haute : | x 0,9 [x 2]
 | Normale : | x 0,7 [x 1]
 | Basse : | x 0,6 [x 0,5]
 | Très basse : | x 0,2 [x 0,2]
> | Versions d'eMule antérieures à la v.20a Modificateur x 0,5 Ces versions antérieures à la v.20a causent une charge élevée du réseau c'est pourquoi elles reçoivent une pénalité sous forme d'un modificateur de 0,5.

Exemple :
Un client a gagné un modificateur de crédit de x 8 grâce à ses émissions importantes. Il demande un fichier avec une priorité haute. Son évaluation totale sera donc de : 100 x 8 x 0,9 = 720

Score
Le Score est calculé avec les mêmes coefficients que l'Evalutation mais cette fois-ci, le temps d'attente du client est aussi pris en considération. Le score détermine l'allocation de slots d'émission libres. Les clients qui possèdent un score élevé et *** après la valeur sont les prochains à recevoir un slot d'émission.
La formule de calcul du score est :

Score = Evaluation x [Temps d'attente dans la[les] file[s]] / 100

Les clients avec un modificateur total > 1 sont représentés par une icône de client jaune.

Dernière mise à jour le : 13/04/03 par Monk


FAQ eMule :: Listes

Listes

La fenêtre des Transferts donne différentes informations sur les taux de téléchargement et d'émission courants. La partie supérieure de la fenêtre est réservée aux téléchargements, la valeur entre parenthèses ( ) est le nombre de téléchargements en cours.
La partie inférieure de la fenêtre affiche les émissions. Cet affichage peut basculer pour montrer d'autres informations.

Pour passer d'une liste à l'autre, cliquez simplement sur le nom de la liste actuellement affichée. Les informations contenues dans ces listes se comprennent facilement.

S'applique à la version : .27a +
Dernière mise à jour le : 13/03/03 par Monk


FAQ eMule :: Préférences - Fichiers utilisés

Fichiers utilisés par eMule

Le fonctionnement d'eMule fait qu'un certain nombre de fichiers sont utilisés ou créés au cours du premier démarrage. La plupart d'entre eux sont créés dans le dossier d'installation d'eMule, d'autres dans le dossier temporaire comme cela est spécifié dans les Préférences.

o | Known.met Le fichier Known.met sauvegarde tous les fichiers connus par eMule qu'ils soient partagés ou en cours de téléchargement. Pour chacun de ces fichiers des informations telles que la taille, le chemin du fichier, le nombre de hash sets et certaines valeurs statistiques sont sauvegardées.
o | Clients.met Ce fichier sauvegarde tous les utilisateurs auquels vous avez accordé du crédit.
o | Server.met Contient tous les serveurs connus.
o | Emfriends.met Si vous avez ajouté des utilisateurs dans votre liste d'amis, ils sont enregistrés dans ce fichier.
o | Preferences.ini Sauvegarde toutes les options réglées dans le dialogue des préférences ainsi que les informations visuelles telles que la taille des colonnes, etc.
o | Fileinfo.ini Contient les commentaires ou les évaluations concernant vos propres fichiers partagés.
o | Category.ini Enregistre les réglages de vos catégories, nom, commentaire et code de couleur.
o | Ipfilter.dat Ce fichier rassemble les intervalles d'IP et les niveaux d'accès filtrés par le Filtrage des IP. Voir aussi les Préférences -> Sécurité
o | Onlinesig.dat Online Signature est un petit fichier qui contient des renseignement comme le serveur sur lequel eMule est connecté et les valeurs statistiques d'émission et de réception. Il peut être utilisé dans des scripts IRC ou des images de signature.
o | Preferences.dat Sauvegarde l'userhash. Cette une valeur calculée lors du premier démarrage d'eMule et qui est utilisée pour identifier le client sur le réseau. Cette valeur est utilisée pour le système de crédit et la reconnaissance des amis.
o | Sharedir.dat Contient tous les chemins menant aux dossiers partagés.
o | Staticservers.dat Les serveurs statiques ne changent jamais d'IP et sont théoriquement toujours en ligne sur le réseau. Ces serveurs peuvent être ajoutés au fichier staticservers.dat à l'aide du menu contextuel (clic droit de la souris) dans la liste des serveurs. Voir aussi les Préférences -> Serveur
o | Adresses.dat eMule met à jour sa liste de serveurs au démarrage si une adresse valide de server.met est présente dans ce fichier. Les Préférences -> Serveur contiennent un bouton pour éditer cette liste et les options de mise à jour au démarrage. Ce fichier peut contenir plusieurs entrées (une seule par ligne), mais seule la première adresse valide sera prise en compte.
o | AC_SearchStrings.dat Enregistre toutes les recherches déjà effectuées ; une nouvelle demande est complétée automatiquement si elle correspond à une recherche antérieure.
o | AC_ServerMetURLs.dat Dans le même esprit que ci-dessus, ce fichier enregistre les URL entrées qui pointent vers les fichiers server.met. Cependant, n'oubliez pas que de nombreux sites modifient régulièrement les adresses de leurs server.met.
o | Cryptkey.dat Il contient la clé RSA privée unique de 384 bits de votre client.
o | eMule.tmpl Les fichiers *.tmpl sont nécessaires au serveur web. Ils définissent l'agencement et les options des pages affichées.
o | xx.part Les fichiers part correspondent aux téléchargements inachevés. eMule peut télécharger à partir de plusieurs utilisateurs à la fois, aussi les fichiers *.part ont toujours la taille du téléchargement achevé. Les parties manquantes sont simplement remplies avec des zéros.
o | xx.part.met A chaque fichier *.part, correspond un *.part.met. Pour identifier un téléchargement sur le réseau et pour vérifier l'absence d'erreur, chaque téléchargement est divisé en parties d'environ 9 MB. Pour chaque partie, ce que l'on appelle une valeur de hachage (hash value) est calculée. Puis une nouvelle valeur de hachage est créée pour l'ensemble complet de ces parties. Cette information ainsi que le nom du fichier et le statut des parties hachées sont sauvegardés dans les fichiers *.part.met.
o | xx.part.met.BAK Une sauvegarde des fichiers *.part.met est créée par mesure de sécurité au cas où ces fichiers se trouvent corrompus lors d'un plantage. Voir Dépannage pour trouver de l'aide si vos téléchargements ont disparu en raison de fichiers *.part.met corrompus.
o | eMule.log Savegarde le fichier de sortie de la fenêtre de Log dans le panneau Serveur si l'option appropriée est activée dans les Préférences -> Propriétés étendues.
o | eMule_Debug.log Savegarde le fichier de sortie de la fenêtre de débogage dans le panneau Serveur si l'option appropriée est activée dans les Préférences -> Propriétés étendues.

S'applique à la version : .29b +
Dernière mise à jour le : 20/06/03 par Monk


FAQ eMule :: Préférences - Général

Préférences - Général

Surnom
Entrez votre surnom ou pseudo tel qu’il apparaîtra aux autres utilisateurs.

Langue
Choisissez votre langue dans la liste déroulante.

Options diverses

o Bip erreurs
Si une erreur ou une corruption de fichier est rencontrée, le haut-parleur du PC émet un bip.

o Premier plan après clic sur lien ED2K
eMule utilise le réseau eD2k, aussi les téléchargements et les serveurs peuvent lui être ajoutés en cliquant sur des liens web appropriés.
Cette option permet de régler le comportement d’eMule lors des clics sur des liens web. Soit la tâche eMule clignote en arrière plan soit la fenêtre du programme repasse au premier plan.

o Activer Online-Signature
Un petit fichier nommé onlinesig.dat est créé dans le répertoire eMule. Ce fichier a le format suivant :

[Statut en ligne]|[Serveur connecté]|[IP:port]
[Réceptions en cours]|[Emissions en cours]|[Utilisateurs en attente]

Ces informations peuvent être envoyées sur un site web via l’outils Online Signature de Dra.:.god ou être utilisées comme bon vous chante.
De nouvelles fonctionnalités devraient être ajoutées dans l’avenir.

o Confirmation en sortie
Un message apparaît à la fermeture du programme demandant une confirmation.

Démarrage

o Vérifier nouvelle version
Si cette option est cochée, eMule recherche une nouvelle version à chaque démarrage. Le curseur permet de régler le délai entre deux recherches.
Si une nouvelle version est trouvée, vous pouvez la télécharger sur www.emule-project.net. La mise à jour d'eMule se fait simplement par une installation / extraction de la nouvelle version dans le même dossier que votre version eMule actuelle. Tous les réglages et téléchargements seront automatiquement utilisés par la nouvelle version.

o Affiche écran démarrage
Affiche un joli écran de démarrage au lancement d’eMule.

o Réduire au démarrage
eMule démarre sous forme réduite en icône.

Editer Webservices
Internet offre des services comme les moteurs de recherches dédiés au réseau. Ces services peuvent être consultés directement depuis eMule. Leur configuration nécessite l'édition du fichier webservices.dat qui se trouve dans le dossier d'installation d'eMule. Le bouton Editer Webservices permet un accès rapide à ce fichier.

Exemple d'un fichier WebServices.Dat:
#########################################
# Fichier de configuration des Webservices
# entrez un service par ligne
#
# Format : Nom,URL
#
# Paramètres substituables :
# #filename -> nom du fichier
# #hashid -> hashid du fichier
# #filesize -> taille du fichier
#
# Exemple:
# Fake Check,http://www.un-moteur-de-recherche-fameux-de-liens-de-téléchargement/search?p=ed2k:#filesize:#hashid
# eMule Homepage,http://www.emule-project.net
# eMule FAQ,http://www.emule-project.net/faq/
#
# Les lignes de commentaire commencent par # ou /

eMule Homepage,http://www.emule-project.net
eMule FAQ,http://www.emule-project.net/faq/

Cet exemple ajoute eMule Homepage (page d'accueil du site d'eMule) et eMule FAQ aux services web. Ces services sont accessibles via le menu contextuel de la liste des Téléchargements.

Bouton Liens ED2K
Lorsque l’on presse ce bouton, eMule prend en charge le format des liens web eDonkey2000 conçus pour les téléchargements et les serveurs.

Note:
Certaines autres applications de p2p modifient parfois les réglages de ces liens. Les réglages corrects peuvent être vérifiés dans la base de registre en utilisant l’outil regedit de Windows :

HKEY_CLASSES_ROOT\ed2k\shell\open\command
Nom: (par défaut)
Type: REG_SZ
Données: "Chemin d’emule.exe(avec les guillemets!)" "%1"

et

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\shell\open\command
idem à ci-dessus

Si vous rencontrez des problèmes avec l'association des liens à eMule, supprimez toutes les entrées après HKEY_CLASSES_ROOT\ed2k\... et HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\... ensuite pressez une nouvelle fois le bouton Liens ED2K.
Faites au préalable une sauvegarde de la base de registre et relancez Windows (reboot) après tout changement dans celle-ci !

S'applique à la version : .27a +
Dernière mise à jour : 12/03/03 par Monk


FAQ eMule :: Préférences - Affichage

Préférences - Affichage

o Barre de progression
Le curseur permet de régler la quantité d'ombrage 3D des barres de progression.

o Délai affichage infobulles (sec)
Si vous arrêtez votre souris un instant sur un fichier en téléchargement, une petite note apparaît qui contient des informations concernant ce fichier. Vous pouvez préciser ici, le délai d'apparition de cette note.

o Double clic pour voir les sources
Cette option autorise le déroulement de la liste des sources d'un fichier en téléchargement non plus sur un simple mais sur un double clic.

o Icônes pour les fichiers avec commentaires/évaluation
Affiche l'icône [image] (commentaires, évaluation favorable), l'icône [image] (évaluation défavorable) pour les téléchargements présents dans la fenêtre des Transferts.

o Show percentage of download completion in progress bar
Un pourcentage indiquant la quantité totale reçue est ajouté dans la barre de progression de chaque téléchargement.

o Montrer les taux de transfert dans le titre
Affiche les taux de réception et d'émission courants dans le titre de la fenêtre du programme eMule.

o Montrer les infos de téléchargement sur les onglets de catégorie
Affiche deux valeurs (x/y) immédiatement après le nom d'une catégorie. La première valeur (x) est le nombre de fichiers actuellement actifs (en cours de téléchargement) et la seconde (y) est le nombre total de fichiers dans cette catégorie.

o Réduire en icône
eMule n'est pas réduit dans la barre des tâches mais comme une icône dans la zone de notification (system tray) lorsque cette option est activée.

Sauvegarde CPU & Utilisation mémoire

o Enlever la liste des clients connus
eMule garde une trace de tous les clients auquels il s'est connecté. Pour épargner de la mémoire, cette liste peut être désactivée par cette option. Faites-le sur des systèmes à court de mémoire.

o Enlever la file d'attente
De manière identique à la liste des clients connus, la file d'attente consomme des ressources du système. Désactivez-là pour les préserver.

o Ne pas mettre à jour en temps réel la file d'attente
L'information affichée dans la file d'attente n'est plus mise à jour aussi souvent ce qui sauvegarde du temps CPU.

o Ne pas recréer les graphs de stats au redimensionnement
eMule peut se "geler" un court instant lorsque la fenêtre est redimensionnée. Ceci est provoqué par l'obligation de générer à nouveau le graphique à partir des données sauvegardées. Si cette option est cochée, le graphique n'est pas redessiné mais repart de zéro.

Sélectionner une police
Ce bouton ouvre une fenêtre de dialogue permettant de choisir la police, le style et la couleur du texte affiché dans les fenêtres Serveurs, Messages et IRC.

S'applique à la version : .30a +
Dernière mise à jour : 24/08/03 par Monk


FAQ eMule :: Préférences - Connexion

Préférences - Connexion

Vous devez connaître la vitesse de votre connexion (Ceci est noté dans votre contrat ou sur le site internet de votre F.A.I).

Les valeurs de vitesse sont en général données en kilo Bits par seconde [kb/s] alors que les valeurs devant être renseignées dans eMule sont en kilo Octets par seconde [ko/s]
La conversion en kilo Octets se fait par une simple division par 8 des kilo Bits.

Exemple:
Vitesse descendante maximale : 768kb/s ÷ 8 = 96 kB/s
Vitesse montante maximale : 128kb/s ÷ 8 = 16 kB/s

Capacités
o Réception
Cette valeur est égale à la bande passante maximale descendante. Dans l’exemple ci-dessus, ce serait 64. Cette valeur est seulement utilisée pour régler l’échelle du graphe d’affichage des statistiques.

o Emission
La vitesse montante maximale. Dans l’exemple, ce serait 16. Cette valeur aussi est simplement utilisée pour régler l’échelle des graphes.

Limites
o Réception
C’est la valeur maximale en download que l’on autorise. Entrez 0 si vous ne voulez pas fixer de limite.

o Emission
C’est un réglage très important. C’est l’upload maximal que vous offrez au réseau. Réglez cette valeur approximativement à 80% de la vitesse montante maximale. Dans l’exemple, cela donne 16x0,8 = 12,8 que l’on arrondit à 13 (n’entrez que des chiffres ronds). Tout comme pour la réception, 0 signifie aucune limite.

Deux aspects importants à prendre en compte :
Réglage trop élevé de la limite d’Emission
Chaque téléchargement nécessite un peu de bande passante en upload afin de faire des requêtes, d’accuser réception des paquets, etc. Aussi si vous réglez cette limite trop haut, le défaut de bande passante en émission ralentira vos téléchargements.

Réglage trop bas de la limite d’Emission
eMule comporte un système d’attribution de crédit selon ce que vous donnez au réseau. Plus votre upload est faible, moins votre crédit est élevé et plus votre progression dans les files d’attente est lente.

Port client
eMule utilise le port 4662 par défaut pour le téléchargement des données à partir d’un autre client. Il est inutile de modifier ce réglage sauf si ce port est bloqué par exemple par un routeur ou un pare-feu. Dans ce cas vous avez une ID faible (lowID). Utilisez ce script (merci à TheDonkeyNetwork) pour vérifier si le port est ouvert.

Port UDP
Ce port supporte le protocole étendu d’eMule qui consiste en l’échange de sources entre Clients et la demande de sources entre clients eMule compatibles. L’utilisation de l’UDP entre clients réduit la surcharge de connexions et diminue aussi la charge des serveurs.
Il est nécessaire d’acheminer ce port en cas d’utilisation d’un routeur et de l’ouvrir par réglage du pare-feu. Si vous n’avez pas la possibilité de l’ouvrir, cochez “désactivé”. De cette manière le mode de communication conventionnel est rétabli (non recommandé).

Connexions max.
C’est le nombre maximal de connexions TCP/IP et UDP autorisées.
Les Connexions ne s’effectuent que si des données sont en cours d’échange, pour les recherches et les requêtes de file d’attente ou pour l’échange de sources de Client à Client.

Notes:
> eMule n’ouvre pas plus de 20 connections en 5 secondes quel que soit la valeur des Connexions Maximales.

> Lorsque le message "Trop de connexions" apparaît dans la liste étendue d’un fichier en cours de téléchargement, cela signifie que la limite des nouvelles connexions a déjà été atteinte. Les sources qui affichent ce message sont placées “en file d’attente” et seront traitées dès que de nouvelles connexions pourront être établies.

Sources max. par fichier
o Limite forte
La limite forte est le nombre maximal de sources autorisées pour un fichier. Dès que cette limite est atteinte, eMule n’accepte plus de source pour ce fichier.

o Limite faible (n’existe plus depuis la version .24b +)
Lorsque la limite faible est atteinte, eMule arrête la recherche de sources via l’Echange de Sources de Client à Client et sur tous les serveurs. Seules les sources en provenance des clients directement connectés pour emettre ou recevoir sont ajoutées jusqu’à ce que la limite forte soit atteinte. La limite faible est obtenue par calcul à partir de la limite forte et ne peut donc pas être modifiée.

o Limite de requêtes UDP (n'existe plus depuis la version .24b +)
Lorsque la limite est atteinte le client eMule arrête sa demande de sources auprès des serveurs à l’exception de celui auquel il est connecté. Les sources supplémentaires sont réunies via l’Echange de Sources de Client à Client et le serveur local.
Cette valeur dépend du réglage des Sources max. par fichier. Un taux de 10-20% des Sources max. par fichier est conseillé. Dans la mesure où cette limite contribue grandement à la réduction de la charge des serveurs, elle ne devrait jamais être réglée plus haut que 100.

Connexion au démarrage
demande à eMule de se connecter à un serveur au moment du démarrage du programme.

Reconnexion automatique
Si la connexion au serveur est perdue, eMule tente automatiquement d’en établir une nouvelle. Il est recommandé de cocher cette option.

Montrer le surplus de bande passante
Cette option affiche dans la barre de statut d'eMule, le surplus de bande passante tant en émission qu'en téléchargement. Ce sont les valeurs entre parenthèses ( ) qui se situent à côté de celles de la vitesse d'émission et de téléchargement courantes. Ce surplus est calculé à partir de la quantité de données nécessaires à la prise en charge de l'interrogation de la source, de l'ouverture de la connexion et du contrôle de tous les autres modes de communication entre les clients. Cette bande passante est inutilisable pour l'émission et le téléchargement.

Important:
Si la somme de votre émission courante et du surplus est proche de votre limite en émission, eMule ouvre trop de connexions ou doit gérer trop de sources. Dans ce cas il vous faut diminuer vos Connexions max. et/ou vos Sources max. par fichier faute de quoi vos taux de téléchargement et d'émission seront mauvais.

Note:
Le nombre de clients dans votre file d'attente n'entraîne pas de trafic supplémentaire et n'a pas d'effet sur le surplus de bande passante.

S'applique à la version .25a +
Dernière mise à jour le : 13/01/03 par Monk


FAQ eMule :: Préférences - Proxy

Préférences - Proxy

Un serveur proxy est une machine dédiée qui relaie le trafic d'un utilisateur connecté vers son adresse cible et vice-versa. Les serveurs proxy sont généralement utilisés pour quatre raisons :

> | Pare-feu Les serveurs Proxy peuvent être configurés pour autoriser seulement certains ports, protocoles et adresses.
> | Routeur Souvent utilisé pour fournir un accès internet simultané à de nombreux ordinateurs en réseau.
> | Cache de contenu Ces proxy ont d'énormes bases de données des contenus et services internet auxquels on accède régulièrement, ce qui augmente la vitesse d'accès à ces contenus.
> | Anonymat Certains, même parmi les proxy gratuits, n'acheminent aucune information personnelle sur l'utilisateur, telles que l'IP, etc. vers l'adresse cible. Le seul ordinateur que voit le destinataire de la connexion est le serveur proxy. Les serveurs proxy gratuits disponibles sur internet ne conviennent pas à eMule. La plupart d'entre-eux sont lents, instables et empêchent probablement toute connexion du client eMule. Utiliser un tel proxy entraîne une diminution sérieuse des performances. Les serveurs proxy locaux n'offrent aucun anonymat.

Si eMule est utilisé sur un ordinateur protégé par un proxy, il est nécessaire d'entrer les paramètres corrects de ce serveur. De mauvais paramètres empêchent toute connexion.

Important :
Activez ces réglages uniquement si vous êtes certains d'utiliser un proxy et si vous connaissez les paramètres à entrer. Les Proxy sont rarement utilisés par des particuliers car ils ne leur offrent aucun avantage en dehors de l'utilisation d'un réseau. Les routeurs matériels ou les modems ne sont pas des proxy !

Général

o Activer Proxy
Active la prise en charge du proxy.

o Type de proxy
Il y a différents types de serveurs proxy. Pour qu'eMule parviennent à se connecter à travers le serveur, le type doit être indiqué.

> | SOCKS v4 / v4a Les proxy SOCKS offrent une application protocole indépendante pour connecter deux hôtes qui ne peuvent être atteints directement par leur IP. Les serveurs v4 and v4a sont capables de relayer seulement le protocole TCP. Lorsque l'on utilise ce type de serveur, il convient de cocher l'option de désactivation dans les Préférences -> Connexion -> Port UDP.
> | SOCKS v5 La principale différence entre les protocoles SOCKS v4 et v5 est la prise en charge de l'UDP, aussi le port UDP devrait être activé.
> | HTTP 1.1 Utilise l'Hypertext Transfer Protocol v1.1 pour la connexion. Tout comme SOCKS v4, ce type ne supporte pas le protocole UDP, aussi il faut appliquer la même procédure que pour le SOCKS v4. Les Proxy HTTP ne peuvent ouvrir des ports en écoute. Il est donc impossible d'obtenir une ID forte (High ID) lorsqu'on les utilise.

o Proxy hôte
Entrez l'adresse hôte du serveur proxy.

o Port du proxy
Le port utilisé pour se connecter au proxy doit être indiqué. En général c'est le port 1080.

Authentification
Certains serveurs proxy nécessitent un nom d'utilisateur et un mot de passe pour accorder la connexion. Si c'est le cas, il convient d'activer l'authentification et d'entrer les références appropriées

Connexion automatique au serveur sans Proxy
Lorsque l'on active cette option, les paramètres du Proxy sont court-circuités lors d'une connexion automatique aux serveurs eMule / eDonkey.

S'applique à la version : .28a +
Dernière mise à jour le : 14/04/03 par Monk


FAQ eMule :: Préférences - Serveur

Préférences - Serveur

Supprime les serveurs inactifs [n] Tentatives
Une réponse incorrecte d’un serveur à une requête de statut, est comptée comme un échec. Après [n] tentatives en échec le serveur est effacé de la liste lors de la requête suivante.

 Mise à jour auto liste de serveurs au démarrage
Dans le répertoire où vous avez décompressé eMule se trouve le fichier adresses.dat. Ce fichier peut être édité en pressant le bouton [image]. Entrez une URL valide pointant vers un server.met et sauvegardez le fichier. Si cette option est cochée, eMule met à jour sa liste de serveurs au démarrage, à partir de l'URL qui se trouve dans l'adresses.dat. Ce fichier accepte de multiples adresses mais seule la première adresse valide est prise en compte.

Note:
Vous pouvez spécifier un éditeur par défaut dans le fichier preferences.ini. Recherchez TxtEditor= et entrez le chemin d'accès complet de votre nouvel éditeur.

Mise à jour liste de serveurs par connexion serveur
Les serveurs eDonkey se « connaissent » dans une certaine mesure. Si vous cochez cette option, le client eMule récupère la liste des serveurs connus du serveur auquel il est connecté..

Mise à jour liste de serveurs par connexion client
Cette fonction ne peut s’effectuer que si un autre client eMule est connecté à votre client. Ils comparent leurs serveurs fonctionnels et mettent à jour leur liste mutuellement.

Toujours filtrer les mauvaises IPs
(La v.29c étend et déplace cette option vers les Proprétés étendues -> Filter server and client LAN IPs)
Si, lors d’une mise à jour, vous recevez une IP de serveur invalide (0.0.0.0, 192.168.x.x ou une autre adresse similaire), cette IP est effacée puisqu’elle ne correspond à aucun serveur fonctionnel.

Utiliser priorité
Dans le menu contextuel de la liste des serveurs, chacun d’entre eux peut se voir assigner une priorité.

La priorité établit quel serveur eMule doit préférer lors de la connexion.

Contrôle futé des lowID à la connexion
Si vous avez reçu une fois une ID forte (high ID), cette fonction suppose que vous avez correctement configuré votre système. Elle déconnecte donc eMule si un serveur vous attribue une ID faible (low ID) sans raison. Si vous recevez 3 ID faibles d'affilée, vous êtes classé comme un utilisateur à ID faible jusqu'à ce que vous receviez à nouveau une ID forte.

Connexion serveur rapide
eMule fait une demande de connexion simultanément sur deux serveurs pour accélérer le processus. Lorsque cette option est activée, un seul serveur est interrogé pour diminuer le risque de recevoir une ID faible. En général, il n'est pas nécessaire d'activer cette option. Notez bien qu'eMule ne conserve sa connexion que sur un serveur.

Connexion auto seulement aux serveurs statiques
Le menu contextuel de la liste des serveurs permet d'en ajouter dans le fichier staticservers.dat situé dans le répertoire d'installation d'eMule. Cette liste se charge automatiquement au démarrage d'eMule. Seuls les serveurs possèdant une IP statique ou utilisant la fonction DynDNS doivent être ajoutés dans cette liste ! Cette option autorise eMule à ne se connecter qu'aux serveurs répertoriés dans cette liste.

Serveurs ajoutés manuellement : Placés en priorité haute
Cette option donne une priorité haute à chaque serveur qui n'est pas ajouté depuis une liste de serveurs.

S'applique à la version : .25b +
Dernière mise à jour : 09/07/03 par Monk


FAQ eMule :: Préférences - Dossiers

Préférences - Dossiers

Fichiers reçus
Indique le répertoire dans lequel sont déplacés les fichiers dont le téléchargement est terminé. Si le chemin par défaut est modifié, un dossier existant doit être indiqué. eMule ne peut pas créer ce dossier.

Fichiers temporaires
Dossier ou répertoire dans lequel sont enregistrés les téléchargements en cours. En raison du système de téléchargement en multi thread, eMule crée des fichiers factices (*.part) de la taille finale des téléchargements en cours.
Si ce dossier est changé, il convient d'agir de même que pour les Fichiers Reçus. eMule doit être redémarré pour que les changements soient pris en compte.

Dossiers partagés
Ces dossiers sont partagés sur le réseau. Une liste des fichiers qu’ils contiennent peut être consultée par les clients eMule, eDonkey ou mldonkey s'ils utilisent leur fonction "Ami" (cela dépend d'un réglage dans les Préférences -> Fichiers). Si vous voulez partager tous les sous-dossiers maintenez la touche CTRL enfoncée pendant que vous cliquez sur le dossier parent. Ceci ne fonctionne pas pour des disques/partitions entiers.

o Répertoires UNC
UNC signifie Uniform Naming Convention (convention de dénomination uniforme). C'est un moyen courant d'accès à des ressources partagées (dossiers ou disques entiers) à l'intérieur d'un réseau sans avoir besoin de les mapper (représentater la localisation d'ensembles de données afin d'en faciliter l'accès et le traitement). Tous les dossiers UNC ont le format suivant ::

\\serveur\ressource\..

Exemple:
\\test\DisqueD\eMule pointe vers le dossier eMule du disque partagé nommé DisqueD d'un ordinateur appelé test

Quelques remarques sur le partage des fichiers :
Chaque fois qu’un client eMule se connecte à un serveur, il transfère une liste de ses fichiers en partage. Le serveur stocke celle liste et la tient à disposition pour les recherches ou les requêtes de sources. Le traitement de ces fichiers consomme du temps CPU. Plus il y a de fichiers plus la charge de travail est lourde pour le serveur et moins il peut traiter de demandes d’utilisateurs.

Merci de suivre ces recommandations pour le partage sur le réseau :

> Vos dossiers “Fichiers reçus” (Incoming) et “Fichiers temporaires” (Temp) sont toujours partagés, aussi il est inutile de les ajouter.
> Le réseau eDonkey n’est pas très bien adapté au partage d’un grand nombre de fichiers individuels ou de petite taille (exemple : toute une collection de mp3). Comprimez ce type de fichiers si vous les partagez.
> Merci de ne surtout pas partager des dossiers comme \Program Files, \Temp, ou \Windows et encore moins des disques durs ou des partitions entiers.

S'applique à la version : .29b +
Dernière mise à jour : 20/06/03 par Monk


FAQ eMule :: Preferences - Fichiers

Préférences - Fichiers

Fichiers partagés vus par
La fonction Ami permet de voir une liste des fichiers que vous partagez. Cette option permet de définir la réponse à une requête de Visualisation des Fichiers.

Traitement intelligent des erreurs (ICH)
Le transfert des données sur le réseau eDonkey se fait par morceaux. Un morceau a une taille de 9MB. Chaque morceau complet téléchargé est vérifié à la recherche d’une corruption ; s’il n’est pas corrompu, il est rendu disponible pour une éventuelle émission.
En principe, les morceaux corrompus doivent être téléchargés à nouveau. Dans ce cas, l’ICH tente de réduire la quantité de données à télécharger ce qui diminue la perte de temps lorsqu’une corruption est détectée.

Initialisations
o Ajouter en mode pause les fichiers à télécharger
Lorsque la liste des téléchargements contient 20 fichiers ou plus, cette commande s'avère pratique en mettant en pause tout nouveau fichier ajouté plutôt que de le laisser en attente. Il devient donc possible d'ajouter des fichiers sans surcharger les connexions d'eMule. Voir Lancer prochain fichier en pause quand un est terminé.

o Mettre les nouveaux fichiers en partage en Auto priorité
Les fichiers complets ou les nouveaux fichiers en partage sont mis en priorité auto. La priorité auto permet à eMule de gérer la priorité en fonction du nombre de requêtes pour un fichier. Les fichiers qui ne reçoivent que quelques requêtes sont mis en priorité haute alors que les fichiers qui reçoivent de nombreuses requêtes sont mis en priorité plus basse. Ceci permet d'augmenter la disponibilité des fichiers rares sur le réseau c'est pourquoi il est recommandé d'utiliser cette fonction.

o Mettre les nouveaux téléchargements en Auto priorité
Cette fonction est identique à la précédente mais s'applique aux fichiers ajoutés dans la liste des Transferts. Selon le nombre de sources trouvées pour un téléchargement, sa priorité est ajustée automatiquement.

Sources trouvées | Priorité
0 - 40 | Haute
41 - 80 | Normale
81+ | Basse

o Nettoyer le nom
Cette option nettoie automatiquement le nom du fichier chaque fois qu'un nouveau téléchargement est ajouté dans la liste. Les caractères spéciaux tels que _ , . , [] sont supprimés ou remplacés par un espace et la première lettre de chaque mot est mise en capitale. De plus, des chaînes de caractères particulières que l'on peut définir à l'aide du bouton Editer sont aussi supprimées du nom du fichier. Des chaînes de caractères sont définies par défaut mais de nouvelles peuvent être aisément ajoutée en utilisant le séparateur |.

Attention :
Les images de CD créées pour les logiciels de gravure comprennent souvent plus d'un fichier, par exemple : *.cue/*.bin (CDRWin), *.mds/*.mdf (Alcohol120%), *.ccd/*.img/*.sub (CloneCD), *.bwt/*.bwi/*.bws (BlindWrite). Cette option ne devrait pas être activée lorsque de tels fichiers sont téléchargés. Une modification du nom du fichier entraîne des messages d'erreur lors des tentatives de gravure car le nom correct est sauvegardé à l'intérieur de ces fichiers.
Si toutefois, vous modifiez le nom du fichier, vous devez aussi le modifier dans le fichier d'agencement correspondant. Pour les fichiers *.cue ceci peut facilement s'effectuer avec le bloc-notes de Windows mais les autres formats requièrent généralement des éditeurs hexadécimaux tels que UltraEdit ou WinHex.

Essayer de transférer toutes les parties des fichiers en UL
Cette option ordonne à eMule d'envoyer des données jusqu'à ce qu'un morceau soit complet. L'avantage de ceci est l'augmentation de la disponibilité des fichiers dans la mesure où seuls des morceaux entiers peuvent être échangés. Lors de la release d'un nouveau fichier, cette option est extrêmement utile, mais de toute façon, il est recommandé de l'employer.

Télécharger la 1ère et la dernière partie d'abord
Pour que la fonction de prévisualisation marche, il faut que le premier et le dernier morceau aient été téléchargés. Cette option tente de les obtenir en premier. Il n'est pas recommandé de l'activer car cela a des effets néfastes sur la disponibilité et la distribution des fichiers.

Regarder le presse-papiers pour les liens ED2K
Lorsqu'un lien eD2k est copié, à partir d'un site internet ou de toute autre source, en utilisant les touches CTRL+c, un message apparaît demandant si ce fichier doit être ajouté à la liste des transferts.

Lancer prochain fichier en pause quand un est terminé
Si un fichier vient d'achever son téléchargement alors que d'autres sont en pause dans la liste des téléchargements, l'un deux est automatiquement relancé.

o Préférer la même catégorie
Cette option n'est disponible que si Lancer prochain fichier en pause quand un est terminé est utilisé. Si les Catégories sont employées, eMule tente de relancer un fichier de la même catégorie que celui qui vient de se terminer.

Lecteur Vidéo
Si le champ est laissé vide, eMule utilise le lecteur multimédia par défaut associé à ce type de fichier lors de la prévisualisation de vidéos. Si le chemin vers un autre lecteur est indiqué, il sera utilisé à la place du lecteur par défaut. Généralement, les lecteurs multimédias ont besoin d'un fichier temporaire car ils ont de la difficulté à gérer les espaces vides des fichiers vidéos incomplets. Si un lecteur par défaut est utilisé, la case Faire une sauvegarde pour prévisualiser devrait être cochée. Un lecteur qui ne nécessite pas ce fichier temporaire est le client VCL - VideoLAN qui peut être utilisé pour la prévisualisation au lieu du lecteur par défaut. Pour plus d'informations consultez aussi la page Prévisualisation des fichiers.

S'applique à la version : .29b +
Dernière mise à jour le : 20/06/03 par Monk


FAQ eMule :: Préférences - Alertes

Préférences - Alertes

Certains évènements provoquent l’apparition d’alertes sous la forme d’un petit graphique qui surgit dans le coin inférieur droit de l’écran. Cette fenêtre apparaît même lorsque vous regardez un film ou que vous êtes en train de jouer.

Système d'alertes
o Utiliser un son
Si vous cochez cette option, vous devez entrer le chemin d’un fichier son dans le champ situé au-dessous. Ce son sera joué lorsqu’un événement surviendra.

Afficher une alerte pour
o Une nouvellle entrée dans la fenêtre de log
Tout événement de la rubrique Serveur entraîne l’affichage du Log dans la fenêtre pop up.

o Le début d'une session de Chat
A l’initiation d’une session dans la rubrique Messages

o Un nouveau message est arrivé
A l’arrivée d’un nouveau message. De plus l’icône [image] apparaît.

o Un téléchargement est ajouté ou terminé
Chaque fois qu’un téléchargement est fini ou ajouté via un lien web/irc ou une recherche.

o Une nouvelle version d'eMule a été détectée
Un message signale qu'eMule a détecté une nouvelle version disponible en téléchargement à l'adresse www.emule-project.net

o Urgent: Espace disque insuffisant, connexion au serveur perdue
S’il n’y a plus d’espace disque disponible, le statut de téléchargement se règle sur pause. Signale aussi parfois un fichier erroné dont le téléchargement est achevé.

S'applique à la version : .27a +
Dernière mise à jour le : 12/03/03 par Monk


FAQ eMule :: Préférences - Statistiques

Préférences - Statistiques

Graphiques
o Délai mise à jour
Détermine la fréquence de rafraîchissement des graphiques. Un réglage de cette valeur trop bas c’est-à-dire entraînant des mises à jour très rapprochées, peut avoir un impact sur le taux d’utilisation du CPU de votre ordinateur.

o Durée pour le graph. de moyenne
Par défaut, le graphique des moyennes est calculé sur les valeurs des 5 dernières minutes. C’est un indicateur des performances à long terme.

o Couleurs
Choisissez, dans la liste déroulante, quelle partie de l'affichage des statistiques doit être modifiée et utilisez le sélecteur de couleurs pour en appliquer une. Même la couleur du petit indicateur de vitesse près de l'icône d'eMule dans la zone de notification peut être changée.

o Echelle de l'axe Y pour les stats des connexions
Dans le tableau des statistiques, au-dessous de l'arbre statistique détaillé, un graphique indique le nombre de connexions actuellement actives et le nombre d'uploads et de downloads. Ce graphique se présente généralement avec une échelle de 0 à 100. Ce réglage permet de modifier l'échelle, ce qui permet d'augmenter ou de diminuer la résolution du graphique.

o Ratio connexions actives
En fonction des connexions internet et des paramètres, le nombre de connexions bien que très dynamique se situe en général au-dessus de 100. Ce réglage permet de diminuer l'échelle et donc d'afficher le graphique des connexions dans son intégralité. Par exemple, un rapport 1 : 4 , divise le nombre de connexions actives par 4 avant de l'afficher dans le graphique.

Astuce :
Pour augmenter la résolution du nombre des uploads et des downloads, tout en continuant d'afficher le graphique complet des connexions, les deux réglages décrits ci-dessus sont utiles. La diminution de Connections Statistics Y-Axis Scale augmente la résolution du graphique des uploads et des downloads et l'augmentation de Active Connections Ratio autorise l'affichage complet du graphique.

Arbre de statistique
o Délai mise à jour
Intervalle de rafraîchissement de la liste statistique détaillée. Voir la remarque sur l’usage du CPU dans Délai de mise à jour à la rubrique Graphiques ci-dessus.

S'applique à la version : .29a +
Dernière mise à jour le : 03/06/03 par Monk


FAQ eMule :: Préférences - IRC

Préférences - IRC

Serveur
Le serveur IRC officiel par défaut est irc.liquidirc.com.

Surnom
Pour IRC, entrez un pseudo différent de celui que vous avez renseigné dans l’onglet Général.

Liste des channels
o Utiliser un filtre pour la liste de channels
Les filtres peuvent être soit un Nom soit un certain nombre d’Utilisateurs. La liste n’affichera que les channels comportant ce Nom ou un nombre d’Utilisateurs supérieur à la limite entrée.

o Exécution
Cette option permet l’exécution d’une action lors de la connexion. Il peut être utile d’automatiser la commande /join [#channel name] ou /ns identify [pwd]. Des commandes multiples peuvent être entrées en les séparant par |.

Exemple:
/ns identify [pwd] | /join #emule-french

o Se connecter aux canaux d'aide
L'activation de cette option permet à eMule de rejoindre automatiquement les canaux IRC officiels d'aide.

Options diverses
o Ajouter l'heure au début des messages
L’heure courante est affichée au début de chaque message

o Charger la liste des channels à la connexion
Affiche automatiquement dans un tableau séparé, la liste de tous les channels disponibles du serveur connecté.

o Ignorer les messages d'info.
Empêche l’affichage des informations sur les channels comme joins ou quits. La séance de chat présente un aspect plus « propre ».

o Ignorer les messages d'eMule Proto
Identique à l'option ci-dessus. Permet d'ignorer les messages du protocole eMule dans le channel.

o Accepter les liens eD2k dans IRC (Utiliser avec précaution)
Lorsqu'elle est activée, cette fonction ajoute automatiquement tous les liens, postés dans un salon de discussions, directement dans la liste des téléchargements.
Afin d'éviter de lancer des liens non désirés, cette option devrait être couplée à l'option Venant d'amis seulement. Si cette dernière option est activée, les seuls liens acceptés seront ceux qui viennent d'utilisateurs figurant dans votre liste d'amis de la fenêtre des Messages d'eMule.

S'applique à la version : .30a +
Dernière mise à jour : 24/10/03 par Monk


FAQ eMule :: Préférences - Planification

Préférences - Planification

La planification est utilisée pour affiner les réglages d'eMule en fonction d'une heure de la journée ou d'un jour de la semaine. Elle peut être utile pour augmenter l'émission et la réception durant la nuit alors que la bande passante demeure libre pour d'autres application pendant les heures de travail.

La planification permet la création de profils avec une ou plusieurs actions à accomplir à l'heure et au jour prévus.
La première liste affiche les Profils avec Le titre, Les jours où doivent s'exécuter les actions et l'Heure de Démarrage. A la sélection de chaque profil, les actions définies et leurs horaires s'affichent dans la zone des Détails.

o Activé
Active la planification.

o Supprimer
Supprime le profil d'action en surbrillance.

o Nouveau
Crée un nouveau profil d'action. Les nouveaux profils sont automatiquement affichés dans la vue des Détails afin d'établir les réglages appropriés.

Détails
Cette zone affiche les réglages en cours et les actions prévues pour le profil d'action sélectionné.

o Activé
Cette boite à cocher active le profil sélectionné. Un ou plusieurs profils peuvent être activés en même temps.

o Titre
Titre ou description du profil.

o Temps
Les actions peuvent être exécutées quotidiennement ou seulement certains jours de la semaine. Chaque action doit comporter une Heure de démarrage et une Heure d'arrêt.
Si aucune action n'est valide à un moment donné, eMule utilise automatiquement les réglages par défaut des autres dialogues de Préférences.

Créer des actions dans un profil
En premier lieu, un profil doit être créé en pressant le bouton Nouveau. Après avoir renseigné le Titre ainsi que l'Heure de démarrage et l'Heure d'arrêt pour le profil, de nouvelles actions sont créées par utilisation du menu de bouton droit de la souris dans la liste Action.

o Ajouter
Crée une nouvelle action dans le profil sélectionné. Après avoir choisi quelle type d'action créer, un message apparaît. Entrez la valeur appropriée pour chaque action pour modifier :

> | Limite E Définit la bande passante maximale en émission en kB/s qu'eMule peut utiliser.
> | Limite R Etablit la bande passante maximale en réception allouée à eMule. Valeur en kB/s.
> | Limite sources Modifie le nombre de sources autorisées (Limite forte) pour un téléchargement.
> | Limite connexions/5secs Modifie le nombre de nouvelles connexions ouvertes en 5 secondes. Cette valeur peut avoir un impact sérieux sur les performances d'eMule. Voir les Préférences -> Propriétés étendues pour plus de détails.
> | Connexions max. Remplace le nombre maximal de connexions des Préférences -> Connexions.
> | Cat : Arrêt réceptions Cette action arrête tous les téléchargements de la Catégorie choisie.
> | Cat : Reprise réceptions Relance tous les téléchargements en pause dans la catégorie choisie.

Toutes les modifications dans les paramètres d'un profil doivent être confirmées par la pression du bouton Appliquer.

o Editer
Modifie la valeur de l'action choisie.

o Supprimer
Supprime l'action sélectionnée.

S'applique à la version : .28a +
Dernière mise à jour le : 02/04/03 par Monk


FAQ eMule :: Préférences ServeurWeb

Préférences - Interface Web

L'Interface Web offre un accès à distance à eMule. Pour plus d'informations, lisez l'article sur l'Interface Web dans la rubrique de cette FAQ qui traite des Fonctions.

Modèles :
L'Interface Web ne peut fonctionner que si le fichier nommé eMule.tmpl est présent. Ce fichier contient le plan et l'aspect général de l'interface du serveur web. Ce fichier est soit distribué avec les versions d'eMule, soit disponible en téléchargement sur www.emule-project.net.
Les ressources images doivent être placées dans le dossier Webserver du répertoire d'installation d'eMule.

Général

o Activé
Cochez cette case pour activer l'Interface Web. Après avoir activé l'option, le modèle qui génère l'interface doit être rechargé en pressant le bouton Recharger modèle. Si aucun fichier eMule.tmpl valide n'est trouvé, le message Ne peut charger modèles : Ne peut ouvrir le fichier \eMule.tmpl s'affiche.
N'activez pas le serveur web tant que vous n'utilisez pas cette fonction. Lancer des serveurs fait courir un risque potentiel de faille de sécurité.

o Port
Détermine le port sur lequel s'exécutera le serveur web. Le port par défaut est le 4711 et il n'est généralement pas besoin d'en changer. Ce port est une partie de l'adresse pour accéder à l'interface web.
Si ce port est bloqué par un pare-feu ou un serveur proxy sur l'ordinateur qui tente d'accéder au serveur web, vous pouvez entrer le port 80. Ce port est utilisé pour la navigation sur internet, il est donc rarement bloqué.
Si vous utilisez un routeur, ce port doit être acheminé.

o Modèle
Généralement, le fichier de modèle *.tmpl se trouve dans le dossier d'installation d'eMule. Le bouton ... permet de modifier facilement le chemin vers ce fichier.

Administrateur
Permet d'établir les mots de passe nécessaire à l'accès à l'Interface Web. Il est très important d'entrer un mot de passe correct sinon n'importe qui pourra accéder à votre eMule via l'interface web. Le mot de passe entré est affiché sous forme de six étoiles ***. Il n'y a aucun mot de passe par défaut.

Invité

o Activé
Contrairement à l'administrateur, qui a accès aux contrôles d'eMule, l'Invité ne peut que voir les réglages et les listes. Il n'a pas l'autorisation de changer quoi que ce soit. Si une connexion pour un invité n'est pas nécessaire, l'option devrait être désactivée.

o Mot de passe
Définit un mot de passe pour restreindre l'accès à l'interface Invité. Il n'y a pas non plus de mot de passe par défaut.

Note:
Parfois, pour les utilisateurs d'Internet Explorer de Microsoft, au lieu d'afficher la liste choisie, le serveur web ouvre une fenêtre de dialogue de téléchargement. Pour empêcher cela, les options Utiliser HTTP 1.1 et Utiliser HTTP 1.1 avec une connexion par proxy doivent être cochées dans Outils -> Options Internet-> Avancé : Paramètres HTTP 1.1

MobileMule
MobileMule est une interface sur laquelle peut se connecter tout téléphone cellulaire compatible java. De la même manière que l'interface web, cela permet un contrôle à distance d'eMule via un téléphone mobile. Pour de plus amples informations, visitez la page de MobileMule http://mobil.emule-project.net/.

o Activer MobileMule
Autorise l'accès à eMule via un téléphone cellulaire compatible java.

o Mot de passe
Aucun mot de passe par défaut n'est entré. Pour des raisons de sécurité, un mot de passe devrait toujours être spécifié lorsque l'interface est activée.

o Port
Règle le port permettant l'accès à l'interface de MobileMule. Si la machine sur laquelle fonctionne eMule se trouve derrière un routeur ou un pare-feu, ce port doit être acheminé / ouvert, faute de quoi, la connexion sera impossible.

S'applique à la version : .30a+
Dernière mise à jour le : 24/08/03 par Monk


FAQ eMule :: Préférences - Securité

Préférences - Sécurité

Filtres IP
Les filtres IP restreignent les connexions en provenance ou en direction d'autres clients. Toutes les IP comprises dans les intervalles entrés dans le fichier ipfilter.dat ne peuvent pas se connecter à eMule et eMule ne peut pas se connecter à elles. Ce fichier s'édite grâce au bouton "éditer" et est sauvegardé dans le dossier d'installation d'eMule. Pour plus d'informations sur le filtrage des IP, lisez le sujet qui en traite dans cette FAQ.
Pour que les modifications apportées à ce fichier ipfilter.dat s'appliquent, eMule doit le recharger.

o Niveau de filtrage
A chaque entrée du fichier ipfilter.dat est assigné un niveau d'accès. Cette valeur définit le niveau de confiance de cette entrée. Les valeurs élevées (par défaut 128+) sont considérées comme sûres alors que les valeurs plus faibles sont bloquées. Le Niveau de filtrage détermine la limite du blocage. Chaque entrée du fichier ipfilter.dat dont le niveau d'accès est inférieur ou égal au réglage du Niveau de filtrage se voit refuser toute connexion au client eMule. La valeur par défaut ne devrait pas être modifiée.

o Filtres Serveurs
Le filtrage d'IP n'est en général valide que pour les autres clients. Cette option l'étend aux serveurs.

Messages
Les messages indésirables peuvent être bloqués en les entrant dans ce champ. Si le texte envoyé est identique, il ne s'affiche pas. Plusieurs messages peuvent être indiqués en les séparant par | .

o Autoriser seulement les amis
Tous les messages sauf ceux des utilisateurs qui se trouvent dans la liste des amis seront bloqués.

o Autoriser seulement les clients valides
Ce réglage assure que les messages ne seront acceptés que si le client expéditeur est valide et n'apparaît pas falsifié. Ce réglage devrait être activé.

o Filtre anti-spam avancé
Le filtre avancé de spam vérifie tous les messages entrants. Lorsqu'un de ces critère de filtrage se présente, l'expéditeur du message est banni. Un bannissement pour spam dure seulement pendant toute la session en cours.
> | Une adresse web ou une URL est envoyée lors du premier contact
> | L'utilisateur a déjà envoyé 5 messages sans obtenir de réponse.

Les utilisateurs de la liste d'Amis ne sont jamais considérés comme des spammers.

Commentaire
Cette fonction est similaire au filtre des messages vu plus haut, mais elle s'applique aux commentaires des fichiers.

Note:
Les commentaires sur les fichiers devraient aider les autres utilisateurs à juger de la qualité d'un téléchargement. Ils n'ont pas pour vocation de discuter de la pluie et du beau temps ou de communiquer des messages publicitaires. Nous vous remercions d'émettre des commentaires corrects.

Options diverses
o Utiliser l'identification sécurisée
Il est recommandé d'utiliser l'identification sécurisée. Pour plus d'informations sur ce sujet voir ici.

S'applique à la version : .29b +
Dernière mise à jour : 20/06/03 par Monk


FAQ eMule :: Préférences - Propriétés étendues

Préférences - Propriétés étendues

Max. nouvelles connexions / 5 secs
C’est le nombre de nouvelles connexions qu’ouvre eMule pendant une période de 5 secondes. Le réglage par défaut est de 20.

Important:
> | Une valeur inappropriée peut provoquer l’apparition d’écran bleus, des blocages de routeurs et l’impossibilité de surfer sur le net. De plus, les téléchargements et les uploads peuvent souffrir de ce mauvais réglage.
> | Vous pouvez légèrement augmenter ce réglage lorsque vous utilisez eMule avec une connexion dont la bande passante est importante : Tx ou Réseau.

o Débogage
Si ce mode prolixe est activé, un tableau de débogage additionnel est affiché dans la fenêtre des Serveurs. Les informations qui s'y trouvent ne sont utiles qu'au développement. Aucun support supplémentaire ne sera apporté à ce sujet. Cette option entraîne une forte charge de la mémoire et du CPU, elle n'est donc pas conseillée en fonctionnement normal.

Liens ED2K actifs quand eMule fonctionne
eMule est automatiquement lancé en cliquant sur un lien web spécial dans votre explorateur. Cette option empêche ce comportement.

Utiliser le système de crédits (Récompense les envois)
Avant tout, reportez-vous au chapitre Système de Crédit pour plus d'informations. Il est fortement recommandé de laisser le Système de Crédit activé car il dissuade les leechers (profiteurs) de nuire au réseau.
Les raisons d'être de cette option sont :
> | Les "releasers" peuvent désormais s'assurer qu'aucun autre fichier ne sera prioritaire sur leur release en désactivant cette option.
> | Un réseau polymorphe résiste mieux aux tentatives d'attaque contre un système.
> | Un meilleur équilibre entre les fichiers rares et les fichiers populaires.

Filtrer les IP locales serveur et client
Les sources qui contiennent des IP des classes privées A (1.0.0.1 à 126.255.255.254), B (128.0.0.1 à 191.255.255.254 ), C (192.0.0.1 à 223.255.255.254) et l'hôte local (127.0.0.0 à 127.255.255.254) ne sont pas valides sur l'internet. De telles sources, qu'elles soient reçues par échange de client à client ou par les serveurs sont éliminées lorsque ce filtre est activé..

Note:
Si vous utilisez eMule en réseau local (LAN) vous devez désactiver cette option sinon eMule sera incapable de trouver une seule source sur ce réseau.

Montrer plus de contrôles (mode contrôles avancés)
Cette option active encore plus de fonctions dans eMule qui ne sont en général pas utiles à son fonctionnement habituel.

o Montrer les métadonnées
C'est une commande du menu sur clic droit que l'on peut appliquer à un téléchargement dans la fenêtre des Transferts. Cela affiche des informations complémentaires qui ont pu être jointes à ce fichier telles que le label d'ID d'un mp3, son auteur, l'année, etc.

o Gestion des sources (A4AF)
eMule n'utilise qu'un accès en file d'attente chez un client distant. Il est impossible d'obtenir simultanément, d'un autre client, deux places en file d'attente. Lorsqu'un client est une source pour plus d'un téléchargement, un seul reçoit une valeur de QR, alors que les autres affichent l'avertissement Demande un autre fichier dans le statut de la source.
La gestion manuelle des sources permet de spécifier quel téléchargement doit recevoir le QR des autres sources. Trois fonctions sont prévues pour déplacer les sources entre les téléchargements :

Passer toutes les sources à ce fichier
C'est un déplacement unique des sources ayant une remarque Demande un autre fichier concernant un téléchargement. Toutes les sources qui affichaient auparavant l'avertissement, recevront l'assignation d'un QR. En conséquence, les téléchargements d'où proviennent ces sources, affichent maintenant pour chacune d'elle le statut A4AF.

Passer toutes les sources à l'un des autres fichiers
Si un téléchargement n'est pas jugé prioritaire, on peut utiliser cette fonction pour tenter de réassigner, si cela est possible, ses sources aux autres téléchargements.

Passer automatiquement toutes les sources (A4AF) à ce fichier
De la même manière que Passer toutes les sources à ce fichier, cette fonction veille à ce que les sources accordent toujours leur préférence à ce téléchargement lors de la requête d'un QR.

o Affiche le nombre de sources auxquelles on demande un autre fichier avec +xx pour chaque téléchargement
Indique le nombre des sources A4AF pour chaque téléchargement dans la liste des transferts.

Intervalle de rafraîchissement de la connexion serveur
Dans certains cas, eMule perd la connexion au serveur à intervalles réguliers lorsqu'elle opère derrière un routeur ou une configuration de réseau qui utilise le NAT - Network Address Translation (Traduction d'adresses de réseau).
Les routeurs ont souvent un délai maximal pour ce type de connexions, après quoi, la connexion est déclarée morte et est fermée. Lorsque cela se produit et qu'eMule tente de vérifier la présence du serveur, une nouvelle connexion est nécessaire car l'ancienne a été supprimée par le routeur.
Si vous êtes victimes de ce phénomène, recherchez la valeur d'expiration du délai dans les paramètres de votre routeur et entrez une valeur très légèrement inférieure dans le champ Server Connection Refresh Interval. Une valeur de 0 signifie qu'eMule gère cela et il n'est en général pas nécessaire de la modifier !
Ne touchez pas à ce réglage si vous n'avez pas de routeur ni de réglages de réseau compliqués. Ceci peut vous amener à un bannissement des serveurs si la valeur que vous entrez est trop basse.

Sauver les journaux sur le disque
Les deux fenêtres de log de la fenêtre des Serveurs - Log et Debug - peuvent être sauvegardées sous forme de fichiers sur le disque, en cochant la case désirée. Ces fichiers se nomment eMule.log et eMule_Debug.log et se trouvent dans le dossier d'installation d'eMule.

Ecriture sûre des fichiers .met/.dat
Sur les systèmes d'exploitation récents utilisant NTFS comme système de fichier, il n'est, en principe, pas nécessaire de modifier cette option. Si les téléchargements sont régulièrements perdus au cours de plantages d'eMule ou lors de la fermeture d'eMule, vous devez essayer la méthode sécurisée.
En fonction du disque dur utilisé, cette option peut augmenter significativement l'activité du disque dur et la charge du système. Ceci peut allonger la phase de fermeture d'eMule !

o A la fermeture
eMule utilise des mesures de sécurité supplémentaires pour consigner les fichiers .met and .dat sur le disque dur lors de l'arrêt de l'application. Ceci peut allonger la phase de fermeture d'eMule.

o Toujours
Les mesures de sécurité sont utilisées lors de chaque accès en écriture à ces fichiers.

Vérifier l'espace disque (Min. d'espace disque [Mo])
La taille temporaire des fichiers en cours de téléchargement augmente dynamiquement à la demande. L'option Vérifier l'espace disque s'assure que les téléchargements en cours pourront être entièrement obtenus. Les téléchargements trop volumineux pour la place disponible à un instant donné sont mis en pause afin que les autres fichiers puissent se terminer.
Si vous entrez une valeur pour le min. d'espace disque, le comportement d'eMule est modifié. Dans ce cas, tous les fichiers sont téléchargés, jusqu'à ce que la limite fixée d'espace libre sur le disque dur, soit atteinte.
Lorsque l'espace libre augmente, les téléchargements en pause sont relancés automatiquement.

Nom d'hôte pour mes propres liens eD2k
Dans la fenêtre des Partages, des liens utilisant l'IP actuelle comme source, peuvent être créés. Inscrire un nom d'hôte dans ce champ, permet la création de liens utilisant ce nom d'hôte au lieu de l'IP. L'avantage de cette manipulation est que le lien demeure valide, même si votre IP change.
Pour de plus amples informations concernant les noms d'hôtes dynamiques, reportez-vous au chapitre Interface Web.

Taille fichier buffer
Certains systèmes peuvent présenter une sorte de "bégaiement" lorsqu'eMule vidange ses caches (buffers) de fichiers. Dans ce cas, une diminution de la taille du buffer peut améliorer les choses mais aux dépens d'une activité du disque dur plus intense résultant d'écritures plus fréquentes. Un réglage trop bas de la taille du buffer peut donc gravement nuire aux performances d'eMule.
L'augmentation de la taille du buffer réduit l'activité du disque dur mais peut générer, elle aussi, des problèmes dans la mesure où cela accroît la probabilité de pertes de données.

Taille file d'attente
Pour que le système de crédit d'eMule fonctionne correctement, la taille de la file d'attente est très importante. Si un client présente une file d'attente pleine, un autre client avec un fort coefficient de crédit n'a aucune chance d'y entrer pour y "dépenser" son crédit. Aussi, le système de crédit fonctionne d'autant mieux et en douceur que la file d'attente est de grande taille. Les clients possédant un crédit élevé, avancent suffisamment rapidement dans les longues files d'attentes pour recevoir les fichiers qu'ils demandent. De plus, le temps d'attente n'est pas réduit lors de la reconnexion due à un changement d'IP ou autre. Le temps avant la reconnexion ne doit jamais dépasser une heure sinon la position dans les files d'attente sera perdue.

Important :
Une file d'attente plus longue ne crée pas un surplus de bande passante pour la gérer. Ni le nombre de connexions, ni le surplus de bande passante nécessaire aux connexions ne sont augmentés par une file d'attente plus longue. Cependant, ces files d'attente longues peuvent consommer plus de mémoire.

S'applique à la version : .30c +
Dernière mise à jour le : 24/10/03 par Monk


FAQ eMule :: Préférences - Preferences.ini

Préférences - Preferences.ini

Tous les paramètres d'eMule sont enregistrés dans le fichier preferences.ini. Toutes les options importantes sont facilement accessibles par le dialogue des Préférences mais le fichier preferences.ini permet de modifier quelques options supplémentaires. Pour cela, il faut ouvrir le fichier à l'aide d'un éditeur de texte et lui apporter des modifications manuellement. Les modifications de ce fichier sont réservées aux utilisateurs expérimentés car des valeurs inapropriées peuvent produire des effets indésirables. Fermez eMule avant cette édition.

o TxtEditor=notepad.exe
Le programme par défaut pour l'édition des fichier webservices.dat et ipfilter.dat doit être entré ici. l'utilisation d'un autre programme que notepad.exe nécessite que son chemin d'accès complet soit indiqué.

o DateTimeFormat=%A, %x, %X
Cette chaine définit comment la date et l'heure sont affichées dans eMule. Reportez-vous à cet article de msn pour obtenir une description de tous les codes de format possibles.

o MaxLogBuff=64 / 128 (v0.30a+)
Définit la quantité de mémoire système attribuée à eMule pour afficher les logs. Pour Windows 98 / ME, 64 kB sont réservés par défaut ; pour Win 2k/XP, ce sont 128 kB. Les logs tournent, ainsi si la mémoire tampon atteint sa limite maximale, le message le plus ancien est purgé lorsqu'un nouveau arrive (FIFO). Ce réglage remplace MaxLogMessages présent dans la v0.29.

o MaxChatHistoryLines=100
Definit le nombre maximal de lignes sauvegardées dans l'historique d'IRC ou des Messages. Lorsque cette valeur est atteinte, le message le plus ancien est purgé à l'arrivée d'une nouvelle entrée (FIFO - First In First Out = Premier entré, premier sorti).

o UseAutocompletion=1
Activation (=1) / Désactivation (=0) de l'historique et du complément automatique des valeurs précédemment entrées dans les diverses boites de texte telles que celle des URL de server.met ou celle des recherches. (v0.29d+)

o ExtractMetaData=1
Contrôle la manière dont les métadonnées sont lues à partir des fichiers. (v0.30a+)
0: désactivé
1: activé pour les fichiers MP3 et AVI
2: par défaut ; activé pour les MP3, AVI, MPEG et autres fichiers

o ServerUDPPort=65535
En principe, le port local pour demander des sources aux serveurs ou rechercher des fichiers est choisi aléatoirement. (Voir le sujet sur les ports - 6). Si eMule fonctionne sur une machine faisant partie d'un réseau plus complexe, surtout lorsque des proxies (serveurs mandataires) sont utilisés, il peut s'avérer nécessaire de spécifier un port précis ou de le désactiver complètement. La désactivation de ce port rend eMule incapable de mettre à jour le statut des serveurs présents dans sa liste, de recevoir des sources de ceux-ci et d'effectuer une recherche globale. Seule la communication avec le serveur auquel eMule est connectée, n'est pas affectée par ce réglage. En règle générale, le réglage par défaut ne doit pas être modifié.
Les valeurs possibles pour le port UDP du serveur sont :

0 | Désactivé
1 - 65534 | port local UDP fixe
65535 | port défini de manière aléatoire (par défaut)

o PreviewSmallBlocks=0
Cette fonction ne devrait être activée (=1) que lorsque l'on utilise le client VLC - VideoLAN pour prévisualiser les fichiers. Elle permet la prévisualisation des fichiers multimédias lorsqu'au moins 16 kB de données pour les fichiers .mpeg ou 256 kB pour tous les autres contenus multimédias (.avi, Images CD avec contenu multimédia), ont été téléchargés. Pour plus d'informations, voir les Préférences -> Fichiers -> Lecteur vidéo et le sujet Prévisualisation des fichiers. Lorsque cette option est utilisée, le réglage Faire une sauvegarde pour prévisualiser doit être désactivé dans le dialogue du Lecteur vidéo.

S'applique à la version : .30a +
Dernière mise à jour le : 23/08/03 par Monk


FAQ eMule :: Ports

Ports

La liste suivante est celle des ports utilisés par défaut dans eMule. Si vous modifiez quoi que ce soit dans Préférences -> Connexion vous devez le prendre en compte lors de la configuration de votre pare-feu ou de votre routeur.

1) Port Local : 4662
Port Distant : tous
Protocole : TCP
Direction : Entrant
Fonction :

Port Client / Connexions venant des autres clients, Echange de sources entre clients

Note :

Vous pouvez changer ce port dans Préférences -> Connexion -> Port Client
Ce port doit être acheminé en cas d'utilisation d'un routeur. Si vous changez ce port dans les préférences, n'oubliez pas de modifier l'acheminement au niveau du routeur
2) Port Local : tous
Port Distant : 4662
Protocole : TCP
Direction : Sortant
Fonction :

Port Client / Connexions aux autres clients, Echange de sources entre clients
Note :

4662 est le port par défaut, mais il se peut que les autres clients aient des réglages différents. Changez le Port Distant en Tous lors de la configuration d'un pare-feu.
3) Port Local : 4672
Port Distant : tous
Protocole : UDP
Direction : Entrant
Fonction :

Demande de sources aux clients / protocole eMule étendu, position dans la file d'attente, Ping nouvelle demande de fichiers.
Note :

Ce port doit être acheminé par le routeur. Si vous changez ce port dans les Préférences, vous devez aussi modifier l'acheminement par le routeur.
Si vous êtes incapable d'acheminer ce port cochez la case désactiver dans Préférences -> Connexion -> Port UDP
4) Port Local : tous
Port Distant : 4672
Protocole : UDP
Direction : Sortant
Fonction :

Demande de sources aux clients / protocole eMule étendu, position dans la file d'attente, Ping nouvelle demande de fichiers.
Note :

4672 est le port par défaut, mais il se peut que les autres clients aient des réglages différents. Changez le Port Distant en Tous lors de la configuration d'un pare-feu.
5) Port Local : tous
Port Distant : 4661
Protocole : TCP
Direction : Sortant
Fonction :

Connexion au serveur
Note :

4661 est le port par défaut des serveurs. De nombreux serveurs utilisent un port différent. Lors de la configuration d'un pare-feu, entrez Tous en Port Distant.
6) Port Local : tous
Port Distant : 4665
Protocole : UDP
Direction : Sortant
Fonction : Demande de sources aux serveurs
Note : Les Serveurs qui utilisent le port TCP par défaut 4661 (voir § 5) règlent automatiquement le port UDP 4665 pour leurs demandes de sources. Si un serveur utilise un port différent comme décrit au § 5, le port UDP correspondant est réglé sur [Port de connexion + 4]. Pour les pare-feu, le port distant dans ce cas est Tous.

Le protocole UDP est non orienté connexion. Contrairement au protocole TCP, aucune connexion n'est maintenue active. Ains,i si par exemple un serveur répond à une requête de sources, cette réponse est traitée comme une nouvelle connexion. Tous les routeurs et les pare-feu communément utilisés par le grand public effectuent un traçage de connexion UDP, c'est pourquoi, il n'est pas nécessaire de préciser un port UDP entrant lors de leur configuration. Les réseaux plus complexes, surtout ceux qui utilisent des serveurs proxies (serveurs mandataires), peuvent nécessiter que l'on définisse ce port local dans la configuration des routeur / pare-feu/ proxy, voire même qu'on le désactive totalement s'il est impossible de le contrôler. Ce port peut être réglé. Voir l'explication contenue dans la page Préférences -> Preferences.ini. Toutefois, généralement, il est inutile de modifier ce paramètre.

7) Port Local : 4711
Port Distant : tous
Protocole : TCP
Direction : Entrant
Fonction : ServeurWeb
Note: C'est le port par défaut pour l'interface web. Si vous utilisez un routeur, ce port doit être acheminé sinon aucune connection au serveur web ne sera possible.

Dernière mise à jour le : 23/08/03 par Monk


FAQ eMule :: Pare-feu

Pare-feu

Pare-feu
Tous les ports mentionnés ici doivent être ouverts dans les règles du pare-feu. Comme la majorité des pare-feu utilisés sous Windows comportent un filtrage logiciel, vous pouvez vous épargner bien des difficultés en ajoutant une règle qui autorise a eMule.exe tout trafic UDP et TCP sur tous les ports et dans toutes les directions. Ceci ne devrait pas compromettre votre sécurité dans la mesure où jusqu’à ce jour, aucune intrusion dans un système par l’intermédiaire d’eMule n’a été rapportée.

Notes:
- ZoneAlarm est connu pour causer des problèmes avec eMule. Son utilisation n’est pas recommandée. Des pare-feu efficaces et gratuits existent : Kerio Personal Firewall et Agnitum Outpost

- J’ajouterai plus d’exemples de configuration lorsque j’aurai un peu de temps. Si vous voulez apporter votre contribution, écrivez un bon petit guide sur la manière d’utiliser votre pare-feu favori. Ajoutez-y quelques jolies captures d’écran et envoyez-le à Monk@emule-project.net

Dernière mise à jour le : 14/12/02 parMonk


FAQ eMule :: ICF

Pare-feu de connexion internet de Windows XP

Le pare-feu de Windows XP n’est généralement pas recommandé car il est vraiment très basique. Mais si vous désirez l’utiliser tout de même, ces quelques étapes sont nécessaires :

1. | Ouvrir eMule
2. | Cliquer sur Préférences > Connexion
3. | Entrer la valeur du port client (par défaut 4662)
4. | Noter la valeur du port UDP (défaut 4672)
5. | Fermer eMule et votre connexion internet
6. | Sous Windows XP cliquez sur Démarrer, puis sur Favoris Réseau.
7. | Allez dans Gestion du Réseau, Cliquez sur Afficher les connexions réseau (Vous pouvez aussi faire un clic droit sur Favoris Réseau puis sur Propriétés.)
8. | Faites un clic droit sur votre connexion internet et choisissez Propriétés
9. | Cliquez sur l’onglet Avancé, puis sur Réglages. Si le bouton de réglages n’est pas disponible, le pare-feu (ICF) n’est pas opérationnel pour cette connexion et vous n’avez pas besoin d’ouvrir un seul port (ils sont déjà tous ouverts).
10. | Cliquez sur Ajouter pour ouvrir un nouveau port.
11. | Entrez un nom dans le champ Description, par exemple, "eMule : TCP Entrant".
12. | Entrez 127.0.0.1 dans le Nom ou l’adresse IP de l’ordinateur hébergeant ce service sur votre réseau privé. Vous pouvez spécifier l’adresse IP d’un ordinateur appartenant à un réseau ; toutefois, dans la majorité des cas, vous utiliserez 127.0.0.1
13. | Entrez le port client que vous avez inscrit dans l’étape n° 3 dans les champs port Externe et port Interne.
14. | Choisissez TCP, et cliquez sur OK.
15. | Cliquez sur Ajouter pour ouvrir un nouveau port.
16. | Cette fois-ci, choisissez un nom de type "eMule : UDP Entrant"
17. | Voir étape n° 12
18. | Ici, la valeur du port Externe et Interne est celle entrée à l’étape n° 4.
19. | Choisissez UDP, et cliquez sur OK.
Si vous changez ultérieurement votre port client, vous devrez reconfigurer la règle ci-dessus.

Pour de plus amples informations, cliquez sur l’un des articles suivants dans la base de connaissance de Microsoft :

Q308127 How to Manually Open Ports in Internet Connection Firewall in Windows XP
Q283673 How to Enable or Disable the Personal Firewall Feature in Windows XP
Q307554 Programs Require Manual Port Configurations with Internet Connection Firewall

F283673 Procédures pour activer la fonctionnalité Pare-feu de connexion Internet dans Windows XP
F307554 Certains programmes nécessitent une configuration manuelle des ports avec pare-feu de connexion Internet

(this nice ICF how to was adopted from -nRoK-. Remerciements)

Dernière mise à jour le : 14/12/02 par Monk


FAQ eMule :: Routeurs

Routeurs

Si vous ne configurez pas correctement votre routeur, vous obtenez une ID faible (“low ID”). Un routeur fonctionne comme un bouclier protégeant le réseau situé derrière lui, en masquant les adresses IP des ordinateurs du réseau local. Lorsqu’un autre client tente de se connecter à votre eMule, il ne voit que l’IP de votre routeur mais pas l’IP réelle de votre ordinateur. Pour remédier à cela, tous les ports entrants de la liste – le port 4662, 4711 TCP et le port 4672 UDP – doivent être réacheminés.
Consultez le manuel de votre routeur. Les mots clés pour bien commencer sont : réacheminement de port (port forwarding), Zone démilitarisée (Demilitarized Zone – DMZ), Filtres et Règles.
De nombreux routeurs possèdent des pare-feu intégrés, aussi pour être certain d’agir sur les ports appropriés, consultez la rubrique sur les pare-feu.

Note :
Lorsque vous utilisez un routeur sur un réseau local l'option DHCP - Dynamic Host Configuration Protocol - du routeur devrait être désactivée. Assignez une IP statique à chaque client du réseau. Cela se règle dans les Connexions réseau et accès à distance de Windows -> Connexion au réseau local -> Propriétés -> TCP/IP. Désactivez obtenir une IP automatiquement et entrez une IP du type 192.168.xxx.xxx. Les différents routeurs acceptent différentes fourchettes d'IP, ceci est spécifié dans le manuel du routeur.
Après avoir entré une IP valide, le champ du Masque de sous-réseau inscrit automatiquement la valeur 255.255.255.0. La dernière étape consiste à entrer l'IP de votre routeur dans Passerelle par défaut.

Si vous savez configurer votre routeur et que vous pensez pouvoir aider les autres utilisateurs, écrivez un petit guide et envoyez-le à Monk@emule-project.net

Note:
Si votre type de routeur n’est pas référencé, consultez tout de même les exemples car les réglages des différents types de matériel sont en général très similaires.

Dernière mise à jour le : 22/03/03 par Monk


FAQ eMule :: Solwise SAR-7x5

Solwise SAR-7x5

Note:
Nous supposons que votre pare-feu est désactivé et que vous êtes sous une configuration NAT.

Premièrement, allez sur la page web de configuration de votre routeur à l'aide de votre navigateur internet. Par défaut c'est l'adresse http://192.168.7.1

Puis cliquez sur Advanced Configuration sur la gauche.

Cliquez sur Security/NAT dans la liste d'options qui s'ouvre.

Ensuite, sur la page qui se charge, recherchez Security Interfaces.

Cliquez sur Advanced NAT Configuration sous la connexion ppp-0. Un écran se charge, recherchez Reserved Mappings.

Dans cette section cliquez sur Add Reserved Mapping.

Voilà la partie délicate. Suivez la capture d'écran et appuyez sur Add Reserved Mapping lorsque c'est fini.
Vous devez faire cela deux fois, une fois pour le port 4662 TCP et une autre pour le port 4672 UDP.

Important :
Vous devez entrer l'IP de la machine sur laquelle tourne le programme eMule. Pour vérifier votre IP allez à Windows Menu démarrer -> Paramètres -> Connexions réseau. Mettez en surbrillance votre connexion réseau, faites un clic droit et choisissez dans la liste contextuelle Propriétés. Choisissez Protocole internet (TCP/IP) et cliquez encore sur Propriétés. La boite de dialogue montre votre adresse IP courante.

Une fois que vous avez fait cela, sauvegardez votre configuration en cliquant sur System dans le menu de gauche, puis sur Save config.

Vous avez configuré avec succès votre routeur SAR7x5 pour l'utilisation d'eMule.

Ce bon guide a été réalisé par aldo. Merci beaucoup.

Dernière mise à jour le : 15/12/02 par Monk


FAQ eMule :: Lucent CellPipe 20A-GX-E

Lucent CellPipe 20A-GX-E

Suivez ces quelques étapes pour configurer votre Lucent CellPipe pour utiliser eMule. Ces explications supposent que vous ayez une connexion DSL PPPOE active.
Démarrer une session telnet avec l'adresse IP de votre routeur. Pour se faire :
 | a) Utilisez l'Hyperterminal de Windows et inscrivez un Nom (peu importe lequel) pour la nouvelle session, choisissez TCP/IP (Winsock) comme type de connexion, puis entrez l'adresse IP de votre routeur comme adresse hôte
 | ou
 | b) Allez sur Démarrer -> Lancer -> IP routeur telnet
Dans la session telent qui s'ouvre entrez les commandes suivantes (chacune sur une ligne séparée) :
 | pat addpatin pppoe 4662/tcp IP du client pat addpatin pppoe 4672/udp IP du client save
L'IP Router est l'adresse IP de votre routeur CellPipe et IP du client est l'adresse IP de votre ordinateur sur lequel est installé eMule.

Grand merci à Jarek pour ce petit guide.

Dernière mise à jour le : 27/12/02 par Monk


FAQ eMule :: SMC Barricade 7004 ABR

SMC Barricade 7004 ABR

Avant-Propos :

Ce guide a été rédigé pour le SMC Barricade 7004ABR (eu) Firmware: V.1.40.02.
Je présume que la configuration est similaire voire identique pour les autres routeurs SMC.
Si votre routeur se configure de la même manière, merci de m'en faire part pour que je puisse faire une mise à jour.
Ce guide concerne les modèles suivants :

SMC Barricade 7004 ABR

SMC Barricade 7004 VBR (Remerciements à Ulf)

SMC Barricade 7004 BR (Remerciements à René) Voir la note du paragraphe 3.2 - Configuration des Ports

Ce guide est rédigé à partir d'un système d'exploitation allemand, aussi les captures d'écran sont en allemand. A part cela, tout devrait être identique chez vous.

Ce guide utilise des graphiques spécialement formatés qui permettent lors du passage de votre souris au-dessus d'eux, d'obtenir des indications complémentaires. Le curseur doit s'arrêter environ une seconde pour que les infobulles apparaîssent.

Si vous avez des commentaires, ou que vous souhaitez ajouter quelque chose, ou si vous avez des questions à propos de ce guide, contactez-moi. (En anglais ou si vous voulez en allemand)

Avant-Propos - Ce qu'il faut lire avant toute chose

Etape 1. - Commencer la configuration du routeur

  • 1.1 - L'écran de connexion

Etape 2. - Comment trouver votre IP réseau

  • 2.1a - Sous Windows 2000
  • 2.1b - Sous Windows 9x et ME

Etape 3. - Configurer votre routeur pour éviter une ID faible (LowID)

  • 3.1 - Commencer la configuration virtuelle du Serveur
  • 3.2 - Configuration des Ports

Divers - Ce qu'il faut aussi savoir.

  • D.1 - Comment configurer le routeur pour deux PC
  • D.2 - Aide pour ceux qui expérimentent des plantages du routeur

Fin - Quelques problèmes et Remerciements.

Etape 1. - Commencer la configuration du routeur

Pour commencer la configuration de votre SMC Barricade 7004 ABR, vous devez seulement aller à l'adresse IP de votre routeur avec un navigateur internet.
L'IP standard est réglée sur 192.168.2.1, aussi l'adresse par défaut où il faut vous rendre est http://192.168.2.1/.

Une fenêtre semblable doit apparaître :

Voici l'URL par défaut de configuration de votre routeur que vous devez taper dans votre navigateur internet. Vous devez entrer votre mot de passe dans ce champ. Après avoir entré votre mot de passe dans le champ approprié, cliquez sur ce bouton de [Login] pour entrer dans la configuration du routeur. Cliquez sur ce bouton pour fermer la fenêtre (Vous devriez recevoir un avertissement de votre navigateur).

Inscrivez votre mot de passe dans le champ dédié et cliquez sur le bouton de [Login] pour entrer dans le menu principal de configuration de votre routeur.

Si vous connaissez votre IP de réseau, allez directement à l'Etape 3 - Configurer votre routeur pour éviter une ID faible (LowID).
Sinon, rendez-vous à l'Etape 2 - Comment trouver votre IP réseau.

Etape 2. - Comment trouver votre IP réseau

Trouver votre IP est facile. Vous n'avez qu'à ouvrir une fenêtre DOS d'invite de commande alors que vous êtes connecté à votre routeur et lancer "ipconfig".

Windows 2000 :

Ouvrez votre menu "Démarrer" et choisissez "Exécuter". Dans la fenêtre qui s'ouvre, tapez "cmd" et cliquez sur ok.
Une fenêtre DOS d'invite de commande s'ouvre. Dans celle-ci tapez "ipconfig" et pressez sur la touche [entrer]. Vous devez voir quelque chose comme ça :

Voici la ligne où vous avec tapé 'ipconfig' avant de presser [entrer]. Ceci est le nom de votre groupe de travail Voici votre IP réseau. Ecrivez-la sur un morceau de papier. Vous en aurez besoin. Ceci est votre masque de sous-réseau. Ce n'est pas important pour la configuration de votre routeur. Ceci devrait être l'IP de votre routeur (par défaut: 192.168.2.1). Ce n'est pas important pour ce que nous avons à faire.

Ecrivez votre IP sur un morceau de papier. Vous allez en avoir besoin.

Windows 9x et ME

Ouvrez votre menu "Démarrer" et choisissez "Exécuter". Dans la fenêtre qui s'ouvre, tapez "command" et cliquez sur ok. Une fenêtre DOS d'invite de commande s'ouvre. Vous devez y taper "ipconfig" et presser la touche [entrer]. Vous devriez voir quelque chose comme ça :

Ceci est la ligne où vous avez tapé 'ipconfig' puis avez pressé [entrer]. Ceci est votre IP réseau. Inscrivez-la sur un morceau de papier. Vous en aurez besoin. Ceci est votre masque de sous-réseau. Ce n'est pas important pour la configuration de votre routeur. Ceci devrait être l'IP de votre routeur (par défaut: 192.168.2.1). Ce n'est pas important pour ce que nous avons à faire.

Inscrivez votre IP sur un morceau de papier. Vous en aurez besoin plus tard.

Vous pouvez activer et désactiver le pare-feu. Aucune raison de modifier cela. Voici les réglages à modifier pour ouvrir et router les ports. Cliquez dessus ! Je ne sais pas à quoi ça sert ;) Ceci sert à l'ouverture de ports pour plusieurs IP à des horaires précis. Vous pouvez le consulter si ça vous intéresse, mais pour l'ouverture et le routage de simples ports, il n'y a pas besoin de regarder cela. Divers. Vous n'avez pas besoin d'y regarder.

Etape 3. - Configurer votre routeur pour éviter une ID faible (LowID)

Maintenant que vous connaissez votre IP, vous pouvez poursuivre la configuration. En suivant les instructions de l'Etape 1. vous devez être dans le menu principal. Il vous faut maintenant cliquer sur Setup.

Sur le côté gauche de la fenêtre du navigateur apparaît une liste de liens. Sous les Advanced Settings (réglages avancés) vous devez cliquer sur Virtual Server (serveur virtuel).

Vous vous trouvez maintenant dans la configuration du Virtual Server. Vous devriez voir quelque chose comme cela sur votre écran (avec les champs vides) :

Vous devez taper ici la dernière partie de votre IP pour quelle soit complète. Dans ce champ 'private port', vous devez entrer le port de votre client eMule (par défaut : 4662). Vous devez laisser coché 'TCP'. Dans ce champ 'public port', vous devez insérer le port de votre client eMule (par défaut : 4662). Vous devez taper ici la dernière partie de votre IP pour quelle soit complète. Dans ce champ 'private port', vous devez entrer le port UDP de votre client eMule (par défaut : 4672). Vous devez laisser coché 'UDP' pour rendre possible l'utilisation du protocole UDP à travers ce port. Dans ce champ 'public port', vous devez insérer le port UDP de votre client eMule (par défaut : 4762).

Pour ouvrir et router les ports nécessaires vous devez :

  • Insérer la dernière partie de votre IP dans le champ correspondant, afin qu'elle soit 'complète'.
  • Sur la première ligne, entrez le port de votre client eMule (par défaut : 4662) dans le champ Public port et le champ Private port.
  • Sur la deuxième ligne, entrez le Port UDP de votre client eMule (par défaut : 4672) dans le champ Public port et le champ Private port.
  • Sur la deuxième ligne, cochez UDP pour rendre possible l'utilisation du protocole UDP à travers ce port.

A la fin, cela devrait ressembler à la capture d'écran ci-dessus.

Si vous avez un SMC Barricade 7004 BR, les champs sont différents. Dans votre configuration, l'IP réseau s'inscrit dans "IP Serveur" et le Port dans "Port Serveur". Vous devez ensuite cocher la boite appelée "Enable" pour activer ce port. Vous n'avez pas non plus le choix entre TCP et UDP. Ceci parce que les ports UDP ne sont pas filtrés, donc vous n'avez pas à régler pour UDP, simplement à router les Ports UDP.

Insérez votre port Client ici. Vous devez entrer la dernière partie de votre IP ici, afin qu'elle soit complète. Cochez ceci pour activer le réglage. Vous devez entrer votre port UDP ici. Vous devez entrer la dernière partie de votre IP ici, afin qu'elle soit complète. Cochez ceci pour activer le réglage.

Maintenant, il ne vous reste plus qu'à cliquer sur le bouton vert [Enter] et vous déconnecter en cliquant le bouton [logout] sur le bord gauche de l'écran.

Maintenant démarrez eMule et connectez-vous sur un serveur. Lorsque vous êtes connecté allez ici, vérifiez si le nombre dans le champ est identique à celui du port de votre client puis cliquez sur [test].
Vous devriez recevoir un message comme ceci : "success ... your id should be (high)". Si ce n'est pas le cas, vérifiez à nouveau si vous avez bien entré le port correct pour votre client eMule et votre IP dans la configuration du Virtual Server. Si ça ne fonctionne pas, vous pouvez me contacter.

Si tout fonctionne, vous venez de configurer votre SMC Barricade pour eMule!

Divers - Ce qu'il faut aussi savoir

D.1 - Comment configurer le routeur pour deux PC :

Tout d'abord, il convient de préciser que l'utilisation de deux clients eMule sur la même connexion internet n'a de sens que si la capacité en émission est supérieure à 20kb/s. En effet, les deux clients doivent partager la capacité en émission et si eMule ne peut pas donner plus de 10kb/s le téléchargement autorisé ne peut dépasser 3 x la limite en émission.
Si donc, votre bande passante en émission est suffisante, ou si la limitation en téléchargement ne vous gêne pas, voici un petit guide de configuration de votre routeur pour deux clients eMule :

Pour éviter l'obtention d'une ID faible ("LowID") en utilisant deux clients eMule (sur le même ordinateur ou sur deux ordinateurs), vous devez définir des ports différents pour ces deux clients (ou plus).
Par exemple :

 | PC 1 | PC 2
Client port: | 4662 | 3662
UDP-Port: | 4672 | 3672

Ensuite, il vous suffit de router ces différents ports vers le ou les PC sur le(les)quel(s) eMule est installé. Dans l'exemple, le Port 4662 (TCP) et le Port 4672 (UDP) doivent être routés vers l'IP du PC 1 ; et le Port 3662 (TCP) et le Port 3672 (UDP) doivent être routés vers l'IP du PC 2.
Vous devez procéder exactement comme précisé ci-dessus dans le guide mais vous devez tout faire en double avec les différents ports et IP.
Si vous désirez utiliser deux clients eMule sur le MEME PC, vous devez router les quatre ports vers l'IP de ce PC (n'oubliez surtout pas d'utiliser deux dossiers temporaires différents !)

D.2 - Aide pour ceux qui expérimentent des plantages du routeur :
J'ai reçu quelques mails provenant d'utilisateurs qui ont ce genre de problème. J'ai regroupé ici quelques explications pour prévenir ces incidents.

1. | Votre routeur plante car il ne peut gérer autant de connexions.
 | Tout d'abord, je vous recommande une mise à jour du Firmware car cela peut améliorer la prise en charge d'un grand nombre de connexions . (A télécharger ici : EU et US) Si ça ne suffit pas, vous devrez réduire les Connexions Max. et les Connexions Max. par 5 s jusqu'à ce que le routeur fonctionne de manière stable
2. | Votre routeur plante car il est victime d'une attaque par des scripts DoS, DDoS etc. (assez improbable)
 | Vous ne pouvez pas faire grand chose pour vous protéger de ces attaques. Peut-être qu'une mise à jour du Firmware peut corriger quelques failles de sécurité dans le logiciel du routeur. La seule autre solution est de changer d'adresse IP (une reconnexion suffit si vous avez une IP dynamique), tout en réduisant la possibilité pour l'attaquant d'obtenir cette nouvelle adresse IP par la fermeture d'ICQ, IRC et de la page d'accueil de son site.
3. | Votre routeur surchauffe.
 | Comme tout autre composant informatique, votre routeur peut surchauffer. Assurez-vous qu'il n'est pas noyé sous votre bazar, caché sous des papiers ou des chaussettes... laissez-le "respirer".
4. | Un bug du logiciel du routeur entraîne des plantages.
 | Vous n'avez qu'une solution, faire une mise à jour du Firmware, (à télécharger ici : EU et US.) en espérant que cela corrigera le bug.

Pour finir, je voudrais remercier les personnes suivantes :

  • L'ensemble de l'équipe de développement d'eMule (en particulier Monk qui a mis à jour ce guide ;-) ) et tous ceux qui la supportent en lui apportant du code ou des idées (tout spécialement les modders),
  • Sourceforge.net pour l'hébergement de l'eMule Project,
  • Jed alias Swamp pour l'invention du réseau eDonkey,
  • Stillman et ocbMaurice pour leur script de test et spécialement Maurice pour ses magnifiques listes de serveurs,
  • Stefan Münz pour son SelfHTML, sans lequel ce guide n'existerait pas,
  • Ulrich pour les captures d'écran de son SMC Barricade 7004 BR,
  • Tous les autres que j'ai oublié de mentionner (Il est 0:05 du matin maintenant :D)

Un grand merci à URMEL pour ce guide très clair.
Dernière mise à jour le : 21/02/03 par Monk


FAQ eMule :: Linksys BEFSX41

Linksys BEFSX41

Ce guide suppose que vous possédiez un routeur Linksys BEFSR41. Les réglages seront sans doute très proches si vous avez un autre routeur Linksys comme la version 'wireless' ou 'firewall' (BEFSX41) bien que je ne puisse l'affirmer car je n'en possède pas.

J'utilise Windows XP Pro, mais ces instructions sont aussi valables pour XP Edition familiale. Les utilisateurs de Windows98 doivent suivre les instructions alternatives.

Le but de ce guide est de vous montrer comment régler votre routeur Linksys de manière à pouvoir utiliser eMule. Il y a deux manières de procéder, soit comme ci-dessous en utilisant UPnP, ou en se servant d'un navigateur internet. Ces instructions sont longues et détaillées afin que vous ne restiez pas bloqué ! En fait, tout est relativement simple, une fois que l'on a compris comment cela fonctionne. Aussi ne vous laissez pas intimider par la longueur de ces instructions.

Remarques importantes sur la Sécurité avec l'UPnP

Il existe des problèmes de sécurité sérieux avec l'Universal Plug and Play. Vous devriez lire ce que l'on en dit ici.
Merci à Monk de m'avoir révélé ceci.

Pour vérifier votre niveau de sécurité, vous devriez essayer de pratiquer certains tests qui se trouvent sur http://www.pcflank.com/ ou ce test de http://www.dslreports.com/scan/

Si après avoir lu / testé vous décidez de désactiver l'UPnP, vous devez suivre mes

instructions alternatives pour régler le routage des ports sans UPnP.

Sinon, si vous pensez que vous êtes malgré tout en totale sécurité, alors continuez à suivre les instructions ci-dessous..

Instructions UPnP Windows XP

  1. La première étape consiste en s'assurer que votre routeur possède une version de firmware assez récente. Le firmware est le programme interne du routeur. Vous pouvez mettre à jour votre appareil vers la version la plus récente en visitant la page des téléchargements de Linksys. Choisissez votre routeur dans la liste déroulante, sélectionnez le lien du firmware, sauvegardez le fichier et suivez les instructions. La procédure est relativement claire et rapide.

  2. Etape suivante... Dans Windows, cliquez sur Démarrer>paramètres>panneau de configuration>connexions réseau pour ouvrir cette page :

    Comparez votre écran avec mon image, si vous voyez Internet Gateway enabled (passerelle internet activée), l'UPnP est déjà installé et le processus n'en sera que plus simple. Windows XP devrait être correctement configuré si votre routeur possède déjà la version 1.42 (?) ou supérieure du firmware. Dans ce cas passez directement à l'étape 4 ci-dessous.

  3. Installer l'UPnP:

    1. Cliquez sur Démarrer>Panneau de configuration puis sur Ajout/Suppression de programme.

    2. Dans le dialogue de l'Ajout/Suppression de programme, cliquez sur Ajouter / Supprimer des composants Windows.

    3. Dans la fenêtre de l'assistant, cliquez sur Services de mise en réseau, puis sur détails et cochez 'Universal Plug and Play'. Vous devriez aussi voir dans la liste 'Internet Gateway Device Discovery and Control Client', cochez aussi cette option comme le montre l'image ci-dessous.

    4. Cliquez sur OK, puis sur Suivant dans la fenêtre de l'Assistant. Votre CD d'installation de Windows XP sera peut-être nécessaire.

      ( J'ai trouvé ces informations sur http://www.microsoft.com/windowsxp/expertzone/columns/crawford/02july22.asp)

    5. A l'aide de votre explorateur internet, allez à l'adresse http://192.168.1.1/Passwd.htm et comme montré ci-dessous assurez-vous que les 'Services UPnP' sont activés :

    6. Cliquez sur Démarrer>Paramètres>Connexions réseau. Faites un clic droit sur 'Connexion au réseau local'. Choisissez 'Propriétés' dans le menu qui s'ouvre. Une petite fenêtre apparaît. Cliquez sur 'Avancé' (en haut). Assurez-vous que le pare-feu de Windows XP est désactivé comme montré ci-dessous :

    7. Maintenant retournez à l'étape 2 pour vous assurer que l'UPnP fonctionne correctement. La fenêtre d'entrée de la passerelle internet peut être longue à apparaître alors soyez patient, attendez quelques minutes s'il le faut. Un rafraîchissement de la fenêtre la fait souvent apparaître miraculeusement.

  4. Maintenant que l'UPnP est activé la configuration du routage des ports est assez simple...

    Premièrement, mettez en surbrillance l'entrée concernant le réseau local dans la page des connexions réseau comme je le fais dans l'image ci-dessous :

    Sur la gauche, dans la rubrique détails vous devriez maintenant voir l'adresse ip assignée à votre routeur comme ci-dessous :

    ...dans cet exemple c'est 192.168.1.100.
  5. Retournez dans la section principale de la page, faites un clic droit sur 'Connexion Internet' et sélectionnez 'Propriétés' dans le menu qui s'ouvre.

    Vous voyez maintenant cette fenêtre :

    Cliquez sur Paramètres et sur 'Ajouter'. C'est là que vous allez entrer les numéros des ports à router pour qu'eMule puisse fonctionner. Remplissez les champs comme ci-dessous à l'exception de l'adresse IP à laquelle vous devez substituer l'IP assignée à votre propre routeur que vous avez vu à l'étape précédente. Le Champ 'Description of Service' peut être renseigné avec ce que vous voulez, cela sert juste à l'identifier plus tard... "eMule" me semble toutefois bien indiqué :

  6. Après avoir cliqué sur 'OK' pour sauvegarder ces nouveaux réglages, cliquez sur 'Ajouter' une nouvelle fois pour configurer un deuxième port à router. Procédez de la même façon que précédemment, entrez "eMule" dans la description du service, et renseignez les autres options comme montré ci-dessous. Sauvegardez en appuyant sur 'Ok' :

  7. Vous avez donc maintenant deux entrées eMule, comme vous le voyez ci-dessous :

    Cliquez sur 'Ok' pour sauvegarder les réglages et fermez la fenêtre. C'est tout ce que vous avez à faire ! Vous avez demandé à votre routeur d'acheminer le trafic entrant au ports 4662 et 4672 de votre ordinateur. Lancez eMule et tout devrait bien fonctionner.

Windows98 / Instructions alternatives / sans utilisation de l'UPnP

Il existe une autre manière de procéder.
  1. Ouvrez votre explorateur internet et entrez l'adresse suivante : http://192.168.1.1 pour aller sur la page d'accès de votre routeur. Entrez votre mot de passe, le nom d'utilisateur est laissé en blanc sur ma machine et ça n'a pas l'air d'être gênant... vous AVEZ changé le mot de passe par défaut, j'espère... sinon, pour votre propre sécurité, lisez votre manuel et faites-le tout de suite !
  2. Cliquez sur le bouton DHCP en haut

    Puis sur le bouton 'DHCP Clients Table'. La fenêtre ci-dessous s'ouvre :

    Regardez dans la colonne Client Hostname, trouvez le nom de votre ordinateur et retenez les trois derniers chiffres de l'adresse IP à droite de ce nom. Dans l'exemple le nom d'hôte du client est 'Christopher', et les trois derniers chiffres de l'adresse IP sont 100. Vous pouvez fermer la fenêtre... retenez bien les trois derniers chiffres.
  3. Dans la partie haute de l'écran, à droite, cliquez sur le bouton coloré en orange intitulé 'Advanced'. Vous tombez sur la page des 'filtres', vous n'avez rien à y faire sauf cliquer sur le bouton 'Forwarding'... et remplir les renseignements comme fait plus haut. En plus, bien entendu, vous devez entrer les trois derniers chiffres de l'adresse IP :

  4. En bas, cliquez sur 'Apply' pour sauvegarder les réglages. Votre routeur est désormais configuré pour acheminer le trafic entrant aux ports 4662 et 4672 de votre ordinateur. Fermez le navigateur internet et lancez eMule, ça devrait marcher !

Configuration avec DHCP via le Port Triggering

  1. Ouvrez votre navigateur internet et entrez l'adresse IP de votre routeur (par défaut : 192.168.1.1). Tapez votre mot de passe (pa défaut :admin - changez-le !). Cliquez sur 'Advanced'. Cliquez sur 'Forwarding'.
  2. Dans l'écran Forwarding (routage) se trouve le bouton Port Triggering. Cliquez sur ce bouton pour entrer dans la fenêtre de configuration montrée ci-dessous. Vous pouvez ignorer les entrées msn pour la configuration d'eMule.

  3. Appuyez sur 'Apply'. Cela devrait permettre à votre routeur d'acheminer les paquets d'eMule à votre machine sans avoir besoin d'adresses IP spécifiques ce qui autorise le DHCP ou l'usage d'eMule sur plusieurs machines.

Grand merci à Violator pour ce guide très détaillé. Merci à ThRaShErUk pour le guide sur le Port Triggering.

Dernière mise à jour le : 16/01/03 par Monk


FAQ eMule :: Cisco 677/678

Cisco 677/678

Suivez ces quelques étapes pour configurer pour eMule votre routeur Cisco 677 ou 678. Ces explications supposent que vous avez une connexion PPPOE DSL et une IP statique.
Démarrez une session telnet avec l'IP de votre routeur.
 | a) Utilisez l'Hyperterminal de Windows et tapez un Nom (le nom importe peu) pour cette nouvelle session, choisissez TCP/IP (Winsock) comme type de connexion puis entrez l'IP réseau de votre routeur (en principe 10.0.0.1 ou 192.168.0.1, mais elle peut être différente) comme adresse de l'hôte
 | ou
 | b) Appuyez sur le bouton Démarrer -> Exécuter -> telnet IP réseau du routeur (normalement 10.0.0.1 ou 192.168.0.1, mais elle peut être différente)
Dans la session telnet qui s'ouvre, entrez les commandes suivantes. Chacune sur une ligne différente :
 | votre_mot_de_passe (Fourni par votre FAI, dans de rares cas cisco s'il n'a pas été modifié) enable votre_mot_de_passe (Fourni par votre FAI, dans de rares cas cisco s'il n'a pas été modifié) set nat entry add LAN IP 4662 WAN IP 4662 tcp set nat entry add LAN IP 4672 WAN IP 4672 udp write reboot
L'IP WAN est votre adresse IP sur internet (l'IP externe du routeur) et l'IP LAN ou IP réseau est l'adresse IP de votre ordinateur sur lequel eMule est installé.
Note : Si quelqu'un connaît la manière de configurer ce routeur pour une IP dynamique, merci d'envoyer une email à Monk

Remerciements à Fuxie - DK pour ce guide.
Dernière mise à jour le : 21/02/03 par Monk


FAQ eMule :: Mise à jour de la liste de serveurs

Mise à jour de la liste de serveurs

Lorsque l’on utilise eMule, les serveurs eDonkey2000 sont les points d’entrée sur le réseau. Une connexion à un serveur est donc nécessaire pour accéder aux ressources du réseau et pour faire connaître votre client sur celui-ci.

En gros, un serveur fournit un index des fichiers que les utilisateurs connectés partagent et permet la recherche de téléchargements ou de sources.

Une liste des serveurs (serverlist) à jour n’est nécessaire que pour un premier contact avec le réseau. Dès qu’eMule est connecté a un serveur, les fonctions avancées comme l’Echange de Sources de Client à Client permettent de trouver des sources ou d’effectuer automatiquement des mises à jour de la liste des serveurs connus.

Il y a plusieurs manières de mettre à jour la liste de serveurs :

Réglages utiles dans Préférences -> Connexions
o Mise à jour auto liste de serveurs au démarrage
Dans le dossier où vous avez décompressé/installé eMule, se trouve le fichier adresses.dat. Ouvrez-le avec un éditeur ASCII (exemple : le bloc-notes de Windows) et entrez une URL valide pointant vers un fichier server.met. Une seule URL est prise en charge.
Si vous cochez cette option, lors de son lancement, eMule met à jour sa liste de serveurs à partir de l’URL inscrite dans adresses.dat.

o Mettre à jour serverlist depuis serveur
Dans une certaine mesure, les serveurs eDonkey se connaissent entre-eux. Cette option autorise le client eMule à obtenir la liste des serveurs connus du serveur sur lequel il est connecté.

o Mise à jour liste de serveurs par connexion client
Cette fonction s’effectue par l’intermédiaire de la connexion d’un autre client eMule sur votre client. Les deux clients comparent leur liste de serveurs fonctionnels et les mettent à jour mutuellement.

Note:
Les deux dernières options garantissent une liste de serveurs mise à jour en permanence. Une mise à jour régulière par un autre moyen n’est pas nécessaire.

Mise à jour server.met depuis URL

Entrez une URL pointant vers un fichier server.met et appuyez sur le bouton Mise à jour. La fenêtre de Log vous donne le nombre de nouveaux serveurs ajoutés.

Nouveau serveur

Entrez une URL pointant vers un fichier server.met et appuyez sur le bouton Mise à jour. La fenêtre de Log vous donne le nombre de nouveaux serveurs ajoutés.

Ajout de serveurs via IRC
Le channel IRC officiel d’eMule comporte une commande !serverlist. Cette commande vous envoie un message contenant les URLs d’une liste de serveurs. En cours d’utilisation du chat eMule, on peut ajouter des liens pointant vers un server.met sur un simple clic de souris.

Ajout de serveurs à partir d’un lien web
Le réseau eDonkey2000 prévoit à cet effet des liens spéciaux, par exemple : //|server|IP|port|/

Dernière mise à jour le 26/11/02 par Monk


FAQ eMule :: Adresses des listes de serveurs

Adresses des listes de serveurs

eMule utilise les mêmes serveurs qu’eDonkey2000, aussi toute liste de serveurs valide pour un programme l’est aussi pour l’autre.

Sites Web proposant des listes de serveurs :
 | TheDonkeyNetwork
 | Server List for eDonkey2000

Liens directs vers les fameuses listes de serveurs d’ocbMaurice :
 |  | Default (Défaut)
 |  | All servers (Tous les serveurs)
 |  | Working Servers (Serveurs fonctionnels)
 |  | Long time proven servers (Serveurs ayant fait leurs preuves)
Notes:
> | Utilisez Google pour trouver de nombreux bons sites disposant de fichiers server.met.
> | Chacun de ces liens peut disparaître ou être inaccessible. Ils ne sont donnés qu’à titre indicatif.
> | Tous nos remerciements à ceux qui fournissent ces listes. Super boulot.

Dernière mise à jour le : 28/12/02 par Monk


FAQ eMule :: DNS

Résolution Dynamique DNS pour les serveurs

L’utilisation d’IP dynamiques est un moyen d’augmenter la réserve limitée d’adresses IP du World Wide Web (en théorie : 2^32). De nombreux F.A.I. utilisent ce système en coupant la connexion après une durée donnée. Ceci oblige à effectuer une nouvelle connexion qui permet l’assignation d’une nouvelle adresse IP.

C’est néfaste pour un serveur car il perd son adresse, bien connue sur le réseau et par tous ses utilisateurs.

De nombreux services web gratuits fournissent un moyen de résoudre ce problème en allouant des noms d’hôtes statiques aux adresses IP dynamiques.

Inscrivez [emDynIP: StaticHostName.host:Port] comme message de bienvenue dans le dserver.
Pour un serveur réglé par défaut, le port sera le 4661.

Ceci informe eMule qu’il faut utiliser le nom d’hôte statique au lieu de l’IP dynamique lors d’une connexion.
Cela offre aussi l’avantage de pourvoir ajouter le nom d’hôte dans staticservers.dat, ainsi, l’adresse du serveur n’est jamais perdue.

Notes:
> | La longueur du nom d’hôte statique ne doit pas dépasser 51 caractères.
> | Ceci ne concerne que les personnes qui entretiennent un serveur pour le réseau. Si vous ne faites qu'utiliser un client eMule, ces informations vous sont inutiles.
> | Sincères félicitations à tous ceux qui administrent un dserver. Vous rendez un fier service à la communauté.

Dernière mise à jour le : 27/12/02 par Monk


FAQ eMule :: Recherche

La Recherche de fichiers

La recherche par eMule signifie généralement que tous les serveurs présents dans la liste sont interrogés pour savoir s'ils connaissent un client possédant un fichier dont le nom correspond aux mots clés entrés. Les serveurs eux-mêmes n'en contiennent aucun, ils compilent simplement une liste des fichiers des clients connectés.
La fonction de recherche avancée d'eMule, permet des recherches précises de fichiers présents sur le réseau. Plus la recherche est précise, mieux c'est car cette opération induit une charge considérable des serveurs. Aussi, eMule ne trouve qu'au maximum 201 sources individuelles, quels que soient les termes de la recherche.

Chercher
o Nom
Les termes recherchés sont entrés dans ce champ. Des mots clés multiples peuvent y être inscrits et eMule n'affichera que les noms de fichiers qui contiennent tous ces mots clés. Pour effectuer des recherches encore plus précises et flexibles, lisez les explications sur les opérateurs booléens un peu plus loin dans ce chapitre..
Ce champ permet le complément automatique du texte entré, par sauvegarde des entrées de recherches précédentes. Pour effacer cette liste, maintenez la touche CTRL ou ALT enfoncée puis appuyez sur SUPPR. Pour désactiver complètement cette fonction, reportez-vous à UseAutocompletion dans Préférences -> Préférences.ini.

o Type
On peut utiliser le type pour filtrer les résultats en fonction de groupes d'extensions particuliers. Les types de téléchargements ainsi que les extensions qui leur sont associées sont donnés dans le tableau ci-dessous :
Tous | pas de filtre
Archive | .ace, .arj, .gz, .hqx, .lha, .rar, .sea, .sit, .tar, .tgz, .uc2, .zip
Audio | .669, .aac, .aif, .aiff, .amf, .ams, .ape, .au, .dbm, .dmf, .dsm, .far, .flac, .it, .mdl, .med, .mid, .midi, .mod, .mol, .mp1, .mp2, .mp3, .mp4, .mpa, .mpc, .mpp, .mtm, .nst, .ogg, .okt, .psm, .ptm, .ra, .rmi, .s3m, .stm, .ult, .umx, .wav, .wma, .wow, .xm.
Images | .bmp, .dcx, .emf, .gif, .ico, .jpeg, .jpg, .pct, .pcx, .pic, .pict, .png, .psd, .psp, .tga, .tif, .tiff, .wmf, .xif
Images-CD | .bin, .bwa, .bwi, .bws, .bwt, .ccd, .cue, .dmg, .dmz, .img, .iso, .mdf, .mds, .nrg, .sub, .toast
Programmes | .bat, .cmd, .com, .exe
Vidéo | asf, .avi, .divx, .m1v, .m2v, .mov, .mp1v, .mp2v, .mpe, .mpeg, .mpg, .mps, .mpv, .mpv1, .mpv2, .ogm, .qt, .ram, .rm, .rv, .vivo, .vob, .wmv

o Méthode
La méthode permet de définir la manière qu'eMule utilise pour faire sa recherche. Les moteurs de recherche internet dédiés au réseau eMule sont aussi disponibles. Les résultats de la recherche internet apparaissent dans le navigateur.
> | Serveur La recherche ne s'effectue que sur le serveur auquel le client est actuellement connecté.
> | Globale (Serveur) Tous les serveurs de la liste des serveurs sont interrogés ; chacun individuellement. La barre verte en bas, affiche la progression de la recherche.
> | Jigle (Web) Moteur de recherche internet. La boite à cocher Match Keyword force Jigle à ne retourner que les résultats qui possèdent le mot clé exact de la recherche dans leur nom.
> | Jigle Cette méthode offre un accès direct à la base de données de Jigle, depuis eMule.
> | Filedonkey Moteur de recherche internet.

Filtre
o Taille min / taille max
Les tailles min et max sont utilisées pour restreindre la recherche en fonction de la taille du fichier. Seuls les résultats qui sont plus grands que la taille min entrée ou plus petits que la taille max indiquée, sont affichés. Si aucune abréviation d'unité n'est inscrite, la taille est considérée comme étant en mega octets (mega bytes).
Unités | Abréviations valides
Bytes | b | byte | bytes
KiloBytes | k | kb | kbyte | kbytes
MegaBytes | m | mb | mbyte | mbytes
GigaBytes | g | gb | gbyte | gbytes

Exemples :
Taille min = 200
sans autre indication d'unité, les résultats n'affichent que les fichiers ayant une taille au minimum de 200 mega octets (mega bytes).
Taille max = 1gb
La taille du fichier ne doit pas dépasser 1 giga octet (giga byte).

o Disponibilité
Spécifie le nombre minimal de sources qu'un fichier référencé sur un seul serveur doit posséder pour être considéré comme un résultat.

Note :
Ce filtre ne traduit pas la disponibilité globale mais la disponibilité par serveur. Régler cette valeur trop haut peut empêcher d'obtenir une réponse car le serveur peut ne pas avoir indexé de fichiers ayant autant de sources.

o Extension
Seuls les fichiers portant l'extension indiquée seront affichés. L'extension doit être entrée seule (sans le point qui la précède). exemple : l'extension avi n'affichera que ce type de fichier.

Recherche booléenne
Cette fonction est utilisée pour créer des requêtes de recherche complexes à l'aide des opérateurs booléens NOT, AND, OR. Ces opérateurs doivent toujours être inscrits en lettres capitales sinon ils sont considérés comme des mots clés de recherche ordinaires.
> | NOT Cet opérateur s'appelle en fait NAND, ce qui signifie "and not" (ET NON). Le mot clé qui suit un NOT sera exclu. C'est-à-dire que tous les résultats qui contiennent ce mot seront éliminés. Priorité la plus haute. Syntaxe : Mot_clé_1 NOT Mot_clé_2
> | AND AND est l'opérateur par défaut si aucun n'est spécifié. Les recherches effectuées avec AND affichent des résultats contenant tous les mots clés inscrits. Opérateur de priorité moyenne. Syntaxe : Mot_clé_1 AND Mot_clé_2 (équivalent à : Mot_clé_1 Mot_clé_2)
> | OR OR signifie que tout mot clé entré est affiché dans les résultats. OR a la priorité la plus basse. Syntaxe : Mot_clé_1 OR Mot_clé_2
Notes:
> | La recherche à l'aide des opérateurs booléens peut être combinée avec n'importe quelle autre méthode ou filtre à l'exception des moteurs de recherche internet jigle et filedonkey.
> | Les opérateurs sont évalués selon leur priorité mathématique. NOT -> AND -> OR. Cette priorité peut être modifiée par l'utilisation de ( ) autour de l'expression qui doit être considérée en premier.
> | Les opérateurs ou les ( ) peuvent être masqués par des guillemets " ". Ainsi ils ne sont pas considérés selon leur signification booléenne mais comme des mots clés de recherche normaux.
> | Les recherches utilisant OR et NOT ne sont pas aussi restrictives que celles qui emploient AND. AND nécessite la totalité des mots clés pour donner lieu à un résultat alors que OR et NOT autorisent des corrélations partielles.
> | OR et NOT prennent aussi en compte les méta données liées comme les étiquettes de mp3 ou les informations sur les fichiers telles que commentaire / auteur.
Exemples:
> | Recherche | Mot_clé_1 Mot_clé_2 OR Mot_clé_3 Mot_clé_4
 | Interprétation booléenne | (Mot_clé_1 AND Mot_clé_2) OR (Mot_clé_3 AND Mot_clé_4)
 | Explication | Trouve les fichiers qui contiennent soit le Mot_clé_ 1 + 2 soit le Mot_clé_ 3 + 4 dans leur nom.
> | Recherche | Mot_clé_1 Mot_clé_2 OR Mot_clé_3 Mot_clé_4 NOT Mot_clé_5
 | Interprétation booléenne | (Mot_clé_1 AND Mot_clé_2) OR ((Mot_clé_3 AND Mot_clé_4) NAND Mot_clé_5)
 | Explication | Tous les fichiers contenant le Mot_clé_ 1 + 2 ou le Mot_clé_ 3 + 4 mais ceux qui correspondent à 3 + 4 ne doivent pas contenir le Mot_clé_ 5
> | Recherche | Mot_clé_1 Mot_clé_2 NOT Mot_clé_5 OR Mot_clé_3 Mot_clé_4 NOT Mot_clé_5
 | Interprétation booléenne | ((Mot_clé_1 AND Mot_clé_2) NAND Mot_clé_5) OR ((Mot_clé_3 AND Mot_clé_4) NAND Mot_clé_5)
 | Explication | Identique à l'exemple ci-dessus avec la différence que le Mot_clé_ 5 ne doit jamais apparaître, ni avec 1 + 2 ni avec 3 + 4.
> | Recherche | (Mot_clé_1 Mot_clé_2 OR Mot_clé_3 Mot_clé_4) NOT Mot_clé_5
 | Interprétation booléenne | ((Mot_clé_1 AND Mot_clé_2) OR (Mot_clé_3 Mot_clé_4)) NAND Mot_clé_5
 | Explication | C'est la même recherche que celle ci-dessus mais plus élégante en raison de l'emploi des ( ) pour appliquer le NOT Mot_clé_5 à l'expression OR entière.
> | Recherche | (Mot_clé_1 "OR" Mot_clé_2) NOT Mot_clé_3
 | Interprétation booléenne | (Mot_clé_1 AND or AND Mot_clé_2) NAND Mot_clé_3
 | Explication | L'utilisation des guillemets " " autour du terme OR fait que cet opérateur n'en est plus un mais est considéré comme une expression régulière. Cette recherche donne des résultats qui contiennent le Mot_clé_1 et le Mot_clé_2 et aussi le mot "or" mais qui ne contiennent pas le Mot_clé_3.

Interprétation des résultats
o Disponibilité (Sources)
La disponibilité est le nombre de sources trouvées sur les serveurs pour un téléchargement donné. Ce n'est pas le nombre total de sources sur le net tout entier. Cela donne cependant une bonne indication de la diffusion du fichier. Si plusieurs résultats correspondent à la recherche, on devrait choisir le fichier qui affiche la meilleure disponibilité. Consultez aussi Le code des couleurs des résultats de recherche.
La valeur entre ( ) à côté de la disponibilité indique le nombre de sources qui peuvent être ajoutées directement en téléchargement sans qu'eMule ait à les chercher à nouveau..

o Le code des couleurs des résultats de recherche

> | Noir, bleu foncé, bleu clair Indique un nombre de sources trouvées pour un fichier particuler. Noir = 1 - 3 sources, bleu foncé = 4 - 9 sources, bleu clair = 10+ sources
> | rouge Les fichiers déjà présents dans la liste des téléchargements sont affichés en rouge
> | Vert Les résultats affichés en vert sont déjà téléchargés et complets.

o Recherche dans les résultats
En pressant les touches CTRL + F, un dialogue de recherche apparaît qui permet de chercher les Mots clés (Nom du fichier), ID, taille, type et disponibilité. La fonction touche F3 permet de passer à l'item suivant possédant le même Mot clé alors que MAJ + F3 revient à l'item précédent.

S'applique à la version : .30b +
Dernière mise à jour le : 27/09/03 par Monk


FAQ eMule :: Système de Crédit

Système de Crédit

Le système de crédit est utilisé pour récompenser les utilisateurs qui contribuent au réseau, par exemple en émettant (upload) des données vers les autres clients.
Au sens strict, le système de file d'attente d'eMule est basé sur le temps d'attente de l'utilisateur dans la file. Le système de crédit apporte une modification importante à ce temps d'attente en prenant en compte les données émises et reçues entre deux clients. Plus un utilisateur émet des données vers un client, plus il progresse rapidement dans la file d'attente de ce client.
Les modificateurs sont calculés à partir de la quantité de données transférées entre les deux clients. Les valeurs utilisées s'affichent dans le dialogue des détails du client. Pour voir cette information, faites un clic droit sur un utilisateur et choisissez Voir Details.

Deux modificateurs de crédit différents sont calculés :
 | Rapport 1 = Total émis x 2 / Total reçu
 | Rapport 2 = Racine carrée (Total émis + 2)
Les deux rapports sont comparés et la valeur la plus faible est utilisée comme modificateur.
Certaines conditions limites existent aussi :
 | > | Total émis < 1MB => Modificateur = 1
 | > | Total reçu = 0 => Modificateur = 10
 | > | Le modificateur ne peut être inférieur à 1 ni supérieur à 10.

Notes :
> | Tous les clients qui émettent vers vous sont récompensés par le système de crédit. Le fait que ce client distant supporte ou non le système de crédit n'est pas pris en compte.
> | Les clients qui ne supportent pas ce système ne vous accordent aucun crédit lorsque vous émettez vers eux.
> | Les crédits ne sont pas globaux. Ils sont échangés entre deux clients particuliers.
> | Les crédits sont sauvegardés dans le fichier clients.met. Le user hash unique est utilisé pour identifier le client.
> | Vos propres crédits sont sauvegardés par le client qui vous accorde le crédit. Ceci afin d'éviter toute fraude.
> | Vos propres crédits ne peuvent pas être affichés.

Dernière mise à jour le : 13/04/03 par Monk


FAQ eMule :: Identification sécurisée des utilisateurs

Identification sécurisée des utilisateurs

Les clients sont identifiés sur le réseau par une valeur unique appelée user hash (hash utilisateur). Cette valeur est sauvegardée dans le fichier preferences.dat et est utilisée pour accorder les crédits gagnés chez les autres utilisateurs.
eMule peut utiliser un cryptage asymétrique afin d'éviter l'exploitation ou la manipulation des valeurs de hash utilisateurs des autres clients. La méthode utilise une clé privée et une clé publique de manière à sécuriser le hash utilisateur tout en permettant une identification correcte par les autres clients.

L'identification sécurisée des utilisateurs peut être activée dans les Préférences -> Sécurité. Il est recommandé de l'utiliser.

Fonctionnement de l'identification sécurisée :

Le client A veut s'assurer que ses crédits sont sécurisés et que lui-seul peut les utiliser. Il crée une clé RSA privée de 384 bits et la sauvegarde dans le fichier cryptkey.dat.
Cette clé privée est créée lors de la première utilisation du cryptage. La perte de cette clé signifie que le client A perd tous ses crédits car il n'est plus en mesure de prouver qu'il en est le propriétaire valide..

Lorsque deux clients supportant le cryptage, échangent des données pour la première fois, il s'envoient l'un l'autre une clé publique, associée à une valeur aléatoire. Chacun sauvegarde la clé de l'autre dans son fichier clients.met. Seule la clé est sauvegardée, la valeur aléatoire est générée à nouveau à chaque connexion suivante..

Si le client A désire s'identifier auprès du client B lors d'une prochaine rencontre, il crée une signature numérique et l'envoie à B. Cette signature est composée de sa clé privée, de la clée publique de B et d'une valeur aléatoire. Elle demeure valide tant que le client A conserve la même IP ou que le client B ne ferme pas eMule.

Lors de la réception de la signature de A, le client B vérifie si elle est créée à partir de sa clé publique et de la valeur aléatoire correcte. Si elle est aussi en accord avec la clé publique du client A, alors le client A est correctement identifié.

Notes:
> | Si le fichier cryptkey.dat est perdu ou supprimé, le fichier preferences.dat doit aussi être supprimé. Sinon aucun nouveau crédit ne pourra être collecté à partir des clients déjà connus.
> | Lors du passage à l'identification sécurisée des utilisateurs, tous les anciens crédits "non-sécurisés" sont perdus. Pour des raisons de sécurité, il n'y a aucun moyen de transférer ces crédits vers le système sécurisé.

S'applique à la version: .29b +
Dernière mise à jour le : 20/06/03 par Monk


FAQ eMule :: Bannissement des clients agressifs

Bannissement des clients agressifs

Lorsqu’un client désire télécharger un de vos fichiers, il en fait la demande puis il la réitère toutes les 10 à 20 minutes pour s’assurer que vous êtes toujours une source valide. Cependant, il est possible de modifier les clients de manière à ce qu’ils fassent des requêtes beaucoup plus fréquentes. Ces programmes modifiés ont une probabilité supérieure d’obtenir satisfaction s’ils s’adressent à un client eDonkey.
Bien qu’eMule ne tienne pas compte de ce comportement (les chances d’obtenir un slot libre n’augmentent pas), cela gaspille les ressources du réseau (connexions et bande passante).
Le système de bannissement inscrit sur liste noire tous les clients qui font de trop fréquentes requêtes (plus d’un fois toutes les dix minutes par fichier). Ils ne sont ainsi pas autorisés à télécharger sur vous. La liste noire est réinitialisée lorsque vous redémarrez eMule.

Voici comment votre client peut se retrouver sur liste noire et être dans l’incapacité de télécharger :

> Vous réglez le paramètre de requêtes de votre client plus bas que 10 min,
> Vous mettez itérativement vos téléchargements en pause puis les reprenez pour accroître la vitesse de téléchargement. Cela crée une nouvelle requête à chaque fois (sur les clients eDonkey seulement),
> Vous relancez votre client toutes les 2 min (ce qui crée aussi une nouvelle requête à chaque fois).

Pour être clair, eMule ne tient aucun compte des demandes répétées en provenance des autres clients (eMule/eDonkey/mldonkey). Tout client envoyant des requêtes trop fréquentes est banni.

Dernière mise à jour le : 14/12/02 par Monk


FAQ eMule :: Echange de sources de Client à Client

Echange de sources de Client à Client

eMule a la capacité de recevoir des sources de téléchargement en provenance d’autres clients eMule.

Pour des sources bien partagées, toutes les 10 minutes, un client choisi au hasard dans la liste des sources, se voit demander la liste de ses sources.
Pour un fichier rare, c’est-à-dire comportant moins de 40 sources, chaque client dans la liste est interrogé sur ses sources dans le même intervalle de temps.

Seules les sources pour des parties manquantes sont acquises. Ceci se fait via TCP* et les paquets sont comprimés pour économiser la bande passante.

Notes:
> | Le protocole utilisé est incompatible avec le protocole de propagation des sources de mldonkey.
> | *Depuis la version 0.23b, on utilise le protocole UDP pour diminuer la surcharche des connexions. C’est le port 4672 qui est réservé à cette extension du protocole eMule. Erratum: L'échange de sources entre clients est effectué à travers le port client 4662 et utilise le protocole TCP.
> | Les sources ayant une ID faible (Low ID) ne sont pas échangées.

S'applique à la version : 0.22a +
Dernière mise à jour le : 04/05/03 par Monk


FAQ eMule :: Prévisualisation des fichiers

Prévisualisation des fichiers

En faisant un clic droit sur le fichier et en choisissant Aperçu, eMule crée un fichier temporaire (dans le dossier Temp) et l’ouvre avec le lecteur de médias par défaut.

Les formats supportés actuellement sont :

- *.avi
- *.mpg
- *.mpeg
- *.divx
- *.xvid
- *.zip
- *.rar

Notes:
> | L’Aperçu ne fonctionne que lorsque (pour les films) la première et la dernière partie ont déjà été téléchargées et qu’il reste suffisamment d’espace disponible sur le disque où se trouve le dossier Temp.
> | Vous devez, bien entendu, avoir le codec adéquat installé sur votre système. Un codec manquant provoque un message d’erreur ou seul le son est joué sans image. Si vous ne savez pas quel codec utiliser, essayez Nimo Codec Pack.

Previsualiser des fichiers multimédias avec VLC

VLC est un lecteur qui permet de lire pratiquement tous les fichiers multimédias. VLC crée un flot de données multimédias qui autorise la lecture des fichiers incomplets ou cassés, ainsi que la lecture en transit (streaming) des fichiers téléchargés. Il est particulièrement approprié à la prévisualisation des fichiers dans eMule.

Pour utiliser VLC :
> | Téléchargez le Client VideoLAN - VLC
> | Entrez le chemin complet de l'exécutable vlc.exe (En général : C:\Program Files\VideoLAN\VLC\vlc.exe) dans les Préférences -> Fichiers -> Lecteur vidéo
> | Désactivez Faire une sauvegarde pour prévisualiser dans le même dialogue
> | Dans Préférences -> Preferences.ini réglez PreviewSmallBlocks à la valeur 1.

VLC et le module d'accès des fichiers part d'eMule

Le module d'accès des fichiers part d'eMule (eMule Part File Access Module) est un module d'extension (plugin) pour VLC, développé spécifiquement pour lire les fichiers incomplets ou cassés. En utilisant ce module, les contenus peuvent être lus de manière fluide et sans temps de recherche. Cela permet par exemple, de se déplacer en n'importe quel point de la vidéo, dès lors que cela est possible. En lisant les informations sur les parties disponibles dans un téléchargement incomplet, directement depuis le fichier part.met d'eMule, le temps de recherche des parties utilisables est très réduit.

o Télécharger et installer le module d'extension

> | Téléchargez le module sur la page d'accueil d'eMule Project dans la section Downloads.
> | Décompressez l'archive zip et copiez le fichier libaccess_partfile_plugin.dll dans le répertoire plugins de VLC (en général : C:\Program Files\VideoLAN\VLC\plugins)
> | Configurez eMule pour une prévisualisation avec VLC, comme décrit ci-dessus
> | Important : le module est seulement compatible avec une version de VLC donnée !
 | le module d'accès des fichiers part d'eMule v1.1 <=> VLC v0.6.2

o Configurer le module d'extension

Après avoir lancé VLC, le dialogue de configuration du module se trouve dans Paramètres -> Préférences -> Modules -> access -> access_partfile

Enable plugin for MPEG / AVI / non MPEG or AVI part files
Ces trois options décident de quels fichiers doivent être traités par le module. Les "non MPEG or AVI part files" sont les fichiers tels que .ogg, .ogm, .mp3, .mkv, etc.
Lorsque cela est possible, VLC tente d'utiliser son module d'accès par défaut au lieu de celui d'eMule si l'une des options est désactivée.

Provide a seekable stream for MPEG / AVI / non MPEG or AVI part files
Généralement, les flots de données provenant de fichiers incomplets ou brisés n'autorisent pas la recherche. Le curseur de position qui permet de se déplacer dans la vidéo ainsi que la fonction d'avance rapide ne fonctionnent pas. L'activation des fonctions Provide a seekable stream rend possible leur fonctionnement pour les téléchargements incomplets d'eMule.
Ces options ne fonctionnent que si le module est activé pour le type précis du fichier. Dans certains cas, en particulier avec des fichiers AVI ou d'autres contenus non MPEG, la recherche ne fonctionne pas correctement.

Enable plugin for all type of files (eMule part files and regular files)
Ce module est développé pour une utilisation avec les fichiers part d'eMule. Cependant, le module d'accès par défaut de VLC présente un bug qui peut causer le gel du système lors d'une tentative d'ouverture d'un contenu brisé ou incomplet. Ce module offre une solution de rechange en autorisant l'ouverture de tous les contenus supportés par VLC à l'aide de celui-ci et à la place du module d'accès par défaut. L'activation de cette option fait que tous les contenus supportés sont traités par le module d'eMule, qu'ils soient ouverts à partir d'eMule, de l'explorateur ou des lignes de commandes.
Le module d'accès des fichiers part d'eMule peut remplacer totalement le module d'accès par défaut de VLC.

Informations complémentaires sur ce module

Screenshot Preview of Video Files
Si un autre client vous autorise à voir la liste de ses partages, (Préférences -> Fichiers -> Fichiers partagés vus par), il est possible d'obtenir une prévisualisation de ses fichiers vidéos partagés.
Faites un clic droit sur une vidéo partagée -> Prévisualiser. Ceci requiert un ensemble de 5 captures d'écran des 10 premières minutes de ce fichier. Les captures sont affichées dans des lecteurs séparés dès leur réception. Leur réception peut nécessiter un certain temps. Cette fonction ne s'applique qu'entre clients v.30b ou supérieure.

S'applique à la version : .30b +
Dernière mise à jour le : 27/09/03 par Monk


FAQ eMule :: Online Signature

Online Signature

Si vous cochez l’option Activer Online Signature dans la boite de dialogue des Préférences, eMule crée dans son dossier d’installation un fichier onlinesig.dat.

Format d’onlinesig.dat:
[Statut en ligne]|[Serveur connecté]|[IP:port]
[Download en cours]|[Upload en cours]|[Utilisateurs en attente]

Prochainement ce fichier devrait permettre une connexion à distance, mais en attendant, il existe un outil créé par Dra.:.god qui se nomme Online Signature. Il vous permet d’agrémenter l’image de votre choix avec les données provenant d’onlinesig.dat et de l’envoyer sur un site web via FTP.

S'applique à la version : .22a +
Dernière mise à jour le : 14/12/02 par Monk


FAQ eMule :: Chat IRC

Chat IRC

Le module de chat IRC d’eMule vous connecte à :

irc.liquidirc.com

Si vous cherchez de l’aide ou si vous souhaitez simplement nous rendre une petite visite, rejoignez-nous sur :

> #emule (officiel)
> #emule-german
> #emule-french
> #emule-spanish

Voir Préférences - IRC pour une information détaillée sur la configuration d’IRC.

Règles :

> Ne pas faire de message ops (les personnes avec @ devant leur nom)
> Ne demandez ou n’offrez pas des Warez ou tout autre matériel comportant un copyright
> Ne faites pas de spam avec des scripts sur les channels
> Ne faites pas de publicité sur les channels

S'applique à la version : 0.22b +
Dernière mise à jour le : 14/12/02 par Monk


FAQ eMule :: Les Amis

Les Amis & Voir fichiers

Le réseau eDonkey est vaste, aussi, il est difficile d’y retrouver un utilisateur. L’option Amis est une manière facile et pratique de conserver la trace de personnes ayant les mêmes centres d’intérêt ou les mêmes goûts. Ceci est d’autant plus intéressant pour les groupes qui font des releases.

Menu contextuel des Sources (faites un clic droit sur une source dans la liste des Transferts)

o Voir détails
Montre quelques informations sur les données transférées, les taux et le coefficient de pondération de cet utilisateur.

o Ajouter aux amis
Lorsque l'on ajoute un utilisateur aux amis, il est symbolisé par une icône "ami" et non plus l'icône habituelle du client et il est répertorié dans le tableau des Messages.

o Envoyer Message
Débute une session de Chat privée avec cet utilisateur.

o Voir fichiers
En fonction du réglage établi dans Préférences -> Fichiers, la liste des fichiers partagés peut être demandée à un Ami. Notez que le réglage par défaut d’eMule refuse la requête. Si la requête est acceptée, les fichiers de cet utilisateur sont affichés dans la fenêtre des recherches.

Actions sur les Amis
Les amis ajoutés sont répertoriés dans l'onglet Messages et permettent diverses actions.

o Voir Détails
Identique à ci-dessus.

o Retirer ami
Enlève ce client de la liste des Amis.

o Envoyer Message
Identique à ci-dessus.

o Voir Fichiers
Identique à ci-dessus.

o Etablissement d'un slot Ami
Un slot d’émission peut être exclusivement réservé à un Ami, ce qui lui permet d’établir une connexion directe sans avoir à patienter en file d’attente.
Un seul slot réservé est autorisé.

Icônes des Amis*

Cet Ami est actuellement en cours de transfert ou connecté.

L'Ami est dans les liste des clients connus actuellement.

Statut : est déconnecté ou inconnu.

Note:
Le statut des Amis n’est pas réactualisé régulièrement afin d’épargner de la bande passante. Pour connaître la situation réelle actuelle des Amis, vous devez exécuter une action.

S'applique à la version : .23a +
Dernière mise à jour le : 27/03/03 par Monk
* Corrigé le 27/03/03


FAQ eMule FAQ :: Filtrage des IP

Filtrage des IP

Il arrive parfois que des utilisateurs envoient, intentionnellement ou non, des données corrompues. Ceci peut empêcher un fichier de se finaliser correctement voire entraîner une corruption totale de ce dernier.
eMule propose donc un filtrage de base des IP. Les intervalles d'IP à filtrer sont enregistrés dans un fichier nommé ipfilter.dat qui se trouve dans le dossier d'installation d'eMule. Cette liste noire a le format suivant (identique à celui de cDonkey) :

# Exemple d'un fichier "ipfilter.dat"
#
# Toutes les intervalles d'IP seront bloqués à la fois en émission et en réception
# Soyez extrêmement prudent avec ce que vous écrivez ici.
# Des entrées erronées peuvent totalement empêcher
# eMule d'accéder au réseau
#
# Format:
# Intervalle d'IP , Niveau d'accès , Description
#
# Niveau d'accès :
# <127 bloqué
# >=127 autorisé

064.094.089.000 - 064.094.089.255 , 000 , Gator.com

Dans l'exemple, l'entrée bloque les IP depuis 064.094.089.000 jusqu'à 064.094.089.255. eMule ne se connectera à aucune IP appartenant à cette fourchette, ni pour envoyer ni pour recevoir des données.

Attention :
L'exemple ci-dessus bloque toute connexion à l'intervalle d'IP spécifié. Ceci peut restreindre le nombre de sources disponibles pour le téléchargement.

Pour le moment, seul un niveau d'accès est implémenté. Une valeur inférieure à 127 (par défaut dans les Préférences -> Securité) signifie que toute tentative de connexion est refusée. Les futures versions d'eMule étendront cette fonction.
Lorsqu'un client/IP est filtré, cela est enregistré dans le log de débogage (Fenêtre Debug).

Les distributions officielles d'eMule ne contiendront pas de fichier ipfilter.dat. N'utilisez pas cette fonction sans savoir exactement ce que vous faites !

Dernière mise à jour le : 27/04/03 par Monk


FAQ eMule :: Catégories

Catégories

Tous les fichiers dans la liste des téléchargements de la fenêtre des Transferts peuvent être ajoutés à des catégories. La première catégorie est toujours affichée et montre soit tous les téléchargements, soit seulement ceux qui n'ont pas été ajoutés à d'autres catégories. Un clic droit sur une catégorie, permet d'accéder à cette option.

Filtrer l'affichage
Cette option est seulement valable dans la première catégorie et vous permet de créer un filtre pour certains types ou certains statuts de fichiers.

Tout | aucun filtre, tous les fichiers sont visibles
Tous les autres | Tous les téléchargements qui ne sont pas présents dans une des autres catégorie sont affichés.
Incomplet, Accompli, En attente, Téléchargement, Erroné, En pause, Stoppé | La liste est filtrée selon le statut des téléchargements affiché dans la colonne Etat.
Vidéo | Les fichiers vidéos portant les extensions suivantes : .mpg, .mpeg, .avi, .divx, .rm, .ram, .wmf, .asf, .vivo, .mov, .ogm, .vob
Audio | Fichiers Audios : .wav, .mp3, .ogg, .mp4, .aac, .flac, .ape, .au, .wma, .mpc, .mp2
Archive | Fichiers Archives : .rar, .zip, .ace, .gz
Images-CD | .cue/.bin (CDRWin), .mds/.mdf (Alcohol120%), .ccd/.img/.sub (CloneCD), .bwa/.bwt/.bwi/.bws (BlindWrite), .nrg (Nero)

Ajouter une catégorie
Cela crée une nouvelle catégorie. Les différents réglages pour cette catégorie sont optionnels et le dossier Incoming par défaut est utilisé à moins qu'un autre ne soit spécifié.

o Titre
Le nom de la catégorie tel qu'il sera affiché.

o Commentaire
Description ou commentaire.

o Fichiers reçus
Un dossier Incoming séparé peut être utilisé pour chaque catégorie. Les fichiers terminés sont déplacés vers ce dossier. eMule utilise le dossier par défaut si ce champ est laissé vide.

o Changer la priorité pour les nouveaux fichiers
Les fichiers ajoutés à cette catégorie sont automatiquement paramétrés selon la priorité spécifiée.

o Assignation auto. à une catégorie
Lors du lancement de nouveaux téléchargements, ils peuvent être assignés automatiquement à cette catégorie, si le nom du fichier correspond à un modèle donné. La barre verticale | est utilisée pour séparer les différents mots clés et * peut être utilisé comme joker, en remplacement d'une chaîne de caractères..
Exemple: *.avi|a*.*
Cela assigne les nouveaux fichiers présentant une extension 'avi', et ceux dont le nom commence par un 'a' à cette catégorie.

o Couleur
Définit la couleur utilisée pour les fichiers de cette catégorie. Ce réglage affecte aussi la catégorie Tous ce qui permet de reconnaître d'un coup d'oeil à quelle catégorie appartient un fichier donné.

Editer Catégorie
Tous les réglages de la rubrique "Ajouter Catégorie" peuvent être modifiés à tout moment.

Supprimer Catégorie
Efface la catégorie sélectionnée. Les fichiers se trouvant dans ces catégories n'en sont pas affectés.

Priorité, Annuler, Stop, Pause, Reprise
Ces commandes s'appliquent à tous les fichiers de la catégorie. Faites attention avec la commande Annuler.

Reprendre le prochain en pause
Lorsqu'un téléchargement s'achève, un autre en pause dans la même catégorie et relancé.

Ajouter des fichiers aux Catégories
Les fichiers peuvent être ajoutés aux catégories par une action de glisser-déposer. Choisissez un téléchargement, enfoncez le bouton gauche de la souris et faites glisser le fichier dans la catégorie désirée. Plusieurs fichiers peuvent être sélectionnés avec la touche CTRL ou la touche MAJ. Les fichiers peuvent aussi être assignés à une catégorie en utilisant le menu contextuel de la liste des téléchargements.
Dans la fenêtre des Recherches les fichiers peuvent être directement ajoutés aux catégories en les choisissant avec les boutons avant de mettre en téléchargement le résultat de la recherche.

S'applique à la version : .30a +
Dernière mise à jour le : 24/08/03 par Monk


FAQ eMule :: ServeurWeb

Interface Web

eMule comporte une Interface Web qui permet des accès ainsi que l'administration de ses fonctions et réglages à distance. L'Interface Web peut être ouverte à partir de n'importe quel navigateur internet à la condition que l'adresse IP courante de la machine qui héberge eMule soit connue.

Pour se connecter à l'Interface Web, l'adresse IP et le port du serveur correspondants doivent être entrés comme adresse dans le navigateur internet. L'adresse doit ressembler à une URL web banale, c'est-à-dire : http://xxx.xxx.xxx.xxx:port. Les petits x représentent l'adresse IP courante et le port est 4711 lorsque l'on utilise les réglages par défaut. Le port du serveur doit être acheminé si vous utilisez un routeur sinon la connexion sera impossible. Reportez-vous à la rubrique sur les Ports dans cette FAQ pour plus d'informations.
Pour tester le serveur sur la même machine que celle sur laquelle le programme eMule s'exécute, entrez l'adresse du localhost http://127.0.0.1:4711

Hôtes DynDNS
De nombreux FAI (Fournisseur d'Accès Internet) effectuent une déconnexion toutes les 24 h pour assigner une nouvelle adresse IP. Or, pour se connecter à l'Interface Web, son adresse IP courante doit être connue.
De nombreux services gratuits offrent une solution pratique pour toujours connaître votre adresse IP courante - Ce sont les hôtes DynDNS. Ces services permettent d'attribuer une adresse d'hôte statique telle que http://monAdresse.monHote.com à des machines qui ont des IP dynamiques. Un petit utilitaire appelé Programme Client DNS Dynamique, qui doit s'exécuter sur la même machine qu'eMule se charge de la mise à jour de l'adresse IP vers l'hôte statique à chaque fois qu'elle change. Ainsi, vous pouvez simplement avoir accès à l'Interface Web par l'intermédiaire de l'hôte statique.http://monAdresse.monHote.com:4711.

Si l'adresse correcte est entrée, l'écran de connexion apparaît. Pour entrer, renseignez le mot de passe que vous avez établi dans les Préférences de l'Interface Web.

Important :
Il est fortement recommandé de prévoir un mot de passe correct dans les préférences. Si aucun mot de passe d'administrateur n'est configuré, n'importe qui peut avoir accès à votre eMule et régler les préférences, effacer ou ajouter des fichiers, etc.

L'accès à presque toutes les fonctions d'eMule est possible dans l'Interface Web. Tous les changements affectent directement eMule sur le PC serveur.

S'applique à la version : .27b +
Dernière mise à jour le : 21/03/03 par Monk


FAQ eMule :: Messages d'erreur

Messages d'erreur

Un client a provoqué des erreurs : Le paquet reçu est invalide ou corrompu. Client déconnecté
Un client connecté a causé une erreur. La pire chose qu’il puisse arriver est que vous le perdiez comme source.

Erreur Fatale : impossible de créer socket sur port 4662
Cette erreur apparaît lorsqu’une autre application tente d’utiliser le port 4662 pour établir une connexion. En général ceci se produit lorsque vous utilisez en même temps eMule et eDonkey sans avoir changé le réglage du port sur l’un des deux.
Il est déconseillé de lancer à la fois eMule et eDonkey ou eMule et Overnet à moins d’avoir une bande passante (en émission) très conséquente.

ERREUR: Votre port 4662 ne peut être joint. Vous avez une LOWID
eMule a détecté un blocage du port 4662. Cela peut être causé par un pare-feu ou un routeur mal configuré. Lisez la FAQ ou faites une recherche sur le forum sur la manière de configurer votre pare-feu/routeur.

ERROR: Your port 4662 is not reachable. You have a LOWID http://www.edonkey2000.com/documentation/lowid.html ! Please correct your network config !
Cette erreur est similaire à celle ci-dessus. Elle ne s'affiche pas dans la fenêtre de Log du serveur mais dans la fenêtre d'info des serveurs. Ce message est généré par les serveurs patchés par Lugdunummaster. Voir ici pour obtenir des détails sur les patches de Lugdunum.

Erreur fatale durant la connexion. La connexion Internet est peut-être perdue
La raison la plus probable d’apparition de cette erreur est une déconnexion d’internet. Toutefois, cela peut aussi se produire lorsque votre connexion à internet est fortement sollicitée ou lorsque vous utilisez le pare-feu Zone Alarm qui semble gérer plutôt mal de nombreuses connexions.

Erreur: Version de part.met invalide ! (x.part.met => (nul))
Une erreur sérieuse est survenue alors qu’eMule inscrivait des données dans un fichier .part.met. Ces fichiers sont ceux dans lesquels eMule garde la trace des téléchargements en cours.
La cause de cette erreur est un crash de Windows ou d’eMule. Pour récupérer les fichiers vous pouvez essayer :

- de localiser le(s) fichier(s) dans votre fichier Temp. Si vous ne pouvez pas les trouver, c’est perdu,
- d'utiliser un programme comme MetMedic, DonkeyDoctor (en espagnol, mais le programme est disponible en français et en anglais et un forum d’aide est disponible en anglais) ou eD2k RecoverMET (lien ed2k) pour reconstruire le fichier .met.
- Vous pouvez aussi essayer de lancer eDonkey en utilisant votre fichier Temp courant. Il sera peut-être en mesure de corriger le problème.

Avant toute opération, arrêtez eMule. N’espérez pas trop de miracles. C’est une erreur sérieuse et la probabilité est grande de devoir télécharger la totalité du fichier à nouveau.

Le statut d’un fichier en téléchargement est "Erroné"
C’est aussi une erreur d’opération sur le fichier. Cela se produit lorsque :

- eMule est incapable d’ouvrir un fichier .part.
Vérifiez votre dossier Temp dans Préférences et corrigez son emplacement si nécessaire,
Vérifiez si aucun fichier se trouvant dans le dossier Temp n’est protégé en écriture,
Redémarrez eMule.

- eMule est incapable de finaliser un téléchargement ou le déplacer vers le dossier Incoming
Vérifiez votre dossier Incoming dans Préférences et corrigez son emplacement si nécessaire,
Vérifiez l’espace disponible sur le disque dur hébergeant le dossier Incoming,
Redémarrez eMule.

Si rien de ceci ne fonctionne, quittez eMule, effacez les fichiers preferences.dat et known.met dans le dossier d’installation d’eMule, puis redémarrez.

Le client 'xxx' (IP:xxx.xxx.xxx.xxx) a provoqué des erreurs : Hashset corrompu ou invalide reçu. Client déconnecté !
De votre côté, vous ne pouvez rien faire. Ceci est provoqué par un autre client qui vous a envoyé un hashset invalide lors de votre demande de source.

Erreur: Impossible de hacher la partie téléchargée : hashset incomplet (XXX). Ceci ne devrait jamais arriver
Cette erreur est un bogue qui peut arriver avec de petits fichiers. Ils se complètent néanmoins correctement. Vous pouvez ignorer ce message.

Erreur inconnue d’écriture de XXX : Erreur inconnue d’accès à C:\Program Files\eMule\temp\YYY.part
Alors qu’eMule tente de compléter un fichier, il rencontre un problème avec le fichier .part. Les raisons possibles sont :

- un déplacement du dossier Temp ou du fichier part,
- un autre programme accède à ce fichier (exemple : un programme antiviral, un autre programme de p2p).

Recherchez la cause et redémarrez eMule.

Versions de tag invalides dans server.met (0x3C)
Le chargement ou la mise à jour du server.met a causé un problème. Soit un server.met invalide a été mis à jour à partir d'une URL, soit le fichier server.met a été corrompu. Essayer de mettre à jour la liste de serveurs à partir d'une autre URL ou effacez le fichier server.met si l'erreur persiste.

An attempt was made to access an unnamed file past its end
Ce message apparait dans une fenêtre et est causé par des paquets invalides provenant du serveur ou d'autres clients. Ce message n'affecte pas les opérations d'eMule et est correctement pris en charge dans les versions .28a+

Dernière mise à jour le : 19/04/03 par Monk


FAQ eMule :: Dépannage

Dépannage

o

Les liens internet eD2k ne fonctionnent pas. Le navigateur affiche un message d'erreur.
eMule a besoin d'être correctement associée avec le format spécial des liens internet. Certains autres programmes peuvent changer cette association. Dans ce cas, un double clic sur le lien produit soit un message d'erreur soit le téléchargement ou la liste de serveurs ne sont pas ajoutés. Si le bouton Liens ED2K dans les Préférences -> Général est grisé mais que les liens ne fonctionnent toujours pas, il vous faut vérifier la base de registre de Windows. Utilisez regedit (Démarrer -> Exécuter -> regedit) pour accéder aux clés suivantes :

HKEY_CLASSES_ROOT\ed2k\shell\open\command
Name: (Standard)
Type: REG_SZ
Données : "Chemin du fichier emule.exe (avec les guillemets !)" %1

et

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\shell\open\command
identique à ci-dessus

Si vous rencontrez des problèmes d'association des liens avec eMule supprimez toutes les entrées après HKEY_CLASSES_ROOT\ed2k\... et HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\... puis appuyez de nouveau sur le bouton Liens eD2k dans eMule.
Faites une sauvegarde de la base de registre avant d'y apporter toute modification !

Opera
Pour permettre aux liens internet de fonctionner avec Opera, un fichier de configuration doit être édité dans le répertoire d'installation du navigateur. Fermez Opera et ouvrez l'un des fichiers suivants dans un éditeur (par exemple, le bloc notes de windows).
Opera 6.x:
Ajoutez la ligne TrustedExternalURLProtocols=ed2k sous [User Prefs] dans le fichier Opera6.ini puis sauvegardez-le.
Opera 7.x:
Pour Opera 7.x, ajoutez la même ligne dans le fichier OperaDef6.ini.

o
 ServeurWeb : Internet Explorer ouvre un dialogue de téléchargement au lieu d'afficher la page
Pour empêcher cela, Utiliser HTTP 1.1 et Utiliser HTTP 1.1 avec une connexion par proxy doivent être cochés dans les Paramètres d'IE. Allez dans Outils -> Options Internet -> Advancé : Paramètres HTTP 1.1
o

Téléchargements perdus
Après un mauvais plantage, un(des) téléchargement(s) peut(vent) soudainement disparaître de la liste bien que son(leurs) fichier(s) soit(soient) toujours présent(s) dans le dossier temporaire. Ceci se produit si un fichier *.part.met est corrompu.

Général
Fermez eMule avant d'entreprendre toute tentative de récupération.
Pour vous assurer que tout est correctement réglé, vérifiez les Préférences -> Dossiers. Le chemin correct menant au dossier temporaire doit y être entré.

Sauvegardes
eMule crée des sauvegardes automatiques (*.part.met.BAK) de tous les fichiers *.part.met. Si vous observez une différence det taille ou de dernière modification (clic droit sur le fichier -> Propriétés), supprimez le fichier *.part.met et renommez la sauvegarde correspondante.

Outils de récupération
Le chapitre concernant les Outils contient quelques liens vers des outils de récupération. Sauvegardez les fichiers *.met et *.part avant de tenter de les récupérer. Les modifications ne peuvent être annulées.

Déplacement manuel
Dans quelques cas rares, un fichier *.part.met est tellement endommagé qu'il empêche les autres fichiers de se charger normalement. En ajoutant les fichiers un par un, le téléchargement endommagé peut être identifié et supprimé ou récupéré.

1. Déplacez tous les fichiers du dossier temporaire vers un dossier de sauvegarde
2. Ramenez un fichier *.part et son *.part.met correspondant depuis la sauvegarde vers le dossier temporaire
3. Démarrez eMule et vérifiez si le téléchargement est correctement ajouté à la liste
4. Fermez eMule
5. Répétez les étapes 2. - 4. jusqu'à ce que le téléchargement corrompu soit identifié
6. Effacez le téléchargement corrompu ou tentez de le récupérer à l'aide d'un outils approprié.
o

"Comportement étrange"
Si des problèmes de mise à jour de la liste des serveur ou de perte de réglages se produisent, certains fichiers de configuration peuvent être corrompus. Ceci se produit particulièrement après des plantages ou après une mise à jour à partir de versions modifiées d'eMule. Dans ce cas, Supprimer tous les fichiers *.met, *.ini et *.dat dans le dossier d'installation d'eMule (n'effacez pas vos téléchargements temporaires !), peut régler ces problèmes. Fermez eMule avant d'effacer ces fichiers. Après l'avoir relancé, réglez à nouveau les options correctement dans les Préférences puis fermez et redémarrez eMule encore une fois.
o

Déconnexion du serveur rapidement après une connexion.
De nombreux serveurs limitent le nombre de fichiers partagés. Si le client atteint cette valeur définie par le serveur, il est déconnecté automatiquement. eMule affiche le nombre de fichiers partagés dans sa page de statistiques. En règle générale, un nombre inférieur à 500 partages ne cause pas de problème et vous assure que tous les fichiers seront acceptés.
A partir de la v.28 d'eMule, le nombre de fichiers acceptés est affiché dans la liste des serveurs. La Limite Faible (Soft Limit) est le nombre de partages qu'un serveur publie, tous les fichiers en excès sont ignorés. Lorsque la Limite Forte (Hard Limit) est atteinte, le serveur déconnecte le client.
Pour éviter les déconnexions, eMule v.29 + ne publie que le nombre de fichiers autorisé par la limite faible du serveur.
o Mise en liste noire sur les serveurs Lugdunum p75+
Les nouveaux serveurs Lugdunum patchés avec la version p75+ ont un système de crédit pour juger du comportement des clients. Chaque action, connexion, recherche, demande de sources, etc. coûte des points de crédit. Lorsque le crédit est épuisé, le serveur déconnecte le client et l'avertit de sa mise en liste noire.
Le problème se pose lorsque l'on télécharge plus d'une trentaine de fichiers car les demandes de sources pour tous ces téléchargements grèvent tellement le crédit que cela conduit au bannissement du client. eMule v.30a+ prend en charge ce problème.
Des informations additionnelles sont disponibles sur le site internet de Silent Bob (en anglais), le site internet d'ed2k.ch (Razorback) (en français).

Dernière mise à jour le : 24/08/03 par Monk


FAQ eMule :: Outils

Outils

Utilitaires de récupération des téléchargements corrompus :
 | MetMedic | Outil d'édition des fichiers .met et de récupération de téléchargements perdus
 | DonkeyDoctor | Outil de récupération d'utilisation facile.
 | eD2k RecoverMET | Outil en ligne de commande. (Lien ed2k).

Outils et Utilitaires divers :
 | Connection test | Script de test réalisé par TheDonkeyNetwork pour vérifier si le port du client est ouvert
 | Online Signature | Ajout des données issues d’onlinesig.dat à des images. Voir Online Signature
 | New Online Signature | Site allemand de développement de l'application Online Signature
 | AC-Plug | Relance la connexion internet perdue
 | Client VideoLAN | Une alternative pour prévisualiser les fichiers multimédias. Voir Préférences -> Dossiers
 | RASPPPOE | pilote PPPOE pour les connexions DSL par Robert Schlabbach

Si vous connaissez un bon outils pour eMule envoyez une email à Monk@emule-project.net afin de l’ajouter sur cette page.

Dernière mise à jour le : 25/04/03 par Monk


FAQ eMule :: FAQ - Désespéré

FAQ

eMule ne fonctionne toujours pas !

Répétez après moi : "Je jure sur la Sainte Babel, avoir lu, compris et appris par coeur la totalité de la FAQ et de l'aide. J'ai aussi utilisé la fonction de recherche pour trouver une réponse existante dans les forums et j'ai déjà demandé poliment de l'aide là-bas. Malheureusement, cela ne fonctionne toujours pas."

Si vous rencontrez ce grave problème, cela peut-être…
• un bogue d'eMule
• un bogue de Windows
• le destin
• ou un problème situé entre le clavier et la chaise.

Dans tous les cas d'amères lamentations sont indiquées.

Mis à jour le : 03/09/03 par Monk


eMule part file access module for VideoLAN - README

Lisez-moi -
Module d'accès aux fichiers part d'eMule pour VideoLAN

Démarrage rapide

  • Téléchargez et installez le client VideoLAN (VLC) sur http://www.videolan.org
  • Décompressez l'archive du module d'accès aux fichiers part d'eMule et copiez le fichier libaccess_partfile_plugin.dll dans le dossier plugins du répertoire d'installation de votre client VideoLAN. En général : C:\Program Files\VideoLAN\VLC\plugins
  • Rendez-vous dans les Préférences/Fichiers d'eMule et spécifiez le client VideoLAN comme lecteur vidéo à utiliser pour la prévisualisation des fichiers part.
    • Entrez le chemin d'accès complet à l'exécutable de VideoLAN client. En général :C:\Program Files\VideoLAN\VLC\vlc.exe
    • Désactivez la fonction : Faire une sauvegarde pour prévisualiser
  • Vérifiez si le module d'accès aux fichiers part d'eMule est correctement reconnu par VLC. Voir aussi : AVERTISSEMENT IMPORTANT

Objectif

L'objectif de ce module d'accès est de fournir à VideoLAN un flot de données en provenance d'un fichier part d'eMule.

Comme, par définition, un fichier part d'eMule ne contient pas des données ininterrompues, le logiciel VideoLAN doit parcourir la totalité du fichier pour trouver toutes les données disponibles. Ce processus peut prendre un temps assez long, en fonction des données présentes et de la taille du fichier..

Ce module accède au fichier part d'eMule pour connaître les données réellement disponibles. Muni de cette information, le module est capable de créer un flot virtuel de données, sans espace, qu'il peut adresser directement à VideoLAN. Ainsi, le client VideoLAN n'a plus besoin de parcourir la totalité du fichier, car il "voit" seulement les parties disponibles du fichier part.

Installation

Copiez le fichier libaccess_partfile_plugin.dll dans le dossier plugins du répertoire d'installation du client VideoLAN. En principe : C:\Program Files\VideoLAN\VLC\plugins

AVERTISSEMENT IMPORTANT : Après l'installation du module d'accès aux fichiers part d'eMule ou après l'installation d'une nouvelle version de VLC, vous devez toujours vous assurer manuellement si la version du module correspond à celle de VLC. VLC ne supporte pas l'installation d'un module développé pour une autre version que celle qui est installée. Cela signifie que si, par exemple, vous utilisez VLC v0.6.1, vous ne pouvez pas bénéficier d'un module développé pour VLC v0.6.2 et réciproquement. La version de VLC doit toujours correspondre à celle du module. Il n'existe aucune possibilité d'effectuer cette vérification de manière automatique. C'est pourquoi, vous devez ouvrir manuellement le dialogue des paramètres de VLC (Paramètres/Préférences/Modules/access) et vérifier si un module access_partfile est disponible. Si ce n'est pas le cas, votre version de VLC ne correspond pas à celle du module. Vous devez donc mettre à jour, soit VLC soit le module d'accès aux fichiers part d'eMule.

Vous avez aussi la possibilité de connaître la version requise de VLC en lisant les informations contenues dans le module d'accès aux fichiers part d'eMule. Utilisez la commande de propriétés du fichier de l'explorateur Windows, comme illustré ci-dessous :

eMule part file module version information

Désinstallation

Supprimez le fichier libaccess_partfile_plugin.dll du dossier plugins du répertoire d'installation du client VideoLAN. En principe :C:\Program Files\VideoLAN\VLC\plugins

Utilisation

Le module d'accès aux fichiers part est appelé automatiquement par le client VideoLAN à chaque ouverture de fichier. Si l'extension du fichier ouvert est .part, le module tente de trouver le fichier .part.met correspondant et le traite de la manière décrite ci-dessus. Aucune autre action n'est requise pour utiliser les fonctions de ce module, que l'ouverture de n'importe quel fichier part que vous désirez visualiser, que ce soit à partir d'eMule (Prévisualisation), de l'Explorateur ou du dialogue d'ouverture des fichiers du client VideoLAN.

De plus, vous pouvez spécifier le fichier part à ouvrir avec partfile://<chemin> pour être sûr que ces fichiers parts sont bien ouverts avec le module d'extension d'eMule lorsque vous procédez à partir du dialogue d'ouverture de fichiers de VLC ou depuis une ligne de commande dans l'Explorateur de Windows. (Cela empêche la détection automatique de VLC).

Exemple: partfile://D:\eDonkeyTMP\001.part

Paramètres

Le dialogue des paramètres du module d'accès est accessible depuis le client VideoLAN dans Paramètres/Préférences/Modules/access/access_partfile.

VideoLAN client - eMule part file access plugin settings

Recherche dans les flots de données

En général, les prévisualisations d'eMule n'autorisent pas les recherches. Vous ne pouvez vous déplacer à l'intérieur du fichier, utiliser le curseur de position, ou aller à un endroit bien défini. Les options du module permettent la création de flots de données qui autorisent ces déplacements à l'intérieur du fichier.

Pour savoir si le fichier part est un AVI ou un MPEG, le module se base sur l'extension du fichier et sur d'autres informations fournies par eMule. Cependant ces informations ne sont pas toujours correctes et il peut arriver qu'un flot de données permettant la recherche soit créé bien que l'option correspondante soit désactivée. (Par exemple, vous êtes en train de télécharger un fichier "Vidéo de mes vacances.mpg", mais le format réel de ce fichier est de type AVI). Si cela se produit, vous pouvez renommer le fichier avec son extension correcte dans le dialogue des détails du fichier d'eMule.

Enable plugin for MPEG part files
Activation du module pour les fichiers part MPEG

Si cette option est activée, le module ne crée le flot virtuel de données que si le fichier part est au format MPEG. Défaut = activé.

Provide a seekable stream for MPEG part files
Obtenir un flot de données autorisant la recherche pour les fichiers part MPEG

Si cette option est activée, le module crée un flot de données autorisant la recherche à partir du fichier part. Cette option est sans effet si l'option "Enable plugin for MPEG part files" est désactivée. Défaut = activé.

Enable plugin for AVI part files
Activation du module pour les fichiers part AVI

Si cette option est activée, le module ne crée le flot virtuel de données que si le fichier part est au format AVI. Défaut = désactivé.

Provide a seekable stream for AVI part files
Obtenir un flot de données autorisant la recherche pour les fichiers part AVI

Si cette option est activée, le module crée un flot de données autorisant la recherche à partir du fichier part. Cette option est sans effet si l'option "Enable plugin for AVI part files" est désactivée. Défaut = désactivé.

Note: les flots de données autorisant la recherche pour les fichiers part AVI peuvent donner de faux résultats (le flot est arrêté trop tôt) et / ou les performances sont inférieures à celles constatées avec les fichiers MPEG.

Enable plugin for other (non MPEG or AVI) part files
Activation du module pour les autres fichiers part (non MPEG ou non AVI)

Si cette option est activée, le module ne crée le flot virtuel de données seulement si le fichier part n'est ni au format AVI ni au format MPEG. Utilisez cette option pour prévisualiser tous les autres formats de fichiers (e.g. OGM, MKV, ...) Défaut = désactivé.

Provide a seekable stream for other (non MPEG or AVI) part files
Obtenir un flot de données autorisant la recherche pour les autres fichiers (non MPEG et non AVI)

Si cette option est activée, le module crée un flot de données autorisant la recherche à partir du fichier part. C'est option est sans effet si l'option "Enable plugin for other (non MPEG or AVI) part files" est désactivée. Défaut = désactivée.

Enable plugin for all type of files (eMule part files and regular files)
Activation du module pour tous types de fichiers (fichiers part d'eMule et autres fichiers)

Si cette option est activée, le module gère tous les types de fichiers ouverts par le client VideoLAN et qui seraient habituellement traités par son module par défaut. Cette option permet de surmonter un bug du module d'accès du client VideoLAN qui entraîne parfois un gel total du système lors de la tentative de lecture d'un fichier brisé. Le module d'accès aux fichiers part d'eMule tente de proposer une solution de rechange concernant ce bug en gérant les fichiers autres que des .part de la même manière que le module d'accès original. Défaut = désactivé.

Fichier d'info pour les fichiers part d'eMule (métadonnées ED2K)

Le dialogue d'information du fichier est accessible depuis le client VideoLAN dans View/File info. Il affiche les paramètres du format du fichier déterminés par VideoLAN et quelques unes des metadonnées eMule/ED2K.

VideoLAN client file information dialog