eMule FAQ 中文版 :: 歡迎

歡迎來到 eMule FAQ 中文版

這個 FAQ 將會不斷的更新請經常地來檢查在 http://www.emule-project.net/faq/ !
所有重要的主題將放置在這裡. 假如您仍然有問題或是對 FAQ 有任何感想及意見請以電子郵件連繫我 Monk@emule-project.net
我將 不會 回答下面包含下面問題的郵件
> | 已經在 FAQ 內的
> | 在論壇已討論過的
> | 有關下載的或與 eMule 無關的檔案
> | 非英文及德文所寫的信件

若對中文翻譯有任何問題請在 官方論壇-中文網頁部分 , 官方論壇-程式中文部分 或是 我的留言板 留言或是以電子郵件連繫 edonkey2000c＠yahoo.com.tw
eDonkey2000 & OverNet 中文站

初學者指南 - 指引使用 eMule

FAQ - 經常被問的問題

網路指南 - eD2k & Kademlia

一般資訊

  • 圖示
  • 進度條顏色
  • QR - 等候順序
  • ID 解釋
  • 等級 & 積分
  • 其他語言
  • 清單
  • 使用的檔案
  • 控制 eMule (快速鍵及祕訣)

設定 eMule - 選項

  • 一般
  • 顯示
  • 連線
  • 代理
  • 伺服器
  • 資料夾
  • 檔案
  • 通知
  • 統計
  • IRC
  • 時間表
  • Web 界面
  • 防護
  • 延伸
  • Preferences.ini

連接埠, 防火牆 & 路由器

  • 連接埠
  • 防火牆 - 一般
  • 防火牆 - WindowsXP
  • 路由器
  • Solwise SAR-7x5 + Allnet ALL129
  • Lucent CellPipe 20A-GX-E
  • SMC Barricade 7004 ABR
  • Linksys BEFSR41
  • Cisco 677/678

伺服器

  • 更新伺服器清單
  • 伺服器清單網址
  • 動態 DNS 解析

特徵

  • 檔案的搜尋 (布林搜尋)
  • 額度系統
  • 安全的使用者識別
  • 禁止侵略性客戶端
  • 來源交換
  • 預覽多媒體檔案
  • 上線簽名檔
  • IRC 聊天
  • 好友
  • IP 過濾 (封鎖不必要的客戶端)
  • 類別
  • Web 界面
  • 指令行參數
  • MuleMRTG (長時間的統計)
  • eD2k 連結 (各種連結格式及 Link Creator)
  • 來源管理 (來源, 等候及A4AF)
  • 損壞的處理 (ICH 和 AICH)

發現及解決

  • 錯誤訊息
  • eD2k 連結
  • Web 界面
  • 下載
  • "奇怪的反應"
  • 伺服器連線
  • 被列入黑名單中

工具

最後更新在: 2004-09-15 (v0.44b) -中文化:CML 2005-02-07(v0.45a)


eMule FAQ 中文版 :: 初學者指南

初學者指南

假如您是使用 eMule 的新手, 讀取這短篇指南來取得並執行它. 這個主題主要是詳述有關於 FAQ 中文版的各種章節.
1. 下載及安裝
在這裡取得它. 您能選擇下載安裝程式或ZIP檔案包裝的型式. 解壓縮這個ZIP檔案到任何您想放置的資料夾並從那裡執行它.

注意:
假如您使用 Windows98 您或許得到 oleacc.dll 找不到 這個錯誤訊息. 這個DLL是 MS System Updates for Win98 一部分.

Windows95/98 使用者注意事項:
1. 由於 Unicode 的使用, 需下載 Microsoft Layer for Unicode on Windows 95/98/ME Systems (MSLU) version 1.0,
2. 且請確定您的系統包含的 Comctl32.dll 最少版本在 5.80.2614.3600 之上 (位於 Windows-System 資料夾內). 更新這個 DLL 請前往 Platform SDK Comctl32 Redistributables 5.80.2614.3600 並且隨著在那裡的指示來下載及安裝.
2. 選項
在 eMule 啟動之後點下 選項. 下列只會描述一些重要設定, 假如您想要更多詳細設定, 請讀取 FAQ 中文版的其他章節.

- 一般

暱稱.
請輸入一個暱稱. 這個 http://emule-project.net 暱稱是無趣的.
eMule 和 ED2K 連結產生關聯
使 eMule 來接受這個特別的網址連結格式按下 [image] -按鈕. 假如按鈕是變成灰色的, 代表 eMule 已產生關聯.
- 連線
連線頁是在選項視窗中最重要的一項. 請花點時間徹底的閱讀 這個說明
精靈
您能使用精靈來做快速設定. 它將會給您好的設定數值.
o | 作業系統
推薦您使用新一代的作業系統像是 Windows 2000 或 XP, 它們能處理複合的連線數, 遠比 Windows 9x/ME 好.
o | 同時下載數量
這個設定值將會影最大的允許來源數. 選擇您將加入下載清單的檔案數.
注意:
不要加入太多檔案到您的下載清單中. 在主視窗中 統計 內的 發現來源數 值不應該高過於 ~3000. 太多的來源數將會使您的固定來源的要求連線阻塞. 當您展開一個下載中的檔案時會看見許多的 (太多連線數) 在來源點上面, 代表您有太多連線數以您所設定的連線類型來處理. 減少您的 硬性限制 數值來解決這個問題.
o | 連線類型
在清單中選擇您的連線方式. 選擇您正確的連線速度是重要的. 假如它不是在清單中, 選擇自訂並輸入您的連線頻寬在視窗中. 留意二種不同的單位 千位元/秒(kiloBits/s) [kb/s] 及 千位元組/秒(kiloBytes/s) [kB/s]. 一個位元組(Byte)等於八個位元(Bits).
在完成連線設定後按下 套用.

- 資料夾
在資料夾選項中您能指定哪裡是儲存已完成檔案的資料夾 (新進檔案資料夾) 及未完成檔案的 (暫存檔案資料夾).
在 已分享資料夾 中有標上記號的資料夾會公開於網路上. 假如您要分享其子資料夾, 按住 CTRL 並點下您要分享的資料夾.

注意:
假如您從 eDonkey2000 轉換到 eMule 簡單的指向與您使用的 eDonkey2000 相同新進及暫存檔案資料夾. 這些檔案將會自動的在 eMule 重新開啟之後加入.
3. | 伺服器
您必須要有伺服器來存取網路. 在第一次啟動它取得新的伺服器清單是重要的.
使用 server.met 從這個網址更新 來更新您的伺服器清單是容易的方法. 請見 這裡 來得到更多有關於伺服器清單更新的詳細資料.
那裡有 許多網站 提供好的 server.met 檔案, 但要快速學習請複製這個網址
http://ocbmaurice.dyns.net/pl/slist.pl?download/server-good.met

到您的剪貼簿並把它貼在更新視窗中然後按下"更新"按鈕. 感謝 Maurice 提供這個伺服器清單服務.
然而您將會在 伺服器 的 記錄 中顯示有許多的伺服器已加入到您的清單.
4. | 連線到一個伺服器
當您已經更新了伺服器清單後, 按下在左上角的 [image] 連線按鈕.
一旦成功的連線到一個伺服器在底部的狀態列看起來會像這樣:

重要的:
表示著高 ID. 連線狀況良好.
假如您得到這個圖示在您每次嘗試的連線都得到低 ID而您應該讀取有關 ID, 防火牆, 及 路由器 在 FAQ 中文版說明文件中.
5. | 就是這樣!

現在您能開始加入檔案到下載清單中, 透過從 eMule (假如未看到您想要的, 使用 全球搜尋 ) 直接搜尋或是使用網站基礎搜尋引擎或是及其他各種支援的站台.
6. | 其他的資訊
o | eMule 圖示 說明
o | 進度條顏色
o | QR - 等候順序
o | 假如您想要有一個好的下載速度請加入有許多來源的檔案. 檔案低於 100 個來源數是被認為成稀有的而且必須花相當多的時間來下載. 忍耐點等待是值得的!
o | eMule 長期執行它變得快速. 但不要期望正確啟動之後能有高的下載比率.
o | 這個網路適合分享大檔案. 請不要分享大量的蒐集於個人的小檔案. 這將會使伺服器花費不必要資源.
o | 分享您將得到 報酬 .
享受使用 eMule 的樂趣!

最後更新在: 2002-12-28 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 網路指南

網路指南

自從釋出 v.42.1 在 eMule 有二個特徵不同的網路 – 傳統的伺服器基礎 eD2k 網路及一個完全新的不需伺服器拓樸基於 Kademlia 的網路.
在這二個網路的本質上都有相同的功能. 他們二者提供了一個獨立的方式尋找其他的使用者或您想要下載的檔案.

基本的
檔案識別
所有的檔案都有一個切細值. 這個切細值是由數字和字母組成來識別獨一無二的檔案. 一個檔案或許會有很多的檔案名稱, 但這個不會在這個檔案的切細值有任何改變. 這個允許每個使用在去找到一個獨特的檔案的來源其檔案名稱會因每個使用者而所不同.
除此之外, 這個檔案是被弄碎到 9.28 MB 的部分資料. 每個部分也會有一個切細值. 例如一個 600 MB 的檔案應該會包含 65 個部分. 每個部分都有一個切細值. 那樣這檔案切細值由那些部分切細段建立並使用在這個網路.

識別其他的客戶端
像檔案切細值一樣, 每個使用者在這網路取得獨一無二且固定的使用者切細值. 這個使用者識別是高安全的由一個 公開 / 私人 鍵值 交握處理預防濫用.

下載資料
在 eMule 重要且必須了解的是網路的選擇不會影響真實的下載. 這網路拓樸只和檔案的搜尋和尋找一個檔案的客戶端來源有關.
一旦一個來源已經發現, 您的客戶端將會連繫它. 那麼這來源將會保留在等候位置於指定的下載. 當您到達第一個等候位置後等待某一段時間您會開始接收資料.

傳統伺服器基礎 eD2k
連線到這個網路
這個網路的關鍵是 eD2k 伺服器. 每個客戶端必須連線到一個伺服器來進入這個網路.
當您的客戶端連線到一個伺服器, 這伺服器會檢查其他客戶端是否能自由地連線到您的客戶端. 假如是, 伺服器會分配您的客戶端一個所謂的 高-ID. 假如通訊阻塞, 伺服器會分配您的客戶端一個 低-ID.
在 ID 分配之後, eMule 將會送出一個所有已分享檔案清單到伺服器. 伺服器會加入您送出的檔案名稱和切細值到它的資料庫.

搜尋檔案
一旦連線到這個網路, 客戶端能搜尋檔案名稱的關鍵字. 搜尋能是本地或全球其中一個. 假如它是一個本地搜尋 (只在您已經連線的伺服器搜尋), 搜尋是快速但將會是少量的結果. 假如搜尋是全球搜尋 (搜尋在這網路的所有伺服器), 它將會花一段時間但結果較多. 每個伺服器在它本地的資料庫查找關鍵字並傳回任何相符合關鍵字的檔案名稱 (以切細值).

尋找檔案的來源
下載能由 eMule 的搜尋功能或是在許多網站提供的指定 eD2k 連結格式被加入.
一旦他們在下載清單, eMule 對於那個別的下載首先詢問本地 (已連線) 伺服器然後才在網路上的其他伺服器. 伺服器會在它的資料庫查找檔案的切細值並傳回它有的到客戶端.
來源是其他客戶端最少有一個完整的部分 (9.28 MB) 且檔案有相符的切細值.

沒有伺服器 Kademlia 網路
連線到這個網路
唯一要做的事是需要連接到這個網路任何已連線的 eMule 客戶端 IP 和連接埠. 這稱做啟動(Boot Strap).
一旦一個客戶端在這個網路, 客戶端會要求其他的客戶端來判斷它是否能自由的連線. 這個過程非常相似於伺服器的 高-ID/低-ID 檢查. 假如您能自由的連線, 您會被分配一個 ID (相似一個 高-ID) 並且是一個 “直接” 狀態. 假如您不能自由的連線, 您會是一個 “防火牆內” 狀態. 自從 v.44a 版本之後, Kademlia 網路支援一個 夥伴 來幫助防火牆的使用者. 夥伴是其他的 Kademlia 客戶端有著 直接 的 Kad 連線狀態並且工作成接替連線的方式, 那樣子防火牆內的使用者不能控制著它.

在 Kademlia 搜尋
在這個網路你的搜尋不是重要的. 對於檔案名稱, 在一個下載的來源或其他使用者的搜尋, 所有工作幾乎一樣.
在那裡沒有伺服器保持追蹝客戶端及他們分享的檔案所以它是由每個在這個網路參與的客戶端完成 – 基本上, 所有的客戶端也是一個小伺服器.
自從每個客戶端是由一個獨一無二的切細值識別, Kademlia 的構想是結合一個特定的 “責任” 基礎在這個切細值. 每個客戶端在 Kademlia 網路為特定的關鍵字或來源工作成一個伺服器. 客戶端的切細值決定了特定的關鍵字或來源.
所以任何種類的搜尋目標是由那些有目前搜尋主題責任的客戶端來尋找. 這個是由一個藉由詢問其他客戶端與目標客戶端可能的最短路徑之複雜計算完成的.

摘要
二個網路有著完全不同的觀念而相同的目的: 搜尋檔案和尋找一個檔案的來源. Kademlia 網路主要的目標是成為無中立伺服器和改善可量測性. 伺服器只能處理特定數量的使用者並且如果是一個較大的伺服器會嚴重的拖垮網路.
Kademlia 是自我組織並且自我調節最佳可能的使用者數及他們的連線品質效能. 因此, 它更能抵抗一個較大尺度的網路損失.

可應用版本: .42a +
最後更新在: 2004-09-12 由 Monk -中文化:CML 2005-02-05


eMule FAQ 中文版 :: FAQ - 索引

FAQ - 索引

安裝 & 更新
> | 作業系統 對什麼會有影響?
> | 錯誤訊息 oleacc.dll 找不到
> | 安裝程式(Installer)或壓縮檔(Binary)?
> | 當我更新 eMule 版本時我如何保留我的設定值和下載的檔案?
> | 從 eDonkey / Overnet 更新到 eMule 並保留下載的檔案
伺服器, 連線 & ID
> | 如何連線到 Kademlia?
> | 哪裡可以取得 伺服器清單?
> | 哪個 伺服器 是 最好最快?
> | 我要時常 更新伺服器清單?
> | 為什麼 eMule 不連線?
> | 為什麼我得到 low ID?
> | eMule 總是從 伺服器斷線
設定 & 速度
> | 我能開啟 eMule, 加入最新的家庭視訊(home video)並觀看它 5 分之後?
> | 哪些事會 影響 下載
> | 什麼是 最佳 設定值?
> | 我如何 增加 我的下載 速度?
> | 我能 期待 到什麼下載速率?
> | 等候區 應該多大?
額度
> | 什麼是額度並且我為什麼應該收集它們?
> | 我在哪裡可以看見我的額度積分?
> | 我遺失或刪除我的 clients.met 檔案. 我的額度遺失了?
> | 額度是安全的?
> | 總之如何去遺失額度.
下載 & 分享檔案
> | 我清單中的 下載消失
> | 在傳輸中 有顏色的條狀物 表示著什麼?
> | 在來源欄位中的數值 xx / yy (zz) 是什麼?
> | QR(排名) 是表示什麼?
> | 為什麼我的來源顯示 已在另一個檔案中要求?
> | 如何依字母次序下載
> | 太多連線數 表示什麼?
> | 我如何改變一個下載的名稱?
> | 紅色和綠色的驚嘆號記號 表示什麼?
> | 我如何加入一個 註解/等級 到一個檔案?
> | 我如何知道那一個檔案是 假的?
> | 我的下載將 不能完成.
> | 我的下載已經完成但顯示 已損壞
> | 我的下載已經完成但沒有 出現在新進檔案資料夾中
> | 暫存檔案資料夾太大了. 我能 刪除 它嗎?
> | 我如何 刪除/移除分享 檔案
使用 eMule
> | 一般提示
> | 我如何增加一位 好友 ?
> | 如何分配一個 好友的上載位置
> | 我如何清除 搜尋自動完成 的歷程?
> | 在來源前面的 圖示 表示著什麼?
> | 我可以 踢掉或禁止 其他的使用者?
> | 為什麼在搜尋我只能取得 201 個結果?
> | 我應該設定我的所有檔案到高的優先權或釋放?
各種方面的
> | 為什麼執行 eMule 時 網路變慢?
> | 什麼是 Mod?
> | Mod 是 更好或更快 ?
> | 我得到訊息 eMule 是被禁止的
> | 哪裡我可以取得更進一步的幫助?
> | eMule 是 匿名的?
> | 我的防火牆報告 攻擊 或為什麼 eMule 送出郵件?
> | 我的防火牆在我關閉 eMule 之後連線之後仍然報告連線
> | 什麼是 IP 過濾器?
> | 我可以 複製 這個 說明/FAQ 到我自己的網站?
eMule 仍然不工作!

最後更新在: 2003-10-03 由 Monk -中文化:CML 2004-11-19


eMule FAQ 中文版 :: FAQ - 安裝 & 更新

FAQ

安裝 & 更新

> | 作業系統 對什麼會有影響?
> | 錯誤訊息 oleacc.dll 找不到
> | 安裝程式(Installer)或壓縮檔(Binary)?
> | 當我更新 eMule 版本時我如何保留我的設定值和下載的檔案?
> | 從 eDonkey / Overnet 更新到 eMule 並保留下載的檔案

作業系統 對什麼會有影響?
eMule 可以工作在 Windows 95 之後的所有 Windows 版本. 一個 P2P 應用程式需要許多的網路連線數量, 因此需要一個穩定的網路平台. Windows 98 和 ME 有個非常差的網路平台會影響 eMule 的效能. 而 Windows 2000 或 XP 較新一代的作業系統會比較適合.
Windows 98 不要使用登錄檔來提升連線數. 它可能不能正常工作並且會使您的系統不穩定.

回頂端

錯誤訊息 oleacc.dll 找不到
這個錯誤訊息或許在一個 Windows 98 電腦內啟動 eMule 時出現. 缺少的 DLL 在 Microsoft 的 Windows 98 System Update 可取得.

回頂端

安裝程式(Installer)或壓縮檔(Binary)?
若是第一次使用 eMule 安裝程式會是比較好的選擇, 它包含了必要的檔案及說明文件. 只須執行 exe 檔案, 這個安裝程式將會引導您安裝的過程.
而壓縮檔只須將其解開到想放置的資料夾內即可. 有助於版本的更新.

回頂端

當我更新 eMule 版本時我如何保留我的設定值和下載的檔案?
解壓縮或安裝新版的 eMule 到您舊版使用的相同資料夾內. 只有 eMule.exe 和非使用者檔案會被取代. 全部的設定值和下載會被保留.
在更新到新版本之前須先關閉 eMule! 要保留先前設定值只須在啟動 eMule 時出現的精靈按下 取消 即可.

回頂端

從 eDonkey / Overnet 更新到 eMule 並保留下載的檔案
eDonkey .47 之前的版本使用和 eMule 相容的部分檔案系統, 然而在 .47 之後的版本使用分割的部分暫存檔案.
舊版的 eDonkey 只須簡單的將 eMule 的暫存資料夾指向 eDonkey 所使用的暫存資夾料. 或是在 eMule 未執行時移動 eDonkey 的暫存檔案到 eMule 的暫存資料夾內.
最近的 eDonkey 和 Overnet 使用分割的部分檔系統. 在這二種類型的客戶端有一個 "舊式部分檔案(old style)" 在選項內, 使用這個選項時, 暫存檔會變成單一個檔案 - 而 part.met 檔案是一個新的且不相容的格式.
eMule v0.30c 引進了一個轉換功能來匯入外部的部分檔到您的 eMule 下載內. 它能正確的匯入舊格式(eMule, eDonkey <=.47)及分割格式("舊式部分檔案(old style)"-格式的 >.47 eDonkey/Overnet 客戶端)之部分檔. 而非 eMule 格式將會被轉換到 eMule 的格式.
您能由快速鍵選單 (按 Alt+X) 或從 工具 圖示使用這個匯入功能. 在那裡您只須指定一個包含部分檔案的資料夾. eMule 將自動地試著去轉換部分檔案並加入它們到您的下載清單內.

回頂端

最後更新在: 2004-02-27 由 Monk -中文化:CML 2004-11-19


eMule FAQ 中文版 :: FAQ - 伺服器, 連線 & ID

FAQ

伺服器, 連線 & ID

> | 如何連線到 Kademlia?
> | 哪裡可以取得 伺服器清單?
> | 哪個 伺服器 是 最好最快?
> | 我要時常 更新伺服器清單?
> | 為什麼 eMule 不連線?
> | 為什麼我得到 low ID?
> | eMule 總是從 伺服器斷線

如何連線到 Kademlia?
eMule 自動地從任何發現的相容客戶端試著去進入 Kademlia 網路啟動區. 假如它不能連線, 只需從 Kademlia 主視窗內選擇 啟動 -> 來自已知的客戶端 並連線到一個伺服器並開始一個下載. Kademlia 將會在不久之後連線.

回頂端

哪裡可以取得 伺服器清單?
http://ed2k.has.it – 只須在 Add to eMule 上點一下.

回頂端

哪個 伺服器 是 最好最快?
沒有最好或最快的伺服器. 它們只用來連線到網路並搜尋檔案和來源. eMule 在使用全球搜尋時會詢問在伺服器清單內的每個伺服器來取得搜尋結果.
並且 eMule 會和其他的 eMule 客戶端交換來源, 因此尋找來源使用這個方式是較快的.

回頂端

我要時常 更新伺服器清單?
在一段時間內或是規律的使用 eMule 是不需要更新伺服器清單, eMule 的預設值 (選項 -> 伺服器 -> 連線到一個伺服器時更新伺服器清單 和 -> 連線到一個客戶端時更新伺服器清單) 將會使清單保持在更新狀態.

回頂端

為什麼 eMule 不連線?
它可能發生在 eMule 連線的伺服器也許關閉或是沒有回應. 假如 eMule 完全不能連線, 請確定您有一個較新的伺服器清單並檢查是否有像防火牆, 路由器, 撥號之類的軟體阻塞了 eMule 的傳輸.
您或許也要檢查 選項 -> 伺服器 -> 只自動連線到靜態伺服器. 假如核選此項而沒有提供一個有效的伺服器在 staticservers.dat 檔案內, eMule 將不會連線.

回頂端

為什麼我得到 low ID?
eMule 將只在下列的連接埠開放時才能完全的正常工作
• 4662 TCP (伺服器 low ID)
• 4672 UDP (Kademlia 防火牆內)
• 4711 TCP (不能使用 Web-界面)
有許多的原因可能阻塞了連接埠:
• 防火牆 - Windows XP 也有內建. (WinXP SP2 在預設情況下是啟用的!)
• 路由器
• 一些 ISP 的撥號軟體
• 連線共享軟體 / 軟體路由器
• 使用任何型式的 NAT 網路連線
• 連接埠被網路服務供應商阻塞
檢查所使用任何的防火牆或路由器軟體及硬體並做好適當的輸入連線的設定. 您也能試著使用不同的客戶端連接埠 6666, 80 或 20.
更多的資訊請見 防火牆及路由器.

回頂端

eMule 總是從 伺服器斷線
造成 eMule 一直從伺服器斷線的原因有:
• 太多的檔案在下載清單內 (只有 eMule v.30a 之前的版本才會)
• 太多的分享檔案 (只有 eMule v.29a 之前的版本才會)
• 伺服器問題
• 一般網路問題
eMule 通常在和伺服器失去連線時重新連線.

回頂端

最後更新在: 2003-09-03 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: FAQ - 設定 & 速度

FAQ

設定 & 速度

> | 我能開啟 eMule, 加入最新的家庭視訊(home video)並觀看它 5 分之後?
> | 哪些事會 影響 下載
> | 什麼是 最佳 設定值?
> | 我如何 增加 我的下載 速度?
> | 我能 期待 到什麼下載速率?
> | 等候區 應該多大?

我能開啟 eMule, 加入最新的家庭視訊(home video)並觀看它 5 分之後?
不, 的確不能. 像 eMule 特別使用在大檔案時網路在所有時間內幾乎是滿載的. 在這裡有一個簡單的規則說明 "上載到網路總量 = 在網路下載的總量". 大檔案需要大量的上載流量並且考慮到現今的網路提供商的一般都為低的上載速度, 別著急這正因為它是下載的本質.
eMule 是一個 共享 檔案的網路而不是用來交換它們的. 假如您留意到這差異 eMule 對您有用的.

回頂端

哪些事會 影響 下載
一些因素影響下載速度:
• eMules 設定值
• 高的 ID (防火牆和路由器設定)
• 持續執行 eMule 時間
• 一個下載的來源數量
• 單一部分的可得性
• 下載的流通性
錯誤的 eMule 設定值(錯誤的限制, 太多連線數), 一個低的 ID 和一個短的執行時間有一個對下載速度的不良影響. 非常流通的檔案 (新釋放) 和有低來源數量的一般檔案或壞的部分蔓延也會造成低的下載速率.

回頂端

什麼是 最佳 設定值?
在 eMule 那裡沒有最好的設定值它是和您的作業系統及網際網路速度及類型而定. 您總是應該使用精靈來得到好的基本設定. 您提供正確的網路連線數值及作業系統大多能改善.

廣泛的 DSL 512 / 128 良好的設定值應為

Windows XP
 | 下載能力: 64 (= 512 / 8)
 | 上載能力: 16 (= 128 / 8)
 | 下載限制: 無 (移去限制的勾選項)
 | 上載限制: 12 (= 16 x 0,75)
 | 硬性限制: 500
 | 最大連線數: 400
 | 新的連線之最大數量 / 5 秒: 30
 | 在同一時間內下載大約 6 到 20 個檔案.
Windows 98 / ME
 | 下載能力: 64 (= 512 / 8)
 | 上載能力: 60 (= 128 / 8)
 | 下載限制: 無 (移去限制的勾選項)
 | 上載限制: 12 (= 16 x 0,75)
 | 硬性限制: 300
 | 最大連線數: 200
 | 新的連線之最大數量 / 5 秒: 20
 | 在同一時間內下載不超過 12 個檔案

假如您使用在 選項 -> 延伸 內的 上載速度感應器 最好是移去限制的核選項並讓 eMule 管理頻寬. 它將會確保您有最大額度收集的最大上載速度並且其他的網際網路應用程式像是線上遊戲也能順暢執行.

回頂端

我如何 增加 我的下載 速度?
從正確的設定值分離只有您想要下載的檔案決定著下載速度. 得到一個良好平均效能注意下列:
• eMule 應該長時間執行. 越長總是越好
• 不要只下載一個檔案
• 取得以 150 或更多來源的檔案
• 不要去嘗試取得最新釋放的, 最少不是快的
• 以最大的上載容許量獲得額度
• 不要注視 eMule. 它不喜歡這樣.

回頂端

我能 期待 到什麼下載速率?
假如您 eMule 供給良好的配置用一些良好的檔案在啟動之後一些時間您通常得到介於 20 kB/秒 – 30 kB/秒. 在那裡將會是非常慢的但您也有可能 2 至 3 次到達這個數值.

回頂端

等候區 應該多大?
一個長的等候區會增加額度系統的效力. 非常高的排名(QR)數值不表示您將從不能在有許多[上載/下載 比例](額度系統產生的修改比例數值)來源的下載會縮短等待時間.

回頂端

最後更新在: 2004-02-27 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: FAQ - 額度

FAQ

額度

> | 什麼是額度並且我為什麼應該收集它們?
> | 我在哪裡可以看見我的額度積分?
> | 我遺失或刪除我的 clients.met 檔案. 我的額度遺失了?
> | 額度是安全的?
> | 總之如何去遺失額度.

什麼是額度並且我為什麼應該收集它們?
額度獎賞上載的使用者. 大的資料傳輸量決定了大的額度. 額度不是全域性的, 換言之這個只能使用在哪個客戶端授予這個額度.
額度主要是用來計算及處理其他客戶端等候的[上載/下載 比例]. 您有更多的額度您的排等將會更快的前進.

回頂端

我在哪裡可以看見我的額度積分?
為阻止積分被操縱, 這個額度不是儲存的位置不在您的硬碟但在其他客戶端的硬碟內. 它是不允許計數自己的額度.

回頂端

我遺失或刪除我的 clients.met 檔案. 我的額度遺失了?
遺失這個檔案不表示您的額度遺失但是在您的客戶端全部其他人的額度會遺失. eMule 建立一個備份 clients.met 的檔案 (clients.met.BAK) 所以您能經由重新命名這個備份成 clients.met 還原這個檔案.

回頂端

額度是安全的?
eMule 使用一個鍵值交握方式來確保額度屬於這個特別的客戶端. 只有在這個認證成功時允許這個使用者儲存額度.

回頂端

總之如何去遺失額度.
如同先前描述的額度是加倍安全的使用者認證. 這個認證的加密鍵值是從儲存在 preferences.dat 和 cryptkey.dat 計算出來的. 萬一其中一個檔案遺失您將不再能夠證明您是額度的合法擁有者.
假如您只遺失 cryptkey.dat, 它也會強制刪除 preferences.dat 檔案.

回頂端

最後更新在: 2003-09-03 由 Monk -中文化:CML 2004-11-21


eMule FAQ 中文版 :: FAQ - 下載 & 分享檔案

FAQ

下載 & 分享檔案

> | 我清單中的 下載消失
> | 在傳輸中 有顏色的條狀物 表示著什麼?
> | 在來源欄位中的數值 xx / yy (zz) 是什麼?
> | QR(排名) 是表示什麼?
> | 為什麼我的來源顯示 已在另一個檔案中要求?
> | 如何依字母次序下載
> | 太多連線數 表示什麼?
> | 我如何改變一個下載的名稱?
> | 紅色和綠色的驚嘆號記號 表示什麼?
> | 我如何加入一個 註解/等級 到一個檔案?
> | 我如何知道那一個檔案是 假的?
> | 我的下載將 不能完成.
> | 我的下載已經完成但顯示 已損壞
> | 我的下載已經完成但沒有 出現在新進檔案資料夾中
> | 暫存檔案資料夾太大了. 我能 刪除 它嗎?
> | 我如何 刪除/移除分享 檔案

我清單中的 下載消失
這可能發生在當機或更新到一個新的版本時.

• | 一個 downloads.txt 檔案是建立在 eMule 資料夾. 它包含在下載清單中每個檔案和 .part 檔案關聯. 您能重新下載檔案由使用這連結或試著使用像是 MetMedic 或 DonkeyDoctor 工具去重建介於 .part 和 .part.met 之間破損的連結.
• | 檢查在 選項 -> 資料夾 的暫存資料夾路徑是否正確
• | 在暫存資料夾中的 .part.met 檔案以它們的備份檔 .part.met.BAK 取代.
• | 檢查在說明文件的 發現及解決 章節.
回頂端

在傳輸中 有顏色的條狀物 表示著什麼?
顏色顯示出檔案部分的可得性. 紅色表示目前這個部分沒有來源. 見 這個主題 來進一步了解.

回頂端

在來源欄位中的數值 xx / yy (zz) 是什麼?
這個數值指出一個下載發現的來源數量.
• xx - 有用的來源數
• yy - 來源數總計
• + aa - 已要求於其他檔案 的來源數 (只在 進階控制 啟用時顯示)
• zz - 目前傳輸中的來源數

回頂端

QR(排名) 是表示什麼?
QR(排名)是排隊等級的縮寫並且是您在其他的客戶端中的排隊位置. 來源的QR(排名)低於 20 在不久之後會開始傳輸. 額度幫助前進這個排隊更為快速.
這個排隊等級在萬一您的 IP 改變或是 eMule 短時間關閉是不會流失的.

回頂端

為什麼我的來源顯示 已在另一個檔案中要求?
eMule 在其他客戶端的等候區只會佔一個位置. 假如其他的使用者有超過一個以上的檔案您想要下載 eMule 將會只有一個檔案排隊等候並且直到這個完成它才會轉換到另一個. 在這個檔案這些來源將會有著 已在另一個檔案中要求 的注解且不能被排隊等候. 見 來源管理 了解詳細.

回頂端

如何依字母次序下載
它能從字母順序理解下載檔案之間的相互關係來可能的話將有效的使用找到的來源. 檢查您想要下載的檔案名稱是依字母次序方式命名 (排序檔案名稱之後, 按 F2 來重新命名), 為它們建立一個類別並且移動檔案到這個類別. 在類別的背景選單點一下 依字母次序下載. 進階控制必須開啟才能工作. 見 來源管理 了解詳細.

回頂端

太多連線數 表示什麼?
這個來源狀態表示能被開啟的連線數超過要被處理來源數. 它通常出現在太多檔案被加入在傳輸清單或 硬性限制 設定太高.

回頂端

我如何改變一個下載的名稱?
您能改變一個下載的檔案名稱到任何想要的而無法識別的下載名稱可由一個獨一無二的切細值來識別. 點一個下載並按右鍵選單中選擇 -> 顯示檔案詳細資訊 或按滑鼠的中鍵. 在 檔案名稱 中改變這個名稱時留意檔案的副檔名.

回頂端

紅色和綠色的驚嘆號記號 表示什麼?
驚嘆號記號是下載的一個註解或等級的指標.
• 綠色 = 正面等級
• 紅色 = 負面等級

回頂端

我如何加入一個 註解/等級 到一個檔案?
您能在 已分享檔案 中加入註解和等級. 只需在任何的分享檔案上按中鍵或右鍵 -> 編輯檔案註解.
請使用有用的註解!

回頂端

我如何知道那一個檔案是 假的?
您能經由查看發現的檔案名稱容易的認出假檔. 在任一個下載上按右鍵 -> 顯示檔案詳細資訊 -> 檔案名稱 或按中鍵開啟一個下載發現的全部檔案名稱清單. 假如檔案名稱很大的不同或是發生矛盾它也許是假的. 搜尋結果中按 + 也可以顯示出發現的不同檔案名稱.

回頂端

我的下載將 不能完成.
一個下載在一段長時間不能完成, 有二個可能的原因:
沒有完整的來源:
假如在進度條顯示出紅色部分從未變成藍色並且所有發現的來源中缺少著相同的部分那麼這個檔案或許死亡且將不再完成. 在傳輸清單中 最後看見完整的 這欄顯示所有的部分曾經可用的最後日期.
已損壞的下載:
假如在伺服器視窗的 記錄 中顯示一項損壞部分已接收. 且您總是得到損壞一直在一個特定的檔案部分, 這個下載它有可能完全的損壞 (發生罕見的).

回頂端

我的下載已經完成但顯示 已損壞
這個錯誤通常出現在暫存檔案和新進檔案資料夾在不同的硬碟或分割. eMule 不能完成這個下載是因為新進磁碟那裡沒有足夠的可用空間.

回頂端

我的下載已經完成但沒有 出現在新進檔案資料夾中
當 eMule 顯示一個下載已經完成但檔案並沒有移動到新進檔案資料夾您能手動去做. 首先在 -> 檔案詳細資料 並確定檔案真正的已經完成的大小. 並且注意下面的 .part 檔案的號碼和複製檔案名稱到剪貼簿. 在視窗的檔案總管中開啟您的暫存資料夾並移動適當的檔案到您的新進檔案資料夾中, 並且重新命名它到它的完成後檔名(使用您複製在剪貼簿內的檔名). 留意檔案的副檔名. 大多數這種檔案不再會是一個 .part.met 檔案類型.

回頂端

暫存檔案資料夾太大了. 我能 刪除 它嗎?
這個資料夾儲存您全部未完成的下載. 刪除它表示刪除全部目前的下載! 因為在 eMule 使用的傳輸系統中或許只有幾 KB 已經下載但有可能會使用了下載完成後所佔用的空間.

回頂端

我如何 刪除/移除分享 檔案
eMule 分享檔案一旦:

• | 一個下載的部分 (區塊) 己經完成並檢查出錯誤
• | 它們在新進檔案 資料夾或是在 選項 -> 資料夾 -> 已分享資料夾 被標記成已分享
回頂端

要移除一個分享您必須從新進或分享資料夾中移出這個檔案. 在主視窗的已分享檔案您也能由滑鼠右鍵 -> 刪除 檔案.
目前正在下載的分享是不能被停止的.

回頂端

最後更新在: 2004-07-18 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: FAQ - 使用 eMule

FAQ

使用 eMule

> | 一般提示
> | 我如何增加一位 好友 ?
> | 如何分配一個 好友的上載位置
> | 我如何清除 搜尋自動完成 的歷程?
> | 在來源前面的 圖示 表示著什麼?
> | 我可以 踢掉或禁止 其他的使用者?
> | 為什麼在搜尋我只能取得 201 個結果?
> | 我應該設定我的所有檔案到高的優先權或釋放?

一般提示
在 eMule 的許多功能都可以由選單中來使用. 在許多不同的物件上按滑鼠右鍵可開啟這個選單. 並且許多區域和物件可由點二下或甚至是用中鍵點下來起作用. 一個常用選單的開啟由按下 ALT + x. 可以嘗試不同的組合. 它是有用的.

回頂端

我如何增加一位 好友 ?
好友的管理在訊息的主視窗內. 增加一位好友, 在好友清單中按右鍵並選擇 -> 增加好友. 您必須有下列資訊:
• IP 位址 – 必要的. 取得它只需問您未來的好友.
• 連接埠 – 通常是 4662; 也是必要的
• 名稱 – 選擇任何名稱. 不是必要的.
另一個加入好友的方式經由直接的在傳輸主要視窗中任何來源按右鍵並選擇 -> 加入到好友名單內. eMule 將會填入所有必要的資訊.

回頂端

如何分配一個 好友的上載位置
在任何一位好友上按右鍵讓您授予他一個好友上載位置. 這個上載位置將會於不久之後有下一個可用的位置時開始作用, 允許您的好友下載.

回頂端

我如何清除 搜尋自動完成 的歷程?
點一下搜尋欄位並按 CTRL 或 ALT 再加 DEL.

回頂端

在來源前面的 圖示 表示著什麼?
尋找一個詳細的描述在 圖示 章節.

回頂端

我可以 踢掉或禁止 其他的使用者?
不能. 這個功能將永遠不會在 eMule 實現如同的它否定了它的原理.

回頂端

為什麼在搜尋我只能取得 201 個結果?
搜尋會使伺服器加重負載. 限制這個影響, 在 eMule 客戶端的一個搜尋只傳回一個最大量結果 201 個. 假如您想要更多, 使用 Web 基礎搜尋 Filedonkey.

回頂端

我應該設定我的所有檔案到高的優先權或釋放?
不. 優先權是使用來超越其他偏愛的某些檔案. 優先權和每個其他的是有關聯, 換言之所有檔案到低的優先權是相同於全部檔案到高或全部檔案到正常.
下載的優先權影響 eMule 在來源搜尋時或連線處理時如何看待這個檔案. 上載優先權決定了在某人要求這個檔案 eMule 偏愛哪個檔案. 要求高優先權上載的其他客戶端將會增快您的等候區.

回頂端

最後更新在: 2003-09-03 由 Monk -中文化:CML 2004-11-23


eMule FAQ 中文版 :: FAQ - 各種方面的

FAQ

各種方面的

> | 為什麼執行 eMule 時 網路變慢?
> | 什麼是 Mod?
> | Mod 是 更好或更快 ?
> | 我得到訊息 eMule 是被禁止的
> | 哪裡我可以取得更進一步的幫助?
> | eMule 是 匿名的?
> | 我的防火牆報告 攻擊 或為什麼 eMule 送出郵件?
> | 我的防火牆在我關閉 eMule 之後連線之後仍然報告連線
> | 什麼是 IP 過濾器?
> | 我可以 複製 這個 說明/FAQ 到我自己的網站?

為什麼執行 eMule 時 網路變慢?
依照 eMule 的設定值或許開啟相當多的連線數並且也使用許多的頻寬. 這會使其他的網路應用變慢, 如 WWW. 尤其是不正確或太高的連線數設定值會造成嚴重的效能下降.

回頂端

什麼是 Mod?
由於無論任何人都能使用 eMule 的原始碼開發了原始版本之外的修改版本. 那些版本是不被官方 eMule 團隊支援的.

回頂端

Mod 是更好或更快?
通常不是的. 官方版本有利於 mod 開發, 但修改者不能改變 eMule 的內部工作使它不相容於目前的網路. 事實上任何速度的改善是不太可能的.
而 mod 提供新的特徵及新的臭蟲您或許喜歡或不喜歡, 然而他們的一些非特徵對整個網路有極端的損害. 這些榨取他人的版本必須不被使用且官方的 eMule 由防護的特徵和禁止它們嘗試去切除它們.
在我們的論壇貼上了 Mod 版本在這個網路的公平規則.

回頂端

我得到訊息 eMule 是被禁止的
在官方的 eMule 版本不會建立這些訊息, 它們是從 mod 發出. 假如您使用的是官方版本您能放心的忽略或過濾它們.

回頂端

哪裡我可以取得更進一步的幫助?
假如在閱讀 FAQ 及說明之後仍然有開啟問題, 您或許可以詢問在:

• | 論壇 (在開啟新的主題之前請使用 搜尋 功能)
• | IRC - 只需在 eMule 的 IRC 主視窗中按下連線. 進入英文 eMule 幫助頻道輸入 /join #emule. 那裡同樣的也有其他的語言聊天室像是 #emule-french, #emule-spanish 或 #emule-dutch.
回頂端

eMule 是 匿名的?
 P2P 網路全部依賴二個使用者的直接連線來傳輸資料夾. 為完成這個目標客戶端 IP 必須是已知的. 這個 IP 使這個使用者識別並可追蹝. 在那裡只有二個方式可以保證匿名: 運輸越過經由匿名的代理伺服器或彈跳它穿過其他的客戶端.
代理伺服器有很多的缺點. 管理員依匿名的依賴程度及運輸他們花費大量金錢, 他們能被關閉的. 讓我們假定一個平均 100.000 客戶端 eMule 伺服器. 每個已連線的客戶端引起 10kB/秒 運輸在每個方向. 這個伺服器必須應付 2.000MB (1,9GB) 每秒傳輸量大小. 沒有一個伺服器能如此供給.
路線全部運輸越過第三個客戶端也會造成相似的問題同樣的有一半的運輸量被用來匿名化. 這表示每個使用者必須以二倍的上載來保持目前這種水準的網路效能.
此時安全且明智方式的匿名在 P2P 網路是不可實行的!

回頂端

我的防火牆報告 攻擊 或為什麼 eMule 送出郵件?
軟體防火牆分析網路運輸由注意在連接埠之上的送出網路運輸. 許多連接埠通常只被某些應用程式所使用. 電子郵件為例, 它通常使用連接埠 110 來接收郵件及連接埠 25 來傳送郵件. 並且特洛伊和其他有害的軟體使用了特殊的連接埠.
現在所有的連接埠在 eMule 可以自由的配置並且一些使用者設定他們的連接埠為其他的應用程式能正常使用的. 只因為 eMule 是連線到某些連接埠這個能表示防火牆報告攻擊或認為 eMule 傳送郵件.
假如您使用官方的 eMule 版本您能放心它將不會傳送件何不必要的資訊. 並且目前版本 .30b 不再開拓是已知的.

回頂端

我的防火牆在我關閉 eMule 之後連線之後仍然報告連線
您的 eMule 在網路獲得已知的它如同在其他客戶端中的一個來源. 並且伺服器傳播您的客戶端如同您分享檔案的來源. 假如當您關閉 eMule 一個連線仍然是可能的您將仍會從其他客戶端接收到網路運輸. 這個效應將會在一會兒消退.

回頂端

什麼是 IP 過濾器?
IP 過濾器是使用來阻塞可能有害這個網路的某些網路位址的運輸. 最普遍的過濾檔案是 Methlabs, Bluetack 或 Lussnig 的 IP 過濾. 加入這個連結到濾濾檔案, 例如 http://bluetack.co.uk/config/antip2p.txt 貼到 選項 -> 防護 -> 從網址更新 並且按下 載入. 假如指定的位址是一個 *.zip 檔案也能被直接的加入封鎖清單.

回頂端

我可以 複製 這個 說明 / FAQ 到我自己的網站?
您可以複製這個說明和 FAQ 的任何部分只要您保持作者及放置一個連結到 http://emule-project.net. 當這麼做時丟一個 短信 給我表示尊重.

回頂端

最後更新在: 2004-02-27 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 圖示

圖示

從這個客戶端 傳輸中 或 片段切細值接收中

在這個客戶端 等候中 或 要求中

連線到這個客戶端中

沒有需要的部分, 已在另一個檔案中要求 或 無法連線 低ID 到 低ID

狀態未知

新訊息

一般 eDonkey 或早期的 eMule 客戶端

能使用 eMule 延伸協定的客戶端

一般客戶端且有高的額度數值 (表示他有較高的優先權)

能使用 eMule 延伸協定的客戶端且有高的額度數值

mlDonkey 客戶端

mlDonkey 客戶端且有高的額度數值

eDonkey2000-Overnet-混合式客戶端

eDonkey2000-Overnet-混合式客戶端且有高的額度數值

Shareaza 客戶端

Shareaza 客戶端且有額度點數

客戶端鑑定經由 安全的使用者識別

在 eD2k (伺服器) 網路和 Kademlia 高的 ID

已連線, 在 eD2k 高的 ID, 在 Kademlia 低的 ID (防火牆內)

在 eD2k 低的 ID, 在 Kademlia 高的 ID

二個網路都低的 ID

Kademlia 尚未連線, 在 eD2k 高的 ID

eD2k 尚未連線, 在 Kademlia 高的 ID

Kademlia 尚未連線, 在 eD2k 低的 ID

eD2k 尚未連線, 在 Kademlia 低的 ID

尚未連線

Kademlia 連繫 - 良好

Kademlia 連繫 - 失敗沒有回應

Kademlia 連繫 - 也許掛掉, 將會被移除

eMule 已連線到一個伺服器高ID的系統列圖示

eMule 已連線到一個伺服器低ID的系統列圖示

eMule 尚未連線到一個伺服器的系統列圖示

在這一個下載的檔案中有註解或是正向(良好)的等級

檔案等級 假的, 損壞的 或 無效的

可應用版本: .42a +
最後更新在: 2004-02-27 由 Monk -中文化:CML 2004-11-23


eMule FAQ 中文版 :: 進度條顏色

進度條顏色

在下載中清單每個檔案都有一個顏色條來顯示目前檔案可得性及進度.

(平坦樣式) [image] (圓滑樣式)

黑色 顯示檔案的這個部分您已經有了
紅色 表示所有已知的來源都缺少這一部分
不同 變化 的藍色 表示這個部分來源可得性. 深藍代表高的可得性.
黃色 表示已下載中的部分
顯示在上面的 綠色條 表示下載的進度總計.

(平坦樣式) [image] (圓滑樣式)
於一個下載已經完成的綠色條直立.

(平坦樣式) [image] (圓滑樣式)
一個暗紅色或暗藍色進度條表示一個停止或暫停的下載.

假如您擴展下載您會看見來源中相同的條狀. 看見來源只需在下載的檔案上點二下(或是單點一下, 在 選項 -> 一般 內做設定). 在這裡不同的顏色中它們代表著:

(平坦樣式) [image] (圓滑樣式)

黑色 顯示檔案的這個部分您已經有了
藍色 這個部分您仍然需要下載
銀色 表示在來源中也同樣缺少的部分
綠色 正在下載中的部分
黃色 表示準備中 (已經要求) 的部分

來源計數
這四個數值 xx / yy +aa (zz) 被顯示在進度條之後它是這個檔案的來源計數而顯示的資訊如下.

• xx - 有用的來源數
• yy - 來源數總計
• + aa - 已要求於其他檔案 的來源數 (只在進階控制啟用時顯示)
• zz - 目前傳輸中的來源數

已獲得部分
假如支援的話由其他客戶端顯示這個長條在上載等候區中. 它顯示這個使用者下載中檔案的進度.

黑色 這個部分這個使用者已經完成
銀色 這個部分仍然缺少
綠色 這個部分正在上載中
黃色 表示準備中 (已經要求) 的部分

已分享檔案的可得性
每個分享的檔案可由這個狀態條來顯示其可得性. 這顏色的解釋和進度條很類似

紅色 表示所有已知的來源中仍缺少的部分
不同 變化 的藍色 指出有多少來源的供給

最後更新在: 2003-09-27 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 等候順序

等候順序 - QR

在檢視來源時 eMule 客戶端會顯示一個 QR:[x].
QR 示表等候順序, 它指出您在遠端來源的排隊順序.

顯然的, 一個低的值是最好的.

最後更新在: 2002-12-14 由 Monk -中文化:CML 2004-04-11


eMule FAQ 中文版 :: ID 解釋

ID 解釋

ID 是從客戶端的 IP 位址所計算出的值. 它由伺服器分配, 當 eMule 成功的連線到伺服器. 伺服器企圖指出適合介於二個客戶端溝通的 ID.

連線之後 ID 顯示在伺服器的記錄視窗當中.

eMule 不會更進一步的顯示 ID 但會在視窗右下角顯示地球圖示表示連線到伺服器 ID 狀態.

表示一個 高的 ID
表示一個 低的 ID

一個高的 ID 表示著在 選項 -> 連線 所選的連接埠(預設值 4662) 是開放的且能直接連線的.

然而一個低的 ID 表示著連接埠是阻塞的或不能抵達的. 這可能由防火牆引起, 路由器或代理伺服器等.
若有一個低的 ID 不表示不能上載或下載但有幾個缺點:

- 在電腦中的 eMule 不知道 IP , 故所有的連線要求都必需經由伺服器. 這將會造成該伺服器的 CPU 負載變重並減少該伺服器的最大使用者數. Lugdunum 的伺服器 會限制或禁止低 ID 的使用者.

- 二個客戶端都是低 ID 將不能互相連線, 它不被允許轉送訊息到二個不同的伺服器. 這將會導致下載的來源數變少

- 在忙碌中的伺服器它或許訊息取得剛好流失而 eMule 未得到重要的資訊關於等候進度或下載要求. 這也許導致減少額度和錯誤的下載.

注意:
- ID 只影響客戶端之間的訊息交換問題. 實際上資料傳輸仍然由客戶端到客戶端間處理.

- 假如伺服器它不允許您取得一個高 ID, 最好是連線到使用者較少的伺服器, 讓該伺服器能有較多的資源處理大量阻塞狀況.

- 您能透過不良的設定值或連線到剛好忙碌中的伺服器時得到低 ID . 當您確定設定正確並且您連線到其他伺服器時 應該 有一個高 ID. 執行 eMule 並且使用 這個測試腳本 (感謝TheDonkeyNetwork) 來比對您的設定值.

- 假如 ID 是高的, 它與任何高的事物沒有關聯. "實際上高的" ID 沒有較好或任何優勢.

- 假如 ID 是低的, 它與任何低的事物沒有關聯. 一個低 ID 是少於 16777216.

- 來比對您的 IP 而一個高的 ID 轉換方式如下: 於 IP = A.B.C.D 高的ID = A + 256*B + 256*256*C + 256*256*256*D.

重要:
自從 .23a 低 ID 來源是被 eMule 丟棄的以保持伺服器負載的最小量. 只有低 ID 來源連線到和您客戶端相同的伺服器時而低 ID 來源從您那裡下載檔案是被接受的. 並且低 ID 來源是不交換客戶端到客戶端的來源交換.

最後更新在: 2002-10-12 -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 等級

等級 & 積分

等候中清單顯示客戶端目前等待上載的位置. 這個清單是在傳輸分頁中按"上載中"來切換顯示.
大多數的數值都能恰當的顯示但除了 等級 和 積分需再解釋.

等級
最初在等候中的每個客戶端都有等級 100. 這個初始值是根據使用者要求的已分享檔案及一些因素而修改:

> | 已禁止 [上載/下載 比例]:: x0 已禁止的使用者沒有等級和上載的位置.
> | 低的 ID [上載/下載 比例]: 沒有 [x0.8] 在 v.27a 版本以前是指定一個[上載/下載 比例] 0.8 給低的 ID 使用者. 這個在不使用了
> | 已連線 [上載/下載 比例]: 沒有 [x1.5] 紅利 x1.5 在開始已經連線而在 v.27a+ 之後的版本不使用了.
> | 額度 [上載/下載 比例]: x1 - x10 這個 額度系統 根據 上/下載比例 來計算出的[上載/下載 比例]數值.
> | 已分享檔案的優先權. [上載/下載 比例]: x1.8 - x0.2 使用者要求一個檔案下載將會接收到一個[上載/下載 比例]給予選擇分享檔案的優先權. 在 [ ] 中是 v.27a 版之前使用的數值.
 | 釋放: | x1.8 [x5]
 | 高: | x0.9 [x2]
 | 一般: | x0.7 [x1]
 | 低: | x0.6 [x0.5]
 | 最低: | x0.2 [x0.2]
> | 比 eMule v.20a 版本還舊的 [上載/下載 比例]: x0.5 在 v.20a 之前的版本會造成網路的高負載並處以[上載/下載 比例]為 x0.5.

範例:
一個客戶端由許多的上載來獲得一個額度[上載/下載 比例] x8. 他要求檔案有著較高的優先權. 他的等級總計將會是: 100 x 8 x 0.9 = 720

積分
這個積分和 等級 中描述的一樣用相同的[上載/下載 比例]去做計算但也考慮了客戶端等待的時間. 這個積分是決定於有多少空的上載位置. 客戶端有著高的積分和 *** 後面的數值將會是下一個接受上載位置.
積分計算公式如下:

積分 = 等級 x [在等候的等待時間] / 100

所有的客戶端以[上載/下載 比例]為 > 1 時客戶端圖示將會是黃色的.

最後更新在: 2003-04-13 由 Monk -中文化:CML 2004-11-21


eMule FAQ 中文版 :: 清單

清單

傳輸分頁中提供了多種關於目前上載和下載的資料. 顯示在上面部分的下載中, 在括號 ( ) 中的數值是目前下載的數量.
在下面部分是通常是顯示目前上載中的. 這個部分也能顯示其他資料.

清單間的轉換可由按目前的清單名稱來切換. 在清單中的資料會有恰當的解釋.

可應用版本: .27a +
最後更新在: 2003-03-13 由 Monk -中文化:CML 2003-04-26


eMule FAQ 中文版 :: eMule 使用的檔案

eMule 使用的檔案

在使用 eMule 的時候有一些檔案是被使用的或是在第一次啟動時被建立. 通常這些檔案是被建立在 eMule 安裝的資料夾內, 其他則放在選項指定的暫存資料夾中.

o | Known.met Known.met 是儲存所有 eMule 知道的檔案無論是分享的或是目前下載清單中的. 用來儲存每個檔案資訊, 像是檔案大小, 檔案路徑, 檔案切細值及一些統計值等.
o | Clients.met 這個檔案是用來儲存您的 eMule 全部使用者 額度
o | Server.met 包含所有已知的伺服器.
o | Emfriends.met 假如使用者是加入在 好友 清單中他們是被儲存在這個檔案.
o | Preferences.ini 儲存所有選項設定值及各項清單欄位大小等.
o | Fileinfo.ini 儲存您自己分享檔案註解或等級設定.
o | Category.ini 儲存您設定的 類別 像是名稱, 註解和顏色解碼.
o | Ipfilter.dat 這個檔案包含了 IP 行列及存取等級來被 IP 過濾器 過濾. 並且請參考 選項 -> 防護
o | Onlinesig.dat 上線簽名檔 是一個小檔案包含了 eMule 已連線的伺服器及上載和下載統計. 也許被使用在 IRC 腳本或簽名檔圖片.
o | Preferences.dat 儲存使用者切細值. 這個數值是在第一次使用 eMule 時計算出的用來識別在網路上的客戶端. 被使用在額度系統及好友.
o | Sharedir.dat 掌握所有已分享資料夾的路徑.
o | Staticservers.dat 靜態伺服器從不改變他們的 IP 而且理論上總是在網路線上. 那些伺服器能由在伺服器清單選單中(按滑鼠右鍵)被加入在 staticservers.dat . 並且請參考 選項 -> 伺服器
o | Adresses.dat eMule 假如提供有效的 server.met 在這個檔案中在啟動時會更新伺服器清單. 選項 -> 伺服器 提供一個按鈕來編輯這個清單並且有啟動時更新的選項. 這個檔案或許包含了多行項目 (一個一行) 但是只有第一個有效傳送的 server.met 位址會被使用.
o | AC_SearchStrings.dat 使用過的每一個搜尋字串會被記錄起來並在新的搜尋和先前有符合的會自動提供字串(似IE的自動完成的功能).
o | AC_ServerMetURLs.dat 相似於上面一個檔案. 唯一的不同是它使用在儲存已輸入 server.met 檔案的 URL. 留意許多站台會規律的改變他們的 server.met 位址.
o | Cryptkey.dat 它包含了獨一無二 384 位元私人的 RSA 鑰匙於您的客戶端
o | eMule.tmpl *.tmpl 檔案是 Web 界面 所需要的. 他們定義顯示網頁佈局及選項.
o | xx.part 是未完成下載的部分檔案. eMule 有能力在同一時間內從多個使用者下載, 所以 *.part 檔案總是有完成後的檔案大小. 缺少的部分則是以零填補.
o | xx.part.met 每個 *.part 檔案都有一個相對應的 *.part.met 檔案. 用來定義在網路的一個下載並且用來檢查每個下載大約 9 MB 部分的錯誤. 於每個都會有切細值被計算出. 一個新的切細值被建立於那些部分切細區塊完成時. 以檔案名稱合起來這個資訊和切細區塊狀態是被儲存在 *.part.met 檔案.
o | xx.part.met.BAK 一個 *.part.met 建立的備份檔案假如一個檔案由當機引損壞它是非常糟的. 假如您的下載因損壞而 *.part.met 檔案消失, 見 發現及解決 取得幫助.
o | eMule.log 假如在選項 -> 延伸 有開啟這項功能將會儲存在伺服器分頁中記錄視窗的輸出
o | eMule_Debug.log 假如在選項 -> 延伸 有開啟這項功能將會儲存在伺服器分頁中除錯視窗的輸出

可應用版本: .29b +
最後更新在: 2003-06-20 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 控制 eMule

控制 eMule

eMule 能由鍵盤及鍵盤的快速鍵來完全控制. 它跟 Microsoft Windows 環境的操作方式非常相似:

• | 功能, 在字母的下方有底線 _ 能直接由按 Alt + 有底線的字母.
• | 在一個標準視窗鍵盤在 Ctrl 鍵左邊的 背景選單 鍵能開啟已經選擇的項目之背景選單.
• | 在一個清單的一項目像是伺服器清單或下載清單能由按住 Ctrl 鍵及滑鼠左鍵來做分散式的多重項選擇. 按住 Shift 鍵將會標記二個項目之間的全部項目.
• | 在一個清單您能由按下項目名稱的第一個字母來快速跳至該項目.

Alt + X | eMule 的快速選單
Alt + C | 連線 / 離線 / 取消連線到伺服器或 Kad
Alt + K | Kademlia 主視窗
Alt + V | 伺服器主視窗
Alt + T | 傳輸主視窗
Alt + S | 搜尋主視窗
Alt + F | 已分享檔案主視窗
Alt + M | 訊息主視窗
Alt + I | IRC 主視窗
Alt + A | 統計主視窗
Alt + P | 選項視窗
Alt + O | 工具選單
Alt + H | 開啟 eMule 的幫助檔案
Alt + F4 | 離開 eMule
Ctrl + C | 複製已選擇的伺服器或下載到剪貼簿. 在記錄, 訊息或 IRC 聊天的項目也一樣能被複製.
Ctrl + V | 從剪貼簿貼下伺服器或下載到 eMule 適當的視窗. 也能貼上文字在訊息或 IRC.
Ctrl + A | 選擇清單中的所有項目.
Ctrl + F | 開啟搜尋視窗, 能被使用在伺服器清單或是一個網路搜尋的結果.
F1 | 開啟 eMule 的幫助檔案
F2 | 選擇的下載重新命名
(Shift + ) F3 | 在一個搜尋之後以 Ctrl + F, F3 跳至下一個相符的搜尋而 Shift + F3 跳至上一個.
Esc | eMule 最小化
Alt + Return (Enter) | 顯示一個已選擇的下載之檔案詳細資訊
Ctrl + Del 或 Alt + Del | 清除在 server.met 下載, 搜尋或啟動-IP(Kad)的自動完成項目
Tab | 能使在 IRC 聊天的暱稱快速輸入, 由輸入一個或幾個字母後按下會自動完成完整的暱稱
滑鼠在下載點二下 | 展開下載來顯示它的來源
滑鼠在伺服器點二下 | 連線到選擇的伺服器
滑鼠在狀態列點二下 (第一欄) | 顯示在記錄的最後一個項目
滑鼠在狀態列點二下 (第三欄) | 開啟統計主視窗
滑鼠在狀態列點二下 (第四欄) | 顯示連線詳細資訊視窗
滑鼠在狀態列點二下 (第五欄) | 開啟訊息主視窗
滑鼠在已分享檔案點二下 | 假如下載已經完成將會以標準的應用程式開啟檔案
Alt + 滑鼠在下載點二下 | 顯示這個下載有需要的部分之所有來源
Ctrl + 滑鼠在下載點二下 | 顯示 QR > 0 的所有來源
Shift + 滑鼠在下載點二下 | 顯示目前動作中 (上載中) 所有來源
滑鼠中鍵-下載 | 開啟已選擇檔案的檔案詳細資訊視窗
滑鼠中鍵-已分享檔案 | 開啟一個已分享檔案的註解及等級視窗
滑鼠右鍵 | 在 eMule 許多地方能開啟背景選單.

最後更新在: 2004-08-01 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 一般

選項 - 一般

暱稱
輸入您顯示其他使用者看見的暱稱.

語言
從下拉式清單中選擇您喜好的語言.

多方面的

o 錯誤時發出聲音
當發生錯誤或檔案損壞時電腦的揚聲器會發出聲音.

o 點下ED2K連結後彈出eMule視窗
當 ED2K 網路下載或伺服器由 eMule 開啟時.
選擇 eMule 在工作列閃爍或 eMule 視窗彈出到頂部.

o 啟用上線簽名檔
一個名稱為 onlinesig.dat 的小檔案將會寫入在 eMule 資料夾中. 這個檔案格式如下:

[上線狀態]|[已連線到伺服器]|[IP:連接埠]
[目前下載速度]|[目前上載速度]|[等候中使用者數]

這個資訊將會由 Dra.:.god's Online Signature 工具或任何方式送到網路空間中.
在未來這個功能將會更為完整.

o 離開時提示
在關閉 eMule 時會出現一個訊息視窗確認是否關閉.

啟動

o 檢查是否有新版本
假如啟用這項功能 eMule 將會在每次啟動時檢查是否有新版本. 在右方的可滾動的是用來調整檢查間隔天數.
假如有一新版您可在 www.emule-project.net 下載. 來更新 eMule 經由簡單的安裝 / 解壓縮新版在您目前 eMule 相同的資料夾中. 所有設定值將會自動的更新到新版的.

o 顯示啟動畫面
當啟用這項時會顯示一個好看的啟動畫面

o 啟動時最小化
啟動 eMule 將會縮至系統列圖示

o 在視窗啟動時執行
在電腦啟動視窗後自動執行 eMule

編輯 Web 服務
於網路中提供一些 web 基礎服務像是搜尋引擎. 那些 web 服務能被 eMule 直接的使用. 去設定這個檔案 webservices.dat 在 eMule 的安裝資料夾中能被編輯. 這個按鈕 編輯 Web 服務 能快速的存取這個檔案.

一個 WebServices.Dat 例子:
#########################################
# Web 服務設定檔
# 每一行輸入一個服務
#
# 格式: 名稱,網址
#
# 可用代號:
# #filename -> 檔案的名稱
# #hashid -> 檔案的切細值
# #filesize -> 檔案的大小
#
# 例如:
# 假檔檢查,http://www.some-well-known-search-engine-for-downloads.com/search?p=ed2k:#filesize:#hashid
# eMule 首頁,http://www.emule-project.net
# eMule FAQ,http://www.emule-project.net/faq/
#
# 以 # 或 / 為註解行

eMule 首頁,http://www.emule-project.net
eMule FAQ,http://www.emule-project.net/faq/

這個例子將會加入 eMule 首頁 及 eMule FAQ 到 web 服務中. 這些服務能在下載清單選單中使用.

ED2K 連結-按鈕
假如按下這個按鈕將會把 ED2K 連結和 eMule 產生關聯.

注意:
某些其他的 p2p 軟體或許會改變連結設定. 修正這個設定能由登錄檔編輯程式來檢查:

HKEY_CLASSES_ROOT\ed2k\shell\open\command
名稱: (預設值)
類型: REG_SZ
資料: "到emule.exe路徑及檔名(包含引號!)" %1

和

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\shell\open\command
同上

假如 eMule 的連結關聯刪除所有的項目 HKEY_CLASSES_ROOT\ed2k\... 和 HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\... 之後仍有問題 隨後 再按在 eMule 內的 eD2k 連結 按鈕一次.
在這之前請先備份您的登錄檔並且在更改登錄檔後重新開機!

可應用版本: .27a +
最後更新在: 2003-03-12 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 顯示

選項 - 顯示

o 進度條樣式
用來調整進度條的 3D 深度.

o 工具提示延遲時間 [秒]
假如滑鼠移到一個下載檔案上將會出現一個資訊欄. 這項為指定延遲這個彈出的資訊消失的時間.

o 下載清單點二下來擴展
假如使用這個功能在下載清單中不管展開或合閉檢視其來源需點二下才可.

o 以圖示來表現出下載的 註解/等級 狀態
在傳輸清單中的下載顯示這個圖示 [image] (註解, 正面等級) 這個圖示 [image] (負面等級).

o 在進度條顯示下載完成百分比
一個 %-已完成數值將會被加入在每個下載的進度條中.

o 顯示傳輸速率在視窗標題
在 eMule 的視窗標題中顯示目前的上載及下載速度.

o 在類別分頁當中顯示下載資訊
將會顯示二個數值 (x/y) 在類別名稱的右方. 第一個數值 (x) 是目前動作中的檔案數量 (下載中) 而第二個 (y) 是這個 類別 的檔案數量總計.

o 最小化時縮到系統列
假如使用這個功能 eMule 將不會最小化到工作列但會出現在系統列.

o 自動清除已完成下載
eMule 顯示出已完成下載以一個綠色進度條. 這個選項將會自動地從下載清單中移除它們.

節省 CPU & 記憶體 使用率

o 停用已知客戶端清單
eMule 保存著追蹤所有已連線的客戶端. 節省記憶體這個清單以這選項來停用. 關閉它來降低系統記憶體的使用.

o 停用等候中清單
跟已知的客戶端清單相似這個等候中清單也將會耗去系統資源. 停用來節省他們.

o 不要即時更新等候中清單
使用這個將不會經常的更新等候中清單來節省 CPU 的使用率.

o 在改變視窗大小時不重新建立統計圖形
eMule 在改變視窗大小時或許會短暫的凍結. 這個會造成儲存資料來重繪圖形. 假如這項啟用, 圖形將不會重新建立而是開始新的.

選擇字型
這個按鈕開啟一個視窗來選擇顯示在伺服器, 訊息及 IRC 視窗的文字字型, 樣式和顏色.

自動完成 (記錄輸入過的文字)
這將會儲存使用者在搜尋時輸入的文字在搜尋, Kademlia 啟動 IP, 伺服器更新網址及 IP 過濾器更新網址等欄位並且在某些已儲存的項目中來提供自動完成的功能.
啟用這個核選項能允許關閉這個功能並且重置按鈕能清除所有儲存的項目.

可應用版本: .42f +
最後更新在: 2004-05-01 由 Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 連線

選項 - 連線

第一步, 在 ISP 合約書上或是在 ISP 網頁內查找您的連線速度.

而速度數值的單位通常使用千位元/秒(kilo Bits per second) [kb/s]
但輸入在 eMule 是以千位元組/秒為單位(kilo Bytes per second) [kB/s]
由千位元轉換到千位元組只需除 8

例如:
最大下載速率: 768kb/秒 ÷ 8 = 96 kB/秒
最大上載速率: 128kb/秒 ÷ 8 = 16 kB/秒

精靈 通常能預先配置普通的連線類型. 使用它找出您正確的設定值.

能力
o 下載
這個值等於最大下載頻寬. 在上面的例子當中它是 96.

o 上載
為最大上載速率. 在例子中它是 16.

注意:
能力是重要的在 eMule 中管理連線. 檢查正確的數值.

限制
o 下載
這是允許 eMule 的最大下載速度. 輸入 0 為沒有限制.

o 上載
這是非常重要的設定. 它表示您給網路的最大上載值. 設定這個值大約在您上載能力的 75% . 或試著使用 上載速度感應器 - 見下面.

考慮的方面:
設定限制在無限制使用上載速度感應器
當 選項 -> 延伸 上載速度感應器使用時並且移除上載限制 eMule 將會使用可用的上載取得最佳效能. 自動地監視反應時間及上載調整將會確保線上遊戲及網路的順暢及額度收集的最大下載.

上載限制值設定太高
每個下載檔案都需要一些上載的頻寬來做為要求連線用, 打招呼封包等. 所以如果您這個上載限制設太高將會使您的下載變慢沒有上載頻寬可用來做要求.

上載限制值設定太低
eMule 特徵之一額度系統基於您在網路上能提供多少. 一個低的上載表示有少量的額度並且需花較長的時間來排隊.

客戶端連接埠
o TCP
eMule 使用 4662 為預設的連接埠用來從其他客戶端下載資料. 假如這個連接埠被封鎖(如在防火牆或路由器不被轉送時)是必須要更改連接埠的. 在實例中若您有一個低 ID. 使用這個腳本(感謝 TheDonkeyNetwork) 來檢查是否有可用來做為直接連線連接埠.

o UDP
這個連接埠是用來處理 eMule 的額外協定像是客戶端到客戶端的來源交換及 eMule 來源要求的相容性. 使用 UDP 來減少連線數峰值並且也減少伺服器的負載.
假如路由器或防火牆是開放的這個連接埠是可被轉送. 假如您不能開放這個連接埠請停用它並會以傳統的方式來做溝通(不推薦).

o 在 WinXP 內建防火牆開啟這些連接埠
假如 Windows XP 內部防火牆啟用這個按鈕將會自動的開啟輸入連接埠來允許 eMule 通訊不被阻塞. 只有 UDP 和 TCP 連接埠被開啟並且建議和 選項 -> 延伸 -> 當 啟動/離開 eMule 時 開啟/關閉 在 WinXP 防火牆的連接埠 的這個功能一起使用. 這會提供最佳的保護.

o 測試連接埠
這個按鈕將在瀏覽器開啟一個網頁執行一個腳本來驗證輸入的連接埠是開啟並且能得到一個高-ID. 假如網頁顯示一個錯誤, 路由器或防火牆的設定值必須被修正.

連線限制
o 最大連線數
這是允許 TCP/IP 及 UDP 的最大連線數值.
假如是在傳輸過程中連線是被打開的, 或在搜尋及等候要求或客戶端到客戶端來源交換也是.
正常狀況都不需更改這個值, 除了在 Windows98/ME, 這個值不要超過 50.

注意:
> 不管最大連線數值多少 eMule 將不會在5秒內開啟超過20個連線數.(可在延伸內調整)

> (太多連線數) 顯示在展開的下載來源中, 其表示已達到新的連線之最大數量上限值. 那些來源將處於 "等候中" 並且將在不久內開啟成為新的連線.

每個檔案最大來源數
o 硬性限制
硬性限制是一個檔案的最大來源的數量. 假如已達到這個限制 eMule 會停止接受這個檔案的更多的來源.

網路
eMule 二個不同的網路特徵. 一個是基於伺服器網路隨著傳統的 eD2k 系統而另一個是不受伺服器約束而工作的 Kademlia. 見 網路指南 在這個說明有更詳細的描述.
核選項目允許去選擇 eMule 按下 連線 按鈕時使用哪個網路連線.

啟動時自動連線
這將會告訴 eMule 在啟動之後和一個伺服器建立連線.

斷線時重連
假如和伺服器失去連線時, eMule 將會自動的嘗試建立一個新的連線. 推薦使用.

顯示額外支出的頻寬
這個值將會顯示在狀態列上、下載速度的()中，其由要求其他來源及各項連線過程中所額外支出的頻寬, 不包含實際檔案的上、下載.

重要的:
假如您的目前上載及其它佔用頻寬之總和是接近您的 上載限制 , eMule 是開啟太多的連線數或是處理太多來源數. 在這種情況下您必須降低您的 最大連線數 和/或 您的 每個檔案的最大來源數 否則您將會忍受不良的下載及上載速度.

注意:
在您的等候中客戶端數量並不會造成任何附加的流量並且不會影響其他佔用頻寬的大小.

可應用版本: .44a +
最後更新在: 2004-09-11 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 代理

選項 - 代理

一個代理伺服器是專注於一個使用者連線到它的目標位址的替換傳輸的機器. 代理伺服器的使用通常在四個不同的目的:

> | 防火牆 代理伺服器能設置只允許確認的連接埠, 協定和位址.
> | 路由器 經常使用在提供一個區網多台電腦同時存取網際網路.
> | 內容快取 內容快取代理有著經常存取網路內容和服務的巨大資料庫. 這個或許能加快那些內容的存取速度.
> | 匿名 一些或免費的代理, 不會轉送任何的使用者特殊資訊, 像 IP 或 referrer 等, 到目標位址. 而目的電腦的連線只會看見代理伺服器. 而在網路上無限制的匿名代理對 eMule 並不適合. 使用它大多數都是慢的, 不穩定且將或許會拒絕 eMule 任何連線. 使用這一類的代理會導致一個嚴重的效能下降. 本地的代理不會提供任何的匿名.

假如使用 eMule 的電腦是在一個代理保護之下則正確的設定值是需要輸入的. 提供錯誤的設定將會導致不能連線.

重要的:
假如您確定您有一個並且能夠提供正確的資訊而您只能輸入一個代理. 代理只有少數的家用電腦會使用且不利於使用者外部區域網路. 硬體路由器或數據機不是代理!

一般

o 啟用代理
啟用代理的支援.

o 代理類型
在那裡有不同的代理伺服器類型. eMule 經由一個代理連線, 它的類型必須提供.

> | SOCKS v4 / v4a SOCKS 代理提供一個二主機連線沒有直接 IP 到達的不受約束協定. v4 和 v4a 伺服器只有轉播 TCP 協定的能力. 使用這一類型時 停用 在 選項 -> 連線 -> UDP 連接埠 必須打勾.
> | SOCKS v5 SOCKS v4 和 v5 協定之間主要的不同是支援 UDP, 所以 UDP 連接埠或許能被啟用.
> | HTTP 1.1 使用超文件傳輸協定 v1.1 來連線. 相似於 SOCKS v4 這個類型不支援 UDP 協定, 所以相同於上面的應用過程. HTTP 代理不能開啟監聽的連接埠. 使用這一類型將不可能有高的 ID.

o 代理主機
輸入代理伺服器的主機位址.

o 代理連接埠
連線到代理伺服器的連接埠需要指定. 典型的代理使用連接埠 1080.

授權
一些代理伺服器需要一個使用者名稱及密碼來允許連線. 假如是這樣, 授權需要啟用並輸入適當的資料.

自動連線到伺服器時不使用代理
啟用這個選項將會在自動連線到 eMule / eDonkey 伺服器時省略代理設定.

可應用版本: .28a +
最後更新在: 2003-04-14 , Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 伺服器

選項 - 伺服器

刪除已掛伺服器於 [n] 次重試
當伺服器沒有正常的回應它的狀態時開始計數失敗次數. 於 [n] 次失敗後從清單中刪除這個伺服器.

在啟動時自動更新伺服器清單
在您解壓縮 eMule 時的資料夾中, 您將會發現檔案 adresses.dat. 可由 [image] 這個按鈕或用 ASCII 編輯器開啟它 (如記事本) 並且輸入一個有效的 server.met 網址. 只支援一個網址而已.
啟用這個功能, eMule 將會在啟動時由 adresses.dat 載入位址並更新伺服器清單.

注意:
您能設定您的預設編輯器在 preferences.ini. 搜尋 TxtEditor= 並且提供您新的編輯器完整的路徑.

連線到一個伺服器時更新伺服器清單
eDonkey 伺服器知道其他的伺服器時. 用這個功能 eMule 將會從您連線的伺服器那裡接收它所知道的伺服器.

連線到一個客戶端時更新伺服器清單
這個功能只工作在 eMule 之間的連線. 二個客戶端將會比對他們工作中的伺服器並且互相更新.

使用優先權系統
在伺服器清單的選單中, 每個伺服器都能指定其優先權.

這個優先權將會告訴 eMule 哪個伺服器優先連線.

在連線時使用智慧型 低-ID 檢查
假如您連線時得到一個 低-ID 而 eMule 會自動斷線並重新連線直到取得 高-ID. 如果連續三次都是 低-ID 而您將會被劃分為 低-ID 使用者直到您再次取得 高-ID 之前都是.

安全的連線
eMule 同時要求二個伺服器來加快連線過程速度. 當安全的連線啟用時, 一次只會連線到一個伺服器來減少得到 低-ID 的機會. 通常不需要. 注意 eMule 仍然只保持和一個伺服器連線而已.

只自動連線到靜態伺服器
在選單中允許您將伺服器加入到在 eMule 安裝的資料夾中的 staticservers.dat . 在開啟 eMule 這個清單將會自動的被載入. 只有以靜態 IP 或伺服器使用 DynDMS 功能加入這個伺服器清單! 這個選項告訴了 eMule 只連線到在這個清單中的伺服器.

手動增加伺服器時將其設為高優先權
這個選項用來告訴 eMule 手動加入的清單有一個高的優先權但不是經由清單加入的.

可應用版本: .29b +
最後更新在: 2003-07-09 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 資料夾

選項 - 資料夾

o 新進檔案資料夾
指定完成檔案後移動到的資料夾.

o 暫存檔案資料夾
用來儲存下載中暫存檔案的資料夾. 因為在多重線程下載系統, eMule 會建立相同大小的暫存檔案 (*.part) 直到檔案下載完成都會存在.

o 已分享資料夾
這些資料夾將會被分享到網路中而且, 假如他們使用他們的好友功能 (詳見設定在 選項 -> 檔案), 這個分享檔案清單或許將會被 eMule,eDonkey 或 mldonkey 客戶端所取得.

o UNC 資料夾
UNC 是 統一命名協定(Uniform Naming Convention) 縮寫(也就是網路芳鄰中別人分享資料夾的名稱). 它通常用來存取共享資源 (資料夾或裝置) 在一個網路沒有映射(連線到網路磁碟機)這個資源. 所有 UNC 資料夾格式如下:

\\server\resource\..

範例:
\\test\DriveD\eMule 將在一個叫做 test 的電腦指出在共享磁碟以這個名稱 DriveD內的資料夾 eMule

一些分享檔案注意事項:
無論如何當 eMule 客戶端連線到一個伺服器時將會傳輸檔案分享清單到伺服器中. 這個清單儲存在伺服器中其用途做為搜尋或來源要求. 處理這個檔案會耗費伺服器的 CPU 負載, 更多的檔案負載也就更高而因此少數的使用者在這個伺服器能夠應付這大量的檔案.

請遵行下列幾點來分享檔案到網路:

> 您的新進及暫存檔案資料夾總是會分享不需要再加入.
> eDonkey 網路不適合分享大量的個人的及小的檔案, 如 mp3 蒐集品. 假如要分享他們請壓成 Zip 檔案.
> 請不要分享像 \Program Files, \Temp, 或 \Windows 之類的資料夾

可應用版本: .29b +
最後更新在: 2003-06-20 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 檔案

選項 - 檔案

看見我分享的檔案/資料夾
這個好友功能允許是否能檢視您的已分享的檔案清單. 使用這項功能會反應在 檢視檔案 這項要求中.

設定初始值
o 增加檔案到下載時為"已暫停"模式
當下載清單包含了 20 或更多項目時, 這個選項遲早有用, 全部新增入的下載會以 已暫停 狀態而不是 等候中狀態. 所以收集檔案仍然可能不會超過 eMule 的連線負載. 請見 完成一個檔案時, 自動下載已暫停且高優先權的一個檔案.

o 加入新的分享檔案時自動設定優先權
已完成檔案或是新增的分享檔案將會被自動的設定優先權. eMule 將會根據一個檔案的要求數量自動設定優先權. 檔案若只有少數的要求將會得到高的優先權然而檔案有許多的要求時將會是低的優先權. 這會有助於網路增加罕見檔案的可得性並且建議使用這項功能.

o 加入新的下載時自動設定優先權
和上面的功能類似這個是應用在檔案加入傳輸清單時. 根據一個下載發現的來源數量將會自動的調整優先權.

發現來源數 | 優先權
0 - 40 | 高
41 - 80 | 一般
81+ | 低

o 自動清除檔案名稱
這個選項將會自動的清除檔案名稱無論一個新的下載是已經加入在下載中清單中. 特別的字元像 _ , . , [] 是被移除或由一個空格取代且每一個字的字母都會變大寫. 更進一步, 特別的字串能由使用 編輯 按鈕 來定義同樣的也會從檔案名稱中移除. 那裡已經有字串被定義將會被使用但新的字串能容易的被加入使用 | 來做為分隔.

警告:
光碟燒錄軟體的影像檔檔案包含超過一個檔案, 如 *.cue/*.bin (CDRWin), *.mds/*.mdf (Alcohol120%), *.ccd/*.img/*.sub (CloneCD), *.bwt/*.bwi/*.bws (BlindWrite). 這個選項不應該使用在這一類的檔案. 改變檔案名稱將會造成燒錄時出現錯誤訊息.
假如無論如何您要改變檔案名稱, 它同樣的也會取代相搭配的佈局檔案. 於 *.cue 檔案能容易的以記事本改變但在其他格式的通常需要一些 hex 編輯器像是 UltraEdit 或 WinHex.

嘗試上載傳輸完整區塊
在 donkey 網路中是以區塊來傳輸. 一個區塊為 9MB. 完成一部分才會分享到網路上, 啟用此項有助於檔案分流, 建議使用.

嘗試首先下載預覽區塊
預覽的功能是工作在第一及最後區塊已完成下載時. 這個選項將會嘗試先取得他們. 不建議使用它, 這將會在檔案可得性及分配方面造成負面的影響.

抓取剪貼簿的 ED2k-檔案連結
從一個網站上或其他來源使用 CTRL+c 複製 eD2k 連結時將會彈出一個訊息, 詢問是否將其加入傳輸清單中.

使用進階的方式來計算剩餘時間
這個將會影響 eMule 如何計算一個下載的剩餘時間. 預設的方式是基於這個檔案目前的下載速度, 反之進階方式會從檔案加入下載時計算平均速度. 假如在 v.43a 之前就已經加入下載的檔案進階計算也許會產生不正確的結果.

完成一個檔案時自動下載下一個已暫停的檔案
假如一個檔案完成時且您清單中還有檔案在暫停狀態, 其中一個會自動地被繼續. 暫停中或加入檔案在已暫停模式這二者使用這個功能將會注意來源數量常數 (一般的 DSL 它應該不大於 3000) 因為太多的來源數可能會阻塞 eMule.

o 偏好使用相同類別
這個選項只在 完成一個檔案時自動下載下一個已暫停的檔案 啟用時才能用. 假如有使用 類別 , eMule 將會嘗試繼續完成相同類別的一個.

o 只使用相同類別
這個將強迫只在相同類別有一個檔案完成時才會被繼續.

影像播放器
假如這欄是空的, eMule 將會在預覽影像檔案時使用預設的多媒體播放器來開啟這一類的檔案. 假如指定到另一個路徑的播放器, 這個將會被更換. 通常大多數的播放器需要一個暫存檔因為他們不能處理未完成且間斷的檔案. 假如使用一個預設播放器 建立備份來預覽 應該被核選. 一個 VCL - VideoLAN Client 影像播放器是不需要暫存檔案來預覽檔案 eMule 可設定並取代預設的播放器.

可應用版本: .44a +
最後更新在: 2004-09-11 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 通知

選項 - 通知

指定通知的觸發事件, 顯示一個工整的小圖形在螢幕的右下角.
即使您正在看影片或玩遊戲它一樣會彈出.

訊息彈出
o 使用音效
當使用了這項功能必須輸入下欄的聲音檔案路徑, 當有事件產生時用來撥放.

彈出當
o 新增項目在記錄
每當有事件出現在 伺服器 -> 記錄 將會彈出並且顯示.

o 聊天會議已開始
在 訊息 中開始一個新的會議時.

o 聊天訊息已接收
有新訊息接收時將會觸發. 並且這個圖示 [image] 也一樣會警告.

o 下載已加入
下載由連結及搜尋方式加入下載清單時會觸發.

o 下載已經完成
下載完成時會觸發.

o 已偵測到新版的 eMule
假如 eMule 偵測到新版本能在 www.emule-project.net 下載時會彈出通知.

o 緊急的: 磁碟空間不足, 伺服器失去連線
假如磁碟空間用光, 下載狀態將會設到 已暫停 或在已經完成檔案案出顯示 已損壞.

可應用版本: .27a +
最後更新在: 2003-03-12 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 統計

選項 - 統計

圖形
o 更新延遲
決定多少時間來刷新圖形一次. 設定值太低, 即快速更新, 會有較高的 CPU 使用率.

o 圖形平均時間
預設值為平均最後5分鐘計算出來的數值. 這是長時間的表示指數.

o 顏色
由下拉式清單中選出您要調整的統計圖形顏色. 再由右方按鈕來選取您要的顏色.

o 連線數統計 Y-軸 刻度
在統計頁詳細統計樹的正下方直接指出目前動作中連線數及上、下載數的一個圖形. 這個圖形通常被分成 0 到 100 等分但這個設定允許去改變它, 如此能增加或減少圖形的解析度.

o 動作中連線數比例
依網際網路連線數而定以及設定的動作中連線數是非常動態但通常在 100 之上. 顯示完全的連線數圖形這個設定能降低刻度. 一個範例 1 : 4 將會把動作中連線數除以 4 這個數值再顯示到圖形中.

提示:
去增加上、下載數的解析度並且還顯示完全的連線數圖形使用上面二個設定. 減少連線數統計 Y-軸 刻度將會增加上、下載圖形解析度而增加動作中連線數比例將能確定圖形仍然被顯示.

樹狀統計
o 更新延遲
刷新統計的詳細資料清單的間隔. 見在圖形中的 更新延遲 那項注意 CPU 的使用率.

可應用版本: .29a +
最後更新在: 2003-06-03 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - IRC

選項 - IRC

伺服器
這是預設的官方 IRC 伺服器 ircchat.emule-project.net.

暱稱
請指定一個不同的 IRC 暱稱來輸入. 在一個 IRC 頻道請使用您自己暱稱不要使用預設的!

頻道清單

o 播放聲音事件
這個功能是從 mIRC 客戶端被知道. 也許它能使在頻道內更多的使用者能來播放聲音檔案. IRC 的聲音檔案必須放置在 eMule 的安裝資料夾內的子資料夾 .\Sounds\IRC. 只限 *.wav 檔案能被使用.
在頻道內下指令 /sound 聲音檔案.wav 能播放出這個聲音檔案. 指令 /sound 暱稱 聲音檔案.wav 將會只播放給這個暱稱的人.

警告:
這個特徵也許會使其他使用者厭煩, 特別是在較大的頻道內. 使用時請注意, 否則將會成為踢除或禁止的目標.

o 使用頻道清單過濾器
能過濾其名稱或使用者數. 這個清單只會顯示符合名稱的或高於所給的數值.

執行
o 在連線時使用執行字串
這個選項用來指定連線成功後所執行的字串. 通常使用 /join [#頻道名稱] 或 /ns 帳號 [密碼] 指令. 能夠使用多行指令以 | 為分隔.

例如:
/ns 帳號 [密碼] | /join #emule

多方面的

o 連線到幫助頻道
這個選項核選時 eMule 會自動地加入官方的 IRC 幫助頻道.

o 在連線時載入伺服器頻道
當連線到伺服器時自動顯示所有可用的頻道清單.

o 在訊息上加時間標籤
在 irc 顯示的訊息前方加上目前時間.

o 忽略通知訊息
沒有頻道通知像是加入或離開的訊息等. 使聊天更為乾淨.

o 忽略 eMule 協定訊息
類似上面的東西, 忽略 eMule 在頻道內的協定訊息.

o 允許使用者將您加入成為好友
eMule IRC 聊天允許從暱稱清單的滑鼠右鍵直接加入好友. 移去這個項目的勾選將禁止別人將您加入 好友 清單的請求. 在拒絕時若使用者嘗試將您加入好友將不會接收到任何訊息.

o 接受 ED2K 連結在 IRC (使用這個要小心!)
假如啟用這個功能將會自動地直接加入所有在聊天室內的 eD2k 連結到下載清單中.
避免聚集不必要的連結應該同時使用 只有來自好友 這個選項. 假如這個啟用將只會接受來自被加入在 eMule 的 訊息 視窗中的 好友

可應用版本: .43a +
最後更新在: 2004-07-24 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 時間表

選項 - 時間表

時間表是用來管理 eMule 的設定和時間的關聯性於平日之間的變化. 它可能使用在晚上時來調高上載及下載的頻寬和是在工作時間時降低來保留頻寬做為其他用途.

時間表允許在平日中建立一個或多個動作來執行.
第一個清單盒中顯示著已建立的規則 標題, 天 執行動作的 開始時間. 選擇一個規則顯示其定義動作及時間設定會在 詳細 區域顯示.

o 啟用
啟用時間表的與否

o 移除
刪除選擇的規則

o 新增
建立新的動作規則. 新的規則會自動的顯示在 詳細 檢視並做適當的設定.

詳細
這個區域用來顯示已選擇動作規則的目前設定值及動作.

o 啟用
用來啟用選擇的規則. 一個或多個規則能被在任何時間被啟用.

o 標題
規則的標題或是描述.

o 時間
動作能被執行 每天 或是只有在 一週的某天. 每個動作也有一個 開始時間 和 結束時間.
假如在所給的時間中沒有動作, eMule 會自動的使用 選項 對話盒中的預設值.

在一個規則中建立動作
先由 新增 按鈕來建立一個新的規則. 之後輸入 標題 和 開始 及 結束時間 於這個規則 新的動作在 動作 清單中按右鍵來建立.

o 增加
在選擇的規則中建立一個新的動作. 之後再選擇動作的類型. 在彈出的視窗中輸入適當的數值:

> | 上載限制 定義 eMule 能使用的最大上載頻寬 kB/秒.
> | 下載限制 設定 eMule 能最大下載的頻寬. 數值單位一樣是 kB/秒
> | 限制來源數 改變一個下載允許的來源數量 (硬性限制).
> | 限制連線數/5秒 改變在5秒內新的連線數數量. 這個數值對 eMule 的效能有很大的影響. 見 選項 -> 延伸 取得更多詳細資料.
> | 最大連線數 推翻在 選項 -> 連線 中的最大連線數量.
> | 類別: 停止下載 這個動作用來停止已選擇 類別 之所有下載.
> | 類別: 繼續下載 繼續指定的類別中所有已停止的下載

所有的規則若要生效必須按 套用 按鈕.

o 編輯
改變已選擇動作的數值

o 移除
刪除選擇的動作.

可應用版本: .28a +
最後更新在: 2003-04-02 , Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - Web 界面

選項 - Web 界面

Web 界面提供遠端存取 eMule. 讀取在 FAQ 特徵類別中的 Web 界面 取得更多資料.

樣板:
Web 界面工作需要的檔案 eMule.tmpl . 這個檔案包含了 Web 界面的佈局及設計. 這個檔案和 eMule 是分開釋出的能在 www.emule-project.net 下載.
而圖片資源能放在 eMule 安裝資料夾中的 Webserver 資料夾內.

一般

o 啟用
核選來啟用 Web 界面. 啟用這項之後按 重新載入 按鈕來重新載入並產生 Web 界面. 假如發現無效的 eMule.tmpl 錯誤訊息 無法載入樣板: 無法開啟檔案 \...\eMule.tmpl 將會被顯示.
不要啟用 Web 界面除非您使用這項功能. 執行伺服器有著潛在的危險性.

o Gzip 網頁壓縮
將會使用壓縮來節省 web 界面使用的頻寬.

o 連接埠
這個決定的連接埠將會被 Web 界面使用. 預設值是 4711 並且在那裡通常不需改變它. 這個連接埠是存取 Web 界面位址的一部分.
假如這個電腦是嘗試存取這個 Web 界面而這個連接埠是被防火牆或一個代理伺服器封鎖您能改變連接埠到 80 這個標準的連接埠來連接到網路並且這個連接埠很少被封鎖的.
假如一個路由器使用這個連接埠是必須被轉送的.

o 樣板
通常樣板檔案 *.tmpl 是在 eMule 安裝的資料夾中. ... 按鈕允許容易的來改變檔案的路徑.

管理員
設定 Web 界面的存取密碼. 設定適當的密碼它是重要的否則任何人都有可能經由 Web 界面來存取您的 eMule . 輸入的密碼會顯示成 6 個***. 這裡沒有預設的密碼.

客人

o 啟用
不同於管理員來存取 eMule 的控制客人只能檢視設定值和清單. 他沒有權利改變任何東西. 假如不需要客人登入這項應該停用.

o 密碼
定義一個密碼來限制客人存取界面. 一樣沒有預設密碼.

注意:
使用 Microsofts Internet Explorer 更換 Web 界面選擇清單的顯示時也許會彈出一個下載視窗. 去阻止這個狀況在 工具 -> 網際網路選項 -> 進階 : HTTP 1.1 設定選項中 使用 HTTP 1.1 及 使用 HTTP 1.1 透過 proxy 連線 必須被核選

MobileMule
MubileMule 是一個界面能被任何 java 手機連線. 類似於 Web 界面它允許經由一個手機來遠端控制 eMule. 更多資訊拜訪 MobileMule 首頁 http://mobil.emule-project.net/.

o 啟用 MobileMule
允許一個 java 手機存取 eMule.

o 密碼
沒有預設密碼是被輸入. 當這個界面啟用為了安全理由那裡應該總是設定一個密碼.

o 連接埠
設定存取 MobileMule 界面的連接埠. 假如 eMule 執行的電腦是在一個路由器或防火牆之後這個連接埠需被 轉送 / 開啟 否則連線將不被允許.

可應用版本: .42a +
最後更新在: 2004-02-27 , Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 防護

選項 - 防護

IP-過濾器
IP-過濾器是使用來限制和從其他客戶端的連線. 在 ipfilter.dat 檔案內所有輸入的 IP 行列將會不能被 eMule 連線或是能被 eMule 到他們. 這個檔案能經由編輯按鈕被編輯並且他是儲存在 eMule 安裝的資料夾中. 取得更多過濾 IP 資請見在 FAQ 內的 IP 過濾.
eMule 能由重新載入 ipfilter.dat 檔案來套用先前的任何變更.

o 過濾等級
在 ipfilter.dat 內的每個項目都有指定存取等級. 這個數值描述著哪些項目是值得信賴的. 高的數值 (預設值 128+) 是被考慮過的防護然而低的數值是被封鎖的. 過濾等級決定了封鎖限制. 在 ipfilter.dat 內的每個項目都有指定存取等級等於或低於過濾等級將會被 eMule 拒絕連線. 這個預設應當不被改變.

o 也過濾伺服器
IP-過濾器通常只對其他的客戶端有效用. 這個選項將會延伸去過濾伺服器.

o 從網址更新
輸入一個過濾檔案的一個連結並按下 載入 將會加入發現的 IP 到 eMule 的 ipfilter.dat. 見 IP 過濾 章節取得連結及更多資訊

訊息
不必要的訊息能在下面欄位輸入後被封鎖. 假如文字符合訊息將不會被顯示出. 多個訊息被拘禁使用 | 來做分隔.

o 只接受好友訊息
除了已增加在 好友清單 的使用者其餘訊息將被封鎖.

o 只接受有效的客戶端訊息
這個設定能確定只有傳送的客戶端是有效的和看起來不是假的訊息才會被接受. 這個設定值應該被開啟.

o 進階廣告過濾器
進階廣告過濾器將會檢查每一個進來的訊息. 假如符合下列任何要過濾的, 而傳送者的訊息將會被禁止. 一個廣告禁止將只會在本次運行中作用.

> | 一個網站位址或 URL 在第一次接觸傳送
> | 這個使用者已經傳送了 5 個訊息沒有接收到一個回覆

在好友清單的使用者將不會被標記成廣告者.

註解
這個功能像是上面區塊的訊息但只應用在檔案註解

注意:
檔案註解應該能幫助其他使用者去判斷一個下載的品質. 他們不是用來討論天氣或任何種類的廣告. 請留下適當的註解.

多方面的
o 使用安全識別
使用安全識別建議使用它. 於更多的資訊請見 這裡 的主題.

o 以沒有特權的使用者執行 eMule
這個功能只在 Win NT 系列 (2k, XP, 2003) 可使用並且允許 eMule 有利於從那些系統提供嚴密的防護.
通常一個使用者是以管理員(Administrator)帳戶來登入他的電腦. 這個帳戶類型允許所有執行的軟體能完全的控制系統. 在這種情況下所有惡意程式碼被執行後將會造成不良的影響.
以沒有特權的使用者執行 eMule 將會建立一個自有的帳戶在作業系統名為 emule_secure 並設定這個特別的使用者允許完全控制它所需的資料夾 (安裝資料夾, 暫存及新進資料夾). 另外這個帳戶也嚴密的限制並禁止在系統其他部分的存取. eMule 啟動在它自己的使用者帳戶確保任何惡意程式碼不會對系統有影響, 因此沒有任何可傷害系統的事. 這可以預防任何被發現的程式弱點.
注意:
o | eMule 注重檔案的權限. 更進一步的防護能被實現由慎重的限制其他資料夾或磁碟的檔案權限. 檔案權限的限制只在 NTFS 可使用而 FAT 不能
o | 在現代的作業系統單獨的帳戶能提供完全控制電腦像是磁碟配額等.
o | 當 eMule 工作在這個模式時在 Windows XP 一個臭蟲阻止任何視覺樣式(圖形主題). 圖形使用者界面將會看起來像標準的 Win98. Windows XP SP2 似乎解決這個問題.
o | 這個設定將不會提供在這個網路任何的匿名但使執行 eMule 的系統更能抵抗外來可能的攻擊.

可應用版本: .42a +
最後更新在: 2004-05-01 由 Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - 延伸

選項 - 延伸

新的連線之最大數量 / 5秒
這是 eMule 在5秒內開啟新的連線數數量. 預設值是 20.

重要的:
> | 弄糟設定值可能會造成藍色畫面, 操掛路由器以及瀏覽器無法使用. 而且在錯誤的設定值上下載資料有可能會受損.
> | 在高頻寬像是 Tx 或 LAN 上執行 eMule 您也許能稍微加大這個值.

半開啟的連線之最大數量
這個設定在 Windows XP SP2 的連線節流是必要的. XP SP2 的更新將只能允許 10 個半開啟的連線數量並且多出的連線數將開始排隊並等候其中這個處理過程是緩慢的. 這將會在 eMule 導致連線逾時和其他不想要的影響.
假如 eMule 執行在 XP SP2 不要 將這個值設超過 9. 雖然有修改檔可增加在 XP 程式鎖定的值, 但不建議您去修改在 Windows 如此重要的部分. 這個設定值只會影響在 eMule 啟動之後獲得來源時變慢一點. 這種情形將在來源發現後慢慢消退.
在其他的作業系統像是 Windows 2000 或較舊的 Windows 98/ME 設定這個值為 50.

只在執行eMule時自動抓取 eD2K 連結
啟用這個功能時, 只會在 eMule 執行自動和 eD2K 連結產生關聯, 當 eMule 關閉後其關聯將會被刪除並允許其他的 eD2K 客戶端能維持原有的關聯性.

當 啟動/離開 eMule 時 開啟/關閉 在 WinXP 防火牆的連接埠
eMule 能夠在 Windows XP 內部防火牆自動的開啟它需要的連接埠. 這個設定將會由啟動 eMule 時開啟及離開時關閉的方式不保持連接埠的開啟而增加安全性. 這個設定只在 Windows XP 的內部防火牆可使用, 不包含任何的第三方產品. 這個選項不能正常工作在目前釋出的 Win XP Sp2 RC.

使用額度系統 (獎賞上載者)
若要更多資料請見 額度系統 這篇. 非常的建議使用額度系統, 它將會制止網路上的寄生蟲.
使用這項功能的理由:
> | 現在釋放者能確定沒有其他檔案能不透過這項功能而優先釋放的他們檔案.
> | 一個混合的網路將會有利於抵抗一個自肥的系統.
> | 罕見及流通的檔案平衡將會增加.

過濾伺服器及客戶端區域網路 IP
來源中包含的 IP 若在私人 IP 階級 A (10.0.0.0 到 10.255.255.255), B (172.16.0.0 到 172.31.255.255), C (192.168.0.0 到 192.168.255.255) 及本地主機 (127.0.0.0 到 127.255.255.254) 及所有以 (0.x.x.x) 開頭的無效 IP 在網際網路上都是無效的. 無論是由客戶端到客戶端的來源交換或從伺服器接收到像這樣子的來源都會在啟用這項功能時被過濾掉.

注意:
若在一個區域網路(LAN)執行 eMule, 需要將這項選項關閉, 否則 eMule 將不能在這個網路找到任何的來源.

顯示更多控制 (進階的模式控制)
這個選項啟用在 eMule 內的更多功能通常不需要執行它.

o 顯示詮譯資料
這個是在 傳輸 視窗的一個下載右鍵選單中的一個指令. 它顯示也許像是 MP3 ID 標籤或作者, 年份等這個檔案的額外資訊.

o 來源處理 (A4AF - 已要求於其他的檔案)
見 eMule 的特徵 來源管理 章節了解詳細.

停用 A4AF 檢查來節省 CPU
這個將會關閉所有的來源處理和在 來源管理 章節描述的一樣. 只在一個下載取消時, 可能的 A4AF 來源才會重新分配優先順序.

建立新的部分檔案成 '疏鬆檔案' (限 NTFS 使用)
若磁碟格式為NTFS(暫存資料夾所在磁碟), eMule 可以'疏鬆檔案'型式來儲存檔案, 更有效的利用硬碟空間.
疏鬆檔案 - 為 0 值的資料不會被配置空間不會佔用實際的硬碟空間大小, 而非 0 值的資料才會配予空間並實際的佔用硬碟空間大小

檢查磁碟空間 (最小的可用磁碟空間 [MB])
在 eMule 下載的暫存檔案大小由需求而不斷地增加. 檢查磁碟空間 選項保證目前下載能完全地下載並完成. 當下載大於目前可用磁碟空間的檔案會變成已暫停所以其他的檔案還是能繼續的被完成.
假如您提供一個 最小的可用磁碟空間 數值, eMule 的運作方式將會改變. 現在全部的檔案下載會直到限制的可用磁碟空間到達時 eMule 才會有所動作.
在可用磁碟空間增加後已暫停的檔案將會自動的重新開始.

自己的 eD2k 連結主機名稱
在已分享檔案視窗中有目前 IP 的 eD2k 連結能被建立. 輸入一個主機名稱在這個空格允許建立一個以主機名稱替代 IP 的連結. 這個有利於您的 IP 改變時這個連結仍然有效.
更多資訊請見 Web 界面 動態的主機名稱這章節.

停用從 PeerCache 下載
PeerCache 是一個在 ISP 層級以完全匿名方式快取下載系統. 這個將由 ISP 自己的系統緩衝下載的部分提供最佳的速度給使用者進而減少 ISP 的流量. ISP 必須支援這個特徵才能有效用.

儲存記錄到磁碟
這是輸出二個記錄視窗 伺服器 分頁中的 - 記錄 和 除錯 - 核選該項即能儲存到磁碟. 他們將會被存成 eMule.log 或 eMule_Debug.log 在 eMule 安裝的資料夾中.

詳細模式 (回覆程式附加資訊)
假如詳細模式開啟, 一個附加頁面 Debug 會顯示在 伺服器 視窗. 顯示在那裡的資訊是開發用並且 在這些將不會提供額外的支援. 這個選項會造成 CPU 及記憶體的負載. 一般運作不建議使用.
記錄標準選項控制哪些記錄訊息會被顯示. 標準 5 代表全部詳細訊息然而 標準 1 只顯示較重要的. 假如您想要知道重要的各種訊息請查看 eMule 的原始碼 ;)

安全的 .met / .dat 檔案寫入
在新的作業系統使用了 NTFS 檔案系統通常不需要改變這個選項. 假如在當機或 eMule 關閉時下載出現流失而安全的方法將會是可靠的.
依硬體的使用的不同, 這個選項或許會明顯的增加 磁碟動作 / 系統負載 或拉長 eMule 的關閉!

o 在關機時
在應用程式關閉時 eMule 將使用特別的安全方式去提交 .met 和 .dat 檔案到磁碟. 這或許會將關機時間拉長.

o 總是
在每次寫入檔案時使用安全方式.

伺服器連線更新間隔
在某些情況下, eMule 運作在一個路由器或網路配置使用 NAT - 網路位址轉化, 在這時會導致 eMule 規律的間隔時間內和伺服器失去連線.
在那些使用 NAT 連線的路由器常常會發生逾時, 之後路由器將宣告這個連線已中斷並關閉它. 當這個發生時 eMule 將會嘗試去重新檢查它的伺服器, 而一個完整的重新連線它是必要的因為舊的一個連線已被路由器移除.
萬一發生這種情況, 檢查在您的路由器設定值中的 NAT 逾時數值, 並且輸入一個 稍微 低於這個數的數值在伺服器連線更新間隔這個欄位內. 0 表示 eMule 自動處理並且通常是不需要改變這個值!
不要 弄亂這個設定值, 除非您有一個路由器或一個更複雜的網路結構需去更動它. 假如這個數值設太低伺服器也許會將您 禁止.

上載速度感應器 (USS)
USS 是一個監視連線反應(ping)時間的功能並且根據反應數值去自動調整 eMule 的上載. 這個確保連線從不阻塞和將會試著保持線上遊戲的順暢. 建議保持它在預設值.

o 自動地找出最佳上載限制
啟用 USS

o 上載最低允許速度
這個是 USS 必須保持的最小上載速度. 建議它最小在您上載速度的 50%

o 反應的容差值 (最低反應的百分比%)
一個初始平均反應決定 eMule 連線狀態. USS 將不會允許反應增大超過初始反應時間的倍數, 例如初始反應時間在 50 ms 而 800% 反應容差值將會導致最大反應在 400 ms.

o反應容差值 (ms)
替代計算最大允許反應的 % 比例, 指定一個毫秒值. 見下個設定.

o 反應容差值方式
選擇判斷最大允許反應的偏好方式. 百分比或毫秒比例二者之一選擇一個來使用.

o 上升延遲 / 下降延遲
這二個值是停留在反應容差值時多快的調整上載限制. 設定錯誤的值將會崩潰連線. 保持預設值!

o 反應平均值的最大計數次數
設定反應做為計算的回應平均值次數數量.

檔案緩衝區大小
當 eMule 沖出它的檔案緩衝時在某些系統也許會表現出 "聲音結巴" 的狀況. 低的緩衝大小也許會有助於這個情況減少但將會造成 eMule 對硬碟的寫入動作頻繁. 設定緩衝大小太小會使 eMule 的效能降低.
增加緩衝大小將會減少硬碟動作但會提高資料流失的危險性(如當機時).

等候區大小
於 eMule 額度系統中工作恰當的等候區大小是非常重要的. 假如一個客戶端等候區已經滿了另一個客戶端以一個高額度的等級將會沒有機會可進入等候區來花費他的額度. 如此一來大的等候區是有助於額度系統的工作. 客戶端以高額度將會促進長久等候變得快速並充分的平均分享.

重要的:
一個大的等候區將不導致較大額外支出的頻寬來管理這個等候區. 連線數及額外支出的頻寬這二個數字都不會因一個較大的等候區而增加. 只會增加記憶體的使用.

可應用版本: .44a +
最後更新在: 2004-09-11 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 選項 - Preferences.ini

選項 - Preferences.ini

所有在 eMule 的設定值是儲存在 preferences.ini 檔案中. 所有重要的選項能容易的由選項視窗中去變更但 preferences.ini 檔案能存取一些更多的選項. 由手動方式用編輯器來開啟這個檔案並改變去存取那些東西. 進階使用者會使用 *.ini 檔案而不正確的項目會立即產生不必要的結果. 編輯之前先關閉 eMule.
每個區段標題即為預設值

注意在 Unicode 和 Windows 記事本:
當 eMule 暱稱或 IRC 暱稱包含 Unicode 字元而 preferences.ini 檔案用記事本編輯它並試著用 Unicode 格式去儲存檔案, 它對 eMule 是無效的檔案. 在記事本的"另存新檔"確定變更文件編碼類型為 ANSI 以避免這種情況發生.

區段: [emule]

o TxtEditor=notepad.exe
預設的編輯 Web 服務 和 IPFilter.dat 程式能在這裡輸入. 可使用任何程式來取代 notepad.exe, 而執行檔的路徑必須提供.

o DateTimeFormat=%A, %x, %X
這個字串用來定義 eMule 如何去顯示日期和時間. 見 這個 MSDN 文章 去了解所有可能的格式碼之詳細資料.

o MaxLogBuff=64 / 128 (v0.30a+)
定義 eMule 顯示記錄使用系統記憶體的數量. 於 Windows 98 / ME 預設值在 64 kB 是保留的, 於 Win 2k/XP 它是 128 kB. 這個記錄是輪換的, 即假如緩衝是填滿到它的限制一個舊的訊息會在新的訊息到達時清除 (FIFO - 先進先出). 這個設定取代 v0.29 的 MaxLogMessages.

o MaxChatHistoryLines=100
定義 IRC / 訊息 記錄的儲存行數最大量. 於這個數值到達之後的舊訊息會在新的訊息到達時清除 (FIFO - 先進先出).

o ExtractMetaData=2/1/0
控制詮譯資料將如何從檔案讀取. (v0.30a+)
0: 停用
1: 啟用於 MP3 及 AVI 檔案
2: 預設值, 啟用於 MP3, AVI, MPEG 及其他的檔案

o ServerUDPPort=65535
正常的這個本地連接埠為了要求伺服器來源或搜尋檔案在他們是亂數選擇 (見 連接埠主題 #6). 假如 eMule 是在一個較複雜網路上的電腦執行, 特別是使用代理的, 它或許必需固定這個連接埠到一個定義數值否則它將會全部無效. 停用這個連接埠表示著 eMule 將不再能更新伺服器清單中的伺服器狀態並且也不能接收來源從伺服器他們也不能做全球搜尋. 免除從 eMule 實際上連線到的這個伺服器. 通常使用預設值應該不被改變.
合適的 ServerUDPPort 數值是:

0 | 停用
1 - 65534 | 固定本地 UDP 連接埠
65535 | 亂數連接埠 (預設值)

o PreviewSmallBlocks=0/1
使用 VLC - VideoLAN Client 來預覽時這個功能應該是只有啟用 (=1) . 在最小 16 kB 資料於 .mpeg 檔案或 256 kB 資料於所有其他的多媒體檔案內容 (.avi, 光碟影像包含多媒體內容) 已被下載時它允許去預覽多媒體檔案. 更多資訊見 選項 -> 檔案 -> 影像播放器 及這個主題 預覽多媒體檔案. 使用這個選項在 影像播放器 視窗的 建立備份來預覽 設定值變成無效.

o RestoreLastMainWndDlg=0/1
假如 RestoreLastMainWndDlg=1 加入在 preferences.ini, eMule 會在離開之前記住主視窗 (Kademlia, 伺服器, 傳輸, 哪個開啟) 並在啟動時還原它.

o RestoreLastLogPane=0/1
相同於 RestoreLastMainWndDlg 但這是記住最後使用哪個記錄頁 (記錄, 除錯Verbose).

o RemoveFilesToBin=1/0
這個設定影響在已分享檔案主視窗的右鍵選單內之 從磁碟刪除 功能. 假如停用 (=0) 檔案將會從磁碟中被永久地刪除不會移動到資源回收筒.

o PreviewCopiedArchives=1/0
當這個選項停用時 (=0), eMule 將會使用一個新的預覽方式並且它是較快的和在暫存資料夾內使用較少的磁碟空間. 歡迎反應這個新版的功能.

o ShowActiveDownloadsBold=0/1
將以粗體字列出目前正在下載中的檔案.

區段: [Perflog]

o File=D:\Path\to\datafile\perflog.csv
假如 MRTG 是使用來繪製 eMule 的效能, 這個項目表示儲存效能資料的路徑和檔案名稱. 通常這個由 MuleMRTG 安裝程式設定並且不需更改它. 假如改變 MuleMRTG 將必須再重新安裝.

o Mode=1
設定收集資料的取樣模式. 假如使用 MuleMRTG 它必須設為 1.

可應用版本: .44a +
最後更新在: 2004-09-15 由 Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 防火牆

防火牆

防火牆
所有監聽的連接埠在防火牆設定值當中都必須被開放的. 大多數視窗的防火牆都是以應用程式為基礎, 您能自己在防火牆加入一個規則允許 eMule.exe 直接存取所有 UDP,TCP 的連接埠解決這些問題. 這將不會危害到您的安全防護開發至今仍沒有這種問題.

注意:
- ZoneAlarm 是會回報 eMule 造成問題. 不建議使用它. 好用且免費的防火牆是 Kerio Personal Firewall 及 Agnitum Outpost

- 若時間允許我將會增加一些範例. 假若您想要投稿您所使用防火牆的一些好點子. 附上一些程式圖片並寄到 Monk@emule-project.net

最後更新在: 2002-12-14 由 Monk -中文化:CML 2003-01-18


eMule FAQ 中文版 :: ICF

XP 網際網路連線防火牆

Windows XP 防火牆一般來說都不建議使用, 因為它是非常基本的防火牆. 假如您無論如何都想要使用它請照下列步驟:

1. | 開啟 eMule
2. | 點 選項 > 連線
3. | 抄下客戶端連接埠數值 (預設值 4662)
4. | 同樣的也記下 UDP 連接埠數值 (預設值 4672)
5. | 關閉 eMule 並且連線到網路
6. | 在 Windows XP [開始]鈕按一下, 並點選[連線到].
7. | 在[連線到]選單中, 按下[顯示所有連線]. (二選一, 您也能直接的在您的連線上按右鍵點下[內容].)
8. | 按右鍵將您的所連線的網際網路連線[內容]打開
9. | 按下[進階]分頁, 再按[設定]. 假如設定無法按下, ICF 是沒有啟用在這個連線而且您不需要開放任何的連接埠 (因為沒有開啟防火牆所以都是開放狀態).
10. | 按[新增...]來增加一個新的連接埠.
11. | 輸入[服務描述], 例如, "eMule : TCP 輸入".
12. | 輸入 127.0.0.1 [在您的網路上這個服務所在電腦的名稱或 IP ]那欄. 您能指定這個 IP 位址是內部電腦的; 無論如何, 大多數都使用 127.0.0.1
13. | 輸入您在步驟 #3 抄下的連接埠在外部及內部連接埠號碼欄位上.
14. | 選 [TCP], 並且按[確定].
15. | 再次新增一個連接埠.
16. | 這次的名稱可像是 "eMule : UDP 輸入"
17. | 見 #12
18. | 如同步驟 #4 輸入您的設定值在外部及內部連接埠號碼欄位上.
19. | 選 [UDP], 並且按[確定].
假如您之後又更改連接埠, 您必須再次做類似的設定. 下列為附加資訊, 按下面的文章編號來檢視微軟的知識庫: Q308127 如何手動開啟 Windows XP 網際網路連線防火牆中的連接埠 Q283673 如何啟用 Windows XP 的個人防火牆功能 Q307554 有網際網路連線防火牆時，需要手動設定連接埠的程式 (如何使用 ICF 是從 -nRoK- 來採用. 感謝他) 最後更新在: 2002-12-14 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 路由器

路由器

當您沒有適當的設定路由器時您將會得到一個低 ID. 一個路由器工作像是保護它後方的網路, 冒充為區網中電腦的 IP 位址. 當其他客戶端連線到您的 eMule 時只會看見路由器的 IP 但不會看見真正執行 eMule 電腦的 IP. 在路由器所有阻止連接埠的清單中, 輸入 方向 – 連接埠 4662 TCP 及 連接埠 4672 UDP – 必須被轉送.
參考您的路由器手冊. 關鍵字是連接埠轉送(port forwarding), DMZ – 解除區域(Demilitarized Zone), 過濾(Filters) 及 規則(Rules).
許多路由器也內建防火牆所以也需確認設定的連接埠是否恰當 (請見防火牆).

注意:
當在一個網路使用一個路由器 DHCP - Dynamic Host Configuration Protocol 這個選項在路由器中應該被關閉. 指定靜態 IP 到每一個客戶端在這個網路. 這個能在 視窗的網路連線 -> 區域連線 -> 內容 -> TCP/IP 完成設定. 使 自動分配 IP 無效並輸入一個 IP 在 192.168.xxx.xxx 範圍內. 不同類型的路由器有 不同的內部 IP 範圍, 這個記錄在路由器手冊中.
之後輸入一個有效的 IP 子網路遮罩 領域自動的改變到 255.255.255.0. 最後一步是輸入您的 路由器的 IP 為標準的閘道.

假如您想幫助其他使用者和知道如何處理您使用的路由器, 寫一小篇說明並送至 Monk@emule-project.net

注意:
假如在列出的說明中沒有您使用的路由器類型, 但路由其的設定方法都是相似的可參考這些來做設定.

最後更新在: 2003-03-22 由 Monk -中文化:CML 2003-07-06


eMule FAQ 中文版 :: SMC Barricade 7004 ABR

SMC Barricade 7004 ABR

內容

內容 | 這個指南的步驟清單
序言 | 有於關這個指南您可能想知道的
登入 | 存取您的路由器配置
IP | 找出您的網路-IP
Virtual Server | 配置步驟一
Special Application | 配置步驟二
結束 | 一些工作
FAQ | 常見問題

序言

這個是我第二版的 SMC 指南應該能夠解釋我所知道和 eMule 有關的所有設定方式.
在這裡我想要感謝傳送給我提示和建議的人. 但我很抱歉由於我的硬碟損壞使在 2004/02/22 之前的所有電子郵件遺失.
這個指南是為 SMC Barricade 7004ABR (eu) Firmware: V.1.40.02. 所寫我認為其他的 SMC 路由器產品的配置也應該相同或相似. 這個指南可用於:

  • SMC Barricade 7004 ABR
  • SMC Barricade 7004 ABR v2 (Virtual Server 看起來有一點不同, 但您能輸入相同的東西) (感謝 Tilube)
  • SMC Barricade 7004 VBR (感謝 Ulf)

注意: 這個清單曾經是大的, 但我遺失了告訴我一些他們的路由器有相同配置人的所有信件. 假如您想要知道您的路由器有相同的設定,
請寄一個短信到 theurmel@arcor.de, 謝謝. 假如您想要包含操作畫面, 請使用低失真的壓縮格式像是 PNG 或 GIF.

登入

存取您的 SMC Barricade 配置是很容易的. 您只需在瀏覽器中輸入它的 IP, 並且按下 ENTER.
標準的 IP 是 192.168.2.1, 所以您應該輸入 http://192.168.2.1/ 在您的瀏覽器, 或是直接點一下這個連結.
您應該會看到一個像這樣的視窗:
登入畫面
現在, 您只須輸入您的密碼到密碼欄位中並按 [image] -按鈕.

IP

找出您的 IP, 您現在在 Status 按一下. 您現在應該會看見一個標題為 "Security Log" 小格的方框在您的畫面中間, 看起來像這個:
2004/03/06 10:32:38 192.168.2.30 login successful
假如您沒有看見像這樣的一行, 捲動方框到底部. 在那些項目之中應該會有一個最近的.
在我的範例這裡我得到了這行:
2004/03/06 10:32:38 192.168.2.30 login successful
所以我的 IP 是 192.168.2.30. 記下或寫在某張紙然後我們才能繼續.

Virtual Server

現在按下 Setup 繼續.
在您的畫面左方, 有一個主題清單會出現. 在 Advanced Settings 上面您應該會找到一個名為 Virtual Server 的項目. 按下它.
假如您是 SMC Barricade 7004 ABR v2, 您將會在 NAT 找到它.
現在您應該會看到一個清單出現. 在這裡, 您將隨下列輸入資料:
Virtual Server
在我的範例中, 我使用的 IP 是 192.168.2.30. 假如您的 IP 是不一樣的 (而且他很有可能), 您將輸入 IP 的最後一段在 Private IP 欄位 (我的是 30).
並且, 我使用預設的客戶端-連接埠 4662 及 UDP-連接埠 4672. 假如設成一個不同的連接埠, 請查看您的 eMule-選項.
假如您不想要使用 eMule Web-伺服器, 那樣子您不用輸入 4711 連接埠這行. 假如您使用它, 請檢查在 Web伺服器-選項 是不是正確的連接埠.

現在, 在 Enter -按鈕 按一下來取存 Special Application 選單.

Special Application

在這裡, 隨著下面輸入資料:
Special Application
我使用預設的客戶端-連接埠 4662 和 UDP-連接埠 4672. 假如設成一個不同的連接埠, 請查看您的 eMule-選項.
假如您不想要使用 eMule Web-伺服器, 那樣子您不用輸入 4711 連接埠這行. 假如您使用它, 請檢查在 Web伺服器-選項 是不是正確的連接埠.

並按下 Enter -按鈕 和 Logout -按鈕.

結束

好吧, 那樣子. 您應該在每個伺服器得到一個 高-ID 及 Kademlia 直接狀態.
假如您仍有任何的問題在 FAQ 找不到答案, 可隨時寄信給我 theurmel@arcor.de.
我不能保證能回答信中的問題, 但我會嘗試. 以及寄信給我時除了德文和英文之外不要用其他的語言 (假如是其他的, 法文也是可以, 但我能寫的很好所以我將會以英文回覆).

FAQ

"我設定過描述的每一項仍得到一個 低-ID. 我能做什麼?"
請重新檢查您設定的客戶端連接埠 eMule-選項, 並且輸入正確的連接埠在 Virtual Server 及 Special Application 配置.
假如每個都正確, 試著在 eMule 伺服器選項 啟用 安全的連線.
留意點, 假如仍然得到一個 低-ID 而您想再檢查總是必需重新連線.

"我在二台電腦使用 eMule 連線到我的路由器, 雖然照您的指南正確的設定, 但是我的 eMule 總是得到 低-ID."
首先, 我強烈建議在每個網路中只使用一個 eMule 它是因為對您會有較少的麻煩及伺服器有較少額外支出的頻寬. 同時, 您的上載能力必須被二個 eMule 分割使用所以假如您的上載在 20kb/秒 以下, 而依這比例使用, 如此一來將會減少您的最大下載. 我建議您使用 Web-伺服器 取代第二個 eMule.
假如您仍然想要使用二個 eMule, 您必須指定他們二個不同的連接埠 (像是 eMule1: 客戶端 4662, UDP連接埠 4672 - eMule2: 客戶端連接埠 3662, UDP連接埠 3672), 轉送那些到正確的電腦 Virtual Server, 並輸入連接埠在 Special Application 配置.

非常感謝 URMEL 製作這個廣泛的指南.
最後更新在: 2003-02-21 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: Solwise SAR-7x5 + Allnet ALL129

Solwise SAR-7x5 + Allnet ALL129

注意:
這是假設在您的防火牆已停用的情況下, 且執行一個 NAT 配置.

首先用瀏覽器連線到您的路由器配置頁下. 它的預設值為 http://192.168.7.1

現在點一下 Advanced Configuration .

在出現的選項清單中按 Security/NAT .

現在載入這一頁, 找 Security Interfaces 這一項.

點下在 ppp-0 連線後面的 Advanced NAT Configuration . 將會載入一個畫面, 為 Reserved Mappings.

在這頁中按 Add Reserved Mapping.

現在開始小心的部分. 隨下面圖片並且按下 Add Reserved Mapping.
您需要做這個動作二次, 一次是連接埠 4662 TCP 而另一次是連接埠 4672 UDP.

重要的:
您必須輸入執行 eMule 電腦的 IP. 確認您的 IP 去 視窗開始功能表 -> 設定 -> 網路 連線. 選您的 區域網路 連線 按右鍵選 內容. 選擇 網路通訊協定 (TCP/IP) 並按 內容. 這個視窗會顯示您目前的 IP 位址

一旦完成動作在左手方選單中 System, 按下 Save config.

您已成功的完成 SAR7x5 路由器來使用 eMule.

這篇教學由 aldo 製作. 非常感謝.

最後更新在: 2002-12-15 由 Monk -中文化:CML 2003-01-20


eMule FAQ 中文版 :: Lucent CellPipe 20A-GX-E

Lucent CellPipe 20A-GX-E

隨下列簡單的步驟來為 eMule 設定您的 Lucent CellPipe. 這是假定在你以 PPPOE DSL 來連線.
在您的路由器 IP 中開始一個 telnet 動作. 方法如下
 | a) 使用 Windows Hyper Terminal 並且 輸入一個 名稱 (不要有相同的) 於這一次動作, 選擇 TCP/IP (Winsock) 為連線類型然後輸入 您的路由器 IP 為主機位址
 | 或
 | b) 去到[開始]功能表 -> 執行 -> telnet 路由器的 IP
在 telent 連線狀態下一次一列輸入這些的指令:
 | pat addpatin pppoe 4662/tcp 客戶端的 IP pat addpatin pppoe 4672/udp 客戶端的 IP save
路由器的 IP 是您的 CellPipe 路由器 IP 而 客戶端的 IP 是您執行 eMule 電腦的 IP 位址.

感謝 Jarek 指導.

最後更新在: 27/12/02 由 Monk -中文化:CML 20/01/03


eMule FAQ 中文版 :: Linksys BEFSX41

Linksys BEFSX41

以下圖片皆為 XP 英文版作業系統, 位置都一樣只是英文照著做應該不會有問題.

這個指南假設在您有一個 Linksys BEFSR41 router. 它跟其他版本的 Linksys 路由器像是 'wireless' 或 'firewall' (BEFSX41) 非常相似但我不確定是否完全是.

我是使用 Windows XP Pro,但用法說明和 XP Home 也一樣. Windows98 使用者將必須看 替代的用法說明.

這個指南的目標是顯示您如何設定您的 Linksys 路由器所以您能使用 eMule. 這裡有二個方法, 一個是使用 UPnP, 而另一個是使用瀏覽器. 這些用法說明是長的且描繪其目的, 但願您不會有困難! 真實的描述所以您能容易上手, 所以請不要對這篇長的用法說明產生恐懼.

UPnP 的安全關聯

在 Universal Plug and Play 有一些 嚴重的安全性問題. 您應該 在這裡讀取相關事物.
感謝 Monk 讓我知道這些.

檢查您的安全性在這裡測試 http://www.pcflank.com/ 或這裡 http://www.dslreports.com/scan/

假如 讀取完/測試完 之後, 您決定要直接停用 UPnP 您將需要隨我的

沒有 UPnP 替代的用法說明來做轉送設定.

或, 假如您決定要完整的安全性請繼續下面動作.

Windows XP UPnP 用法說明

  1. 首先要確認您的路由器韌體版本是最近的. 韌體像是路由器內部的軟體. 您能參觀Linksys 下載頁來更新最新版的. 在下拉式清單中選擇您的路由器, 選擇韌體連結, 儲存這個檔案並隨其用法說明. 他們是容易的, 並且是快速的.

  2. 一旦您完成先前步驟... 在視窗中, 按 開始>設定>控制台>網路連線 開啟這頁:

    比照我的圖片, 假如您的項目中網路閘道器啟用代表您已經安裝 UPnP 且進度會更早完成. Windows XP 應該已經設定完全而且路由器韌體版本 1.42 (?) 或更新. 總之你可以略過並到 步驟 4.

  3. 安裝 UPnP:

    1. 按 [開始], [控制台], 並按 [新增或移除程式].

    2. 在 [新增或移除程式] 視窗中, 按 [新增/移除 Windows 元件].

    3. 在 [Windows 元件精靈], 點 [Networking Services], 按 [詳細資料...] , 並且核選 'Universal Plug and Play'. 您應該也看見 'Internet Gateway Device Discovery and Control Client' 列在上面, 並且它也要核選.

    4. 按下 [確定], 並且 [Windows 按元件精靈] 也按 [確定]. 您必須放入您的 Windows XP 安裝 CD.

      5. ( 我發現這個消息在 http://www.microsoft.com/windowsxp/expertzone/columns/crawford/02july22.asp)

    5. 使用您的瀏覽器, 去到 http://192.168.1.1/Passwd.htm 並且將會顯示如下方的圖片, 確定 'UPnP Services' 是否啟用:

    6. 按 開始>設定>網路連線. 在 '區域連線' 上按右鍵. 選 '內容'. 一個小視窗出現. 在上方按 '進階'. 使 XP 防火牆關閉如下圖:

    7. 現在回到步驟 2 檢查您的 UPnP 是否工作中. 它出現時為網路閘道, 忍耐點等個數分鐘再次檢查它是否出現.

  4. 現在您有了 UPnP up 而執行連接埠轉送是很簡單的...

    首先選 [區域連線] 使它如下面圖片一樣:

    在左方的詳細資料中您應該看見您的 IP 由您的路由器指定, 如下圖:

    ...在這個例子中它是 192.168.1.100, 無論如何注意這裡.
  5. 回到主畫面中, 在 '網路連線' 上按右鍵選 '內容'.

    您將會看到這個視窗:

    按[設定...], 並且選 '新增...'. 這個將會指定路由器需轉送 eMule 工作的連接埠. 填寫下方空格, 但是 IP 位址填寫您路由器指定給您的位址. 這個 '服務描述' 文字可填入您喜歡的文字 - 在這裡指定為... "eMule" 就好了:

  6. 隨後按 '確定' 來儲存新的設定值, 再次按 '新增...' 來加入第二個轉送連接埠. 再次填入您自己的 IP 位址, 輸入 "eMule" 為服務描述, 並且照抄下面的資料. 再按 '確定' 來儲存設定值:

  7. 您將會看到二個 eMule 的項目在這裡, 如下圖:

    按 '確定' 來儲存設定值並離開. 您完成了所有動作! 您將告訴路由器轉送輸入的連接埠 4662 和 4672 到您的電腦. 執行 eMule 它應該能工作.

Windows98 / 替代的使用方法 / 不使用 UPnP

在這裡是其他的方法來完成這個動作.
  1. 開啟您的瀏覽器並在網址列輸入: http://192.168.1.1 來存取您的路由器狀態頁. 輸入您的使用者名稱及密碼在空格中在我的機器中它似乎不相同... 您有改變過預設密碼? 假如沒有讀取您的 linksys 手冊來找到它!

  2. 在畫面頂端按下 DHCP

    然後再按下名稱為 'DHCP Clients Table' 的按鈕. 您將會看到出現像下面的視窗:

    看 Client Hostname 那一列, 找出您的電腦名稱並記下 IP 位址的最後一部分. 在例子中 client hostname 是 'Christopher', 而他 IP 位址最後一部分為 100. 再次記住這個號碼然後關閉這個視窗.

  3. 在畫面的右上方, 按下橘色的 'Advanced'. 您將會被轉換到 'filters' 這頁 - 在這裡您不需做任何事, 在上方按第二個標籤 'Forwarding'... 並且填入像下方的值. 但是您必須填您記住 IP 的最後一部分 (100 是我喜好的值):

  4. 在底部按下 'Apply' 並儲存您調整的設定值. 現在您的路由器會轉送連接埠 4662 及 4672 到您的電腦. 關閉瀏覽器視窗, 並執行 eMule, 它現在應該能工作!

配置 DHCP 經由連接埠觸發

  1. 開啟您的瀏覽器並輸入您的路由器 IP 位址 (預設值: 192.168.1.1). 輸入您的密碼 (預設值: admin - 變更它!). 按 'Advanced'. 按 'Forwarding'.
  2. 在轉送(Forwarding)畫面您將會找到 Port Triggering 這個按鈕. 按下它並輸入如下顯示的配置. 只配置 eMule 您能忽略 msn 這項.

  3. 按下 'Apply'.現在您的路由器應該會轉送 eMule 封包到您的電腦而不需指定 IP 位址允許 DHCP 或多台電腦使用 eMule.

感謝 Violator 這是很容易了解的說明. 感謝 ThRaShErUk 提供如何使用連接埠觸發.

最後更新在: 2004-03-06 由 Monk -中文化:CML 2004-03-08


eMule FAQ 中文版 :: Cisco 677/678

Cisco 677/678

隨下列簡單的步驟來為 eMule 設定您的 Cisco 677 或 678 路由器. 這是假定在你以 PPPOE DSL 來連線並且是一個 靜態 IP.
在您的路由器 IP 中開始一個 telnet 動作. 方法如下
 | a) 使用 Windows Hyper Terminal 並且輸入一個 名稱 (不要有相同的) 於這一次動作, 選擇 TCP/IP (Winsock) 為連線類型然後輸入 您的路由器 LAN IP (一般為 10.0.0.1 或 192.168.0.1, 但可能不一樣) 為主機位址
 | 或
 | b) 去到[開始]功能表 -> 執行 -> telnet 路由器的 LAN IP (一般為 10.0.0.1 或 192.168.0.1, 但可能不一樣)
在 telent 連線狀態下一次一列輸入這些的指令:
 | 您的密碼(由您的 ISP 提供, 假如沒改變是 cisco ) enable 您的密碼 (由您的 ISP 提供, 假如沒改變是 cisco ) set nat entry add LAN IP 4662 WAN IP 4662 tcp set nat entry add LAN IP 4672 WAN IP 4672 udp write reboot
WAN IP 是您在網路上有的 IP (路由器的外部 IP) 及 LAN IP 是執行 eMule 電腦的 IP.
注意: 假如任何人知道如何設定這個路由器在動態分配 IP, 請寄信給 Monk

非常感謝 Fuxie - DK 指導.
最後更新在: 2003-21-02 由 Monk -中文化:CML 2004-03-08


eMule FAQ 中文版 :: 連接埠

連接埠

下面列出的是 eMule 預設值所使用的連接埠. 假若您想改變在 選項 -> 連線 中的值, 您將必須得到進入設定防火牆或路由器的帳號(若沒有則不需要).

1) 本地連接埠: 4662
遠端連接埠: 任何的
協定: TCP
方向: 輸入
目的:

客戶端連接埠 / 從其他客戶端連線, 客戶端到客戶端來源交換
注意:

您能由 選項 -> 連線 -> 來改變 客戶端連接埠,
這個連接埠必須能被路由器轉送. 在選項內改變這個設定也必須改變路由器的轉送設定.
2) 本地連接埠: 任何的
遠端連接埠: 4662
協定: TCP
方向: 輸出
目的:

客戶端連接埠 / 連線到其他使用者, 客戶端到客戶端來源交換
注意:

4662 是預設的連接埠, 但其他的客戶端或許有不同的設定值. 在配置防火牆時改變 遠端連接埠到任何的.
3) 本地連接埠: 4672
遠端連接埠: 任何的
協定: UDP
方向: 輸入
目的:

客戶端來源要求 / 延伸的 eMule 協定, 排隊等級, 檔案重新要求
注意:

這個連接埠必須被路由器轉送. 這個連接埠必須能被路由器轉送. 在選項內改變這個設定也必須改變路由器的轉送設定.
假如您不能夠轉送這個連接埠請在選項 -> 連線 -> UDP 連接埠核選 停用

4) 本地連接埠: 任何的
遠端連接埠: 4672
協定: UDP
方向: 輸出
目的:

客戶端來源要求 / 延伸的 eMule 協定, 排隊等級, 檔案重新要求
注意:

4672 是預設的連接埠, 但其他的客戶端或許有不同的設定值. 在配置防火牆時改變 遠端連接埠到任何的.
5) 本地連接埠: 任何的
遠端連接埠: 4661
協定: TCP
方向: 輸出
目的:

連線到伺服器
注意:

4661 是預設的連接埠, 但其他的客戶端或許有不同的設定值. 在配置防火牆時改變 遠端連接埠到任何的.
6) 本地連接埠: 任何的
遠端連接埠: 4665
協定: UDP
方向: 輸出
目的: 在伺服器上要求來源
注意:

伺服器預設使用的連接埠是 4661 TCP (見 #5) 自動的設定他們的來源要求連接埠為 4665 UDP. 假如一個伺服器使用不同的連接埠在 #5 那相配合的 UDP 連接埠會被設定到 [連線連接埠 + 4]. 防火牆的 遠端連接埠在這裡設為 任何的.

UDP 是一個連線較少的協定, 換言之不同於 TCP 沒有連線是保持活躍. 假如一個伺服器回應 例如:一個來源要求這個回應是視為一個新的連線. 所有一般使用的路由器和防火牆在家用電腦防域區表現一個 UDP 連線行蹝因此它是不必在這個路由器或防火牆的配置中指定一個 UDP 的輸入連接埠. 更複雜的網路, 特別是使用了代理伺服器, 可能需要定義這個本地連接埠去配置這這個 路由器 / 防火牆 / 代理 假如它不允許它們被控制否則全部停用. 它允許設定這個連接埠在 選項 -> Preferences.ini 但在那裡通常 不需要 改變它.

7) 本地連接埠: 4711
遠端連接埠: 任何的
協定: TCP
方向: 輸入
目的: Web 界面
注意: 這是 web 界面預設的連接埠. 當使用路由器這個連埠必須被轉送否則這個 Web 界面將不可能被連接.

最後更新在: 2003-08-23 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 更新伺服器清單

更新伺服器清單

在 eMule, eDonkey2000 是需要伺服器來存取這個網路. 建立一個伺服器連線來存取網路資源和使您的客戶端知道這個網路是必要的.

基本上伺服器只提供已連線使用者分享檔案的指標. 搜尋下載及要求下載的來源都是經由伺服器.

eMule 只在第一次連接網路時才需更新伺服器清單. eMule 連線到伺服器不久後使用智慧型功能來交換客戶端之間已知的伺服器並予以更新.

在這裡有幾個不同的更新 eMule 伺服器清單方式:

有用的設定在 選項 -> 伺服器
o 在啟動時自動更新伺服器清單
在您解壓縮 eMule 時的資料夾中, 您將會發現檔案 adresses.dat. 用 ASCII 編輯器開啟它 (如記事本) 並且輸入一個有效的 server.met 網址. 只支援一個網址而已.
啟用這個功能, eMule 將會在啟動時由 adresses.dat 載入位址並更新伺服器清單.

o 連線到一個伺服器時更新伺服器清單
eDonkey 伺服器知道其他的伺服器時. 用這個功能 eMule 將會從您連線的伺服器那裡接收它所知道的伺服器.

o 連線到一個客戶端時更新伺服器清單
這個功能只工作在 eMule 之間的連線. 二個客戶端將會比對他們工作中的伺服器並且互相更新.

注意:
最後二項會固定的保持伺服器清單的更新. 所以規律的更新伺服器清單是不必要的.

伺服器清單由網址更新

輸入一個 server.met 網址在視窗中並按下更新鈕. 記錄視窗將會顯示您有多少伺服器已新增.

增加單一伺服器

輸入一個伺服器的 IP 及名稱來加入單一伺服器到您的清單中. 假如在您的記錄中出現 伺服器沒有增加! 代表這個伺服器已在清單中.

經由 IRC 增加伺服器
在官方 eMule IRC 頻道中有一個 !serverlist 指令的功能. 這個指令會發出給您一個伺服器清單網址. 使用 eMule 的 IRC 聊天, 按下連結能直接的加入到一個 server.met 到清單中.

增加伺服器從網站連結
eDonkey2000 網路提出指定的 html 連結, 如下 ed2k://|server|IP|連接埠|/ 能被 eMule 直接加入.

最後更新在: 2002-11-26 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 伺服器清單網址

伺服器清單網址

eMule 和 eDonkey2000 使用相同的伺服器, 所以這些伺服器清單對 eMule 也是有效用的.

伺服器清單的網站:
 | TheDonkeyNetwork
 | Server List for eDonkey2000

由 ocbMaurice 提供的伺服器清單直接連結:
 |  | 預設值
 |  | 所有伺服器
 |  | 工作中伺服器
 |  | 長時間服務的伺服器
注意:
> | 使用 Google 來找許多良好的 server.met 提供網站.
> | 任何的連結也許已經掛掉或關閉. 這只是最初放置的地方.
> | 非常感謝這些提供的人們.

最後更新在: 2002-12-28 由 Monk -中文化:CML 2004-09-11


eMule FAQ 中文版 :: 伺服器動態 DNS 解析

伺服器動態 DNS 解析

動態 IP 是有利於短缺的 IP 位址限制 (理論上有 2^32) 在全球資訊網. 許多 ISP 使用這個系統, 中斷連線後再重新連線會得到一個新的分配 IP.

這對伺服器來說是不好的因為伺服器失去他獨特的位址, 這樣一來這個伺服器的使用者就不知他目前在網路上的哪個位置.

許多 免費網站服務 提供一個 靜態主機名稱 方法解決這個動態 IP 位址問題.

輸入 [emDynIP: 靜態主機名稱.主機:連接埠] 如同在 dserver 上的歡迎訊息.
在伺服器的預設值中, 它的連接埠是 4661.

這將會指引 eMule 來使用靜態主機名稱更換為動態 IP 來連線.
它相對的也提供增加主機名稱到 staticservers.dat 中, 所以它的位址從不會流失.

注意:
> | 靜態主機名稱長度必須小於 51 個字母.
> | 這只能在網路上運行中伺服器應用. 假如您是執行 eMule 客戶端, 它對您來說是無用的.
> | 對於運行 dserver 的所有人們是光榮的. 您們為這個社區做了很大的服務.

最後更新在: 2002-12-27 由 Monk -中文化:CML 2003-01-18


eMule FAQ 中文版 :: 搜尋

檔案的搜尋

檔案的搜尋在 eMule 通常是指在伺服器清單中所有伺服器詢問他們已知其他的客戶端有你搜尋關鍵字相匹配的檔案. 伺服器他們自己不會儲存任何的檔案, 他們只編譯一個已連線客戶端的檔案清單.
進階搜尋功能在 eMule 允許精確在網路搜尋檔案. 更精確一個搜尋的進行是有助於伺服器降低負載. 因此 eMule 最大只找到 200 個別來源於任何一次的搜尋. 假如已連線的伺服器, 可能給予超過 200 個結果 更多 按鈕將可使用並且允許從本地伺服器查詢結果上限可到 1200 個.

搜尋
o 名稱
這一欄是用來輸入搜尋名稱. 多個關鍵字能被輸入並且 eMule 將只會顯示符合所有關鍵字的檔案名稱. 於更精確並靈活的搜尋見在較下面的布林搜尋章節.
這個文字框有一個自動完成的特徵儲存先前的搜尋項目. 清除這個清單按住 CTRL 或 ALT 再按 DEL. 自動完成的特徵也能被不啟用.

o 以 Unicode 搜尋
這個特徵在 eMule v.44a 加入並且將允許以非拉丁字母的方式搜尋檔案, 例如. 日文, 希伯來語, 阿拉伯語等. 而 Unicode 客戶端並不是能很快的普及化並且 Unicode 搜尋也還未像 ANSI 的搜尋數量一樣多, 這個核選項目只使用在特定的 Unicode 搜尋. 在輸入的字含有 Unicode 它才能動作.

o 類型
類型能用來過濾出相同群組的副檔名. 下載類型及他們相關的副檔名如下面列出:

任何的 | 沒有過濾
壓縮檔 | .ace, .arj, .gz, .hqx, .lha, .rar, .sea, .sit, .tar, .tgz, .uc2, .zip, .7z
音槳 | .669, .aac, .aif, .aiff, .amf, .ams, .ape, .au, .dbm, .dmf, .dsm, .far, .flac, .it, .mdl, .med, .mid, .midi, .mod, .mol, .mp1, .mp2, .mp3, .mp4, .mpa, .mpc, .mpp, .mtm, .nst, .ogg, .okt, .psm, .ptm, .ra, .rmi, .s3m, .stm, .ult, .umx, .wav, .wma, .wow, .xm.
圖片 | .bmp, .dcx, .emf, .gif, .ico, .jpeg, .jpg, .pct, .pcx, .pic, .pict, .png, .psd, .psp, .tga, .tif, .tiff, .wmf, .xif
光碟影像 | .bin, .bwa, .bwi, .bws, .bwt, .ccd, .cue, .dmg, .dmz, .img, .iso, .mdf, .mds, .nrg, .sub, .toast
程式 | .bat, .cmd, .com, .exe, .ace, .arj, .gz, .hqx, .lha, .rar, .sea, .sit, .tar, .tgz, .uc2, .zip, .bin, .bwa, .bwi, .bws, .bwt, .ccd, .cue, .dmg, .dmz, .img, .iso, .mdf, .mds, .nrg, .sub, .toast, .7z
影像 | .asf, .avi, .divx, .m1v, .m2v, .mov, .mp1v, .mp2v, .mpe, .mpeg, .mpg, .mps, .mpv, .mpv1, .mpv2, .ogm, .qt, .ram, .rm, .rv, .vivo, .vob, .wmv

o 方式
方式是 eMule 搜尋的方法. 並且網站基礎搜尋引擎在 eMule 網路是可用的. 而網站基礎搜尋結果將會開啟在瀏覽器.

> | 伺服器 只會在客戶端目前連線的這個伺服器搜尋.
> | 全球搜尋 (伺服器) 從伺服器清單中詢問所有伺服器. 每個伺服器個別的被詢問. 在底部綠色的長條是顯示搜尋的進度.
> | Kademlia 以指定的關鍵字搜尋整個 Kademlia 網路. eD2k 網路, 即沒有伺服器的搜尋方式. 在搜尋得到結果前可能會花上一段時間. 如果搜尋一個很普遍的檔案卻沒有結果那麼可能是系統的 UDP 連接埠也許被防火牆或路由器封鎖.
> | Jigle (Web) Web 基礎的搜尋引擎. 相符的關鍵字 這個選項會強迫 Jigle 只傳回準確的搜尋關鍵字結果, 如同在檔案名稱的一個單一片語.
> | Jigle 這個方式提供 eMule 直接存取 Jigle 資料庫.
> | Filedonkey 網站基礎搜尋引擎

過濾器
o 最小大小 / 最大大小
最小和最大大小是用來縮小搜尋符合的檔案大小. 只有在大於最小大小和小於最大大小的檔案會被顯示. 假如沒有附加檔案大小的單位縮寫將會假定為 mega bytes.

單位 | 有效的縮寫
Bytes | b | byte | bytes
KiloBytes | k | kb | kbyte | kbytes
MegaBytes | m | mb | mbyte | mbytes
GigaBytes | g | gb | gbyte | gbytes

範例:
最小大小 = 200
沒有指定單位, 這將只會傳回最少 200 mega bytes 大小以上的檔案
最大大小 = 1gb
檔案大小不超過 1 giga byte

o 可得性
指出單一檔案一個別伺服器最小的來源數量.

注意:
這個過濾和全球可得性沒有關聯但與每一個伺服器可得性有關. 設定這個數值太高或許導致找不到檔案.

o 副檔名
只有所提供副檔名之檔案類型將會被找到. 副檔名不需輸入 . 例如副檔名 avi 將只會找出這個檔案類型.

布林搜尋
這個功能使用布林運算元 NOT, AND, OR 是用來建立複雜的搜尋詢問. 這些運算元總是以大寫輸入否則他們被認定為正常的搜尋關鍵字.

> | NOT 這個運算元實際上稱為 NAND 意指 "and not". 而在一個 NOT 之後的關鍵字將會被排除, 即 沒有包含這個關鍵字2的項目. 最高的優先. 字串: 關鍵字1 NOT 關鍵字2
> | AND 假如沒有指定運算元則 AND 是預設的運算元. 在結果項目中 AND-連接起來的 搜尋必須包含所有輸入關鍵字. 中間運算元優先. 字串: 關鍵字1 AND 關鍵字2 (等於: 關鍵字1 關鍵字2)
> | OR OR 表示在結果中任何輸入的關鍵字都包含. OR 最低的優先 字串: 關鍵字1 OR 關鍵字2
注意:
> | Kademlia 搜尋的啟始字串必須超過或3個字以上. 第一個關鍵字之後必須不是任何布林運算元 AND.
> | 除了網站基礎搜尋引擎 filedonkey 的布林搜尋或許結合了任何的方式或過濾.
> | 這些運算元根據他們精確的優先來評價. NOT -> AND -> OR. 這個優先能由 ( ) 來改變評價為第一.
> | 去掩飾運算元或 ( ) 引用語記號 " " 能被使用. 運算元或 ( ) 隔絕在 " " 將不會翻譯他們的布林表示式但會被使用成正常的搜尋關鍵字.
> | OR 和 NOT 連接的搜尋是不會限制成 AND 搜尋. AND 需要完全的關鍵字符合然而 OR 和 NOT 也允許部分符合在不同的字.
> | OR 和 NOT 同樣的也能深入內部來考慮在檔案的詮釋資料像是 mp3 標籤或 注釋 / 作者 資訊.
範例:
> | 搜尋 | 關鍵字1 關鍵字2 OR 關鍵字3 關鍵字4
 | 布林表示 | (關鍵字1 AND 關鍵字2) OR (關鍵字3 AND 關鍵字4)
 | 解釋 | 找到的檔案的檔案名稱必須包含 關鍵字 1 + 2 或關鍵字 3 + 4 二者之間任一個.
> | 搜尋 | 關鍵字1 關鍵字2 OR 關鍵字3 關鍵字4 NOT 關鍵字5
 | 布林表示 | (關鍵字1 AND 關鍵字2) OR ((關鍵字3 AND 關鍵字4) NAND 關鍵字5)
 | 解釋 | 所有檔案以關鍵字 1 + 2 或關鍵字 3 + 4 但任何檔案符合 3 + 4 必須不包含關鍵字 5
> | 搜尋 | 關鍵字1 關鍵字2 NOT 關鍵字5 OR 關鍵字3 關鍵字4 NOT 關鍵字5
 | 布林表示 | ((關鍵字1 AND 關鍵字2) NAND 關鍵字5) OR ((關鍵字3 AND 關鍵字4) NAND 關鍵字5)
 | 解釋 | 相似於上面的範例只有關鍵字 5 的差異必須 1 + 2 或 3 + 4 二者都不出現關鍵字 5.
> | 搜尋 | (關鍵字1 關鍵字2 OR 關鍵字3 關鍵字4) NOT 關鍵字5
 | 布林表示 | ((關鍵字1 AND 關鍵字2) OR (關鍵字3 關鍵字4)) NAND 關鍵字5
 | 解釋 | 相同於上面一個搜尋但更優美的來表示使用 ( ) 去套用 NOT 關鍵字5 到全體的 OR 語法
> | 搜尋 | (關鍵字1 "OR" 關鍵字2) NOT 關鍵字3
 | 布林表示 | (關鍵字1 AND or AND 關鍵字2) NAND 關鍵字3
 | 解釋 | 經由使用 " " 包含的部分, OR 運算元不再被認定但成為一個正規的表達. 這個搜尋翻譯成必須包含 關鍵字1 和 關鍵字2 和 這個字 "or" 也包含但必須不包含關鍵字3.

解釋結果
o 可得性 (來源數)
可得性是在伺服器發現一個下載的來源數量. 這不是在整個網路中來源數的總計但伺服器指出多少良好檔案的擴展. 假如那裡有不相符合項目於一個搜尋檔案以較高可得性應該被選擇. 並且見 搜尋結果的顏色表示.
一個數值在 ( ) 之後可得性來源在 eMule 沒有再次搜尋能被直接加入下載的來源.

o 搜尋結果的顏色表示

> | 黑, 暗藍, 亮藍 指出一個指定的檔案發現的來源數. 黑色 = 1 - 3 個來源, 暗藍 = 4 - 9 個來源, 亮藍 = 10+ 個來源
> | 紅色 顯示紅色代表檔案已經在下載清單中或是下載完成且在分享清單中.
> | 綠色 顯示綠色代表已經下載過或是分享過的檔案但目前並未在分享清單中分享的檔案.

o 搜尋結果的內部
按 CTRL + f 顯示搜尋關鍵字 (檔案名稱), ID, 大小, 類型及可得性的一個搜尋視窗. 功能鍵 F3 跳到下一個找到項目同樣的要跳到上一個按 SHIFT + F3 .

o 找到的一個檔案多重檔名
檔案是由切細值識別不是由檔案名稱. 一個搜尋在相同的檔案也許會有許多不同的檔案名稱. 這個顯示像檔案總管一樣用 + 去展開結果. 假如一個結果有許多不同的檔案名稱, 他可能是假的.

可應用版本: .44a +
最後更新在: 2004-09-12 由 Monk -中文化:CML 2004-11-22


eMule FAQ 中文版 :: 額度系統

額度系統

這個額度系統是用來獎賞有助於這個網路的使用者 , 如上載給其他客戶端.
在 eMule 精確的排隊系統是建立在一個使用者花費多少時間排隊在等待時間. 這個額度系統提供了一個[上載/下載 比例]來考慮二個客戶端之間花費在上、下載的等待時間. 較多的一個使用者上載到一個客戶端會快速的推進客戶端的排隊.
[上載/下載 比例]是由二個客戶端之間的資料傳輸量來計算. 這個數值能在客戶端詳細資訊視窗中查看. 檢視這個資料, 在任何的使用者上按右鍵 顯示詳細資訊.

這裡有二個不同的額度修改計算:
 | 比例1 = 已上載總計 x 2 / 已下載總計
 | 比例2 = 平方根(已上載總計 + 2)
比較二者的比例而 低的 數值才是[上載/下載 比例].
一些界限條件也會存在:
 | > | 已上載總計 < 1MB => [上載/下載 比例] = 1
 | > | 已下載總計 = 0 => [上載/下載 比例] = 10
 | > | 這個[上載/下載 比例]不會低於 1 或高過 10

注意:
> | 所有上載給您的客戶端會被額度系統獎賞. 他和該客戶端有沒有支援額度系統都無關聯.
> | 當您上載給不支援的客戶端時將不會授予您額度.
> | 額度並不是全面性的. 他們只在交換的二個客戶端中作用
> | 額度系統被存在 clients.met 檔案. 而獨一無二的使用者切細值是用來識別客戶端.
> | 您的額度是存在對方的電腦中. 這是預防假的額度.
> | 您的額度將不會被顯示

最後更新在: 2003-04-13 由 Monk -中文化:CML 2004-11-21


eMule FAQ 中文版 :: 安全的使用者識別

安全的使用者識別

客戶端在網路是由一個獨一無二的名稱為使用者切細的數值去識別.
這個使用者切細是被儲存在 preferences.dat 檔案並且是使用在其他使用者授予獲得額度.
eMule 能使用一個不對稱加密來避免開拓或利用其他使用者的切細數值. 這方法使用一個私人及一個公開鑰匙來使使用者切細值安全並確保一個適當的識別在其他的客戶端.

安全的使用者識別能被啟用在 選項 -> 防護. 建議您使用它.

安全的使用者識別如何工作:

客戶端 A 想要確定他的額度是否是安全的並且只有他在使用. 他建立一個私人的 384 位元 RSA 鑰匙並儲存它在 cryptkey.dat 檔案.
這個私人鑰匙在第一次被用加密方式建立. 自從他不再能證明他是有效的擁有它們流失這個鑰匙表示著客戶端 A 遺失他所有的額度.

當二個支援加密的客戶端於第一次交換資料他們一起互相傳送一個公開鑰匙以一個亂數. 每一儲存不同的一個鑰匙在它的 clients.met 檔案. 只有鑰匙被儲存, 亂數在新的每個下列連線被產生.

客戶端 A 想要去識別他自己在客戶端 B 在下次他建立一個數位簽名並傳送到 B . 這個簽名是從他的私人鑰匙, 公開鑰匙 B 和一個亂數. 它在客戶端 A 改變他的 IP 或客戶端 B 關閉 eMule 前一直有效.

之後接收了 A 的簽名客戶端 B 檢查假如它是建立從他的公開鑰匙 B 及正確的亂數. 假如它也符合客戶端 A 的公開鑰匙, 那麼客戶端 A 是正確的被識別.

注意:
> | 假如 cryptkey.dat 檔案流失或被刪除, preferences.dat 檔案同樣也被刪除否則在已經知的客戶端沒有新額度能被收集.
> | 當轉換到安全的使用者識別所有舊的, "不穩固的" 額度將會被遺失. 於安全的原因, 那裡傳輸那些額度現在使用安全的系統方式.

可應用版本: .29b +
最後更新在: 2003-06-20 由 Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 禁止侵略性客戶端

禁止侵略性客戶端

假如其他客戶端想要從您這裡下載一個檔案, 他將會在每 10-20 分重新對您發出檔案要求來確定您是否還為有效的來源. 無論如何它是允許客戶端來調高要求頻率, 假如被要求的客戶端是 eDonkey 而他得到上載位置的機率就會變高.
當 eMule 不去注意重新要求頻率 (得到上載位置的機率不會因而增加), 這樣一來會浪費寶貴的資源 (連線數及頻寬).
新的客戶端系統將會把重新要求太頻繁的客戶端列入黑名單中 (一個檔案 10 分鐘內超過一次), 並且他們不被允許下載您的檔案. 這個黑名單在重新啟動 eMule 時會清除.

在下面的例子中您會被列入黑名單並且不能從 eMule 客戶端下載:

> 您客戶端設定的重新要求參數低於 10 分鐘.
> 您增加檔案下載的暫停及繼續狀態次數來加快您的下載速度 - 在每次將會取得一個新的檔案要求 (只在 eDonkey 客戶端)
> 您每二分鐘重新啟動您的客戶端 (當然也將會造成新的要求).

更明確的: eMule 不 需要注意這些客戶端 (eMule/eDonkey/mldonkey) 的要求. 每個要求太頻繁的客戶端都會被禁止的.

最後更新在: 2002-12-14 由 Monk -中文化:CML 2004-04-11


eMule FAQ 中文版 :: 客戶端到客戶端來源交換

客戶端到客戶端來源交換

eMule 能夠在其他 eMule 客戶端下載時獲得來源

為使檔案分享更為良好, 每10分鐘將會在來源清單中要求任一個客戶端他那個檔案的來源節點.
假如檔案是稀有的, 如. 少於 40 個來源數, 每個客戶端將在這個間隔時間被要求他們的來源節點.

只有缺少部分的來源會獲得. 這個動作只經由 TCP* 及被壓縮過的封包來節省頻寬.

注意:
> | 這個協定不相容於 mldonkey 的來源增加協定.
> | 客戶端到客戶端來源交換是完成於客戶端連接埠 4662 使用 TCP 協定
> | 低-ID 來源不被進行交換

可應用版本: 0.22a +
最後更新在: 2003-05-04 由 Monk -中文化:CML 2004-02-29


eMule FAQ 中文版 :: 預覽多媒體檔案

預覽多媒體檔案

在檔案上按右鍵並選預覽. eMule 會建立一個暫存檔案在 eMule 的暫存資料夾內並用預設的多媒體播放器來開啟它.

支援的格式:

- *.avi
- *.mpg
- *.mpeg
- *.divx
- *.xvid
- *.zip
- *.rar
- *.ace
- VLC 被使用的任何多媒體格式

注意:
> 預覽 只 工作在開頭和最後部分已下載完時並且在暫存磁碟中要有足夠的空間來放置預覽檔案.

> 您仍然要有正確的影像編碼器來檢視檔案. 缺少這些編碼器將會產生錯誤訊息或播放時有聲音沒影像. 假如您不確定編碼器可試著使用 Codec Pack

用 VLC 預覽多媒體檔案

VLC 是一個播放器允許播放大多數的多媒體檔案. VLC 從這個檔案建立一個多媒體串流因此甚至能夠播放 破碎/不完整 檔案或橫過網路的串流. 它非常適合 eMule 預覽檔案.

使用 VLC:
> | 下載 VideoLAN Client - VLC
> | 設定完整路徑到 vlc.exe (典型的: C:\Program Files\VideoLAN\VLC\vlc.exe) 在 選項 -> 檔案 -> 影像播放器
> | 在相同的視窗中停用 建立備份來預覽
> | 在 選項 -> Preferences.ini 設 PreviewSmallBlocks 到 1.

VLC 和 eMule 部分檔存取模組

這個 eMule 部分檔案存取模組是為了播放不完整或破碎檔案特別開發的 VLC 外掛. 使用這個外掛如此的檔案或許能被播放不會結結巴巴和甚至是尋找中, 換言之跳至任何所給的影像位置是可能的. 從 eMule 的 .part.met 讀取這個部分不完整下載資訊是可得的它也能節省時間消耗掃描可用的部分.

o 下載及安裝這個外掛

> | 下載這個外掛在 eMule 專案首頁 的 下載 區.
> | 解壓縮 zip 檔案並複製 libaccess_partfile_plugin.dll 到 VLC 的外掛資料夾 (典型的: C:\Program Files\VideoLAN\VLC\plugins)
> | 使用 VLC 上面所述的來設置 eMule
> | 重要的: 這個外掛只相容於指定的 VLC 版本!
 | Part File Access Modul v1.1 <=> VLC v0.6.2
 | Part File Access Modul v1.2 <=> VLC v0.7.0

o 設置這個外掛

之後啟動 VLC 設置視窗於 Settings -> Preferences -> Plugins -> access -> access_partfile 能發現這個外掛

Enable plugin for MPEG / AVI / non MPEG or AVI part files
這三個 "啟用" 選項決定哪個檔案應該被這個外掛處理. "non MPEG or AVI part files" 的檔像是 .ogg, .ogm, .mp3, .mkv 等.
在任何的選項停用情況之下假如有可能的 VLC 將會試著去使用它的預設存取模組改為這個外掛.

Provide a seekable stream for MPEG / AVI / non MPEG or AVI part files
正常的串流從不完整或破碎檔案是沒有尋找能力, 換言之即不能跳至任何所給的影像位置或快轉. 啟用這個選項將會使 eMule 的不完整下載的串流將能允許使用尋找這個功能.
這些選項只工作在這個外掛啟用了指定的檔案類型. 在一些情況下, 特別是 AVI 或 其他非 MPEG 檔案, 這個串流尋找能力或許不能正確的運作.

Enable plugin for all type of files (eMule part files and regular files)
這個外掛的設計是使用它在 eMule 的部分檔. 在 VLC 使用預設存取模組開啟破碎或不完整的檔案有一個臭蟲或許會凍結整個系統. 這個外掛提供一個工作環境為了解決這個臭蟲開啟這個選項來使 VLC 所有支援的檔案以這個外掛來取代預設存取模組. 啟用這個選項表示用 eMule, 檔案總管或指令列 開啟時所有支援的檔案會經由這個外掛處理.
eMule 部分檔案存取模組是完全取代在 VLC 中的預設存取模組.

這個外掛的更進一步資訊

不同的預覽應用
不是所有的播放器都能在全部種類的檔案能有相同的運用表現. 其中最靈活且可靠的是 Video LAN Client 但像是 Media Player Classic 或 Zoom Player 等播放器在不完整的檔案也能運作的很好.
為了提供選擇不同播放器時 eMule 的配置, 在 eMule config 資料夾內會有一個名為 PreviewApps.dat 檔案. 這是一般的文字檔案, 例如以視窗的記事本來開啟它. 預覽的運用方式如下面列出的格式

<選單標籤> = <應用程式-路徑> <應用程式-指令行-參數>
<選單標籤> | 這是名稱, 出現在 eMule 預覽選單內
<應用程式-路徑> | 這是播放器執行檔的完整路徑. 若路徑包含空格必須以 "" 括住
<應用程式-指令行-參數> | 這個給應用程式的參數
範例:
VideoLAN Client 0.6.2=C:\Programme\VideoLAN-0.6.2\VLC\vlc.exe
VideoLAN Client 0.7.1=C:\Programme\VideoLAN\VLC\vlc.exe --config "%USERPROFILE%\Applicationdata\vlc\vlcrc-0.7.1"
Media Player Classic="C:\Programme\Media Player Classic\mplayerc.exe"
注意:
o | 以沒有特權的使用者執行 eMule 也許在一些應用程式不能正常工作就像是所有啟動的程式只在限定的使用者下才能被允許.
o | 指令行參數能包含系統變數像是 %USERPROFILE%. 在這個變數是以系統路徑的適當使用者資料夾內的 "Documents and Settings" . 這有助於以沒有特權使用者時能正常的工作.

螢幕快照預覽於影像檔案
假如其他的客戶端允許檢視他的分享檔案清單 (選項 -> 檔案 -> 看見我分享的檔案/資料夾) 它是有可能於他分享的影像檔來取得一個預覽.
在影像檔上按右鍵 -> 預覽 將會要求一筆五個螢幕快照於檔案開始的10分鐘. 在接收到不久之後這個螢幕快照是顯示在分離的檢視器中. 從他們那裡被送來或許要一段時間. 這個功能只工作在 v.30b 或較新版的客戶端.

可應用版本: .42b +
最後更新在: 2004-05-01 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 上線簽名檔案

上線簽名檔案

假如在選項內使用 啟用上線簽名檔 功能, 一個名稱為 onlinesig.dat 的小檔案將會寫入在 eMule 資料夾中.

onlinesig.dat 的格式:
[上線狀態] | [已連線到伺服器] | [IP:連接埠]
[目前下載速度] | [目前上載速度] | [等候中使用者數]

在未來這個功能將能登入遠端, 但在此時有一個好用的功具由 Dra.:.god 所製作名稱為 Online Signature. 它允許您能從 onlinesig.dat 變更圖片檔案並由FTP方式傳送到網路空間.

可應用版本: .22a +
最後更新在: 2002-12-14 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: IRC 聊天

IRC 聊天

在 eMule 內的 IRC 聊天模組您將會連線到:

irc.freshirc.com

假如您想要取得幫助或是想拜訪我們請加入:

> #emule (英文)
> #emule-german
> #emule-french
> #emule-spanish

請見 選項 - IRC 取得在 IRC 設定的詳細資料.

規則:

> 不要發送訊息給 ops (在他的名稱前有 @ 字元)
> 不要詢問或提供軟體或版權性質的檔案
> 不要在頻道內以腳本(scripts)散佈廣告
> 不要刊登廣告在頻道內

可應用版本: 0.22b +
最後更新在: 2004-02-27 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 好友

好友

eDonkey 網路是非常大的所以要找其他使用者是很困難的. 這個好友功能提供了簡單且容易的方法來保持您喜歡或有興趣的人之行蹤. 特別是團體釋放檔案時它是一個有價值的附加功能.

來源選單 (在傳輸清單中一個來源上按右鍵)

o 顯示詳細資訊
顯示詳細資訊如同在 下載/上載 中的功能並且取得一些傳輸資料 到/從 這個使用者及各種其他多方面資訊.

o 加入到好友名單內
一個使用者已加入成好友時其原來的客戶端圖示會取代為好友圖示並且會列出在 訊息 頁中.

o 傳送訊息
在這個使用者上開始私人的聊天.

o 檢視檔案
這個動作是依據在 選項 -> 檔案 是否能看見我分享的檔案/資料夾來決定. 注意 eMule 的預設值是沒有人能看到. 假如要求成功這個使用者的檔案會顯示在搜尋頁中.

好友動作
一個已加入的好友會列在訊息頁中並且允許下列動作.

o 顯示詳細資訊
相同於上面.

o 移除好友
從清單中移除這個好友.

o 傳送訊息
相同於上面.

o 檢視檔案
相同於上面.

o 建立好友位置
能指定好友來保留他的上載位置, 使他能直接連線不需等待.
只允許保留一個位置.

好友圖示

這個好友目前正在傳輸或已連線.

好友在已知的客戶端清單中.

狀態是離線或未知的.

注意:
這個好友狀態不會規律的更新以節省頻寬. 想知道實際狀態需執行一些動作(檢視檔案,傳送訊息...).

可應用版本: .23a +
最後更新在: 2003-03-27 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: IP 過濾

IP 過濾

某些時候使用者會故意地傳送一些損壞的資料. 這個或許可以阻止一個檔案從從正常的完成變成為完全的損壞.
eMule 引進了一個基本的過濾 IP 功能. IP-區段 過濾是儲存在一個檔案名稱為 ipfilter.dat 它位於安裝 eMule 的資料夾裡. 這個黑名單格式如下 (類似於 cDonkey):

# 一個 "ipfilter.dat" 範例檔案
#
# 所有輸入的 IP 區段將會被 eMule 封鎖其上、下載
# 請非常小心地輸入在這裡. 錯誤的項目將會完全地封住 eMule 對網路的存取
#
# 格式:
# IP-區段 , 存取等級 , 描述
#
# 存取等級:
# <127 封鎖
# >=127 允許

064.094.089.000 - 064.094.089.255 , 000 , Gator.com

上面的項目將會封鎖 IP 從 064.094.089.000 到 064.094.089.255, 即 eMule 將不會連線到任何包含這區段 IP , 不會上載及下載任何的資料.

警告:
上面這個範例將會封鎖任何連線到指定的 IP-區段. 這或許會減少下載的來源數.

在目前只有一種存取等級實行. 一個低於 127 (預設在 選項 -> 防護) 的數值表示著 連線-嘗試 是被拒絕.

更新 IP 過濾
在 選項 -> 防護 選項的 從網址更新. 加入一個過濾檔案連結, 例如 http://bluetack.co.uk/config/antip2p.txt 按下 載入. IP 過濾格式使用 Methlabs, Bluetack 或 Lussnig 的 IP 過濾 清單是被這個功能支援的. 假如指定的位址是一個 *.zip 檔案也能被直接的加入封鎖清單.

IP 過濾工具
在 工具 區域或是在 常用選單 (Alt+x) 您能使用 IP 過濾器 工具來附加額外的清單, 刪除項目及其他操作. 並且也統計 命中 次數顯示提供的某些 IP 被過濾情形.

注意:
• | 過濾將會阻止被禁止客戶端的上載和下載
• | 它不允許由滑鼠在禁止客戶端清單點擊方式加入單一客戶端, 也將永遠不會有這個功能.
• | 過濾是在 TCP 層級所以從不會建立連線到禁止客戶端.

最後更新在: 2003-04-27 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 類別

類別

所有檔案在 傳輸的下載清單 能被加入在自己定義的類別. 第一個類別總是 全部 顯示所有下載或下載過濾由 檢視過濾器. 在任何存在的類別標籤上按右鍵去存取類別的選項.

選擇檢視過濾器
這個選項只能在第一個類別中可使用並且允許您過濾某些檔案類型或檔案狀態.

全部 | 沒有過濾, 所有檔案會被顯示
未分配 | 只有下載沒有在任何自訂的類別中時會被顯示
不完全的, 已完成, 等候中, 下載中, 已損壞, 已暫停, 已停止 | 過濾器會根據下載狀態欄位顯示的狀態
影像 | 影像檔案副檔名 .mpg, .mpeg, .avi, .divx, .rm, .ram, .wmf, .asf, .vivo, .mov, .ogm, .vob
音樂 | 音樂檔案: .wav, .mp3, .ogg, .mp4, .aac, .flac, .ape, .au, .wma, .mpc, .mp2
壓縮檔 | 壓縮檔案: .rar, .zip, .ace, .gz
光碟影像 | .cue/.bin (CDRWin), .mds/.mdf (Alcohol120%), .ccd/.img/.sub (CloneCD), .bwa/.bwt/.bwi/.bws (BlindWrite), .nrg (Nero)

增加類別
建立一個新的類別. 這個設定值用來選擇這個類別選項和預設的 新進檔案 資料夾可指定其他的.

o 標題
類別的名稱它將會被顯示

o 註解
描述或註解.

o 新進檔案資料夾
用來分隔每一類別的 新進檔案資料夾. 已完成的檔案將會移到這個資料夾. 假如這項空白 eMule 會使用預設的資料夾.

o 改變新分配檔案的優先權
檔案加入到這個類別會自動的設定優先權到所指定的.

o 自動 類別-分配
當開始新的下載, 他們能被自動分配到這個類別, 假如檔案名稱符合一個給予的樣式. | 是使用來分隔不同的關鍵字且 * 能被使用為萬用字元代表任意字串.
例如: *.avi|a*.*
這個將會分配新的檔案以副檔名 'avi', 和檔案名稱由 'a' 開頭的到這個類別.

o 顏色
定義在這個類別中檔案使用的顏色. 這個設定值也會影響 全部 這個類別的顯示所有檔案之顏色.

編輯類別
所有由 增加類別 增加的項目能由此再次變更.

移除類別
刪除已選擇的類別. 在這個類別的檔案將不會受影響.

優先權, 取消, 停止, 暫停, 繼續
這些命令套用在這類別中的所有檔案. 請小心取消這個命令.

依字母次序下載
見 來源管理 章節的類別優先權了解詳細.

繼續下一個已暫停
在完成下載之後在選擇的類別中的其他一個已暫停下載將會被繼續.

增加檔案到類別
檔案能被加入到一類別經由拖及丟. 選擇一個下載, 按住滑鼠左鍵並拖到想要的類別. 多個檔案能由 CTRL-按鍵 或 SHIFT-按鍵 來選擇. 這個檔案也能由下載清單中的選單來指定.
在 搜尋 視窗的檔案經由在下載一個搜尋結果之前按下面按鈕選擇類別能直接的加入到類別.

可應用版本: .30a +
最後更新在: 2004-07-18 , Monk 中文化:CML 2004-11-19


eMule FAQ 中文版 :: Web 界面

Web 界面

Web 界面是 eMule 特徵之一允許遠端存取及它的功能和設定的管理. Web 界面能以 eMule 主機目前的 IP 被任何的瀏覽器開啟內部.

連線到這個 Web 界面必須將 IP 位址及相配合的連接埠輸入在瀏覽器中. 這個位址看起來像是一般的 web 網址, 如 http://xxx.xxx.xxx.xxx:連接埠. x 表示目前的 IP 位址而 連接埠 4711 是 Web 界面預設所使用的. 伺服器的連接埠需要被路由器轉送否則將不可能登入. 參考在 FAQ 中的 連接埠 主題取得更多資訊
在和 eMule 執行的同一機器上輸入本地位址 http://127.0.0.1:4711 做測試.

DynDNS Hosts
許多 ISP 使用撥接方式提供網際網路的存取每 24 小時就會強制重撥並指定新的 IP 位址. 登入 Web 界面是必須知道目前的 IP 位址.
許多 免費服務 提供了一個方便的解決方式來知道目前的 IP 位址 - DynDNS Hosts. 那些服務允許指定一個靜態主機名稱位址像是 http://myAddress.myHost.com 給動態 IP 的機器. 一個小的公用程式, 名稱為 Dynamic DNS Client Program, 執行在 eMule 運行的電腦上將會自動的更新靜態主機名稱的 IP 位址. 現在 Web 界面能簡單的由靜態主機名稱 http://myAddress.myHost.com:4711 被存取.

假如輸入了正確的位址登入畫面將會被顯示出. 並輸入在選項內 Web 界面設定的密碼.

重要的:
強烈建議在選項內設定一個專屬的密碼. 假如沒有設定管理密碼, 任何人都能存取您的 eMule 及做設定, 刪除或加入檔案等.

Web 界面提供了 eMule 幾乎全部的功能. 所有的改變將會直接在伺服器電腦上的 eMule 做出反應.

可應用版本: .27b +
最後更新在: 2003-03-21 , Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 指令行參數

指令行參數

在 eMule 一些基本功能能由指令行參數被控制. 這允許以批次 Script 執行或以 Telnet 遠端控制.

語法:
emule.exe status

• | status
寫入目前傳輪資訊到檔案 status.log
• | connect
連線到一個伺服器
• | disconnect
從一個伺服器離線
• | limits=up,down
設定限制的上載及下載速度. 相同於 選項 -> 連線 -> 限制 的設定值
• | resume
繼續任何在下載清單內已暫停或停止的檔案
• | restore
還原一個最小化 eMule 工作列
• | ignoreinstances
允許執行多個 eMule. 注意: 在同一電腦上執行二個 eMule 它們必須安裝在不同資料夾, 必須有不同的暫存資料夾並且每個 eMule 也使用不同的連接埠. 根據測試不建議同時執行二個 eMule.
• | exit
離開 eMule
• | assertfile
除錯選項. 寫入可能的資訊到一個檔案來替代執行中斷.

可應用版本: .42b +
最後更新在: 2004-05-01 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: MuleMRTG

MuleMRTG

Windows NT 系列 (NT, 2k, XP, 2003) 能記錄並顯示效能資訊內建在 perfmon 操控台. eMule (v.42.1+) 也能夠記錄和 perfmon 資料一樣的一些效能.

MRTG - 多重路由流量圖形是一個顯示這個資訊在 HTML 文件的圖形工具. 首先放置這個工具是使用來監視伺服器或路由器 輸入及輸出 流量但是工作在長時間監視 eMule 也是相同的好. 見這個 範例.

下列過程描述如何使用下載頁提供的安裝程式設定 MRTG 成一個 NT 服務.
只工作在 Windows NT, 2k, XP, 2003 不在 Win9x/ME

• | 下載 並用預設值安裝 Active Perl
• | 執行 MRTG 成服務是需要 srvany.exe 和 intsrv.exe . 下載 Windows Server 2003 Resource Kit Tools (MS 安裝程式只工作在 XP 和 2003 但不工作於 2k (這包含了 srvany 能工作在 2k) 或在 Google 下載它. 複製這二個檔案到任何資料夾.
• | 下載 並執行 MuleMRTG 安裝程式. 您必須指定 Active Perl 安裝的路徑 (例如 C:\Perl) 和 srvany.exe 的路徑. 其他的路徑應該已經被填入正確的路徑. 所有使用的路徑必須不包含任何空格或斜線 \

每 5 分鐘 MRTG 從 eMule 的效能記錄讀取一個取樣並建立一個 HTML 輸出來檢視. HTML 檔案被儲存在 HTML 輸出資料夾(Output directory)並且可能以任何的瀏覽器開啟. 只需在 index.html 檔案上點二下.

MRTG 是使用長時間統計量. 第一個圖形的顯示延遲大約 10 到 15 鐘.

可應用版本: v.42.a+
最後更新在: 2004-02-27 由 Monk -中文化:CML 2004-02-29


eMule FAQ 中文版 :: eD2k 連結

eD2k 連結

eD2k 連結是一個特別的連結格式, 允許直接的加入一個下載到 eMule. 這些連結允許 eMule 直接的從 web-管理員 所提供他們的 web 網頁下載並且使它非常容易在這網路交換下載. 一個主要位置看起來像這樣的連結 eMule Content DB

連結格式
eMule 支援並且可以產生複雜的連結.

• | 基本的 eD2k 連結
 | ed2k://|file|<檔案名稱>|<檔案大小>|<檔案切細值>|/ 一個 eD2k 連結包含必要的檔案描述像是名稱, 大小及切細值形成基本的格式
• | eD2k 片段切細值連結
 | ed2k://|file|<檔案名稱>|<檔案大小>|<檔案切細值>|p=<片段切細值>|/ 在檔案的完整的片段切細值確保檔案總是正確的並且幫助新的罕見的檔案散佈.
• | eD2k 來源連結
 | ed2k://|file|<檔案名稱>|<檔案大小>|<檔案切細值>|/|sources,<IP:連接埠>|/ 加入一個或多個已知的 eMule 來源在格式 <IP:連接埠> 到這連結, 提供立即來源來下載.
• | eD2k 主機連結
 | ed2k://|file|<檔案名稱>|<檔案大小>|<檔案切細值>|/|sources,<主機名稱:連接埠>|/ 相同於來源連結但使用主機名稱來替代 IP. 特別是在變動 IP 提供更靈活的. 一個主機名稱必須設定在 選項 -> 延伸 -> 自己的 eD2K 連結主機名稱
• | eD2k HTML 連結
 | <a href="ed2k://|file|<檔案名稱>|<檔案大小>|<檔案切細值>|/">顯示在 web 網頁名稱</a> 容易的建立一個連結來顯示在一個 web 網頁
• | eD2k HTTP 來源連結
 | ed2k://|file|<檔案名稱>|<檔案大小>|<檔案切細值>|s=http://anyweb.net/檔案名稱|/ eMule 也能夠直接的從 web 來源下載. 一個對於 web-管理員 非常有用的且方便的格式. 見在下一段的 Link Creator 了解更多資訊.
• | eD2k 根切細值連結
 | ed2k://|file|<檔案名稱>|<檔案大小>|<檔案切細值>|h=<根切細值>|/ 根切細值連結允許由 AICH 提供一個可靠的值來做進階錯誤修正及檢查的方式. 閱讀 這篇 取得 AICH 和根切細值更進一步的資訊.

在 eMule 建立連結
在 eMule 它非常容易的產生每個 eD2k 連結除了 HTTP 連結之外.
在您的清單中選擇任一個下載並按滑鼠右鍵:

已分享檔案 主視窗提供已完成檔案更多可能的選擇:

Link Creator
Web 管理員釋放流行軟體常常面對擁擠的反應及在一個新的釋放有非常大的流量問題. 提供 web 下載來源並且 eD2k 在相同連結能非常的有助於這個情形. 它提供使用者一個方便的方式來加入下載到 eMule 的下載管理器, 散佈檔案在網路並且提供較大的下載速度透過 HTTP 伺服器.
Link Creator 是非常容易使用的工具能快速的產生這樣的連結.

只需輸入檔案來計算切細值並且產生連結. 選擇性的 HTTP web 來源也許也能被加入. 使用 移除 按鈕來移除一個已選擇的 HTTP 來源或是 清除 來移除全部.
建議加入片段切細值它可以改善下載的可靠性. 按下 開始 來產生連結.

最後更新在: 2004-09-12 , Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 來源管理

來源管理

在網路的來源尋找是極端的重要. 事實上, 伺服器, Kademlia 和 eMule 它自己是能連接向一個有較多數有效率的來源獲得. 最佳的 eMule 效能一些觀念必需了解. 每個下載的來源清單是在它上面點二下來顯示. 進階的來源資訊及處理設定 延伸 -> 顯示更多控制 (進階的模式控制) 必須被啟用.

• | 一個下載的來源尋找
 | eMule 使用不同的方式來尋找下載的來源. 在一個下載點二下來展開會顯示它是何種來源在 大小 的欄位.
 | - | eD2k 伺服器 來源發現由在下載加入之後剛已連線的伺服器或是由在伺服器清單內的任一伺服器規律間歇的要求.
 | - | Kademlia Kademlia 提供一個非常快速的方式來尋找來源, 穿越一個大量的分散式使用者無需中央伺服器. 更多資訊見 網路指南.
 | - | 來源交換 一個來源加入一個下載之後, 假如這個來源知道在自己下載而仍然缺少的部分之更多來源, eMule 會詢問這個來源. 假如是, 連線的客戶端送出一個清單包含這來源.
 | - | 被動 被動來源是其他客戶端的連線. 假如他們可能成為來源在它自己的下載其中一個並且假如他們在取得加入成為適當的來源之前不知道 eMule 要求他們.
• | 來源的數量總計 基本上更多的來源發現使一個下載較為速度但那裡下載有一個限制. 太多的來源將會被來源管理阻塞而變慢 eMule 的連線, 因此實際的下載變慢. 全部下載的發現來源總計顯示在 統計 主視窗 -> 傳輸 -> 下載 -> 發現來源數. 它應該不超過 3000.
• | 等候及來源狀態 一旦其他的客戶端加入成為一個來源, 它取得並詢問目前來源狀態. 可能的來源狀態是:
 | - | 等候中 和 QR: xx 這個是等候等級. 它指出在這個客戶端等待的位置. 當等候位置到達開頭時, 例如 QR:1 這個來源將會開始上載資料. 額度 [上載/下載 比例]會改進等候速度.
 | - | 等候區已滿 最大的等候限制在這個來源已經到達, 太多的其他客戶端已經在等待它.
 | - | 太多連線數 現在 eMule 詢問其他的來源太忙碌所以這個來源需延遲直到一個連線可用時才詢問這個來源. 這個狀態通常消失非常快速. 假如不是 eMule 對付太多的來源. 見上面 來源的數量總計 那一段指出的.
 | - | 沒有需要的部分 (縮寫: NNP) 來源沒有提供任何部分自己缺少的下載. 來源可用的部分也顯示在 上色的進度條.
 | - | 已在另一個檔案中要求 (縮寫: A4AF) 一個個別的來源只能被使在一個下載. 假如這個來源也有提供其他檔案的部分, eMule 會決定哪個下載先接收. 其他的下載將會列出這個來源成 已在另一個檔案中要求. 下一段描述 eMule 如何複雜的處理那些來源.

進階的 A4AF 處理

這個圖片顯示一些下載他們發現的來源 (進階控制開啟時). 例如第四個檔案總計有 27 個來源其中有 26 個有用且 49 個是 A4AF.
假如下載屬於一個系列的檔案或是分割成多個部分的檔案(如影集或分割的壓縮檔), eMule 將會顯示一個來源分配相似於上面圖片的 Filename1_Part_X. 大多數在那個來源的發現有可能是那來源他們在那檔案之外可能也一起提供其他檔案的部分. eMule 只會在那來源佔領一個等候位置因此那些檔案有較高的 AF4A 計數.
在每一個檔案那些 A4AF 來源的背景選單給予二個控制方式. 優先權 及 自動地置換所有 (A4AF)來源到這個檔案 的控制.

並且 類別 背景選單也提供 A4AF 來源處理方式. 在他們的類別 優先權 及 依字母次序下載.

eMule 的進階 A4AF 處理決定哪個檔案取得來源的次序如下:
• | 自動地置換所有 (A4AF)來源到這個檔案 (最高重要性) 只有一個檔案可以核選這個且總是取得 A4AF 來源.
• | 類別優先權 檔案在一個類別有高優先權是優先於未分類檔案或是較低優先權的
• | 檔案優先權 在一個類別檔案的優先權決定哪個將接受來源
• | 依字母次序下載 (最低重要性) 分配來源依下載的檔案名稱. 例如在上面的 Filename1_Part_X 這表示 Filename1_Part_1 取得所有的 A4AF 來源, 當它完成時所有的來源會交換到 Part_2 等. 下載符合哪個形態建議建立一個類別. 確保檔案是在依字母次序下載並且核選此選項. 重新命名一個下載按 F2 或是滑鼠中間或選擇背景選單的 顯示檔案詳細資訊.
注意:
• | 設定一個類別到 依字母次序下載 將會切換所有檔案到 一般 優先權. 之後加入這個類別的檔案將會保留他們的優先權設定值. 檔案依字母次序下載, 請確定他們設定在相同的優先權 (非自動).
• | 假如一個來源也許交換到一個較低優先權檔案只為允許客戶端到客戶端來源交換 A4AF 處理制止. 這個確保低的優先權下載也能快速找到全部的可能來源.
• | 來源交換必須遵從網路的重新要求時間. 它或許在來源交換之前需花上 30 分鐘.
• | 一個來源有低於 50 的 QR 將從來不會被較高優先下載取得交換以確保它開始從這個來源下載.

可應用版本: .43a +
最後更新在: 2004-07-18 , Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 損壞的處理

損壞的處理

eMule 使用各種的方式來確保檔案在網路分享及下載沒有錯誤. 萬一錯誤發生, 稱為損壞, eMule 有進階功能以最小的額外重新下載資料量來修正這個損壞.

檔案切細值和 ICH - 智慧型損壞處理

檔案切細值, 部分切細值 & 片段切細值
在網路分享的每個檔案有一個獨一無二的識別值是由 MD4 密碼數學運算所建立. 這個值稱為檔案切細值並且每個標準的 eD2k 連結都有包含, 例如

ed2k://|file|name|12043984|6744FC42EDA527B27F0B2F2538728B3E|/

其中 6744FC42EDA527B27F0B2F2538728B3E 是檔案切細值以確定這個檔案在整個網路是獨一無二的被識別出.
這個 檔案切細值 是將檔案劃分為 9.28 MB 為一個部分所計算出來. 每個部分的部分切細值也是使用相同的 MD4 運算方式計算出來. 那些 部分切細值, 稱為 片段切細值, 並且它是使用來計算出最終的檔案切細值. 例如一個 600 MB 檔案被劃分為 65 個部分每個部分都有它自己的 部分切細值 而它是用來建立最終的 檔案切細值.
為確保 eMule 總是接收到正確的一個特別的連結能包含片段切細值, 例如

ed2k://|file|name|12043984|6744FC42EDA527B27F0B2F2538728B3E| p=264E6F6B587985D87EB0157A2A7BAF40:17B9A4D1DCE0E4C2B672DF257145E98A|/

其中 p= 值表示 片段切細值. 每個 部分切細值 是由 ":" 來區隔. 這個檔案大小為 12043984 位元組 (=11.49 MB) 這表示它有一個完整的 9.28 部分和剩下的到 11.49 MB 部分為二個 部分切細片段.

ICH 智慧型損壞處理
無論何時 eMule 完成某一個部分它將會被檢查, 假如下載的資料和部分切細值一樣這個將成為已完成部分. 如果是, 這個部分會提供上載來幫助檔案的散佈.
假如不是, 一個損壞發生且這部分會再次下載. 為避免下載全部 9.28 MB, ICH 從這部分的開頭 180 KB 重新下載並且再次檢查部分是否完整. 假如不是, 下一個 180 KB 會再下載, 並再次檢查. 直到部分切細值正確為止. 最佳情況下假如損壞只在部分的開頭 eMule 只再次下載 180 KB. 最差的情況可能會整個重新下載. 在部分的損壞 ICH 平均可節省 50%.

AICH - 進階智慧型損壞處理
標準的 ICH 是相當有效的雖然它有它的限制只在整個 9.28 MB 能被驗證並且沒有完美的區塊. 假如超過一個以上的位置是損壞或是惡意客戶端一再的散佈損壞的資料或甚至是假的 部分切細值, ICH 再也沒有能力去處理.
在這裡 AICH 將會考慮完全的完整資料用一個最小重新下載量或者由建立非常完美的切細值來管理.

根切細值, 區塊切細值 & AICH 片段切細值

這次我們的起點是在一個檔案的 9.28 MB 部分. 每個部分是被分割成 180 KB 的區塊, 在每個部分將會產生 53 個區塊並且每個區塊使用 SHA1 切細運算方式計算出切細值. 那些值稱為 區塊切細值 並且根據一個低標準的一個完整 AICH 片段切細值.
在上面的圖片是顯示一個完整的切細值樹狀圖如何建立在一個完整 4 部分檔案的區塊. 每個部分包含 53 個區塊產生出 212 個 區塊切細值 其中建立在一個切細樹狀的第七層直到 根切細值 到達時. 這整個樹狀稱為 AICH 片段切細值.
綠色和黃色點顯示小型的 區塊切細值 到 根切細值 之數學相關性. 這個表示假如我們有一個可信任的根切細值整個樹狀能被逆向的來驗證它.
eMule 能建立包含根切細值的連結, 例如

ed2k://|file|name|12043984|6744FC42EDA527B27F0B2F2538728B3E| h=A2NWOTYURUU3P3GCUB6KCNW3FTYYELQB|/

其中 h= 是 根切細值. 由提供一個可信賴的 根切細值 並發佈它應該能有明顯的改善檔案的損壞抵抗性. 閱讀 根切細值的信任

從一個損壞還原
無論何時 eMule 在一個部分偵測到一個損壞它需要用一個完整 AICH 切細值資料從隨便一個客戶端中取得一個還原封包. 這個還原封包包含在切細樹狀整體損壞部分的全部 53 個 區塊切細值 和一個 驗證切細值 的號碼. 上面圖片顯示一個 4 部分檔案的一個還原封包. 驗證切細值 的號碼是由檔案的分割部分數量來決定 (2^x >= '部分數量', 用 x = 驗證切細值號碼).
接收還原封包之後 eMule 檢查 驗證切細值 逆向確認它的根切細值. 假如它們相符, eMule 從還原封包的 區塊切細值 逆向檢查損壞部分的全部 53 個區塊. AICH 能還原全部區塊用它們的 區塊切細值 逆向相符來讓只有損壞的區塊重新下載.
在記錄中一個成功的還原看起來會像下面列出的:

09.09.2004 02:43:43: 已下載部分 6 損壞了 :( ([file])
09.09.2004 02:43:46: AICH 成功的還原 8.22 於 9.28 從部分 6 於 [file]

根切細值的信任
最佳的方式是從有 根切細值 的連結來下載. 假定這個連結的來源是可信任的根切細值而一但受信任將會把這個檔案的根切細值儲存在磁碟.
假如不是由連結提供的根切細值而是由檔案的來源送出的 eMule 也會去信任這根切細值. 它只會在一個 根切細值 最少 10 個不同的來源送出相同的值和最少全部 92% 的來源同意這個值才會去相信它是真的. 因為這個 根切細值 不是那麼可靠它只有效於目前工作階段並且不能儲存也不能用 根切細值 建連結.
一旦 eMule 建立整個 AICH 片段切細值, 例如:檔案已經完成, 它將開始傳播 根切細值 給其他的客戶端.

注意:
• | 新釋放或罕見的檔案將也許沒有足夠的完整來源來產生一個可信任的 根切細值. 建議釋放檔案時包含這個切細值.
• | 在一般情況下假如在那裡沒有 根切細值 或甚至是一個偽造的 eMule 將能夠成功下載並且完成這個檔案. 而 AICH 特徵不能使用在這種情況.
• | 如同 AICH 片段切細值能非常大他們不儲存在記憶體但存在 known2.met 並且只能做讀取需求.
• | AICH 將只能在 eMule 客戶端 v.44a 及更新版本有效但保留舊客戶端的向下相容性.

最後更新在: 2004-09-11 , Monk 中文化:CML 2004-09-24


eMule FAQ 中文版 :: 錯誤訊息

錯誤訊息

一個客戶端造成一個未知處理錯誤當接收或處理一個封包. 客戶端斷線中!
當一個客戶端連線到您時偵測到一個錯誤. 在最差的情況發生時您將會失去這一個來源.

重大錯誤: 無法建立插口在連接埠 4662
假如其他應用程式使用連接埠 4662 來建立連線這個錯誤將會發生. 這大部分都發生在同時間使用 eMule 及 eDonkey 且沒有更改其中一個的連接埠為不同值.
不建議您同時執行 eMule 和 eDonkey 或 eMule 和 Overnet 除非你有 (上載) 頻寬能這麼做.

ERROR: Your port 4662 is not reachable. You have a LOWID
eMule 偵測到某些阻塞在您的連接埠 4662. 這可能由防火牆或不正確的路由器設定造成. 讀取 FAQ 或搜尋論壇如何設定您的 防火牆/路由器.

ERROR: Your port 4662 is not reachable. You have a LOWID http://www.edonkey2000.com/documentation/lowid.html ! Please correct your network config !
這個錯誤跟上面是相似的. 它將不會出現在伺服器記錄視窗中但在會出現伺服器資訊視窗中. 這個訊息由 Lugdunummaster 所架設的伺服器產生. 請見 這裡 取得 Lugdunum 詳細資料.

嘗試連線重大錯誤. 網路可能已斷線
顯然的這個錯誤大多數原因是您的連線中斷, 但它也可能發生在網路非常忙碌或您使用的防火牆 Zone Alarm 似乎把處理太多連線是相當嚴重問題.

錯誤: 無效的 part.met 檔案版本! (x.part.met => (null))
當 eMule 寫入資料到一個 .part.met 檔案所發生的一個嚴重錯誤. 那些檔案保持行蹤在 eMule 的下載暫存.
引起的原因是當掉的 Windows 或 eMule. 您能試著還原這個檔案:

- 在您的暫存資料夾中能找出這個檔案. 假如找不到他們, 您的運氣不好
- 使用一個程式像是 Known Metinator, DonkeyDoctor (西班牙文, 但程式及說明討論區也有英文, 也有中文請在eDonkey & Overnet 中文站下載) 或 eD2k RecoverMET 來重建 .met 檔案.
- 您一樣也能嘗試執行 eDonkey 在相同的暫存資料夾中, 或許他能修正這個問題.
- 見 發現及解決 -> 下載流失 取得更多資訊.

在做任何動作之前總是關閉 eMule 並且不要期望太高. 這是一個嚴重的錯誤而您有好的機會可以再次下載這個檔案.

一個下載狀態為 "已損壞"
這也是一個檔案操作錯誤. 它發生在:

- eMule 無法開啟一個 .part 檔案.
在選項中檢查您的暫存資料夾是否正確
檢查在暫存資料夾中的任何檔案是有寫入保護(唯讀)
重新啟動 eMule

- 完成一個下載或移動到新進資料夾
在選項中檢查您的新進資料夾是否正確
檢查新進資料夾的硬碟是否有足夠的空間
重新啟動 eMule

假如沒有作用, 離開 eMule, 在您安裝 eMule 的資料夾中刪除 preferences.dat 和 known.met, 並且重新啟動它.

客戶端 'xxx' (IP:xxx.xxx.xxx.xxx) 造成一個錯誤: 已接收到損壞或無效的片段切細值. 客戶端斷線中!
您可以不理會這個. 在來源要求時由其他客戶端送給您一個無效的片段切細值所引起.

錯誤: 無法切細已下載部分 - 片段切細值不完全 (XXX). 這應該從不會發生
這個錯誤是一個程式臭蟲發生在小檔案上. 踓然如此他們仍然能正確的完成. 您能忽略這個不管.

意外的檔案寫入錯誤 XXX : 一個未知錯誤發生當存取 C:\Program Files\eMule\temp\YYY.part
當 eMule 嘗試去完成一個檔案中時, 他偶然的出現一個問題在這個部分檔案. 其可能的原因是

- 一個已被移動暫存資料夾或部分檔案
- 其他程式存取這個檔案 (像是 防毒軟體, 其它 p2p 軟體)

檢查這些原因並重新啟動 eMule.

無效版本標籤在 server.met (0x3C)
載入或更新 server.met 造成一個問題. 一個無效的 server.met 從一個 URL 更新或是自己的 server.met 檔案已經損壞. 嘗試其他的 URL 來更新伺服器清單或是假如錯誤仍然存在刪除這個 server.met 檔案.

An attempt was made to access an unnamed file past its end
這個訊息是由於無效的封包從伺服器或是其他客戶端傳來時彈出. 這個訊息並不會影響 eMule 的運作並且在 .28a+ 版之後以經有修正

最後更新在: 2003-04-19 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: 發現及解決

發現及解決

o

eD2k 連結不能工作. 瀏覽器出現一個錯誤訊息
假如 eD2k 網頁連結在 Internet Explorer 點擊後不能被加入到 eMule, 特別的 eD2k 連結格式沒有正確的關聯. 在 eMule 選項 -> 一般 內檢查 "ED2K 連結" 按鈕. 假如是灰色的那樣子可能是視窗登錄值有一些項目亂掉. 下載這個工具(由 Resterampe)並且移除舊的關聯, 並再按一次 "ED2K 連結" 按鈕.

檢查登錄使用 regedit (開始 -> 執行 -> regedit) 去存取這個登錄值:
HKEY_CLASSES_ROOT\ed2k\shell\open\command
名稱: (Standard)
類型: REG_SZ
資料: "emule.exe 的路徑(包含引號!)" %1

及

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\shell\open\command
是否相同於上面

假如您有 eMule 的連結關聯問題刪除所有 HKEY_CLASSES_ROOT\ed2k\... 和 HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\... 項目 之後 再按 eD2k 連結 按鈕再按一次.
做任何改變之前請先備份!

Opera
允許連結在 Opera 上工作, 需要編輯在 Opera 安裝資料夾中的一個設定檔案. 離開 Opera 並用編輯器開檔案, 例如 notepad.
Opera 6.x:
在檔案 Opera6.ini 加入這行 TrustedExternalURLProtocols=ed2k 在 [User Prefs] 的下面並儲存它.
Opera 7.x:
於 Opera 7.x 加入相同上面的那行在檔案 OperaDef6.ini.

Mozilla, Firefox
您將需要一個特別的外掛使 Mozialla 或 Firefox 瀏覽器和不同格式的連結產生關聯像是 eD2k 連結. 取得 mozex (替代的 下載連結), 開啟您的瀏覽器設置並輸入
eMule的路徑\emule.exe %r
在 eD2k 編輯欄位於 mozex 外掛.

例如: C:\ProgramFiles\eMule\emule.exe %r
o
 Web 界面: Internet Explorer 開啟一個下載視窗取代顯示網頁
去阻止這個狀況在 工具 -> 網際網路選項 -> 進階 : HTTP 1.1 設定選項中 使用 HTTP 1.1 及 使用 HTTP 1.1 透過 proxy 連線 必須被核選
o

下載流失
因當機或某些因素造成下載的檔案從清單中消失雖然檔案仍然在暫存資料夾中. 這也有可能是 *.part.met 損壞.

一般
去做任何的還原動作之前離開 eMule.
確定在 選項 -> 資料夾 的每個設定都正確. 正確的暫存資料夾路徑是需要輸入的.

備份
eMule 自動的建立所有的 *.part.met 檔案的備份 (*.part.met.BAK). 假如在那裡有任何不同大小或最後修改日期 (在檔案上按右鍵 -> 內容) 刪除這個 *.part.met 檔案並重新命名這個備份檔案成相對應的檔名.

還原工具
工具 這章有些還原工具的連結. 在做任何還原動作嘗試之前先備份 *.met 和 *.part. 改變無法被變回的.

手動搬移
在一些罕見的事件中一個 *.part.met 檔案是完全損壞然而它將會阻止其他檔案的載入. 經由加入檔案來一步一步的找出損壞的檔案並 移除/還原

1. 將暫存資料夾中的所有檔案移到一個備份資料夾
2. 移動一個 *.part 及相對應的 *.part.met 到暫存資料夾中
3. 開啟 eMule 並檢查是否正確的加入在清單中
4. 關閉 eMule
5. 重覆步驟 2. - 4. 直找到損壞的下載為止
6. 刪除或是用還原工具去試著還原損壞的下載
o
 "奇怪的反應"
假如更新伺服器清單發生問題或是因設置檔案的損壞引起設定值的流失. 這特別是發生在當機之後或是從另一版本的 eMule 更新之後. 刪除所有在 eMule 安裝資料夾中的 *.met, *.ini 及 *.dat 檔案 (不用刪除您的下載暫存檔!) 或許能幫助解決這個問題. 刪除檔案之前先離開 eMule. 之後再重新開啟 eMule 並重新做選項的設定.
o
 連線到伺服器之後立即斷線
許多伺服器都有限制分享檔案的數量. 假如客戶端的檔案數量已達到將會被斷線. eMule 會在 統計頁 中顯示檔案分享的數量. 通常 是少於 500 分享 將不會造成這個問題並且確定所有的檔案能被接受.
從 eMule v.28 伺服器能接受的檔案數量將會顯示在伺服器清單中.
去預防這個斷線 eMule v.29 + 只發表伺服器允許的軟性限制檔案數量. 軟性限制 數值是一個伺服器公開分享的數量, 所有超過的檔案將會被忽略. 當 硬性限制 到達時客戶端將會被斷線.
o 被列入黑名單中在 Lugdunum p75+ 伺服器
新的 Lugdunum 修補伺服器 p75+ 有一個額度系統來判斷客戶端的行為. 每一個動作像是連線中, 搜尋中, 來源要求中 等. 花費額度點. 假如他們全部使用完, 這個伺服器斷線且送出一個警告那麼這個客戶端被列入黑名單中.
這個特別是一個問題當下載中超過 ~30 個檔案, 同樣地全部下載來源要求將會花費許多額度, 禁止這個客戶端. eMule v.30a+ 已注意這個問題.
這個主題的額外資訊在 Silent Bob's web site.

最後更新在: 2004-09-23 , Monk 中文化:CML 2005-02-07


eMule FAQ 中文版 :: 工具

工具

還原已損壞檔案公用程式下載:
MetMedic | 用來編輯 .met 檔案和還原流失的下載的工具
DonkeyDoctor | 還原工具. 容易使用.
eD2k RecoverMET | 命令列工具. (eD2k 連結)
eD2k 連結殺手 | 從登錄檔清除 破壞 eD2k 連結 關聯性.

其他工具 & 公用程式:
連線測試 | 測試腳本由 TheDonkeyNetwork 製作用來檢查客戶端開啟的連接埠
上線簽名 | 從 onlinesig.dat 檔案來變更圖片. 請見 上線簽名檔
新的上線簽名 | 德國人設置開發的上線簽名應用程式
AC-Plug | 連線中斷重新撥號
VideoLAN 客戶端 | 替代多媒體檔案預覽的方式之一. 見選項 -> 資料夾
RASPPPOE | PPPOE 驅動程式是用在 DSL 撥號用由 Robert Schlabbach 提供
WinSockFix | 用來修補 Windows Winsocks 的工具.
LSPFix | 用來修補 Windows Winsocks 的工具.

假如您知道一個好用且有關於 eMule 的工具請送電子郵件至 Monk@emule-project.net 而我將會加入它到這頁.

最後更新在: 2004-05-02 由 Monk -中文化:CML 2005-02-07


eMule FAQ 中文版 :: FAQ - 絕望

FAQ

eMule 仍然不工作!

讀出這句後: "我以神聖的巴別塔之名發誓有用心的去閱讀, 了解和學習整個 FAQ 及說明文件. 我也使用了搜尋功能去找在論壇中存在的回覆文章並且已經有禮貌的在那裡詢問取得幫助. 悲傷地它仍然不工作."

假如您有那樣的壞問題, 它可能是…
• 在 eMule 的一個臭蟲
• 在 Windows 的一個臭蟲
• 命運
• 或是鍵盤和椅子之間位置問題.

無論如何請節哀.

最後更新在: 2003-09-03 由 Monk -中文化:CML 2003-10-05


eMule FAQ 中文版 :: eMule 支援各種不同語言

eMule 支援各種不同語言

由德國團體指定在討論區那裡是使用英文.

在這個 FAQ 中文版連結提供了其他語言的站台. 在列出的其他站台是尚未被檢查的, 若有不正當的請告知 eMule 團體成員知道. 假如您想要推薦站台請連繫 Monk@emule-project.net.

中文繁體
eDonkey2000 & OverNet 中文站

German
Here! See the Forums.

Dutch
www.donkeynl.com - eMule Forum
http://www.dutchemulefaq.tk/ FAQ

French
Visit the French Support Forum here
www.open-files.com

Spanish
Visit the Spanish Support Forum here
 www.zonap2p.com
Eshock
http://emuleitor.com/

Lithuanian
http://emulelt.sytes.net/faq/index.html Lithuanian eMule FAQ

Italian
http://rmattioli.gamersrevolt.it/eMule-faq.html Italian eMule FAQ

Danish
http://emule.edonkey2000.dk

Portugese
http://www.tutoriais.t2u.com

最後更新在: 2003-01-08 由 Monk -中文化:CML 2004-07-28


eMule 部分檔 VideoLAN 存取模組 - 讀我檔案

快速開始

  • 下載並安裝 VideoLAN client (VLC) 在 http://www.videolan.org
  • 解壓縮 eMule 部分檔案存取模組 Zip 封裝並複製 libaccess_partfile_plugin.dll 檔案到您安裝的 VideoLAN client 外掛資料夾中. 例如 C:\Program Files\VideoLAN\VLC\plugins
  • 開啟 eMule 選項/檔案 視窗並指定 VideoLAN client 成預覽部分檔案所使用的影像播放器.
    • 指定 VideoLAN client 執行檔完整路徑. 例如 C:\Program Files\VideoLAN\VLC\vlc.exe
    • 停用這個選項 建立備份來預覽
  • 檢查, 假如 eMule 部分檔案存取模組是正確的被 VLC 認出. 也見: 重要的注解

目的

這個存取模組目的是於一個 eMule 暫存檔案提供 VideoLAN 一個媒體串流輸出.

因為一個 eMule 暫存檔案通常不包含一個完整的媒體串流, VideoLAN 這個軟體會掃描整個檔案來找出所有實際可用的資料. 這個掃描整個檔案的過程或許會花很長的時間, 依實際可用的資料及檔案大小而定.

這個存取模組將會評估 eMule part.met 檔案來知道相對應的部分檔案實際可用的檔案資料. 存取模組以這個資訊是有能力建立一個虛擬媒體串流沒有任何缺口並且將正確的放入這個媒體串流到 VideoLAN. VideoLAN 將不再長時間的去掃描整個檔案, 因為它 "看見" 只有部分檔案真正可用的資料.

安裝

複製 libaccess_partfile_plugin.dll 檔案到您安裝 VideoLAN client 的外掛資料夾中. 例如 C:\Program Files\VideoLAN\VLC\plugins

重要的注解: 在安裝 eMule 部分檔存取外掛之後或安裝新版的 VLC 之後您應該手動檢查 eMule 部分檔存取外掛是否和 VLC 版本相配合. 這是因為 VLC 不支援以不同版本的 VLC 開發的外掛. 這表示, 假如您使用 VLC v0.6.1 您不能使用一個以 VLC v0.6.2 開發的 eMule 部分檔存取外掛且反過來也一樣. 更進一步的表示, 這個版本的 VLC 總是有相配合的 eMule 部分檔存取外掛. 在那裡沒有自動檢查的方式, 因此您必須手動開啟 VLC 設定視窗 (Settings/Preferences/Plugins/access) 並檢查那裡是否有　access_partfile 模組可用的. 假如沒有, 您的 VLC 版本和 eMule 部分檔存取外掛版本不相配合. 更新 VLC 或 eMule 部分檔存取模組的其中任一個.

在視窗檔案總管的 檔案/內容 也可以檢查 eMule 部分檔存取模組的資訊得到 VLC 安裝所需的版本, 如下面圖片所示:

反安裝

移除 libaccess_partfile_plugin.dll 檔案從您安裝 VideoLAN client 的外掛資料夾中. 例如 C:\Program Files\VideoLAN\VLC\plugins

用法

這個部分檔案存取模組將會自動地實行經由 VideoLAN client 每次開啟一個檔案時. 假如開啟檔案的副檔名是 .part, 這個存取模組試著去找出相對應的 .part.met 檔案並且將處理部分檔案依在上面描述的方法. 這個表示, 那麼在那裡沒有指定動作去使用那個存取模組功能. 僅開啟您想要檢視任何部分檔案. 從 eMule (預覽) 或從視窗檔案總管或從 VideoLAN client 檔案開啟視窗的任一個方法.

附加的您能指定暫存檔案被開啟以 partfile://<path> 開啟一個暫存檔案從 VLC 開啟視窗或視窗檔案總管網址列來確保部分檔案是以部分存取外掛開啟 (將會阻止 VLC 的自動偵測).

範例: partfile://D:\eDonkeyTMP\001.part

設定

這個設定視窗頁是 VideoLAN client 在 Settings/Preferences/Plugins/access/access_partfile 可用的存取模組.

VideoLAN client - eMule 部分檔案存取外掛模組設定

Seekable streams

正常的 eMule 的預覽是沒有尋找能力, 換言之即不能跳至任何所給的影像位置或快轉. 啟用這個選項將會建立允許使用尋找功能的串流.

這個決定了假如一個 part.met 檔案是 AVI 或 MPEG 之上的檔案範圍並且 eMule 提供的其他詮釋資訊. 同樣的這個資訊總不是 100% 正確它或許發生那樣一個尋找能力串流是被建立雖然符合的選項沒有啟用 (例如 您正在下載一個檔案 "My vacation video.mpg", 但實際檔案格式類型是 AVI). 應該這個發生在您也許想要在 eMule 的檔案詳細資料視窗中重新命名這個檔案到它適合的副檔名.

Enable plugin for MPEG part files

假如這個選項啟用, 只有在假如部分檔案包含了一個 MPEG 檔案, 這個部分檔案存取模組將會從這個部分檔建造提供虛擬媒體串流. 預設值 = 啟用.

Provide a seekable stream for MPEG part files

假如這個選項啟用, 這個部分檔案存取模組將會從這個部分檔建造提供虛擬媒體串流. 假如 "Enable plugin for MPEG part files" 選項是停用, 這個選項不會生效. 預設值 = 啟用.

Enable plugin for AVI part files

假如這個選項啟用, 只有在假如部分檔案包含了一個 AVI 檔案, 這個部分檔案存取模組將會從這個部分檔建造提供虛擬媒體串流. 預設值 = 停用.

Provide a seekable stream for AVI part files

假如這個選項啟用, 這個部分檔案存取模組將會從這個部分檔建造提供虛擬媒體串流. 假如 "Enable plugin for AVI part files" 選項是停用, 這個選項不會生效. 預設值 = 停用.

注意: 尋找能力串流於 AVI 部分檔案或許會造成失敗結果 (媒體串流太早停止) 和/或 比 MPEG 尋找能力串流較稍微差的效能.

Enable plugin for other (non MPEG or AVI) part files

假如這個選項啟用, 只有在假如部分檔案不是包含了一個 AVI 或 MPEG 檔案, 這個部分檔案存取模組將會從這個部分檔建造提供虛擬媒體串流. 使用這個選項來預覽任何其他的檔案類型 (例如 OGM, MKV, ...) 預設值 = 停用.

Provide a seekable stream for other (non MPEG or AVI) part files

假如這個選項啟用, 這個部分檔案存取模組將會從這個部分檔建造提供虛擬媒體串流. 假如 "Enable plugin for other (non MPEG or AVI) part files" 選項是停用, 這個選項不會生效. 預設值 = 停用.

Enable plugin for all type of files (eMule part files and regular files)

假如這個選項啟用, 這個部分檔案存取模組將會處理經由 VideoLAN client 開啟的所有檔案類型並且將會以不同於 VideoLAN client 的預設檔案存取模組去處理. 啟用這個選項或許在 VideoLAN client 的檔案存取模組在某些時候讀取破碎的多媒體檔案時凍結整個系統的臭蟲有關. eMule 部分檔案存取模組嘗試去解決這個臭蟲並處理非部分檔案在相同於原始的檔案存取模組方式. 預設值 = 停用.

eMule 部分檔案的檔案資訊 (ED2K 詮釋資料)

這個檔案資訊視窗在 VideoLAN client 的 檢視/檔案 可用的並且顯示了經由 VideoLAN 檔案格式參數判決和一些 eMule/ED2K 詮釋資料.

中文化:CML 2005-02-07